]> git.pld-linux.org Git - packages/apache-mod_perl.git/blob - apache-mod_perl.spec
- removed explicit requirements for perl = %%{version} and %%{perl_sitearch}
[packages/apache-mod_perl.git] / apache-mod_perl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A Perl interpreter for the Apache Web server
3 Summary(pl):    Interpreter perla dla serwera WWW Apache
4 Name:           apache-mod_perl
5 Version:        1.25
6 Release:        2
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
11 Patch0:         apache-perl-rh.patch
12 # from ftp://ftp.kddlabs.co.jp/Linux/packages/Kondara/pub/Jirai/
13 Patch1:         mod_perl-v6.patch
14 BuildRequires:  rpm-perlprov >= 3.0.3-16
15 BuildRequires:  perl >= 5.005_03-14
16 BuildRequires:  apache-devel
17 BuildRequires:  gdbm-devel
18 BuildRequires:  perl-libwww
19 BuildRequires:  perl-HTML-Parser
20 BuildRequires:  perl-MIME-Base64
21 BuildRequires:  perl-BSD-Resource
22 BuildRequires:  perl-B-Graph
23 BuildRequires:  perl-Devel-Symdump
24 BuildRequires:  perl-URI
25 Requires:       apache
26 Provides:       perl(mod_perl_hooks)
27 Provides:       mod_perl
28 Obsoletes:      mod_perl
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Mod_perl incorporates a Perl interpreter into the Apache web server,
33 so that the Apache web server can directly execute Perl code. Mod_perl
34 links the Perl runtime library into the Apache web server and provides
35 an object-oriented Perl interface for Apache's C language API. The end
36 result is a quicker CGI script turnaround process, since no external
37 Perl interpreter has to be started.
38
39 %description -l pl
40 Mod_perl jest modu³em, który wyposa¿a serwer Apache w interpreter
41 perla, umo¿liwiaj±c w ten sposób bezpo¶rednie wykonywanie kodu perla
42 przez serwer bez potrzeby anga¿owania zewnêtrznego interpretera, co
43 przyspiesza procesy zwi±zane z uruchamianiem skryptów CGI.
44
45 %prep
46 %setup  -q -n mod_perl-%{version}
47 %patch0 -p1
48 %patch1 -p1
49
50 %build
51 perl Makefile.PL \
52         USE_APXS=1 \
53         WITH_APXS=%{_sbindir}/apxs \
54         EVERYTHING=1 \
55         PERL_STACKED_HANDLERS=1
56
57 (cd apaci; ln -s ../src/modules .; chmod +x find_source)
58 %{__make}
59
60 (cd faq; make)
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{_libdir}/apache,/home/httpd/html/manual/mod}
65
66 %{__make} pure_install DESTDIR=$RPM_BUILD_ROOT
67         
68 install -m 755 apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache
69 install htdocs/manual/mod/mod_perl.html \
70         $RPM_BUILD_ROOT/home/httpd/html/manual/mod
71
72 find $RPM_BUILD_ROOT -name \*.so -exec strip --strip-unneeded {} \;
73
74 (
75         cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/mod_perl/
76         mv .packlist .packlist.old
77         sed -e "s|$RPM_BUILD_ROOT||g" < .packlist.old > .packlist
78         rm -f .packlist.old
79 )
80
81 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
82         README INSTALL ToDo
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post
88 %{_sbindir}/apxs -e -a -n perl %{_libexecdir}/libperl.so 1>&2
89 if [ -f /var/lock/subsys/httpd ]; then
90    /etc/rc.d/init.d/httpd restart 1>&2
91 fi
92
93 %preun
94 %{_sbindir}/apxs -e -A -n perl %{_libexecdir}/libperl.so 1>&2
95
96 if [ -f /var/lock/subsys/httpd ]; then
97         /etc/rc.d/init.d/httpd stop 1>&2
98 fi
99
100
101 %files
102 %defattr(644,root,root,755)
103 %doc {README,INSTALL,ToDo}.gz faq/*.html apache-modlist.html eg
104 %doc /home/httpd/html/manual/mod/*html
105
106 %attr(755,root,root) %{_libdir}/apache/*.so
107
108 %{perl_sitearch}/*.pm
109 %{perl_sitearch}/*.pod
110 %{perl_sitearch}/*.PL
111
112 %{perl_sitearch}/Apache/*.pm
113 %{perl_sitearch}/Apache/Constants
114 %{perl_sitearch}/Bundle/*.pm
115 %{perl_sitearch}/auto/mod_perl
116 %dir %{perl_sitearch}/auto/Apache/Leak
117 %dir %{perl_sitearch}/auto/Apache/Symbol
118
119 %{perl_sitearch}/auto/*/*/*.bs
120 %attr(755,root,root) %{perl_sitearch}/auto/*/*/*.so
121
122 %{_mandir}/man3/*
This page took 0.031764 seconds and 3 git commands to generate.