]> git.pld-linux.org Git - packages/apache-mod_fastcgi.git/blob - apache-mod_fastcgi.spec
- fix broken %post, rel. 4
[packages/apache-mod_fastcgi.git] / apache-mod_fastcgi.spec
1 %define         mod_name        fastcgi
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Support for the FastCGI protocol for apache webserver
4 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
5 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
6 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
7 Name:           apache-mod_%{mod_name}
8 # NOTE: remember about apache1-mod_fastcgi.spec when messing here
9 Version:        2.4.2
10 Release:        4
11 License:        distributable
12 Group:          Networking/Daemons
13 Source0:        http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
15 Patch0:         %{name}-allow-uid-gid.patch
16 Source1:        %{name}.conf
17 URL:            http://www.FastCGI.com/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2
20 BuildRequires:  libtool
21 Requires(post,preun):   %{apxs}
22 Requires:       apache >= 2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
27
28 %description
29 This 3rd party module provides support for the FastCGI protocol.
30 FastCGI is a language independent, scalable, open extension to CGI
31 that provides high performance and persistence without the limitations
32 of server specific APIs.
33
34 %description -l pl
35 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
36 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
37 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
38
39 %description -l ru
40 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
41 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
42 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
43
44 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
45
46 %description -l uk
47 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
48 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
49 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
50
51 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
52
53 %prep
54 %setup -q -n mod_%{mod_name}-%{version}
55 %patch0 -p1
56
57 %build
58 %{__make} -f Makefile.AP2 \
59         top_dir=%{_pkglibdir} \
60         INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
65
66 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
67 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 if [ -f /var/lock/subsys/httpd ]; then
74         /etc/rc.d/init.d/httpd restart 1>&2
75 else
76         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
77 fi
78  
79 %preun
80 if [ "$1" = "0" ]; then
81         if [ -f /var/lock/subsys/httpd ]; then
82                 /etc/rc.d/init.d/httpd restart 1>&2
83         fi
84 fi
85  
86 %files
87 %defattr(644,root,root,755)
88 %doc docs/LICENSE.TERMS CHANGES docs/*.html
89 %attr(755,root,root) %{_pkglibdir}/*.so
90 %config %{_sysconfdir}/httpd.conf/*.conf
This page took 0.058592 seconds and 4 git commands to generate.