]> git.pld-linux.org Git - SPECS.git/blob - apache-mod_auth_xradius.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / apache-mod_auth_xradius.spec
1 #
2 %define         mod_name        auth_xradius
3 %define         apxs            %{_sbindir}/apxs
4 Summary:        Apache module:
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4.6
7 Release:        5
8 License:        GPL
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://www.outoforder.cc/downloads/mod_auth_xradius/mod_auth_xradius-%{version}.tar.bz2
11 # Source0-md5:  eeecc96f15dec9fe0a9c78c0b022903d
12 Source1:        %{name}.conf
13 Patch0:         mod_auth_xradius-unixd.patch
14 URL:            http://www.outoforder.cc/projects/apache/mod_auth_xradius/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.2
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires:       apache(modules-api) = %apache_modules_api
19 Requires:       apache-mod_auth_basic >= 2.2
20 Requires:       apache-mod_authz_user >= 2.2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
25
26 %description
27 mod_auth_xradius provides high performance authentication against RFC
28 2865 RADIUS Servers. Features:
29 - Supports popular RADIUS Servers including OpenRADIUS, FreeRADIUS and
30   commercial servers.
31 - Distributed Authentication Cache using apr_memcache.
32 - Local Authentication Cache using DBM.
33 - Uses standard HTTP Basic Authentication, unlike mod_auth_radius
34   which uses cookies for sessions.
35
36 %prep
37 %setup -q -n mod_%{mod_name}-%{version}
38 %patch0 -p1
39
40 %build
41 %configure
42
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %service -q httpd restart
59
60 %postun
61 if [ "$1" = "0" ]; then
62         %service -q httpd restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
69 %attr(755,root,root) %{_pkglibdir}/*
This page took 1.292747 seconds and 3 git commands to generate.