]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blob - apache-mod_auth_any.spec
9789cb2de2765fae6526d6091bbb90e37d81b614
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
1 %define mod_name        auth_any
2 %define apxs            /usr/sbin/apxs
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí shellových pøíkazù
5 Summary(da):    En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de):    Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it):    Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(nb):    En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl):    Podstawowy modu³ uwierzytelnienia dla Apache, u¿ywaj±cy poleceñ pow³oki
11 Summary(pt):    Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl):    Osnovna avtentikacija za spletni stre¾nik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv):    Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache-mod_%{mod_name}
15 Version:        1.2.2
16 Release:        1
17 Epoch:          1
18 License:        BSD
19 Group:          Networking/Daemons
20 Source0:        http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}-apache2.tar.gz
21 # Source0-md5:  e9a1825b818d108e1204692da3d7bfd0
22 URL:            http://www.itlab.musc.edu/webNIS/mod_auth_any.html
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache-devel >= 2.0
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires:       apache(modules-api) = %apache_modules_api
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
30 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
31
32 %description
33 This module allows you to use any command line program (such as
34 webNIS) to authenticate a user.
35
36 %description -l cs
37 Balíèek mod_auth_any slou¾í pro omezení pøístupu k dokumentùm, které
38 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
39 jakéhokoliv pøíkazu (jeho návratovým kódem).
40
41 %description -l de
42 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
43 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
44 gegebenen arbiträren Befehls prüft.
45
46 %description -l es
47 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
48 desde un servidor web verificando el código de retorno de un comando
49 arbitrario especificado.
50
51 %description -l fr
52 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
53 servis par un serveur Web en vérifiant le code de retour d'une
54 commande spécifiée arbitraire.
55
56 %description -l it
57 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
58 serviti da un server Web controllando il codice di ritorno di un dato
59 comando arbitrario.
60
61 %description -l ja
62 Mod_auth_any ¤ÏǤ°Õ¤Ë»ØÄꤵ¤ì¤¿¥³¥Þ¥ó¥É¤ÎÌá¤ê¥³¡¼¥É¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
63 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
64 ¤¬¤Ç¤­¤Þ¤¹¡£
65
66 %description -l pl
67 Ten modu³ pozwala na u¿ycie dowolnego programu dzia³aj±cego z linii
68 poleceñ (jak np. webNIS) do uwierzytelniania u¿ytkownika.
69
70 %description -l sv
71 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
72 servade av en webbserver genom att kontrollera returkoden från ett
73 godtyckligt angivet kommando.
74
75 %prep
76 %setup -q -n mod_%{mod_name}-%{version}-apache2
77
78 %build
79 %{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.la
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
84
85 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
86 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
87         $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 %service -q httpd restart
94
95 %postun
96 if [ "$1" = "0" ]; then
97         %service -q httpd restart
98 fi
99
100 %files
101 %defattr(644,root,root,755)
102 %doc docs/*
103 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
104 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.045615 seconds and 3 git commands to generate.