]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
add hack to workaround moronic version detection; rel 2
[packages/aom.git] / aom.spec
1 %bcond_with     wxwidgets
2
3 Summary:        Royalty-free next-generation video format
4 Name:           aom
5 Version:        1.0.0
6 Release:        2
7 License:        BSD
8 Group:          Libraries
9 URL:            http://aomedia.org/
10 # Source0:      https://aomedia.googlesource.com/aom/+archive/v%{version}.tar.gz
11 Source0:        v%{version}.tar.gz
12 # Source0-md5:  dd4689f0425e55dbc255eab73989dca5
13 Patch0:         %{name}-build.patch
14 BuildRequires:  cmake
15 BuildRequires:  doxygen
16 BuildRequires:  graphviz
17 BuildRequires:  libstdc++-devel
18 %{?with_wxwidgets:BuildRequires:        wxGTK3-devel}
19 BuildRequires:  yasm
20
21 %description
22 The Alliance for Open Media's focus is to deliver a next-generation
23 video format that is:
24
25  - Interoperable and open;
26  - Optimized for the Internet;
27  - Scalable to any modern device at any bandwidth;
28  - Designed with a low computational footprint and optimized for
29    hardware;
30  - Capable of consistent, highest-quality, real-time video delivery;
31    and
32  - Flexible for both commercial and non-commercial content, including
33    user-generated content.
34
35 %package devel
36 Summary:        Development files for aom
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Development files for aom the royalty-free next-generation video
42 format.
43
44 %prep
45 %setup -qc
46 %patch0 -p1
47
48 %{__sed} -i -e 's/v0\.1\.0/v%{version}/' CHANGELOG
49
50 %build
51 install -d build; cd build
52 %cmake \
53    -DLIB_INSTALL_DIR=%{_libdir} \
54    -DENABLE_CCACHE=1 \
55    -DCMAKE_SKIP_RPATH=1 \
56 %ifnarch aarch64 %{arm} %{ix86} x86_64
57    -DAOM_TARGET_CPU=generic \
58 %endif
59 %ifarch %{arm}
60    -DAOM_TARGET_CPU=arm \
61 %endif
62 %ifarch aarch64
63    -DAOM_TARGET_CPU=arm64 \
64 %endif
65 %ifarch %{ix86}
66    -DAOM_TARGET_CPU=x86 \
67 %endif
68 %ifarch x86_64
69    -DAOM_TARGET_CPU=x86_64 \
70 %endif
71    -DCONFIG_WEBM_IO=1 \
72    -DENABLE_DOCS=1 \
73    %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
74    ..
75
76 %{__make}
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %{?with_wxwidgets:install -pm 0755 build/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS CHANGELOG README.md PATENTS
96 %{?with_wxwidgets:%attr(755,root,root) %{_bindir}/aomanalyzer}
97 %attr(755,root,root) %{_bindir}/aomdec
98 %attr(755,root,root) %{_bindir}/aomenc
99 %attr(755,root,root) %{_libdir}/libaom.so.0
100
101 %files devel
102 %defattr(644,root,root,755)
103 %doc build/docs/html
104 %{_includedir}/%{name}
105 %attr(755,root,root) %{_libdir}/libaom.so
106 %{_pkgconfigdir}/%{name}.pc
This page took 0.094603 seconds and 4 git commands to generate.