]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
- use dropin
[packages/aom.git] / aom.spec
1 #
2 # Conditional build:
3 %bcond_without  wxwidgets       # wxWidgets based analyzer
4
5 Summary:        Royalty-free next-generation video format
6 Summary(pl.UTF-8):      Format wideo nowej generacji bez opłat licencyjnych
7 Name:           aom
8 %define basever 1.0.0
9 %define subver  errata1
10 Version:        %{basever}.%{subver}
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 # tarball is recreated with different md5 on each download
15 #Source0:       https://aomedia.googlesource.com/aom/+archive/v%{basever}-%{subver}.tar.gz?fake=/%{name}-%{version}.tar.gz
16 Source0:        %{name}-%{version}.tar.gz
17 # Source0-md5:  5b22f5d026057ded5339bd17fd214e8a
18 Patch0:         %{name}-build.patch
19 URL:            https://aomedia.org/
20 BuildRequires:  cmake >= 3.5
21 BuildRequires:  doxygen
22 BuildRequires:  graphviz
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  sed >= 4.0
25 %{?with_wxwidgets:BuildRequires:        wxGTK3-unicode-devel}
26 BuildRequires:  yasm
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Alliance for Open Media's focus is to deliver a next-generation
31 video format that is:
32 - Interoperable and open;
33 - Optimized for the Internet;
34 - Scalable to any modern device at any bandwidth;
35 - Designed with a low computational footprint and optimized for
36   hardware;
37 - Capable of consistent, highest-quality, real-time video delivery;
38   and
39 - Flexible for both commercial and non-commercial content, including
40   user-generated content.
41
42 %description -l pl.UTF-8
43 Celem Alliance for Open Media jest dostarczenie nowej generacji
44 formatu wideo, który jest:
45 - interoperacyjny i otwarty
46 - zoptymalizowany dla Internetu
47 - skalowalny na dowolne współczesne urządzenie przy dowolnym paśmie
48 - zaprojektowany z myślą o małym narzucie obliczeniowym,
49   zoptymalizowany dla sprzętu
50 - umożliwiający spójne udostępnianie wysokiej jakości obrazu w czasie
51   rzeczywistym
52 - elastyczny zarówno dla treści komercyjnych, jak i niekomercyjnych, w
53   tym wygenerowanych przez użytkownika.
54
55 %package devel
56 Summary:        Development files for AOM
57 Summary(pl.UTF-8):      Pliki programistyczne AOM
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description devel
62 Development files for AOM the royalty-free next-generation video
63 format.
64
65 %description devel -l pl.UTF-8
66 Pliki programistyczne AOM - formatu obrazu nowej generacji, bez opłat
67 licencyjnych.
68
69 %package gui
70 Summary:        Graphical analyzer for AOM
71 Summary(pl.UTF-8):      Graficzny analizator formatu AOM
72 Group:          X11/Applications/Multimedia
73 Requires:       %{name} = %{version}-%{release}
74
75 %description gui
76 Graphical analyzer for AOM.
77
78 %description gui -l pl.UTF-8
79 Graficzny analizator formatu AOM.
80
81 %prep
82 %setup -qc
83 %patch0 -p1
84
85 %{__sed} -i -e 's/^Next Release/v%{version}/' CHANGELOG
86
87 %build
88 install -d builddir
89 cd builddir
90 %cmake .. \
91         -DLIB_INSTALL_DIR=%{_libdir} \
92 %ifnarch aarch64 %{arm} %{ix86} %{x8664}
93         -DAOM_TARGET_CPU=generic \
94 %endif
95 %ifarch %{arm}
96         -DAOM_TARGET_CPU=arm \
97 %endif
98 %ifarch aarch64
99         -DAOM_TARGET_CPU=arm64 \
100 %endif
101 %ifarch %{ix86}
102         -DAOM_TARGET_CPU=x86 \
103 %endif
104 %ifarch %{x8664}
105         -DAOM_TARGET_CPU=x86_64 \
106 %endif
107         -DCMAKE_SKIP_RPATH=1 \
108         %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
109         -DCONFIG_WEBM_IO=1 \
110         -DENABLE_CCACHE=1 \
111         -DENABLE_DOCS=1 \
112         -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk3-unicode-config
113
114 %{__make}
115
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} -C builddir install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{?with_wxwidgets:install -pm 0755 builddir/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS CHANGELOG LICENSE PATENTS README.md
134 %attr(755,root,root) %{_bindir}/aomdec
135 %attr(755,root,root) %{_bindir}/aomenc
136 %attr(755,root,root) %{_libdir}/libaom.so.0
137
138 %files devel
139 %defattr(644,root,root,755)
140 %doc builddir/docs/html/*
141 %attr(755,root,root) %{_libdir}/libaom.so
142 %{_includedir}/aom
143 %{_pkgconfigdir}/aom.pc
144
145 %if %{with wxwidgets}
146 %files gui
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/aomanalyzer
149 %endif
This page took 0.128774 seconds and 3 git commands to generate.