]> git.pld-linux.org Git - packages/aom.git/blob - aom.spec
3f2cc4b00d6eb0cb0d838139ca303dca536c0a27
[packages/aom.git] / aom.spec
1 #
2 # Conditional build:
3 %bcond_without  wxwidgets       # wxWidgets based analyzer
4
5 Summary:        Royalty-free next-generation video format
6 Summary(pl.UTF-8):      Format wideo nowej generacji bez opłat licencyjnych
7 Name:           aom
8 %define basever 1.0.0
9 %define subver  errata1
10 Version:        %{basever}.%{subver}
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 Source0:        https://aomedia.googlesource.com/aom/+archive/v%{basever}-%{subver}.tar.gz?fake=/%{name}-%{version}.tar.gz
15 # Source0-md5:  5b22f5d026057ded5339bd17fd214e8a
16 Patch0:         %{name}-build.patch
17 URL:            https://aomedia.org/
18 BuildRequires:  cmake >= 3.5
19 BuildRequires:  doxygen
20 BuildRequires:  graphviz
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  sed >= 4.0
23 %{?with_wxwidgets:BuildRequires:        wxGTK3-unicode-devel}
24 BuildRequires:  yasm
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Alliance for Open Media's focus is to deliver a next-generation
29 video format that is:
30 - Interoperable and open;
31 - Optimized for the Internet;
32 - Scalable to any modern device at any bandwidth;
33 - Designed with a low computational footprint and optimized for
34   hardware;
35 - Capable of consistent, highest-quality, real-time video delivery;
36   and
37 - Flexible for both commercial and non-commercial content, including
38   user-generated content.
39
40 %description -l pl.UTF-8
41 Celem Alliance for Open Media jest dostarczenie nowej generacji
42 formatu wideo, który jest:
43 - interoperacyjny i otwarty
44 - zoptymalizowany dla Internetu
45 - skalowalny na dowolne współczesne urządzenie przy dowolnym paśmie
46 - zaprojektowany z myślą o małym narzucie obliczeniowym,
47   zoptymalizowany dla sprzętu
48 - umożliwiający spójne udostępnianie wysokiej jakości obrazu w czasie
49   rzeczywistym
50 - elastyczny zarówno dla treści komercyjnych, jak i niekomercyjnych, w
51   tym wygenerowanych przez użytkownika.
52
53 %package devel
54 Summary:        Development files for AOM
55 Summary(pl.UTF-8):      Pliki programistyczne AOM
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description devel
60 Development files for AOM the royalty-free next-generation video
61 format.
62
63 %description devel -l pl.UTF-8
64 Pliki programistyczne AOM - formatu obrazu nowej generacji, bez opłat
65 licencyjnych.
66
67 %package gui
68 Summary:        Graphical analyzer for AOM
69 Summary(pl.UTF-8):      Graficzny analizator formatu AOM
70 Group:          X11/Applications/Multimedia
71 Requires:       %{name} = %{version}-%{release}
72
73 %description gui
74 Graphical analyzer for AOM.
75
76 %description gui -l pl.UTF-8
77 Graficzny analizator formatu AOM.
78
79 %prep
80 %setup -qc
81 %patch0 -p1
82
83 %{__sed} -i -e 's/^Next Release/v%{version}/' CHANGELOG
84
85 %build
86 install -d builddir
87 cd builddir
88 %cmake .. \
89         -DLIB_INSTALL_DIR=%{_libdir} \
90 %ifnarch aarch64 %{arm} %{ix86} %{x8664}
91         -DAOM_TARGET_CPU=generic \
92 %endif
93 %ifarch %{arm}
94         -DAOM_TARGET_CPU=arm \
95 %endif
96 %ifarch aarch64
97         -DAOM_TARGET_CPU=arm64 \
98 %endif
99 %ifarch %{ix86}
100         -DAOM_TARGET_CPU=x86 \
101 %endif
102 %ifarch %{x8664}
103         -DAOM_TARGET_CPU=x86_64 \
104 %endif
105         -DCMAKE_SKIP_RPATH=1 \
106         %{?with_wxwidgets:-DCONFIG_ANALYZER=1} \
107         -DCONFIG_WEBM_IO=1 \
108         -DENABLE_CCACHE=1 \
109         -DENABLE_DOCS=1 \
110         -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk3-unicode-config
111
112 %{__make}
113
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} -C builddir install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %{?with_wxwidgets:install -pm 0755 builddir/examples/analyzer $RPM_BUILD_ROOT%{_bindir}/aomanalyzer}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS CHANGELOG LICENSE PATENTS README.md
132 %attr(755,root,root) %{_bindir}/aomdec
133 %attr(755,root,root) %{_bindir}/aomenc
134 %attr(755,root,root) %{_libdir}/libaom.so.0
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc builddir/docs/html/*
139 %attr(755,root,root) %{_libdir}/libaom.so
140 %{_includedir}/aom
141 %{_pkgconfigdir}/aom.pc
142
143 %if %{with wxwidgets}
144 %files gui
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/aomanalyzer
147 %endif
This page took 0.138349 seconds and 3 git commands to generate.