]> git.pld-linux.org Git - packages/anyterm.git/blob - anyterm.spec
- Epoch: 0, rel 0.1 if it doesn't work
[packages/anyterm.git] / anyterm.spec
1 %define         apxs            /usr/sbin/apxs
2 Summary:        Terminal emulator in a web browser
3 Name:           anyterm
4 Version:        1.1.4
5 Release:        0.1
6 Epoch:          0
7 License:        GPL
8 Group:          Networking/Daemons
9 Source0:        http://anyterm.org/download/%{name}-%{version}.tbz2
10 # Source0-md5:  cf841703b7438866e573f5a33137ff6f
11 Patch0:         %{name}-makefile.patch
12 URL:            http://anyterm.org/
13 BuildRequires:  apache-devel >= 2.0.52-2
14 BuildRequires:  apr-devel
15 BuildRequires:  rote-devel >= 0.2.8
16 BuildRequires:  rpmbuild(macros) >= 1.194
17 BuildRequires:  %{apxs}
18 Requires:       apache >= 2.0.52-2
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _httpdir        %{_datadir}/%{name}
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir /etc/httpd
24
25 %description
26 An apache module plus scripts to make a terminal within a web browser.
27
28 %prep
29 %setup -q
30 %patch0 -p1
31
32 %build
33 rm -rf $RPM_BUILD_ROOT
34 cd apachemod
35 %{__make} \
36         INCLUDES='-I%{_includedir}/apr-util' \
37         APXS2=apxs \
38         APR_CONFIG=apr-1-config
39 cd ..
40 cd anygetty
41 %{__make}
42 cd ..
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/httpd.conf,%{_pkglibdir},%{_mandir}/man8,%{_httpdir}}
47
48 cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_anyterm.conf <<END
49 LoadModule anyterm modules/%{name}.so
50 Alias /%{name} "%{_httpdir}/%{name}"
51 anyterm_command '%{_sbindir}/anygetty --remotehost "Anyterm: %h"'
52 END
53
54 install apachemod/.libs/%{name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{name}.so
55 cp -a browser $RPM_BUILD_ROOT/%{_httpdir}/%{name}
56 install anygetty/anygetty $RPM_BUILD_ROOT/%{_sbindir}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README
64 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*
65 %attr(755,root,root) %{_pkglibdir}/%{name}.so
66 %attr(755,root,root) %{_sbindir}/anygetty
67 %{_httpdir}/%{name}
68
69 %post
70 %banner %{name} <<EOF
71 For full function, setuid %{_sbindir}/anygetty.
72 EOF
This page took 0.06313 seconds and 4 git commands to generate.