]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- fix building with mpeg4ip >= 1.6
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 # - karma & MFS (see README)
10 # - ProjectM (see README)
11 #
12 # Conditional builds:
13 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
14 %bcond_without  mas             # disable MAS audio backend
15 %bcond_without  xine            # disable xine engine
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
18 %bcond_without  helix           # disable HelixPlayer engine
19 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
20 %bcond_with     nmm             # enable NMM audio backend
21 %bcond_with     mysql           # enable MySQL support
22 %bcond_with     pgsql           # enable PostgreSQL support
23 #
24 %ifarch i386
25 %undefine       with_helix
26 %endif
27
28 Summary:        A KDE audio player
29 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
30 Name:           amarok
31 Version:        1.4.7
32 Release:        5
33 License:        GPL
34 Group:          X11/Applications/Multimedia
35 Source0:        ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  f1299e142da8a69bc3cff5d585e38d43
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         %{name}-sparc.patch
41 Patch4:         kde-ac260-lt.patch
42 Patch5:         kde-common-PLD.patch
43 Patch6:         %{name}-gcc4.patch
44 Patch7:         %{name}-titleorder.patch
45 Patch8:         %{name}-mpeg4ip.patch
46 URL:            http://amarok.kde.org/
47 BuildRequires:  SDL-devel
48 BuildRequires:  alsa-lib-devel
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  dbus-glib-devel
52 BuildRequires:  gettext-devel
53 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
54 BuildRequires:  kdebase-devel
55 %{?with_akode:BuildRequires:    kdemultimedia-akode}
56 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
57 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.4.2}
58 %{?with_mp3players:BuildRequires:       libifp-devel >= 1.0.0.2}
59 BuildRequires:  libltdl-devel
60 %{?with_mp3players:BuildRequires:       libmtp-devel >= 0.1.1}
61 %{?with_mp3players:BuildRequires:       libnjb-devel >= 2.2.4}
62 %{?with_pgsql:BuildRequires:            libpqxx-devel}
63 BuildRequires:  libtunepimp-devel >= 0.5.1-6
64 BuildRequires:  libvisual-devel >= 0.4.0
65 BuildRequires:  mpeg4ip-devel >= 1:1.6
66 %{?with_mysql:BuildRequires:            mysql-devel}
67 BuildRequires:  pcre-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  rpm-pythonprov
70 BuildRequires:  rpmbuild(macros) >= 1.129
71 BuildRequires:  ruby-devel >= 1.8
72 BuildRequires:  sed >= 4.0
73 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
74 BuildRequires:  taglib-devel >= 1.4
75 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
76 Requires(post): /sbin/ldconfig
77 Requires:       %{name}-plugin = %{version}-%{release}
78 Requires:       kdebase-core >= 9:3.1.93
79 Requires:       kdemultimedia-audiocd >= 9:3.1.93
80 Suggests:       libvisual-plugin-actor-JESS
81 Suggests:       libvisual-plugin-actor-bumpscope
82 Suggests:       libvisual-plugin-actor-corona
83 Suggests:       libvisual-plugin-actor-flower
84 Suggests:       libvisual-plugin-actor-gdkpixbuf
85 Suggests:       libvisual-plugin-actor-gforce
86 Suggests:       libvisual-plugin-actor-gstreamer
87 Suggests:       libvisual-plugin-actor-infinite
88 Suggests:       libvisual-plugin-actor-jakdaw
89 Suggests:       libvisual-plugin-actor-lv_analyzer
90 Suggests:       libvisual-plugin-actor-lv_gltest
91 Suggests:       libvisual-plugin-actor-lv_scope
92 Suggests:       libvisual-plugin-actor-madspin
93 Suggests:       libvisual-plugin-actor-nastyfft
94 Suggests:       libvisual-plugin-actor-oinksie
95 Suggests:       libvisual-plugin-input-alsa
96 Suggests:       libvisual-plugin-input-esd
97 Suggests:       libvisual-plugin-input-jack
98 Suggests:       libvisual-plugin-input-mplayer
99 Suggests:       libvisual-plugin-morph-alphablend
100 Suggests:       libvisual-plugin-morph-flash
101 Suggests:       libvisual-plugin-morph-slide
102 Suggests:       libvisual-plugin-morph-tentacle
103 Obsoletes:      amarok-arts
104 Obsoletes:      amarok-xmms
105 # sr@Latn vs. sr@latin
106 Conflicts:      glibc-misc < 6:2.7
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
110 %define         filterout_ld    -Wl,--as-needed
111
112 %description
113 A KDE audio player.
114
115 %description -l pl.UTF-8
116 Odtwarzacz audio dla KDE.
117
118 %package akode
119 Summary:        Plugin akode
120 Summary(pl.UTF-8):      Wtyczka akode
121 Group:          X11/Applications/Multimedia
122 Requires:       %{name} = %{version}-%{release}
123 Provides:       %{name}-plugin = %{version}-%{release}
124
125 %description akode
126 Plugin akode.
127
128 %description akode -l pl.UTF-8
129 Wtyczka akode.
130
131 %package helix
132 Summary:        Helix/Realplayer playback support for amarok
133 Summary(pl.UTF-8):      Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
134 Group:          X11/Applications/Multimedia
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       helix-core
137 Provides:       %{name}-plugin = %{version}-%{release}
138
139 %description helix
140 Helix/Realplayer playback support for amarok.
141
142 %description helix -l pl.UTF-8
143 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
144
145 %package gstreamer
146 Summary:        Plugin gstreamer
147 Summary(pl.UTF-8):      Wtyczka gstreamer
148 Group:          X11/Applications/Multimedia
149 # deps, to get it working:
150 # mp3 decoder:  gstreamer-mad
151 # ogg decoder:  gstreamer-vorbis
152 # audio output driver:  gstreamer-audiosink-alsa
153 # from gstreamer-audio-effects to control volume, etc
154 # needed libs:
155 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
156 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
157 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
158 # gstreamer-musicbrainz for being able to edit id3 tags on files.
159 Requires:       %{name} = %{version}-%{release}
160 Requires:       gstreamer-audio-effects
161 Requires:       gstreamer-audiosink
162 Requires:       gstreamer-mad
163 Requires:       gstreamer-musicbrainz
164 Requires:       gstreamer-vorbis
165 Provides:       %{name}-plugin = %{version}-%{release}
166
167 %description gstreamer
168 Plugin gstreamer.
169
170 %description gstreamer -l pl.UTF-8
171 Wtyczka gstreamer.
172
173 %package xine
174 Summary:        Plugin xine
175 Summary(pl.UTF-8):      Wtyczka xine
176 Group:          X11/Applications/Multimedia
177 Requires:       %{name} = %{version}-%{release}
178 Requires:       xine-plugin-audio
179 Provides:       %{name}-plugin = %{version}-%{release}
180
181 %description xine
182 Plugin xine.
183
184 %description xine -l pl.UTF-8
185 Wtyczka xine.
186
187 %package zeroconf
188 Summary:        Zeroconf data
189 Summary(pl.UTF-8):      Dane dla zeroconf
190 Group:          X11/Applications/Multimedia
191 Requires:       %{name} = %{version}-%{release}
192 Requires:       kdenetwork-kdnssd
193 Provides:       %{name}-plugin = %{version}-%{release}
194
195 %description zeroconf
196 Zeroconf data.
197
198 %description zeroconf -l pl.UTF-8
199 Dane dla zeroconf.
200
201 %package scripts
202 Summary:        amaroK scripts
203 Summary(pl.UTF-8):      Skrypty amaroKa
204 Group:          X11/Applications/Multimedia
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       kdebase-kdialog
207 Requires:       python-PyQt
208 Requires:       ruby-modules
209
210 %description scripts
211 amaroK scripts allow you extend amaroK functionality.
212
213 You can learn more about scripts in amaroK from here:
214 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
215
216 %description scripts -l pl.UTF-8
217 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
218
219 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
220 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
221
222 %prep
223 %setup -q
224 %patch0 -p1
225 %patch1 -p1
226 %patch2 -p1
227 %patch3 -p1
228 %patch4 -p1
229 %patch5 -p1
230 %patch6 -p1
231 %patch7 -p1
232 %patch8 -p1
233
234 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
235         amarok/src/amarok.desktop \
236
237 # see kde bug #110909
238 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
239
240 # kill env, call interpreter directly, so rpm automatics could rule
241 %{__sed} -i -e '
242         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
243         1s,#!.*bin/env.*python,#!%{__python},
244 ' amarok/src/scripts/*/*.{py,rb} amarok/src/amarok_proxy.rb
245
246 %build
247 cp -f /usr/share/automake/config.sub admin
248 %{__make} -f admin/Makefile.common cvs
249
250 # hack: passing something other than "no" or "yes" to --with-helix allows
251 # us to pass HELIX_LIBS
252 %configure \
253         HELIX_LIBS=%{_libdir}/helixplayer \
254         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
255         --disable-rpath \
256         --with%{!?with_mas:out}-mas \
257         --with%{!?with_xine:out}-xine \
258         --with%{!?with_gstreamer:out}-gstreamer10 \
259         --with%{!?with_akode:out}-akode \
260         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
261         --with%{!?with_nmm:out}-nmm \
262         --with%{!?with_mp3players:out}-libgpod \
263         --with%{!?with_mp3players:out}-libnjb \
264         --with%{!?with_mp3players:out}-libmtp \
265         --with%{!?with_mp3players:out}-ifp \
266         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
267         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
268         --disable-final \
269         --with-mp4v2 \
270         --with-qt-libraries=%{_libdir} \
271         --with%{!?with_included_sqlite:out}-included-sqlite
272
273 %{__make}
274
275 %install
276 rm -rf $RPM_BUILD_ROOT
277
278 %{__make} install \
279         DESTDIR=$RPM_BUILD_ROOT \
280         kde_htmldir=%{_kdedocdir} \
281         kde_libs_htmldir=%{_kdedocdir}
282
283 # remove bogus dir
284 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
285
286 rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
287 rm $RPM_BUILD_ROOT%{_libdir}/ruby_lib/libhttp11.la
288
289 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
290         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
291 %find_lang amarok --all-name --with-kde
292
293 %clean
294 rm -rf $RPM_BUILD_ROOT
295
296 %post -p /sbin/ldconfig
297
298 %postun -p /sbin/ldconfig
299
300 %files -f amarok.lang
301 %defattr(644,root,root,755)
302 %doc AUTHORS ChangeLog README
303 %attr(755,root,root) %{_bindir}/amarok
304 %attr(755,root,root) %{_bindir}/amarokapp
305 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
306 %attr(755,root,root) %{_bindir}/amarok_libvisual
307 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
308 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
309 %attr(755,root,root) %{_libdir}/libamarok.so
310 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
311 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
312 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
313 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
314 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
315 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
316 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
317 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
318 %dir %{_libdir}/ruby_lib
319 %{_libdir}/ruby_lib/http11.rb
320 %attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so
321 %attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
322 %dir %{_datadir}/apps/amarok
323 %dir %{_datadir}/apps/amarok/scripts
324 %{_datadir}/apps/amarok/ruby_lib
325 %{_datadir}/apps/amarok/*.rc
326 %{_datadir}/apps/amarok/data
327 %{_datadir}/apps/amarok/icons
328 %{_datadir}/apps/amarok/images
329 %{_datadir}/apps/amarok/themes
330 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
331 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
332 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
333 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
334 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
335 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
336 %{_datadir}/apps/profiles/amarok.profile.xml
337 %{_datadir}/config/amarokrc
338 %{_datadir}/config.kcfg/amarok.kcfg
339 %{_datadir}/services/amarok_generic-mediadevice.desktop
340 %{_datadir}/services/amarok_void-engine_plugin.desktop
341 %{_datadir}/services/amarok_daap-mediadevice.desktop
342 %{_datadir}/services/amarok_massstorage-device.desktop
343 %{_datadir}/services/amarok_nfs-device.desktop
344 %{_datadir}/services/amarok_smb-device.desktop
345 %{_datadir}/services/amaroklastfm.protocol
346 %{_datadir}/services/amarokitpc.protocol
347 %{_datadir}/services/amarokpcast.protocol
348 %{_datadir}/servicetypes/amarok_codecinstall.desktop
349 %{_datadir}/servicetypes/amarok_plugin.desktop
350 %{_desktopdir}/kde/amarok.desktop
351 %{_iconsdir}/*/*/apps/amarok.*
352 # TODO: move to subpackage
353 %if %{with mp3players}
354 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
355 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
356 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
357 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
358 %{_datadir}/services/amarok_ifp-mediadevice.desktop
359 %{_datadir}/services/amarok_ipod-mediadevice.desktop
360 %{_datadir}/services/amarok_mtp-mediadevice.desktop
361 %{_datadir}/services/amarok_njb-mediadevice.desktop
362 %endif
363
364 %if %{with akode}
365 %files akode
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
368 %{_datadir}/services/amarok_aKode-engine.desktop
369 %endif
370
371 %if %{with gstreamer}
372 %files gstreamer
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
375 %{_datadir}/config.kcfg/gstconfig.kcfg
376 %{_datadir}/services/amarok_gst10engine_plugin.desktop
377 %endif
378
379 %if %{with helix}
380 %files helix
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
383 %{_datadir}/config.kcfg/helixconfig.kcfg
384 %{_datadir}/services/amarok_helixengine_plugin.desktop
385 %endif
386
387 %if %{with xine}
388 %files xine
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
391 %{_datadir}/config.kcfg/xinecfg.kcfg
392 %{_datadir}/services/amarok_xine-engine.desktop
393 %endif
394
395 %if 0
396 %if %{with zeroconf}
397 %files zeroconf
398 %defattr(644,root,root,755)
399 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
400 %endif
401 %endif
402
403 %files scripts
404 %defattr(644,root,root,755)
405 %dir %{_datadir}/apps/amarok/scripts/common
406 %{_datadir}/apps/amarok/scripts/common/Publisher.py
407 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
408
409 %dir %{_datadir}/apps/amarok/scripts/templates
410 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
411 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
412 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
413
414 # amarok searches for executable programs for scripts
415 # to figure out which files need to have execute permission, use this
416 # find command:
417 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
418
419 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
420 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
421 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
422
423 %dir %{_datadir}/apps/amarok/scripts/playlist2html
424 %{_datadir}/apps/amarok/scripts/playlist2html/README
425 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
426 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
427 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
428
429 %dir %{_datadir}/apps/amarok/scripts/webcontrol
430 %{_datadir}/apps/amarok/scripts/webcontrol/README
431 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
432 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
433 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
434 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
435 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
436 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
437 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
438 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
439 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
440 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
441 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
442 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
443 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
444 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
445 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
446 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
447 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
448 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
449 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
450
451 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
452 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
453 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
454 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
455 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
456
457 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
458 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
459 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
460 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
461 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
462
463 %dir %{_datadir}/apps/amarok/scripts/score_default
464 %{_datadir}/apps/amarok/scripts/score_default/COPYING
465 %{_datadir}/apps/amarok/scripts/score_default/README
466 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
467 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
468 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
469 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
470 %{_datadir}/apps/amarok/scripts/score_impulsive/README
471 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
472 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
473
474 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
475 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
476
477 %if 0
478 %dir %{_datadir}/apps/amarok/scripts/amarok_live
479 %{_datadir}/apps/amarok/scripts/amarok_live/README
480 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
481 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
482 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
483 %endif
This page took 0.062254 seconds and 4 git commands to generate.