]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- use conflicts for kdelibs/base; rel 5
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 # - ProjectM (see README)
10 # - karma & MFS (see README)
11 #
12 # Conditional builds:
13 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
14 %bcond_without  mas             # disable MAS audio backend
15 %bcond_without  xine            # disable xine engine
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
18 %bcond_without  helix           # disable HelixPlayer engine
19 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
20 %bcond_with     nmm             # enable NMM audio backend
21 %bcond_with     mysql           # enable MySQL support
22 %bcond_with     pgsql           # enable PostgreSQL support
23 #
24 %ifarch i386
25 %undefine       with_helix
26 %endif
27
28 Summary:        A KDE audio player
29 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
30 Name:           amarok
31 Version:        1.4.10
32 Release:        5
33 License:        GPL
34 Group:          X11/Applications/Multimedia
35 Source0:        ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  3bdbf26181bf5e5925f48968caba7ac2
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         %{name}-sparc.patch
41 Patch4:         kde-ac260-lt.patch
42 Patch5:         kde-common-PLD.patch
43 Patch6:         %{name}-gcc4.patch
44 Patch7:         %{name}-titleorder.patch
45 Patch8:         %{name}-mongrel.patch
46 Patch9:         %{name}-libmtp.patch
47 URL:            http://amarok.kde.org/
48 BuildRequires:  SDL-devel
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  dbus-glib-devel
53 BuildRequires:  gettext-devel
54 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
55 BuildRequires:  kdebase-devel
56 %{?with_akode:BuildRequires:    kdemultimedia-akode}
57 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
58 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.6.0}
59 %{?with_mp3players:BuildRequires:       libifp-devel >= 1.0.0.2}
60 BuildRequires:  libltdl-devel
61 %{?with_mp3players:BuildRequires:       libmtp-devel >= 0.3.0}
62 %{?with_mp3players:BuildRequires:       libnjb-devel >= 2.2.4}
63 %{?with_pgsql:BuildRequires:            libpqxx-devel}
64 BuildRequires:  libtunepimp-devel >= 0.5.1-6
65 BuildRequires:  libvisual-devel >= 0.4.0
66 BuildRequires:  mpeg4ip-devel >= 1:1.6
67 %{?with_mysql:BuildRequires:            mysql-devel}
68 BuildRequires:  pcre-devel
69 BuildRequires:  pkgconfig
70 BuildRequires:  rpm-pythonprov
71 BuildRequires:  rpmbuild(macros) >= 1.129
72 BuildRequires:  ruby-devel >= 1.8
73 BuildRequires:  sed >= 4.0
74 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
75 BuildRequires:  taglib-devel >= 1.4
76 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
77 Requires(post): /sbin/ldconfig
78 Requires:       %{name}-plugin = %{version}-%{release}
79 Requires:       ruby-mongrel
80 Suggests:       kdemultimedia(audiocd) >= 9:3.1.93
81 Suggests:       libvisual-plugin-actor-JESS
82 Suggests:       libvisual-plugin-actor-bumpscope
83 Suggests:       libvisual-plugin-actor-corona
84 Suggests:       libvisual-plugin-actor-flower
85 Suggests:       libvisual-plugin-actor-gdkpixbuf
86 Suggests:       libvisual-plugin-actor-gforce
87 %{?with_gstreamer:Suggests:     libvisual-plugin-actor-gstreamer}
88 Suggests:       libvisual-plugin-actor-infinite
89 Suggests:       libvisual-plugin-actor-jakdaw
90 Suggests:       libvisual-plugin-actor-lv_analyzer
91 Suggests:       libvisual-plugin-actor-lv_gltest
92 Suggests:       libvisual-plugin-actor-lv_scope
93 Suggests:       libvisual-plugin-actor-madspin
94 Suggests:       libvisual-plugin-actor-nastyfft
95 Suggests:       libvisual-plugin-actor-oinksie
96 Suggests:       libvisual-plugin-input-alsa
97 Suggests:       libvisual-plugin-input-esd
98 Suggests:       libvisual-plugin-input-jack
99 Suggests:       libvisual-plugin-input-mplayer
100 Suggests:       libvisual-plugin-morph-alphablend
101 Suggests:       libvisual-plugin-morph-flash
102 Suggests:       libvisual-plugin-morph-slide
103 Suggests:       libvisual-plugin-morph-tentacle
104 Suggests:       python-PyKDE
105 Obsoletes:      amarok-arts
106 Obsoletes:      amarok-xmms
107 Conflicts:      kdelibs-libs < 9:3.5.9
108 # sr@Latn vs. sr@latin
109 Conflicts:      glibc-misc < 6:2.7
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
113 %define         filterout_ld    -Wl,--as-needed
114
115 %description
116 A KDE audio player.
117
118 %description -l pl.UTF-8
119 Odtwarzacz audio dla KDE.
120
121 %package akode
122 Summary:        Plugin akode
123 Summary(pl.UTF-8):      Wtyczka akode
124 Group:          X11/Applications/Multimedia
125 Requires:       %{name} = %{version}-%{release}
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description akode
129 Plugin akode.
130
131 %description akode -l pl.UTF-8
132 Wtyczka akode.
133
134 %package helix
135 Summary:        Helix/Realplayer playback support for amarok
136 Summary(pl.UTF-8):      Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
137 Group:          X11/Applications/Multimedia
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       helix-core
140 Provides:       %{name}-plugin = %{version}-%{release}
141
142 %description helix
143 Helix/Realplayer playback support for amarok.
144
145 %description helix -l pl.UTF-8
146 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
147
148 %package gstreamer
149 Summary:        Plugin gstreamer
150 Summary(pl.UTF-8):      Wtyczka gstreamer
151 Group:          X11/Applications/Multimedia
152 # deps, to get it working:
153 # mp3 decoder:  gstreamer-mad
154 # ogg decoder:  gstreamer-vorbis
155 # audio output driver:  gstreamer-audiosink-alsa
156 # from gstreamer-audio-effects to control volume, etc
157 # needed libs:
158 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
159 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
160 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
161 # gstreamer-musicbrainz for being able to edit id3 tags on files.
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       gstreamer-audio-effects
164 Requires:       gstreamer-audiosink
165 Requires:       gstreamer-mad
166 Requires:       gstreamer-musicbrainz
167 Requires:       gstreamer-vorbis
168 Provides:       %{name}-plugin = %{version}-%{release}
169
170 %description gstreamer
171 Plugin gstreamer.
172
173 %description gstreamer -l pl.UTF-8
174 Wtyczka gstreamer.
175
176 %package xine
177 Summary:        Plugin xine
178 Summary(pl.UTF-8):      Wtyczka xine
179 Group:          X11/Applications/Multimedia
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       xine-plugin-audio
182 Provides:       %{name}-plugin = %{version}-%{release}
183
184 %description xine
185 Plugin xine.
186
187 %description xine -l pl.UTF-8
188 Wtyczka xine.
189
190 %package zeroconf
191 Summary:        Zeroconf data
192 Summary(pl.UTF-8):      Dane dla zeroconf
193 Group:          X11/Applications/Multimedia
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       kdenetwork-kdnssd
196 Provides:       %{name}-plugin = %{version}-%{release}
197
198 %description zeroconf
199 Zeroconf data.
200
201 %description zeroconf -l pl.UTF-8
202 Dane dla zeroconf.
203
204 %package scripts
205 Summary:        amaroK scripts
206 Summary(pl.UTF-8):      Skrypty amaroKa
207 Group:          X11/Applications/Multimedia
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       kdebase-kdialog
210 Requires:       python-PyQt
211 Requires:       ruby-modules
212
213 %description scripts
214 amaroK scripts allow you extend amaroK functionality.
215
216 You can learn more about scripts in amaroK from here:
217 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
218
219 %description scripts -l pl.UTF-8
220 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
221
222 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
223 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
224
225 %prep
226 %setup -q
227 %patch0 -p1
228 %patch1 -p1
229 %patch2 -p1
230 %patch3 -p1
231 %patch4 -p1
232 %patch5 -p1
233 %patch6 -p1
234 %patch7 -p1
235 %patch8 -p1
236 %patch9 -p0
237
238 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
239         amarok/src/amarok.desktop \
240
241 # see kde bug #110909
242 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
243
244 # kill env, call interpreter directly, so rpm automatics could rule
245 %{__sed} -i -e '
246         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
247         1s,#!.*bin/env.*python,#!%{__python},
248 ' amarok/src/scripts/*/*.{py,rb} amarok/src/amarok_proxy.rb
249
250 %build
251 cp -f /usr/share/automake/config.sub admin
252 %{__make} -f admin/Makefile.common cvs
253
254 # hack: passing something other than "no" or "yes" to --with-helix allows
255 # us to pass HELIX_LIBS
256 %configure \
257         HELIX_LIBS=%{_libdir}/helixplayer \
258         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
259         --disable-rpath \
260         --with%{!?with_mas:out}-mas \
261         --with%{!?with_xine:out}-xine \
262         --with%{!?with_gstreamer:out}-gstreamer10 \
263         --with%{!?with_akode:out}-akode \
264         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
265         --with%{!?with_nmm:out}-nmm \
266         --with%{!?with_mp3players:out}-libgpod \
267         --with%{!?with_mp3players:out}-libnjb \
268         --with%{!?with_mp3players:out}-libmtp \
269         --with%{!?with_mp3players:out}-ifp \
270         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
271         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
272         --disable-final \
273         --with-mp4v2 \
274         --with-qt-libraries=%{_libdir} \
275         --with%{!?with_included_sqlite:out}-included-sqlite
276
277 %{__make}
278
279 %install
280 rm -rf $RPM_BUILD_ROOT
281
282 %{__make} install \
283         DESTDIR=$RPM_BUILD_ROOT \
284         ruby_rubylibdir=%{ruby_rubylibdir} \
285         kde_htmldir=%{_kdedocdir} \
286         kde_libs_htmldir=%{_kdedocdir}
287
288 # remove bogus dir
289 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
290
291 rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
292 rm $RPM_BUILD_ROOT%{_libdir}/libamarok.{so,la}
293
294 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
295         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
296 %find_lang amarok --all-name --with-kde
297
298 %clean
299 rm -rf $RPM_BUILD_ROOT
300
301 %post -p /sbin/ldconfig
302
303 %postun -p /sbin/ldconfig
304
305 %files -f amarok.lang
306 %defattr(644,root,root,755)
307 %doc AUTHORS ChangeLog README
308 %attr(755,root,root) %{_bindir}/amarok
309 %attr(755,root,root) %{_bindir}/amarokapp
310 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
311 %attr(755,root,root) %{_bindir}/amarok_libvisual
312 # used by last.fm and daap
313 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
314 # used by daap
315 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
316 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
317 %attr(755,root,root) %ghost %{_libdir}/libamarok.so.0
318 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
319 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
320 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
321 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
322 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
323 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
324 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
325 %dir %{_datadir}/apps/amarok
326 %dir %{_datadir}/apps/amarok/scripts
327 %{_datadir}/apps/amarok/*.rc
328 %{_datadir}/apps/amarok/data
329 %{_datadir}/apps/amarok/icons
330 %{_datadir}/apps/amarok/images
331 %{_datadir}/apps/amarok/themes
332 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
333 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
334 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
335 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
336 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
337 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
338 %{_datadir}/apps/profiles/amarok.profile.xml
339 %{_datadir}/config/amarokrc
340 %{_datadir}/config.kcfg/amarok.kcfg
341 %{_datadir}/services/amarok_generic-mediadevice.desktop
342 %{_datadir}/services/amarok_void-engine_plugin.desktop
343 %{_datadir}/services/amarok_daap-mediadevice.desktop
344 %{_datadir}/services/amarok_massstorage-device.desktop
345 %{_datadir}/services/amarok_nfs-device.desktop
346 %{_datadir}/services/amarok_smb-device.desktop
347 %{_datadir}/services/amaroklastfm.protocol
348 %{_datadir}/services/amarokitpc.protocol
349 %{_datadir}/services/amarokpcast.protocol
350 %{_datadir}/servicetypes/amarok_codecinstall.desktop
351 %{_datadir}/servicetypes/amarok_plugin.desktop
352 %{_desktopdir}/kde/amarok.desktop
353 %{_iconsdir}/*/*/apps/amarok.*
354
355 # TODO: move to subpackage
356 %dir %{ruby_rubylibdir}/amarok
357 # used by daap
358 %{ruby_rubylibdir}/amarok/codes.rb
359 # used by daap and lyrics_lyrc
360 %{ruby_rubylibdir}/amarok/debug.rb
361
362 # TODO: move to subpackage
363 %if %{with mp3players}
364 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
365 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
366 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
367 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
368 %{_datadir}/services/amarok_ifp-mediadevice.desktop
369 %{_datadir}/services/amarok_ipod-mediadevice.desktop
370 %{_datadir}/services/amarok_mtp-mediadevice.desktop
371 %{_datadir}/services/amarok_njb-mediadevice.desktop
372 %endif
373
374 %if %{with akode}
375 %files akode
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
378 %{_datadir}/services/amarok_aKode-engine.desktop
379 %endif
380
381 %if %{with gstreamer}
382 %files gstreamer
383 %defattr(644,root,root,755)
384 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
385 %{_datadir}/config.kcfg/gstconfig.kcfg
386 %{_datadir}/services/amarok_gst10engine_plugin.desktop
387 %endif
388
389 %if %{with helix}
390 %files helix
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
393 %{_datadir}/config.kcfg/helixconfig.kcfg
394 %{_datadir}/services/amarok_helixengine_plugin.desktop
395 %endif
396
397 %if %{with xine}
398 %files xine
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
401 %{_datadir}/config.kcfg/xinecfg.kcfg
402 %{_datadir}/services/amarok_xine-engine.desktop
403 %endif
404
405 %if 0
406 %if %{with zeroconf}
407 %files zeroconf
408 %defattr(644,root,root,755)
409 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
410 %endif
411 %endif
412
413 %files scripts
414 %defattr(644,root,root,755)
415 %dir %{_datadir}/apps/amarok/scripts/common
416 %{_datadir}/apps/amarok/scripts/common/Publisher.py
417 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
418
419 %dir %{_datadir}/apps/amarok/scripts/templates
420 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
421 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
422 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
423
424 # amarok searches for executable programs for scripts
425 # to figure out which files need to have execute permission, use this
426 # find command:
427 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
428
429 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
430 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
431 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
432
433 %dir %{_datadir}/apps/amarok/scripts/playlist2html
434 %{_datadir}/apps/amarok/scripts/playlist2html/README
435 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
436 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
437 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
438 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.spec
439 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.spec
440
441
442 %dir %{_datadir}/apps/amarok/scripts/webcontrol
443 %{_datadir}/apps/amarok/scripts/webcontrol/README
444 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
445 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
446 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
447 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
448 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
449 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
450 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
451 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
452 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
453 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
454 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
455 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
456 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
457 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
458 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
459 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
460 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
461 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
462 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
463
464 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
465 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
466 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
467 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
468 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
469
470 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
471 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
472 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
473 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
474 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
475
476 %dir %{_datadir}/apps/amarok/scripts/score_default
477 %{_datadir}/apps/amarok/scripts/score_default/COPYING
478 %{_datadir}/apps/amarok/scripts/score_default/README
479 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
480 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
481 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
482 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
483 %{_datadir}/apps/amarok/scripts/score_impulsive/README
484 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
485 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
486
487 %if 0
488 %dir %{_datadir}/apps/amarok/scripts/amarok_live
489 %{_datadir}/apps/amarok/scripts/amarok_live/README
490 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
491 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
492 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
493 %endif
This page took 0.05644 seconds and 4 git commands to generate.