]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- up to 1.3.9
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_without  helix           # disable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25 Summary:        A KDE audio player
26 Summary(pl):    Odtwarzacz audio dla KDE
27 Name:           amarok
28 Version:        1.3.9
29 Release:        1
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33 # Source0-md5:  fb4cb3dafd3d15657b78e24c33abcf76
34 Patch0:         kde-common-gcc4.patch
35 Patch1:         %{name}-lyricsurl.patch
36 Patch2:         %{name}-libtunepimp-0.4.0.patch
37 Patch3:         %{name}-helixplayer-morearchs.patch
38 URL:            http://amarok.kde.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  arts-qt-devel
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  gettext-devel
45 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
46 BuildRequires:  kdebase-devel
47 %{?with_akode:BuildRequires:    kdemultimedia-akode}
48 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
49 BuildRequires:  libltdl-devel
50 BuildRequires:  libtunepimp-devel >= 0.4.0
51 BuildRequires:  libvisual-devel >= 0.2.0
52 %{?with_pgsql:BuildRequires:            libpqxx-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 BuildRequires:  pcre-devel
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  rpmbuild(macros) >= 1.129
57 BuildRequires:  sed >= 4.0
58 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
59 BuildRequires:  taglib-devel >= 1.4
60 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
61 %{?with_xmms:BuildRequires:             xmms-devel}
62 Requires:       %{name}-plugin = %{version}-%{release}
63 Requires:       kdebase-core >= 9:3.1.93
64 Requires:       kdemultimedia-audiocd >= 9:3.1.93
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 A KDE audio player.
69
70 %description -l pl
71 Odtwarzacz audio dla KDE.
72
73 %package arts
74 Summary:        Plugin arts
75 Summary(pl):    Wtyczka arts
76 Group:          X11/Applications/Multimedia
77 Requires:       %{name} = %{version}-%{release}
78 Provides:       %{name}-plugin = %{version}-%{release}
79
80 %description arts
81 Plugin arts.
82
83 %description arts -l pl
84 Wtyczka arts.
85
86 %package akode
87 Summary:        Plugin akode
88 Summary(pl):    Wtyczka akode
89 Group:          X11/Applications/Multimedia
90 Requires:       %{name} = %{version}-%{release}
91 Provides:       %{name}-plugin = %{version}-%{release}
92
93 %description akode
94 Plugin akode.
95
96 %description akode -l pl
97 Wtyczka akode.
98
99 %package helix
100 Summary:        Helix/Realplayer playback support for amarok
101 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
102 Group:          X11/Applications/Multimedia
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       helix-core
105 Provides:       %{name}-plugin = %{version}-%{release}
106
107 %description helix
108 Helix/Realplayer playback support for amarok.
109
110 %description helix -l pl
111 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
112
113 %package gstreamer
114 Summary:        Plugin gstreamer
115 Summary(pl):    Wtyczka gstreamer
116 Group:          X11/Applications/Multimedia
117 # deps, to get it working:
118 # mp3 decoder: gstreamer-mad
119 # ogg decoder: gstreamer-vorbis
120 # audio output driver: gstreamer-audiosink-alsa
121 # from gstreamer-audio-effects to control volume, etc
122 # needed libs:
123 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
124 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
125 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
126 # gstreamer-musicbrainz for being able to edit id3 tags on files.
127 Requires:       %{name} = %{version}-%{release}
128 Requires:       gstreamer-audio-effects
129 Requires:       gstreamer-audiosink
130 Requires:       gstreamer-mad
131 Requires:       gstreamer-musicbrainz
132 Requires:       gstreamer-vorbis
133 Provides:       %{name}-plugin = %{version}-%{release}
134
135 %description gstreamer
136 Plugin gstreamer.
137
138 %description gstreamer -l pl
139 Wtyczka gstreamer.
140
141 %package xine
142 Summary:        Plugin xine
143 Summary(pl):    Wtyczka xine
144 Group:          X11/Applications/Multimedia
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       xine-plugin-audio
147 Provides:       %{name}-plugin = %{version}-%{release}
148
149 %description xine
150 Plugin xine.
151
152 %description xine -l pl
153 Wtyczka xine.
154
155 %package xmms
156 Summary:        Xmms wrapper
157 Summary(pl):    Wrapper xmms
158 Group:          X11/Applications/Multimedia
159 Requires:       %{name} = %{version}-%{release}
160
161 %description xmms
162 Xmms wrapper.
163
164 %description xmms -l pl
165 Wrapper xmms.
166
167 %package zeroconf
168 Summary:        Zeroconf data
169 Summary(pl):    Dane dla zeroconf
170 Group:          X11/Applications/Multimedia
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       kdenetwork-kdnssd
173 Provides:       %{name}-plugin = %{version}-%{release}
174
175 %description zeroconf
176 Zeroconf data.
177
178 %description zeroconf -l pl
179 Dane dla zeroconf.
180
181 %package scripts
182 Summary:        amaroK scripts
183 Summary(pl):    Skrypty amaroKa
184 Group:          X11/Applications/Multimedia
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       kdebase-kdialog
187 Requires:       python-PyQt
188
189 %description scripts
190 amaroK scripts allow you extend amaroK functionality.
191
192 You can learn more about scripts in amaroK from here:
193 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
194
195 %description scripts -l pl
196 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
197
198 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
199 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %{?with_altlyrics:%patch1 -p1}
205 #%patch2 -p1 ## probably unnided
206 %patch3 -p1
207 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
208         amarok/src/amarok.desktop \
209
210 # see kde bug #110909
211 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
212
213 %build
214 cp -f /usr/share/automake/config.sub admin
215
216 %{__make} -f admin/Makefile.common cvs
217
218 # hack: passing something other than "no" or "yes" to --with-helix allows
219 # us to pass HELIX_LIBS
220 %configure \
221         HELIX_LIBS=%{_libdir}/helixplayer \
222         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
223         --disable-rpath \
224         --with%{!?with_arts:out}-arts \
225         --with%{!?with_mas:out}-mas \
226         --with%{!?with_xine:out}-xine \
227         --with%{!?with_gstreamer:out}-gstreamer \
228         --with%{!?with_akode:out}-akode \
229         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
230         --with%{!?with_nmm:out}-nmm \
231         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
232         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
233         --disable-final \
234         --with-qt-libraries=%{_libdir} \
235         --with%{!?with_included_sqlite:out}-included-sqlite
236
237 %{__make}
238
239 %install
240 rm -rf $RPM_BUILD_ROOT
241
242 %{__make} install \
243         DESTDIR=$RPM_BUILD_ROOT \
244         kde_htmldir=%{_kdedocdir} \
245         kde_libs_htmldir=%{_kdedocdir}
246
247 # remove bogus dir
248 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
249
250 %find_lang amarok --all-name --with-kde
251
252 %clean
253 rm -rf $RPM_BUILD_ROOT
254
255 %post
256 if [ "$1" = 1 ]; then
257         echo "Remember to install libvisual-plugins-* packages if you"
258         echo "want to have a visualizations in amaroK."
259 fi
260
261 %files -f %{name}.lang
262 %defattr(644,root,root,755)
263 %doc AUTHORS ChangeLog README
264 %attr(755,root,root) %{_bindir}/amarok
265 %attr(755,root,root) %{_bindir}/amarokapp
266 %attr(755,root,root) %{_bindir}/amarok_libvisual
267 #%attr(755,root,root) %{_bindir}/release_amarok
268 %{_libdir}/kde3/konqsidebar_universalamarok.la
269 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
270 %{_libdir}/kde3/libamarok_void-engine_plugin.la
271 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
272 %dir %{_datadir}/apps/amarok
273 %dir %{_datadir}/apps/amarok/scripts
274 %{_datadir}/apps/amarok/*.rc
275 %{_datadir}/apps/amarok/data
276 %{_datadir}/apps/amarok/icons
277 %{_datadir}/apps/amarok/images
278 %{_datadir}/apps/amarok/themes
279 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
280 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
281 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
282 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
283 %{_datadir}/apps/profiles/amarok.profile.xml
284 %{_datadir}/config/amarokrc
285 %{_datadir}/config.kcfg/amarok.kcfg
286 %{_datadir}/services/amarok_void-engine_plugin.desktop
287 %{_datadir}/servicetypes/amarok_plugin.desktop
288 %{_desktopdir}/kde/amarok.desktop
289 %{_iconsdir}/*/*/apps/amarok.*
290
291 %if %{with arts}
292 %files arts
293 %defattr(644,root,root,755)
294 %{_libdir}/kde3/libamarok_artsengine_plugin.la
295 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
296 %{_libdir}/libamarokarts.la
297 %attr(755,root,root) %{_libdir}/libamarokarts.so
298 %{_libdir}/mcop/Amarok
299 %{_libdir}/mcop/amarokarts.mcopclass
300 %{_libdir}/mcop/amarokarts.mcoptype
301 %{_datadir}/services/amarok_artsengine_plugin.desktop
302 %endif
303
304 %if %{with akode}
305 %files akode
306 %defattr(644,root,root,755)
307 %{_libdir}/kde3/libamarok_aKode-engine.la
308 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
309 %{_datadir}/services/amarok_aKode-engine.desktop
310 %endif
311
312 %if %{with gstreamer}
313 %files gstreamer
314 %defattr(644,root,root,755)
315 %{_libdir}/kde3/libamarok_gstengine_plugin.la
316 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
317 %{_datadir}/config.kcfg/gstconfig.kcfg
318 %{_datadir}/services/amarok_gstengine_plugin.desktop
319 %endif
320
321 %if %{with helix}
322 %files helix
323 %defattr(644,root,root,755)
324 %{_libdir}/kde3/libamarok_helixengine_plugin.la
325 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
326 %{_datadir}/config.kcfg/helixconfig.kcfg
327 %{_datadir}/services/amarok_helixengine_plugin.desktop
328 %endif
329
330 %if %{with xine}
331 %files xine
332 %defattr(644,root,root,755)
333 %{_libdir}/kde3/libamarok_xine-engine.la
334 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
335 %{_datadir}/config.kcfg/xinecfg.kcfg
336 %{_datadir}/services/amarok_xine-engine.desktop
337 #%{_datadir}/services/amarok_xineengine_plugin.desktop
338 %endif
339
340 %if %{with xmms}
341 %files xmms
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
344 %endif
345
346 %if 0
347 %if %{with zeroconf}
348 %files zeroconf
349 %defattr(644,root,root,755)
350 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
351 %endif
352 %endif
353
354 %files scripts
355 %defattr(644,root,root,755)
356
357 %dir %{_datadir}/apps/amarok/scripts/alarm
358 %{_datadir}/apps/amarok/scripts/alarm/README
359 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
360
361 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
362 %{_datadir}/apps/amarok/scripts/graphequalizer/README
363 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
364
365 %dir %{_datadir}/apps/amarok/scripts/playlist2html
366 %{_datadir}/apps/amarok/scripts/playlist2html/README
367 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
368 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
369 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
370
371 %dir %{_datadir}/apps/amarok/scripts/templates
372 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
373 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
374 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
375
376 %dir %{_datadir}/apps/amarok/scripts/webcontrol
377 %{_datadir}/apps/amarok/scripts/webcontrol/README
378 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
379 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
380 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
381 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
382 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
383 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
384 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
385 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
386 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
387 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
388 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
389 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
390 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
391 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
392 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
393 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
394
395 %dir %{_datadir}/apps/amarok/scripts/common
396 %{_datadir}/apps/amarok/scripts/common/Publisher.py
397 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
398
399 #%dir %{_datadir}/apps/amarok/scripts/shouter
400 #%{_datadir}/apps/amarok/scripts/shouter/README
401 #%{_datadir}/apps/amarok/scripts/shouter/ChangeLog
402 #%{_datadir}/apps/amarok/scripts/shouter/Amarok.py
403 #%{_datadir}/apps/amarok/scripts/shouter/Globals.py
404 #%{_datadir}/apps/amarok/scripts/shouter/Playlist.py
405 #%{_datadir}/apps/amarok/scripts/shouter/Services.py
406 #%{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
407 #%{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
408 #%{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
409 #%{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
410 #%{_datadir}/apps/amarok/scripts/shouter/StreamController.py
411 #%{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
412 #%{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
413 #%{_datadir}/apps/amarok/scripts/shouter/debug.py
414 #%{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
415 #%dir %{_datadir}/apps/amarok/scripts/shouter/silence
416 #%{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
417 #%dir %{_datadir}/apps/amarok/scripts/shouter/test
418 #%{_datadir}/apps/amarok/scripts/shouter/test/client.py
419 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
420
421 %if 0
422 %dir %{_datadir}/apps/amarok/scripts/amarok_live
423 %{_datadir}/apps/amarok/scripts/amarok_live/README
424 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
425 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
426 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
427 %endif
This page took 0.05191 seconds and 4 git commands to generate.