]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
4360644c723d1f54228c6e0076255e05cb3914f8
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 #
10 # Conditional builds:
11 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
12 %bcond_without  mas             # disable MAS audio backend
13 %bcond_without  xine            # disable xine engine
14 %bcond_without  xmms            # disable xmms wrapping
15 %bcond_without  zeroconf        # disable support for zeroconf
16 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
17 %bcond_without  helix           # disable HelixPlayer engine
18 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
19 %bcond_with     nmm             # enable NMM audio backend
20 %bcond_with     mysql           # enable MySQL support
21 %bcond_with     pgsql           # enable PostgreSQL support
22 #
23 %ifarch i386
24 %undefine       with_helix
25 %endif
26
27 Summary:        A KDE audio player
28 Summary(pl):    Odtwarzacz audio dla KDE
29 Name:           amarok
30 Version:        1.4.4
31 Release:        3
32 License:        GPL
33 Group:          X11/Applications/Multimedia
34 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
35 Source0:        http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  56a9aec42088c338b81252f8e0651781
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         kde-ac260-lt.patch
41 Patch4:         kde-common-PLD.patch
42 URL:            http://amarok.kde.org/
43 BuildRequires:  SDL-devel
44 BuildRequires:  alsa-lib-devel
45 BuildRequires:  autoconf
46 BuildRequires:  automake
47 BuildRequires:  dbus-glib-devel
48 BuildRequires:  gettext-devel
49 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
50 BuildRequires:  kdebase-devel
51 %{?with_akode:BuildRequires:    kdemultimedia-akode}
52 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
53 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
54 %{?with_mp3players:BuildRequires:       libifp-devel}
55 %{?with_mp3players:BuildRequires:       libmtp-devel}
56 %{?with_mp3players:BuildRequires:       libnjb-devel}
57 BuildRequires:  libltdl-devel
58 %{?with_pgsql:BuildRequires:            libpqxx-devel}
59 BuildRequires:  libtunepimp-devel >= 0.5.1-6
60 BuildRequires:  libvisual-devel >= 0.4.0
61 BuildRequires:  mpeg4ip-devel
62 %{?with_mysql:BuildRequires:            mysql-devel}
63 BuildRequires:  pcre-devel
64 BuildRequires:  pkgconfig
65 BuildRequires:  rpm-pythonprov
66 BuildRequires:  rpmbuild(macros) >= 1.129
67 BuildRequires:  ruby-devel >= 1.8
68 BuildRequires:  sed >= 4.0
69 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
70 BuildRequires:  taglib-devel >= 1.4
71 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
72 %{?with_xmms:BuildRequires:     xmms-devel}
73 Requires(post): /sbin/ldconfig
74 Requires:       %{name}-plugin = %{version}-%{release}
75 Requires:       kdebase-core >= 9:3.1.93
76 Requires:       kdemultimedia-audiocd >= 9:3.1.93
77 Obsoletes:      amarok-arts
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
81 %define         filterout_ld    -Wl,--as-needed
82
83 %description
84 A KDE audio player.
85
86 %description -l pl
87 Odtwarzacz audio dla KDE.
88
89 %package akode
90 Summary:        Plugin akode
91 Summary(pl):    Wtyczka akode
92 Group:          X11/Applications/Multimedia
93 Requires:       %{name} = %{version}-%{release}
94 Provides:       %{name}-plugin = %{version}-%{release}
95
96 %description akode
97 Plugin akode.
98
99 %description akode -l pl
100 Wtyczka akode.
101
102 %package helix
103 Summary:        Helix/Realplayer playback support for amarok
104 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
105 Group:          X11/Applications/Multimedia
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       helix-core
108 Provides:       %{name}-plugin = %{version}-%{release}
109
110 %description helix
111 Helix/Realplayer playback support for amarok.
112
113 %description helix -l pl
114 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
115
116 %package gstreamer
117 Summary:        Plugin gstreamer
118 Summary(pl):    Wtyczka gstreamer
119 Group:          X11/Applications/Multimedia
120 # deps, to get it working:
121 # mp3 decoder:  gstreamer-mad
122 # ogg decoder:  gstreamer-vorbis
123 # audio output driver:  gstreamer-audiosink-alsa
124 # from gstreamer-audio-effects to control volume, etc
125 # needed libs:
126 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
127 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
128 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
129 # gstreamer-musicbrainz for being able to edit id3 tags on files.
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       gstreamer-audio-effects
132 Requires:       gstreamer-audiosink
133 Requires:       gstreamer-mad
134 Requires:       gstreamer-musicbrainz
135 Requires:       gstreamer-vorbis
136 Provides:       %{name}-plugin = %{version}-%{release}
137
138 %description gstreamer
139 Plugin gstreamer.
140
141 %description gstreamer -l pl
142 Wtyczka gstreamer.
143
144 %package xine
145 Summary:        Plugin xine
146 Summary(pl):    Wtyczka xine
147 Group:          X11/Applications/Multimedia
148 Requires:       %{name} = %{version}-%{release}
149 Requires:       xine-plugin-audio
150 Provides:       %{name}-plugin = %{version}-%{release}
151
152 %description xine
153 Plugin xine.
154
155 %description xine -l pl
156 Wtyczka xine.
157
158 %package xmms
159 Summary:        Xmms wrapper
160 Summary(pl):    Wrapper xmms
161 Group:          X11/Applications/Multimedia
162 Requires:       %{name} = %{version}-%{release}
163
164 %description xmms
165 Xmms wrapper.
166
167 %description xmms -l pl
168 Wrapper xmms.
169
170 %package zeroconf
171 Summary:        Zeroconf data
172 Summary(pl):    Dane dla zeroconf
173 Group:          X11/Applications/Multimedia
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       kdenetwork-kdnssd
176 Provides:       %{name}-plugin = %{version}-%{release}
177
178 %description zeroconf
179 Zeroconf data.
180
181 %description zeroconf -l pl
182 Dane dla zeroconf.
183
184 %package scripts
185 Summary:        amaroK scripts
186 Summary(pl):    Skrypty amaroKa
187 Group:          X11/Applications/Multimedia
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       kdebase-kdialog
190 Requires:       python-PyQt
191 Requires:       ruby-modules
192
193 %description scripts
194 amaroK scripts allow you extend amaroK functionality.
195
196 You can learn more about scripts in amaroK from here:
197 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
198
199 %description scripts -l pl
200 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
201
202 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
203 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
204
205 %prep
206 %setup -q
207 %patch0 -p1
208 %patch1 -p1
209 %patch2 -p0
210 %patch3 -p1
211 %patch4 -p1
212
213 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
214         amarok/src/amarok.desktop \
215
216 # see kde bug #110909
217 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
218
219 # kill env, call interpreter directly, so rpm automatics could rule
220 %{__sed} -i -e '
221         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
222         1s,#!.*bin/env.*python,#!%{_bindir}/python,
223         1s,#!.*bin/env.*bash,#!/bin/bash,
224 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
225
226 %build
227 cp -f /usr/share/automake/config.sub admin
228 %{__make} -f admin/Makefile.common cvs
229
230 # hack: passing something other than "no" or "yes" to --with-helix allows
231 # us to pass HELIX_LIBS
232 %configure \
233         HELIX_LIBS=%{_libdir}/helixplayer \
234         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
235         --disable-rpath \
236         --with%{!?with_mas:out}-mas \
237         --with%{!?with_xine:out}-xine \
238         --with%{!?with_gstreamer:out}-gstreamer10 \
239         --with%{!?with_akode:out}-akode \
240         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
241         --with%{!?with_nmm:out}-nmm \
242         --with%{!?with_xmms:out}-xmms \
243         --with%{!?with_mp3players:out}-libgpod \
244         --with%{!?with_mp3players:out}-libnjb \
245         --with%{!?with_mp3players:out}-libmtp \
246         --with%{!?with_mp3players:out}-ifp \
247         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
248         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
249         --disable-final \
250         --with-mp4v2 \
251         --with-qt-libraries=%{_libdir} \
252         --with%{!?with_included_sqlite:out}-included-sqlite
253
254 %{__make}
255
256 %install
257 rm -rf $RPM_BUILD_ROOT
258
259 %{__make} install \
260         DESTDIR=$RPM_BUILD_ROOT \
261         kde_htmldir=%{_kdedocdir} \
262         kde_libs_htmldir=%{_kdedocdir}
263
264 # remove bogus dir
265 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
266
267 %find_lang amarok --all-name --with-kde
268
269 %clean
270 rm -rf $RPM_BUILD_ROOT
271
272 %post
273 /sbin/ldconfig
274 if [ "$1" = 1 ]; then
275         echo "Remember to install libvisual-plugins-* packages if you"
276         echo "want to have a visualizations in amaroK."
277 fi
278
279 %postun -p /sbin/ldconfig
280
281 %files -f %{name}.lang
282 %defattr(644,root,root,755)
283 %doc AUTHORS ChangeLog README
284 %attr(755,root,root) %{_bindir}/amarok
285 %attr(755,root,root) %{_bindir}/amarokapp
286 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
287 %attr(755,root,root) %{_bindir}/amarok_libvisual
288 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
289 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
290 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
291 %{_libdir}/kde3/konqsidebar_universalamarok.la
292 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
293 %{_libdir}/kde3/libamarok_generic-mediadevice.la
294 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
295 %{_libdir}/kde3/libamarok_void-engine_plugin.la
296 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
297 %{_libdir}/libamarok.la
298 %{_libdir}/kde3/libamarok_daap-mediadevice.la
299 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
300 %{_libdir}/kde3/libamarok_massstorage-device.la
301 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
302 %{_libdir}/kde3/libamarok_nfs-device.la
303 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
304 %{_libdir}/kde3/libamarok_smb-device.la
305 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
306 %{_libdir}/ruby_lib/http11.rb
307 %{_libdir}/ruby_lib/libhttp11.la
308 %attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
309 %dir %{_datadir}/apps/amarok
310 %dir %{_datadir}/apps/amarok/scripts
311 %{_datadir}/apps/amarok/ruby_lib
312 %{_datadir}/apps/amarok/*.rc
313 %{_datadir}/apps/amarok/data
314 %{_datadir}/apps/amarok/icons
315 %{_datadir}/apps/amarok/images
316 %{_datadir}/apps/amarok/themes
317 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
318 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
319 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
320 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
321 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
322 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
323 %{_datadir}/apps/profiles/amarok.profile.xml
324 %{_datadir}/config/amarokrc
325 %{_datadir}/config.kcfg/amarok.kcfg
326 %{_datadir}/services/amarok_generic-mediadevice.desktop
327 %{_datadir}/services/amarok_void-engine_plugin.desktop
328 %{_datadir}/services/amarok_daap-mediadevice.desktop
329 %{_datadir}/services/amarok_massstorage-device.desktop
330 %{_datadir}/services/amarok_nfs-device.desktop
331 %{_datadir}/services/amarok_smb-device.desktop
332 %{_datadir}/services/amaroklastfm.protocol
333 %{_datadir}/services/amarokitpc.protocol
334 %{_datadir}/services/amarokpcast.protocol
335 %{_datadir}/servicetypes/amarok_codecinstall.desktop
336 %{_datadir}/servicetypes/amarok_plugin.desktop
337 %{_desktopdir}/kde/amarok.desktop
338 %{_iconsdir}/*/*/apps/amarok.*
339 # TODO: move to subpackage
340 %if %{with mp3players}
341 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
342 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
343 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
344 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
345 %{_libdir}/kde3/libamarok_mtp-mediadevice.la
346 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
347 %{_libdir}/kde3/libamarok_njb-mediadevice.la
348 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
349 %{_datadir}/services/amarok_ifp-mediadevice.desktop
350 %{_datadir}/services/amarok_ipod-mediadevice.desktop
351 %{_datadir}/services/amarok_mtp-mediadevice.desktop
352 %{_datadir}/services/amarok_njb-mediadevice.desktop
353 %endif
354
355 %if %{with akode}
356 %files akode
357 %defattr(644,root,root,755)
358 %{_libdir}/kde3/libamarok_aKode-engine.la
359 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
360 %{_datadir}/services/amarok_aKode-engine.desktop
361 %endif
362
363 %if %{with gstreamer}
364 %files gstreamer
365 %defattr(644,root,root,755)
366 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
367 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
368 %{_datadir}/config.kcfg/gstconfig.kcfg
369 %{_datadir}/services/amarok_gst10engine_plugin.desktop
370 %endif
371
372 %if %{with helix}
373 %files helix
374 %defattr(644,root,root,755)
375 %{_libdir}/kde3/libamarok_helixengine_plugin.la
376 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
377 %{_datadir}/config.kcfg/helixconfig.kcfg
378 %{_datadir}/services/amarok_helixengine_plugin.desktop
379 %endif
380
381 %if %{with xine}
382 %files xine
383 %defattr(644,root,root,755)
384 %{_libdir}/kde3/libamarok_xine-engine.la
385 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
386 %{_datadir}/config.kcfg/xinecfg.kcfg
387 %{_datadir}/services/amarok_xine-engine.desktop
388 %endif
389
390 %if %{with xmms}
391 %files xmms
392 %defattr(644,root,root,755)
393 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
394 %endif
395
396 %if 0
397 %if %{with zeroconf}
398 %files zeroconf
399 %defattr(644,root,root,755)
400 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
401 %endif
402 %endif
403
404 %files scripts
405 %defattr(644,root,root,755)
406 %dir %{_datadir}/apps/amarok/scripts/common
407 %{_datadir}/apps/amarok/scripts/common/Publisher.py
408 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
409
410 %dir %{_datadir}/apps/amarok/scripts/templates
411 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
412 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
413 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
414
415 # amarok searches for executable programs for scripts
416 # to figure out which files need to have execute permission, use this
417 # find command:
418 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
419
420 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
421 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
422 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
423
424 %dir %{_datadir}/apps/amarok/scripts/playlist2html
425 %{_datadir}/apps/amarok/scripts/playlist2html/README
426 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
427 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
428 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
429
430 %dir %{_datadir}/apps/amarok/scripts/webcontrol
431 %{_datadir}/apps/amarok/scripts/webcontrol/README
432 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
433 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
434 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
435 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
436 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
437 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
438 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
439 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
440 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
441 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
442 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
443 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
444 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
445 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
446 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
447 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
448 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
449 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
450 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
451
452 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
453 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
454 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
455 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
456 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
457
458 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
459 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
460 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
461 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
462 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
463
464 %dir %{_datadir}/apps/amarok/scripts/score_default
465 %{_datadir}/apps/amarok/scripts/score_default/COPYING
466 %{_datadir}/apps/amarok/scripts/score_default/README
467 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
468 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
469 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
470 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
471 %{_datadir}/apps/amarok/scripts/score_impulsive/README
472 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
473 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
474
475 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
476 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
477
478 %if 0
479 %dir %{_datadir}/apps/amarok/scripts/amarok_live
480 %{_datadir}/apps/amarok/scripts/amarok_live/README
481 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
482 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
483 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
484 %endif
This page took 0.061613 seconds and 2 git commands to generate.