]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- next part modification .. still not finished.
[packages/amanda.git] / amanda.spec
1 Summary:        A network-capable tape backup solution
2 Name:           amanda
3 Version:        2.4.1p1
4 Release:        3
5 Source:         ftp://ftp.amanda.org/pub/amanda/%{name}-%{version}.tar.gz
6 Copyright:      distributable
7 Group:          Networking/Utilities 
8 Group(pl):      Sieciowe/Narzêdzia
9 URL:            http://www.amanda.org/
10 BuildRoot:      /tmp/%{name}-%{version}-root
11
12 %description 
13 A network-capable tape backup solution.
14
15 %package client
16 Summary:        The client side of Amanda
17 Group:          Networking/Utilities
18 Group(pl):      Sieciowe/Narzêdzia
19
20 %description client
21 This package should be installed on machines that are to be backed
22 up by Amanda.  (Including, the server if it should be backed up.)
23
24 %package server
25 Summary:        The server side of Amanda
26 Group:          Networking/Utilities
27 Group(pl):      Sieciowe/Narzêdzia
28 Requires:       gnuplot
29
30 %description server
31 This package should be installed on the machine that has the device
32 (such as a tape drive) where backups will be written.
33
34 %prep
35 %setup -q
36
37 %build
38 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
39 ./configure \
40         --prefix=/usr \
41         --sysconfdir=/etc \
42         --localstatedir=/var \
43         --disable-static \
44         --with-index-server=localhost \
45         --with-user=amanda \
46         --with-group=amanda \
47         --with-samba-user=amanda \
48         --with-tape-device=/dev/null \
49         --with-ftape-rawdevice=/dev/null \
50         --with-changer-device=/dev/null \
51         --with-fqdn \
52         --with-smbclient=/usr/bin/smbclient \
53         --with-bsd-security \
54         --with-buffered-dump \
55         --with-amandahosts \
56         --with-debugging=/var/amanda/debug
57
58 make
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 make install \
63         prefix=$RPM_BUILD_ROOT/usr \
64         sysconfdir=$RPM_BUILD_ROOT/etc \
65         libexecdir=$RPM_BUILD_ROOT/usr/sbin \
66         SETUID_GROUP=`id -g`
67
68 gzip -9nf $RPM_BUILD_ROOT/usr/man/man8/*
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post           -p /sbin/ldconfig
74 %postun         -p /sbin/ldconfig
75 %post   client  -p /sbin/ldconfig
76 %postun client  -p /sbin/ldconfig
77 %post   server  -p /sbin/ldconfig
78 %postun server  -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 /usr/lib/libamanda*
83 /usr/lib/libamtape*
84 /usr/lib/amanda/amidxtaped
85 %attr(755,root,root) /usr/sbin/amrestore
86 /usr/man/man8/amrestore.8*
87
88 %files server
89 /usr/lib/libamserver*
90 /usr/sbin/amindexd
91 /usr/sbin/amtrmidx
92 /usr/sbin/driver
93 /usr/sbin/dumper
94 /usr/sbin/getconf
95 /usr/sbin/planner
96 #/usr/sbin/reporter
97 /usr/sbin/taper
98 /usr/sbin/chg-chio
99 /usr/sbin/chg-manual
100 /usr/sbin/chg-multi
101 /usr/sbin/chg-mtx
102 /usr/sbin/chg-rth
103 /usr/sbin/chg-chs
104 /usr/sbin/amcat.awk
105 /usr/sbin/amplot.awk
106 /usr/sbin/amplot.g
107 /usr/sbin/amplot.gp
108 /usr/sbin/amadmin
109 /usr/sbin/amcheck
110 /usr/sbin/amflush
111 /usr/sbin/amlabel
112 /usr/sbin/amtape
113 /usr/sbin/amcheckdb
114 /usr/sbin/amcleanup
115 /usr/sbin/amdump
116 /usr/sbin/amoverview
117 /usr/sbin/amrmtape
118 /usr/sbin/amtoc
119 /usr/sbin/amverify
120 /usr/sbin/amplot
121 /usr/sbin/amreport
122 /usr/sbin/amstatus
123 /usr/man/man8/amadmin.8*
124 /usr/man/man8/amrmtape.8*
125 /usr/man/man8/amtape.8*
126 /usr/man/man8/amtoc.8*
127 /usr/man/man8/amanda.8*
128 /usr/man/man8/amcheck.8*
129 /usr/man/man8/amcleanup.8*
130 /usr/man/man8/amdump.8*
131 /usr/man/man8/amflush.8*
132 /usr/man/man8/amlabel.8*
133 /usr/man/man8/amplot.8*
134 /usr/man/man8/amreport.8*
135 /usr/man/man8/amstatus.8*
136
137 %files client
138 /usr/lib/libamclient*
139 /usr/sbin/versionsuffix
140 /usr/sbin/amandad
141 /usr/sbin/calcsize
142 /usr/sbin/rundump
143 /usr/sbin/runtar
144 /usr/sbin/selfcheck
145 /usr/sbin/sendbackup
146 /usr/sbin/sendsize
147 /usr/sbin/patch-system
148 /usr/sbin/killpgrp
149 /usr/sbin/amrecover
150 /usr/man/man8/amrecover.8*
151
152 %changelog
153 * Sat Jan 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
154   [2.4.1-2d]
155 - added -q %setup parameter,
156 - added gzipping man pages,
157 - added Group(pl),
158 - added LDFLAGS="-s" to ./configure enviroment,
159 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
160 - added using %%{name} and %%{version} in Source,
161 - added stripping shared libraries,
162 - added %attr and %defattr macros in %files (allows build package from
163   non-root account).
164
165 * Tue Oct 27 1998 Cristian Gafton <gafton@redhat.com>
166 - version 2.4.1
167
168 * Tue May 19 1998 Cristian Gafton <gafton@redhat.com>
169 - upgraded to full 2.4.0 release
170
171 * Thu Feb 19 1998 Otto Hammersmith <otto@redhat.com>
172 - fixed group for -client and -server packages (Network->Networking)
173
174 * Wed Feb 11 1998 Otto Hammersmith <otto@redhat.com>
175 - updated to 2.4.0b6, fixes security hole among other things
176   (as well as finally got the glibc patch in the main source.)
177  
178 * Tue Jan 27 1998 Otto Hammersmith <otto@redhat.com>
179 - moved versionsuffix to client package to remove dependency of amanda on amanda-client
180
181 * Mon Jan 26 1998 Otto Hammersmith <otto@redhat.com>
182 - fixed libexec garbage.
183
184 * Wed Jan 21 1998 Otto Hammersmith <otto@redhat.com>
185 - split into three packages amanda, amanda-client, and amanda-server
186
187 * Fri Jan  9 1998 Otto Hammersmith <otto@redhat.com>
188 - updated to latest beta... builds much cleaner now.
189
190 * Thu Jan  8 1998 Otto Hammersmith <otto@redhat.com>
191 - created the package
This page took 0.05023 seconds and 4 git commands to generate.