]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
s-/usr/sbin-%{_sbindir}-
[packages/amanda.git] / amanda.spec
1 Summary:        A network-capable tape backup solution
2 Name:           amanda
3 Version:        2.4.1p1
4 Release:        3
5 Source:         ftp://ftp.amanda.org/pub/amanda/%{name}-%{version}.tar.gz
6 Copyright:      distributable
7 Group:          Networking/Utilities 
8 Group(pl):      Sieciowe/Narzêdzia
9 URL:            http://www.amanda.org/
10 BuildRoot:      /tmp/%{name}-%{version}-root
11
12 %description 
13 A network-capable tape backup solution.
14
15 %package client
16 Summary:        The client side of Amanda
17 Group:          Networking/Utilities
18 Group(pl):      Sieciowe/Narzêdzia
19
20 %description client
21 This package should be installed on machines that are to be backed
22 up by Amanda.  (Including, the server if it should be backed up.)
23
24 %package server
25 Summary:        The server side of Amanda
26 Group:          Networking/Utilities
27 Group(pl):      Sieciowe/Narzêdzia
28 Requires:       gnuplot
29
30 %description server
31 This package should be installed on the machine that has the device
32 (such as a tape drive) where backups will be written.
33
34 %prep
35 %setup -q
36
37 %build
38 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
39 ./configure %{_target} \
40         --prefix=/usr \
41         --sysconfdir=/etc \
42         --localstatedir=/var \
43         --disable-static \
44         --with-index-server=localhost \
45         --with-user=amanda \
46         --with-group=amanda \
47         --with-samba-user=amanda \
48         --with-tape-device=/dev/null \
49         --with-ftape-rawdevice=/dev/null \
50         --with-changer-device=/dev/null \
51         --with-fqdn \
52         --with-smbclient=%{_bindir}/smbclient \
53         --with-bsd-security \
54         --with-buffered-dump \
55         --with-amandahosts \
56         --with-debugging=/var/amanda/debug
57
58 make
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 make install \
63         prefix=$RPM_BUILD_ROOT/usr \
64         sysconfdir=$RPM_BUILD_ROOT/etc \
65         libexecdir=$RPM_BUILD_ROOT%{_sbindir} \
66         SETUID_GROUP=`id -g`
67
68 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man8/*
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post           -p /sbin/ldconfig
74 %postun         -p /sbin/ldconfig
75 %post   client  -p /sbin/ldconfig
76 %postun client  -p /sbin/ldconfig
77 %post   server  -p /sbin/ldconfig
78 %postun server  -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %{_libdir}/libamanda*
83 %{_libdir}/libamtape*
84 %{_libdir}/amanda/amidxtaped
85 %attr(755,root,root) %{_sbindir}/amrestore
86 %{_mandir}/man8/amrestore.8*
87
88 %files server
89 %{_libdir}/libamserver*
90 %{_sbindir}/amindexd
91 %{_sbindir}/amtrmidx
92 %{_sbindir}/driver
93 %{_sbindir}/dumper
94 %{_sbindir}/getconf
95 %{_sbindir}/planner
96 #%{_sbindir}/reporter
97 %{_sbindir}/taper
98 %{_sbindir}/chg-chio
99 %{_sbindir}/chg-manual
100 %{_sbindir}/chg-multi
101 %{_sbindir}/chg-mtx
102 %{_sbindir}/chg-rth
103 %{_sbindir}/chg-chs
104 %{_sbindir}/amcat.awk
105 %{_sbindir}/amplot.awk
106 %{_sbindir}/amplot.g
107 %{_sbindir}/amplot.gp
108 %{_sbindir}/amadmin
109 %{_sbindir}/amcheck
110 %{_sbindir}/amflush
111 %{_sbindir}/amlabel
112 %{_sbindir}/amtape
113 %{_sbindir}/amcheckdb
114 %{_sbindir}/amcleanup
115 %{_sbindir}/amdump
116 %{_sbindir}/amoverview
117 %{_sbindir}/amrmtape
118 %{_sbindir}/amtoc
119 %{_sbindir}/amverify
120 %{_sbindir}/amplot
121 %{_sbindir}/amreport
122 %{_sbindir}/amstatus
123 %{_mandir}/man8/amadmin.8*
124 %{_mandir}/man8/amrmtape.8*
125 %{_mandir}/man8/amtape.8*
126 %{_mandir}/man8/amtoc.8*
127 %{_mandir}/man8/amanda.8*
128 %{_mandir}/man8/amcheck.8*
129 %{_mandir}/man8/amcleanup.8*
130 %{_mandir}/man8/amdump.8*
131 %{_mandir}/man8/amflush.8*
132 %{_mandir}/man8/amlabel.8*
133 %{_mandir}/man8/amplot.8*
134 %{_mandir}/man8/amreport.8*
135 %{_mandir}/man8/amstatus.8*
136
137 %files client
138 %{_libdir}/libamclient*
139 %{_sbindir}/versionsuffix
140 %{_sbindir}/amandad
141 %{_sbindir}/calcsize
142 %{_sbindir}/rundump
143 %{_sbindir}/runtar
144 %{_sbindir}/selfcheck
145 %{_sbindir}/sendbackup
146 %{_sbindir}/sendsize
147 %{_sbindir}/patch-system
148 %{_sbindir}/killpgrp
149 %{_sbindir}/amrecover
150 %{_mandir}/man8/amrecover.8*
151
152 %changelog
153 * Sat Jan 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
154   [2.4.1-2d]
155 - added -q %setup parameter,
156 - added gzipping man pages,
157 - added Group(pl),
158 - added LDFLAGS="-s" to ./configure enviroment,
159 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
160 - added using %%{name} and %%{version} in Source,
161 - added stripping shared libraries,
162 - added %attr and %defattr macros in %files (allows build package from
163   non-root account).
164
165 * Tue Oct 27 1998 Cristian Gafton <gafton@redhat.com>
166 - version 2.4.1
167
168 * Tue May 19 1998 Cristian Gafton <gafton@redhat.com>
169 - upgraded to full 2.4.0 release
170
171 * Thu Feb 19 1998 Otto Hammersmith <otto@redhat.com>
172 - fixed group for -client and -server packages (Network->Networking)
173
174 * Wed Feb 11 1998 Otto Hammersmith <otto@redhat.com>
175 - updated to 2.4.0b6, fixes security hole among other things
176   (as well as finally got the glibc patch in the main source.)
177  
178 * Tue Jan 27 1998 Otto Hammersmith <otto@redhat.com>
179 - moved versionsuffix to client package to remove dependency of amanda on amanda-client
180
181 * Mon Jan 26 1998 Otto Hammersmith <otto@redhat.com>
182 - fixed libexec garbage.
183
184 * Wed Jan 21 1998 Otto Hammersmith <otto@redhat.com>
185 - split into three packages amanda, amanda-client, and amanda-server
186
187 * Fri Jan  9 1998 Otto Hammersmith <otto@redhat.com>
188 - updated to latest beta... builds much cleaner now.
189
190 * Thu Jan  8 1998 Otto Hammersmith <otto@redhat.com>
191 - created the package
This page took 0.045299 seconds and 4 git commands to generate.