]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- %attr(660,amanda,amanda) for %{_localstatedir}/state/amanda.
[packages/amanda.git] / amanda.spec
1 Summary:        A network-capable tape backup solution
2 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
3 Name:           amanda
4 Version:        2.4.1p1
5 Release:        1
6 Copyright:      distributable
7 Group:          Networking/Utilities
8 Group(pl):      Sieciowe/Narzêdzia
9 Source0:        ftp://ftp.amanda.org/pub/amanda/%{name}-%{version}.tar.gz
10 Source1:        amanda-srv.crontab
11 Source2:        amanda.inetd
12 Source3:        amandaidx.inetd
13 Source4:        amidxtape.inetd
14 BuildRequires:  flex
15 BuildRequires:  dump
16 BuildRequires:  tar
17 BuildRequires:  ncurses-devel
18 BuildRequires:  readline-devel
19 Prereq:         /sbin/ldconfig
20 URL:            http://www.amanda.org/
21 BuildRoot:      /tmp/%{name}-%{version}-root
22
23 %define         _sysconfdir     /etc
24 %define         _localstatedir  /var
25 %define         _libexecdir     %{_libdir}/amanda
26
27 %description 
28 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a backup
29 system that allows the administrator of a LAN to set up a single master
30 backup server to back up multiple hosts to a single large capacity tape
31 drive. AMANDA uses native dump and/or GNU tar facilities and can back up a
32 large number of workstations running multiple versions of Unix. Newer
33 versions of AMANDA (including this version) can use SAMBA to back up
34 Microsoft(TM) Windows95/NT hosts. The amanda package contains the core
35 AMANDA programs and will need to be installed on both AMANDA clients and
36 AMANDA servers. Note that you will have to install the amanda-client and
37 amanda-server packages as well.
38
39 %description -l pl
40 Sieciowo zorientowany system tworzenia kopii zapasowych
41
42 %package client
43 Summary:        The client side of Amanda
44 Summary(pl):    Klient Amandy
45 Group:          Networking/Utilities
46 Group(pl):      Sieciowe/Narzêdzia
47 Prereq:         /sbin/ldconfig
48 Requires:       %{name} = %{version}
49
50 %description client
51 The Amanda-client package should be installed on any machine that will be
52 backed up by AMANDA (including the server if it also needs to be backed up).
53 You will also need to install the amanda package to each AMANDA client.
54
55 %description -l pl client
56 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
57 zawarto¶ci bêd± tworzone kopie zapasowe.
58
59 %package server
60 Summary:        The server side of Amanda
61 Summary(pl):    Serwer Amandy
62 Group:          Networking/Utilities
63 Group(pl):      Sieciowe/Narzêdzia
64 Prereq:         rc-inetd
65 Prereq:         /sbin/ldconfig
66 Requires:       gnuplot
67 Requires:       %{name} = %{version}
68 Requires:       crondaemon
69 Requires:       /etc/cron.d
70
71 %description server
72 The amanda-server package should be installed on the AMANDA server, the
73 machine attached to the device (such as a tape drive) where backups will be
74 written. You will also need to install the amanda package to the AMANDA
75 server. And, if the server is also to be backed up, the server also needs to
76 have the amanda-client package installed.
77
78 %description -l pl server
79 Ten pakiet powinien byæ zainstalowanych na maszynach, na których
80 bêd± magazynowane kopie zapasowe (lub do których podpiête s±
81 urz±dzenia typu streamer).
82
83 %prep
84 %setup -q
85
86 %build
87 LDFLAGS="-s"; export LDFLAGS
88 %configure \
89         --disable-static \
90         --with-index-server=localhost \
91         --with-user=amanda \
92         --with-group=amanda \
93         --with-samba-user=amanda \
94         --with-tape-device=/dev/null \
95         --with-ftape-rawdevice=/dev/null \
96         --with-changer-device=/dev/null \
97         --with-fqdn \
98         --with-smbclient=%{_bindir}/smbclient \
99         --with-bsd-security \
100         --with-buffered-dump \
101         --with-amandahosts \
102         --with-debugging=%{_localstatedir}/amanda/debug
103
104 make
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT/etc/{amanda,cron.d,sysconfig/rc-inetd} \
109         $RPM_BUILD_ROOT%{_localstatedir}/state/amanda
110
111 make install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         SETUID_GROUP=`id -g`
114
115 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
116 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
117 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
118 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
119
120 install example/{amanda,chg-multi,chg-scsi}.conf $RPM_BUILD_ROOT%{_sysconfdir}/amanda
121 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/state/amanda
122
123 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
124
125 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man8/*
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %pre
131 /usr/sbin/groupadd -g 80 -r -f amanda
132
133 %post
134 /sbin/ldconfig
135 if [ -f /var/lock/subsys/rc-inetd ]; then
136         /etc/rc.d/init.d/rc-inetd restart 1>&2
137 else
138         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
139 fi
140
141 %preun
142 if [ $1 = 0 ]; then
143         groupdel amanda
144 fi
145
146 %posun
147 /sbin/ldconfig
148 if [ -f /var/lock/subsys/rc-inetd ]; then
149         /etc/rc.d/init.d/rc-inetd restart
150 fi
151
152 %post client
153 /sbin/ldconfig
154 if [ -f /var/lock/subsys/rc-inetd ]; then
155         /etc/rc.d/init.d/rc-inetd restart 1>&2
156 else
157         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
158 fi
159
160 %postun client
161 /sbin/ldconfig
162 if [ -f /var/lock/subsys/rc-inetd ]; then
163         /etc/rc.d/init.d/rc-inetd restart
164 fi
165
166 %post server
167 /sbin/ldconfig
168 if [ -f /var/lock/subsys/rc-inetd ]; then
169         /etc/rc.d/init.d/rc-inetd restart 1>&2
170 else
171         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
172 fi
173
174 %postun server
175 /sbin/ldconfig
176 if [ -f /var/lock/subsys/rc-inetd ]; then
177         /etc/rc.d/init.d/rc-inetd restart
178 fi
179
180 %files
181 %defattr(644,root,root,755)
182 %config(noreplace) /etc/sysconfig/rc-inetd/amandaidx
183 %attr(755,root,root) %{_libdir}/amidxtaped
184 %attr(755,root,root) %{_libdir}/libamanda*.so.*.*
185 %attr(755,root,root) %{_libdir}/libamtape*.so.*.*
186 %attr(755,root,root) %{_sbindir}/amrestore
187 %attr(770,root,amanda) %dir %{_libexecdir}
188 %{_mandir}/man8/amrestore.8*
189
190 %files server
191 %defattr(644,root,root,755)
192 %config(noreplace) /etc/sysconfig/rc-inetd/amidxtape
193
194 %dir %{_sysconfdir}/amanda
195 %attr(640,root,amanda) %{_sysconfdir}/amanda/*
196
197 %attr(660,amanda,amanda) %dir %{_localstatedir}/state/amanda
198 %{_localstatedir}/state/amanda/*
199
200 %attr(640,root,root) /etc/cron.d/amanda-srv
201
202 %attr(755,root,root) %{_libdir}/libamserver*.so.*.*
203 %attr(755,root,root) %{_libexecdir}/amindexd
204 %attr(755,root,root) %{_libexecdir}/amtrmidx
205 %attr(755,root,root) %{_libexecdir}/driver
206 %attr(755,root,root) %{_libexecdir}/dumper
207 %attr(755,root,root) %{_libexecdir}/getconf
208 %attr(755,root,root) %{_libexecdir}/planner
209 %attr(755,root,root) %{_libexecdir}/taper
210 %attr(755,root,root) %{_libexecdir}/chg-chio
211 %attr(755,root,root) %{_libexecdir}/chg-manual
212 %attr(755,root,root) %{_libexecdir}/chg-multi
213 %attr(755,root,root) %{_libexecdir}/chg-mtx
214 %attr(755,root,root) %{_libexecdir}/chg-rth
215 %attr(755,root,root) %{_libexecdir}/chg-chs
216 %attr(755,root,root) %{_sbindir}/amadmin
217 %attr(755,root,root) %{_sbindir}/amcheck
218 %attr(755,root,root) %{_sbindir}/amflush
219 %attr(755,root,root) %{_sbindir}/amlabel
220 %attr(755,root,root) %{_sbindir}/amtape
221 %attr(755,root,root) %{_sbindir}/amcheckdb
222 %attr(755,root,root) %{_sbindir}/amcleanup
223 %attr(755,root,root) %{_sbindir}/amdump
224 %attr(755,root,root) %{_sbindir}/amoverview
225 %attr(755,root,root) %{_sbindir}/amrmtape
226 %attr(755,root,root) %{_sbindir}/amtoc
227 %attr(755,root,root) %{_sbindir}/amverify
228 #%attr(755,root,root) %{_sbindir}/amplot
229 %attr(755,root,root) %{_sbindir}/amreport
230 %attr(755,root,root) %{_sbindir}/amstatus
231 %{_mandir}/man8/amadmin.8*
232 %{_mandir}/man8/amrmtape.8*
233 %{_mandir}/man8/amtape.8*
234 %{_mandir}/man8/amtoc.8*
235 %{_mandir}/man8/amanda.8*
236 %{_mandir}/man8/amcheck.8*
237 %{_mandir}/man8/amcleanup.8*
238 %{_mandir}/man8/amdump.8*
239 %{_mandir}/man8/amflush.8*
240 %{_mandir}/man8/amlabel.8*
241 %{_mandir}/man8/amplot.8*
242 %{_mandir}/man8/amreport.8*
243 %{_mandir}/man8/amstatus.8*
244
245 %files client
246 %defattr(644,root,root,755)
247 %config(noreplace) /etc/sysconfig/rc-inetd/amanda
248
249 %attr(755,root,root) %{_libdir}/libamclient*.so.*.*
250 %attr(755,root,root) %{_libexecdir}/versionsuffix
251 %attr(755,root,root) %{_libexecdir}/amandad
252 %attr(755,root,root) %{_libexecdir}/calcsize
253 %attr(755,root,root) %{_libexecdir}/rundump
254 %attr(755,root,root) %{_libexecdir}/runtar
255 %attr(755,root,root) %{_libexecdir}/selfcheck
256 %attr(755,root,root) %{_libexecdir}/sendbackup
257 %attr(755,root,root) %{_libexecdir}/sendsize
258 %attr(755,root,root) %{_libexecdir}/patch-system
259 %attr(755,root,root) %{_libexecdir}/killpgrp
260 %attr(755,root,root) %{_sbindir}/amrecover
261 %{_mandir}/man8/amrecover.8*
This page took 0.040739 seconds and 4 git commands to generate.