]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- fix errors introduced by -Werror-security
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 # - pico shouldn't link with kerberos, should it?
6 # - switch to http://re-alpine.sourceforge.net/ - RIP alpine
7 %define         ver             2.00
8 %define         patchlevel      84
9 Summary:        University of Washington Alpine mail user agent
10 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
11 Name:           alpine
12 Version:        %{ver}.%{patchlevel}
13 Release:        9
14 Epoch:          1
15 License:        Apache v2.0
16 Group:          Applications/Mail
17 # Main site:
18 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
20 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
21 # Source0-md5:  70ba4281354f1ba2d341038ec0e323c7
22 Source1:        pico.desktop
23 Source2:        %{name}.desktop
24 Source3:        %{name}.png
25 Patch0:         %{name}-index_display.patch
26 Patch1:         %{name}-doc.patch
27 Patch2:         %{name}-filter.patch
28 Patch3:         %{name}-fhs.patch
29 Patch4:         %{name}-libc-client.patch
30 Patch5:         %{name}-ssl.patch
31 Patch6:         %{name}-no_1777_warning.patch
32 Patch7:         %{name}-home_etc.patch
33 Patch8:         %{name}-RFC1522_MAXW.patch
34 Patch9:         mimedesc.patch
35 Patch10:        re-alpine-2.01.smime-signandencrypt.patch
36 Patch11:        format-security.patch
37 URL:            http://www.washington.edu/alpine/
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  home-etc-devel
41 %if "%{pld_release}" != "ac"
42 BuildRequires:  heimdal-devel
43 %endif
44 BuildRequires:  libtool
45 BuildRequires:  ncurses-devel
46 BuildRequires:  openldap-devel
47 BuildRequires:  openssl-devel
48 BuildRequires:  pam-devel
49 # Only for web-frontend:
50 #BuildRequires: tcl-devel
51 Suggests:       aspell
52 Suggests:       ca-certificates
53 Conflicts:      ca-certificates < 20080809-4
54 Provides:       pine = 6.00
55 Obsoletes:      pine
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         alpineconfdir   %{_sysconfdir}/%{name}
59 %define         filterout_ld    -Wl,--as-needed
60
61 %description
62 Alpine -- an Alternatively Licensed Program for Internet News & Email
63 -- is a tool for reading, sending, and managing electronic messages.
64 Alpine is the successor to Pine and was developed by Computing &
65 Communications at the University of Washington. Though originally
66 designed for inexperienced email users, Alpine supports many advanced
67 features, and an ever-growing number of configuration and
68 personal-preference options.
69
70 %description -l pl.UTF-8
71 Alpine, czyli Alternatively Licensed Program for Internet News & Email
72 (alternatywnie licencjonowany program do newsów i poczty internetowej)
73 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
74 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
75 wydział Computing & Communications (Obliczeń i komunikacji) na
76 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
77 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
78 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
79 ciągle rośnie.
80
81 %package -n pico
82 Summary:        Simple text editor in the style of the Pine Composer
83 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
84 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
85 Group:          Applications/Editors
86 Provides:       pico = 6.00
87
88 %description -n pico
89 Pico is a simple, display-oriented text editor based on the Alpine
90 message system composer. As with Pine, commands are displayed at the
91 bottom of the screen, and context-sensitive help is provided. As
92 characters are typed they are immediately inserted into the text.
93
94 %description -n pico -l pl.UTF-8
95 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
96 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
97 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
98 włączane do tekstu.
99
100 %description -n pico -l pt_BR.UTF-8
101 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
102 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
103 e ajuda de acordo com o contexto está disponível.
104
105 %package -n pilot
106 Summary:        Simple file system browser in the style of the Alpine Composer
107 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
108 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
109 Group:          Applications/Shells
110 Provides:       pilot = 6.00
111
112 %description -n pilot
113 Pilot is a simple, display-oriented file system browser based on the
114 Alpine message system composer. As with Alpine, commands are displayed
115 at the bottom of the screen, and context-sensitive help is provided.
116
117 %description -n pilot -l pl.UTF-8
118 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
119 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
120 na dole ekranu oraz jest dostępna pomoc kontekstowa.
121
122 %description -n pilot -l pt_BR.UTF-8
123 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
124 como no Pine, comandos são apresentados na parte de baixo da tela, e
125 ajuda de acordo com o contexto está disponível.
126
127 %prep
128 %setup -q -n %{name}-%{ver}
129 %patch0 -p1
130 %patch1 -p1
131 %patch2 -p1
132 %patch3 -p1
133 %patch4 -p1
134 %patch5 -p1
135 %patch6 -p1
136 %patch7 -p1
137 %patch8 -p1
138 %patch9 -p1
139 %patch10 -p1
140 %patch11 -p1
141
142 %build
143 rm -f libtool missing
144 %{__libtoolize}
145 %{__aclocal} -I m4
146 %{__autoconf}
147 %{__autoheader}
148 %{__automake}
149 %configure \
150         --%{?debug:en}%{!?debug:dis}able-debug \
151         --enable-quotas \
152         --without-tcl \
153         --with-smtp-msa=/usr/lib/sendmail \
154         --with-simple-spellcheck=aspell \
155         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
156         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
157         --with-krb5-dir=%{_prefix} \
158         --with-ldap-dir=%{_prefix} \
159         --with-system-mail-directory=/var/mail \
160         --with-c-client-target=slx \
161 %if "%{pld_release}" == "ti"
162         --with-ssl-dir=/var/lib/openssl/certs \
163         --with-ssl-certs-dir=/var/lib/openssl/certs \
164 %else
165         --with-ssl-dir=/etc/openssl/certs \
166         --with-ssl-certs-dir=/etc/certs \
167         --with-ssl-lib-dir=%{_libdir} \
168 %endif
169         --with-passfile=.pine.pwd
170
171 %{__make} \
172         GCCOPTLEVEL="%{rpmcflags}"
173
174 %install
175 rm -rf $RPM_BUILD_ROOT
176 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
177
178 %{__make} install \
179         DESTDIR=$RPM_BUILD_ROOT
180
181 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
182 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
183 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
184
185 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
186
187 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
188 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
189 #
190 # Alpine system-wide enforced configuration file - customize as needed
191 #
192 # This file holds the system-wide enforced values for alpine configuration
193 # settings. Any values set in it will override values set in the
194 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
195 # the user's own configuration file (~/.pinerc).
196 # For more information on the format of this file, read the
197 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
198
199 EOF
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %files
205 %defattr(644,root,root,755)
206 %doc README doc/tech-notes.txt
207 %dir %{_sysconfdir}/%{name}
208 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
209 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
210 %attr(755,root,root) %{_bindir}/%{name}
211 %attr(755,root,root) %{_bindir}/pine
212 %attr(755,root,root) %{_bindir}/rpload
213 %attr(755,root,root) %{_bindir}/rpdump
214 %{_mandir}/man1/%{name}.1*
215 %{_mandir}/man1/rpload.1*
216 %{_mandir}/man1/rpdump.1*
217 %{_desktopdir}/%{name}.desktop
218 %{_pixmapsdir}/%{name}.png
219
220 %files -n pico
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/pico
223 %{_desktopdir}/pico.desktop
224 %{_mandir}/man1/pico*
225
226 %files -n pilot
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_bindir}/pilot
229 %{_mandir}/man1/pilot*
This page took 0.064226 seconds and 3 git commands to generate.