]> git.pld-linux.org Git - packages/alex.git/blob - alex.spec
- oops, too many docs ;)
[packages/alex.git] / alex.spec
1 Summary:        A lexical analyser generator for Haskell
2 Summary(pl):    Generator analizatorów sk³adniowych dla Haskella
3 Name:           alex
4 Version:        2.0.1
5 Release:        1
6 License:        BSD-like w/o adv. clause
7 Group:          Development/Tools
8 Source0:        http://www.haskell.org/alex/dist/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  edb62560e29c8de23913c65c52adbf19
10 Patch0:         %{name}-DESTDIR.patch
11 URL:            http://www.haskell.org/alex/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  docbook-dtd31-sgml
15 BuildRequires:  docbook-style-dsssl
16 BuildRequires:  ghc >= 5.04
17 BuildRequires:  gmp-devel
18 BuildRequires:  jadetex
19 BuildRequires:  openjade
20 BuildRequires:  tetex-dvips
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Alex is a tool for generating lexical analysers in Haskell, given a
25 description of the tokens to be recognised in the form of regular
26 expressions. It is similar to the tool lex or flex for C/C++.
27
28 %description -l pl
29 Alex to narzêdzie do generowania analizatorów sk³adniowych w Haskellu
30 na podstawie opisu tokenów do rozpoznawania w postaci wyra¿eñ
31 regularnych. Jest podobne do narzêdzi lex lub flex dla C/C++.
32
33 %prep
34 %setup -q
35
36 %build
37 chmod u+w configure*
38 %{__aclocal}
39 %{__autoconf}
40 cp -f /usr/share/automake/config.sub .
41 %configure
42 %{__make} depend
43 %{__make}
44 %{__make} html -C alex/doc
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
49
50 %{__make} install \
51         bindir=$RPM_BUILD_ROOT%{_bindir} \
52         libdir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}
53
54 cp -a alex/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc alex/{ANNOUNCE,LICENSE,README} alex/doc/alex
62 %attr(755,root,root) %{_bindir}/*
63 %dir %{_libdir}/%{name}-%{version}
64 %{_libdir}/%{name}-%{version}/A*
65 %attr(755,root,root) %{_libdir}/%{name}-%{version}/alex.bin
66 %{_examplesdir}/%{name}-%{version}
This page took 0.051455 seconds and 3 git commands to generate.