]> git.pld-linux.org Git - packages/aircrack-ng.git/blob - aircrack-ng.spec
35f016820fd2ddcbd4947b2288377295410a3a5f
[packages/aircrack-ng.git] / aircrack-ng.spec
1 #
2 # TODO:
3 # - PLD it more
4 # - sbin/bin - change to bin?
5 # - finish ext_scripts bcond:
6 # -- check python related BR and R
7 # -- fix packaging python releated stuff
8 # -- create subpackage for airoscript
9 # -- fix directory for airoscript*.conf files
10 # -- fix installation of airoscript desktop files
11 #
12 # Conditional build:
13 %bcond_without  sqlite                  # build without sqlite support
14 %bcond_without  experimental
15 %bcond_with     ext_scripts             # build with extra scripts (NFY)
16
17 Summary:        Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
18 Summary(pl.UTF-8):      Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
19 Name:           aircrack-ng
20 Version:        1.3
21 Release:        1
22 License:        GPL
23 Group:          Applications/Networking
24 Source0:        http://download.aircrack-ng.org/%{name}-%{version}.tar.gz
25 # Source0-md5:  c7c5b076dee0c25ee580b0f56f455623
26 URL:            http://www.aircrack-ng.org/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  libnl-devel
30 BuildRequires:  libtool
31 BuildRequires:  openssl-devel
32 BuildRequires:  pcre-devel
33 BuildRequires:  pkgconfig
34 %{?with_sqlite:BuildRequires:   sqlite3-devel}
35 BuildRequires:  zlib-devel
36 Requires:       ethtool
37 Requires:       grep
38 Requires:       iw
39 Requires:       usbutils
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 aircrack-ng is a set of tools for auditing wireless networks. It's an
44 enhanced/reborn version of aircrack. It consists of airodump-ng (an
45 802.11 packet capture program), aireplay-ng (an 802.11 packet
46 injection program), aircrack (static WEP and WPA-PSK cracking),
47 airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
48 capture files (merge, convert, etc.).
49
50 %description -l pl.UTF-8
51 aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
52 Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
53 airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
54 wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
55 WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
56 WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
57 convert, etc.).
58
59 %prep
60 %setup -q
61
62 %build
63 %{__libtoolize}
64 %{__aclocal} -I build/m4/stubs -I build/m4
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         ETHTOOL=/sbin/ethtool \
69         --with-openssl \
70         --with%{!?with_experimental:out}-experimental \
71         --with%{!?with_ext_scripts:out}-ext-scripts \
72         --with-%{!?with_sqlite:out}-sqlite3 \
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog README test patches
92 %attr(755,root,root) %{_bindir}/aircrack-ng
93 %attr(755,root,root) %{_bindir}/airdecap-ng
94 %attr(755,root,root) %{_bindir}/airdecloak-ng
95 %{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
96 %attr(755,root,root) %{_bindir}/ivstools
97 %attr(755,root,root) %{_bindir}/kstats
98 %attr(755,root,root) %{_bindir}/makeivs-ng
99 %attr(755,root,root) %{_bindir}/packetforge-ng
100 %attr(755,root,root) %{_bindir}/wpaclean
101 %attr(755,root,root) %{_sbindir}/airbase-ng
102 %attr(755,root,root) %{_sbindir}/aireplay-ng
103 %attr(755,root,root) %{_sbindir}/airmon-ng
104 %attr(755,root,root) %{_sbindir}/airodump-ng
105 %attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
106 %attr(755,root,root) %{_sbindir}/airventriloquist-ng
107 %attr(755,root,root) %{_sbindir}/airserv-ng
108 %attr(755,root,root) %{_sbindir}/airtun-ng
109 %attr(755,root,root) %ghost %{_libdir}/libaircrack-crypto-x86-avx.so.0
110 %attr(755,root,root) %{_libdir}/libaircrack-crypto-x86-avx.so.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libaircrack-crypto-x86-avx2.so.0
112 %attr(755,root,root) %{_libdir}/libaircrack-crypto-x86-avx2.so.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libaircrack-crypto-x86-sse2.so.0
114 %attr(755,root,root) %{_libdir}/libaircrack-crypto-x86-sse2.so.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libaircrack-crypto.so.0
116 %attr(755,root,root) %{_libdir}/libaircrack-crypto.so.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libaircrack-osdep.so.0
118 %attr(755,root,root) %{_libdir}/libaircrack-osdep.so.*.*
119
120 %{_mandir}/man1/aircrack-ng.1*
121 %{_mandir}/man1/airdecap-ng.1*
122 %{_mandir}/man1/airdecloak-ng.1*
123 %{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
124 %{_mandir}/man1/besside-ng-crawler.1*
125 %{_mandir}/man1/ivstools.1*
126 %{_mandir}/man1/kstats.1*
127 %{_mandir}/man1/makeivs-ng.1*
128 %{_mandir}/man1/packetforge-ng.1*
129 %{_mandir}/man1/wpaclean.1*
130 %{_mandir}/man8/airbase-ng.8*
131 %{_mandir}/man8/aireplay-ng.8*
132 %{_mandir}/man8/airventriloquist-ng.8*
133 %{_mandir}/man8/airmon-ng.8*
134 %{_mandir}/man8/airodump-ng-oui-update.8*
135 %{_mandir}/man8/airodump-ng.8*
136 %{_mandir}/man8/airserv-ng.8*
137 %{_mandir}/man8/airtun-ng.8*
138
139 %if %{with experimental}
140 %attr(755,root,root) %{_bindir}/besside-ng-crawler
141 %attr(755,root,root) %{_bindir}/buddy-ng
142 %attr(755,root,root) %{_sbindir}/besside-ng
143 %attr(755,root,root) %{_sbindir}/easside-ng
144 %attr(755,root,root) %{_sbindir}/tkiptun-ng
145 %attr(755,root,root) %{_sbindir}/wesside-ng
146 %{_mandir}/man1/buddy-ng.1*
147 %{_mandir}/man8/besside-ng.8*
148 %{_mandir}/man8/easside-ng.8*
149 %{_mandir}/man8/tkiptun-ng.8*
150 %{_mandir}/man8/wesside-ng.8*
151 %endif
This page took 0.063728 seconds and 3 git commands to generate.