]> git.pld-linux.org Git - packages/aethera.git/blob - aethera.spec
- debug off
[packages/aethera.git] / aethera.spec
1 %define         _rel    0.1
2 Summary:        Aethera - Email and PIM application
3 Summary(pl):    Aethera - aplikacja e-mail i zarz±dcy informacji osobistej (PIM)
4 Name:           aethera
5 Version:        1.2.1
6 Release:        050331.%{_rel}
7 License:        GPL
8 Group:          X11/Applications
9 Source0:        %{name}-%{version}.tar.gz
10 Patch0:         %{name}-libs.patch
11 Patch1:         %{name}-includes.patch
12 Patch2:         %{name}-install.patch
13 # Source0-md5:  f3efd064b5e9884bd7adf49bf763e213
14 URL:            http://www.thekompany.com/projects/aethera/
15 BuildRequires:  korelib-devel
16 BuildRequires:  qt-devel
17 #Requires: thekompany-support
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Aethera is a pim application, i.e. it handles all kinds of personal
22 information: email, contacts, notes, tasks, todos, journals.
23
24 %description -l pl
25 Aethera jest aplikacj± zarz±dcy informacji osobistej (PIM). Obs³uguje
26 wszystkie rodzaje informacji osobistych: e-mail, kontakty, notatki,
27 zadania, sprawy do za³atwienia, dzienniki.
28
29 %package devel
30 Summary:        Header files for Aethera
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for Aethera library.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40 %patch1 -p1
41 %patch2 -p1
42
43 mkdir -p include/aethera
44 ln -sf ../../aethera/libs/clientskel/clientrmi.h include/aethera
45 ln -sf ../../aethera/libs/clientskel/vfsmodule.h include/aethera
46
47 %build
48 export QTDIR=/usr
49 export QMAKE_STRIP=:
50
51 # Use the new libraries in building process
52 export LD_LIBRARY_PATH=$dir/lib:$LD_LIBRARY_PATH
53 dir=$(pwd)
54
55 # Compile tkcBase
56 cd tkcbase
57 cat <<EOF > defines.pri
58 TKCBASE_LIB=%{_libdir}
59 TKCBASE_INCLUDE=%{_includedir}/tkcbase
60 CONFIG += release thread
61 EOF
62 qmake desktop.pro
63 %{__make}
64
65 # Compile tkcSSL
66 cd ../tkcssl
67 cat <<EOF > defines.pri
68 TKCSSL_LIB=%{_libdir}
69 TKCSSL_INCLUDE=%{_includedir}/tkcssl
70 INCLUDEPATH += $dir/tkcbase
71 DEPENDPATH += $dir/tkcbase
72 CONFIG += release thread
73 EOF
74 qmake tkcssl.pro
75 %{__make}
76
77 # Compile webdav
78 cd ../webdav
79 cat <<EOF > defines.pri
80 WEBDAV_LIB=%{_libdir}
81 WEBDAV_INCLUDE=%{_includedir}/tkcbase
82 CONFIG += release thread
83 EOF
84 qmake webdav.pro
85 %{__make}
86
87 # Compile Aethera
88 cd ../aethera
89 cat <<EOF > defines.pri
90 AETHERA_DIR=%{_libdir}/aethera
91 AETHERA_BIN=%{_bindir}
92 AETHERA_LIB=%{_libdir}
93 AETHERA_INCLUDE=%{_includedir}/aethera
94 TINO_LIB=%{_libdir}
95 TINO_INCLUDE=%{_includedir}/tino
96 INCLUDEPATH += $dir/include
97 INCLUDEPATH += $dir/tkcbase
98 DEPENDPATH += $dir/tkcbase
99 INCLUDEPATH += $dir/tkcssl
100 DEPENDPATH += $dir/tkcssl
101
102 CONFIG += qt warn_on release thread
103 EOF
104
105 qmake aethera.pro
106 %{__make}
107
108 # Compile KOrganizer plugin
109 cd ../koplugin
110 cat <<EOF > defines.pri
111 AETHERA_DIR = %{_libdir}/aethera
112
113 INCLUDEPATH += $dir/include
114 INCLUDEPATH += $dir/tkcbase
115 DEPENDPATH += $dir/tkcbase
116
117 INCLUDEPATH += $dir/tkcssl
118 DEPENDPATH += $dir/tkcssl
119
120 INCLUDEPATH += $dir/aethera/libs
121 DEPENDPATH += $dir/aethera/libs
122
123 INCLUDEPATH += $dir/aethera/libs/aethera
124 DEPENDPATH += $dir/aethera/libs/aethera
125
126 INCLUDEPATH += $direbdav/webdav
127 DEPENDPATH += $dir/webdav/webdav
128
129 INCLUDEPATH += $dir/aethera/libs/clientskel
130 DEPENDPATH += $dir/aethera/libs/clientskel
131
132 INCLUDEPATH += $dir/include/aethera/libs/plugins/kommailplugin
133 DEPENDPATH += $dir/include/aethera/libs/plugins/kommailplugin
134
135 INCLUDEPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
136 DEPENDPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
137
138 INCLUDEPATH += $dir/include/tino
139 DEPENDPATH += $dir/include/tino
140
141 CONFIG += qt warn_on release thread
142 DEFINES += AETHERA_KOLAB
143 EOF
144
145 qmake KOPlugin.pro
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT%{_libdir}/aethera
151
152 export QTDIR=/usr
153 %{__make} -C tkcbase install \
154         INSTALL_ROOT=$RPM_BUILD_ROOT
155 %{__make} -C tkcssl install \
156         INSTALL_ROOT=$RPM_BUILD_ROOT
157 %{__make} -C webdav install \
158         INSTALL_ROOT=$RPM_BUILD_ROOT
159 %{__make} -C aethera install \
160         INSTALL_ROOT=$RPM_BUILD_ROOT
161 %{__make} -C koplugin install \
162         INSTALL_ROOT=$RPM_BUILD_ROOT
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %files
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/aethera
170 %dir %attr(755,root,root) %{_libdir}/aethera
171 %dir %attr(755,root,root) %{_libdir}/aethera/plugins
172 %attr(755,root,root) %{_libdir}/aethera/plugins/libkommailplugin.so.1.0.0
173 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomnotesplugin.so.1.0.0
174 %attr(755,root,root) %{_libdir}/aethera/plugins/libkorganizer.so.1.0.0
175 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomcontactsplugin.so.1.0.0
176 %dir %{_libdir}/aethera
177 %{_libdir}/aethera/help
178 %{_libdir}/aethera/pics
179 %{_libdir}/aethera/sound
180 %{_libdir}/aethera/data
181 %dir %{_libdir}/aethera/i18n
182 %lang(de) %{_libdir}/aethera/i18n/aethera_de.qm
183 %lang(de) %{_libdir}/aethera/i18n/aethera_de.ts
184 %lang(de) %{_libdir}/aethera/i18n/koplugin_de.ts
185 %lang(en) %{_libdir}/aethera/i18n/aethera_en.ts
186 %lang(en) %{_libdir}/aethera/i18n/koplugin_en.ts
187 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.qm
188 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.ts
189 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.qm
190 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.ts
191 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.qm
192 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.ts
193 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.qm
194 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.ts
195 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.qm
196 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.ts
197 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.qm
198 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.ts
199 %{_desktopdir}/aethera.desktop
200 %{_iconsdir}/hicolor/*/apps/aethera.png
201 %{_pixmapsdir}/*.png
202
203 %files devel
204 %defattr(644,root,root,755)
205 %{_includedir}/aethera
206 %{_includedir}/tino
207 %{_includedir}/tkcbase
208 %{_includedir}/tkcssl
This page took 0.070754 seconds and 4 git commands to generate.