]> git.pld-linux.org Git - packages/aethera.git/blob - aethera.spec
ef368211cf474683eb75178d0d8f9f567d04a1bd
[packages/aethera.git] / aethera.spec
1 %define         _rel    0.1
2 Summary:        Aethera - Email and PIM application
3 Summary(pl):    Aethera - aplikacja e-mail i zarz±dcy informacji osobistej (PIM)
4 Name:           aethera
5 Version:        1.2.1
6 Release:        050331.%{_rel}
7 License:        GPL
8 Group:          X11/Applications
9 Source0:        %{name}-%{version}.tar.gz
10 Patch0:         %{name}-libs.patch
11 Patch1:         %{name}-includes.patch
12 Patch2:         %{name}-install.patch
13 # Source0-md5:  f3efd064b5e9884bd7adf49bf763e213
14 URL:            http://www.thekompany.com/projects/aethera/
15 BuildRequires:  korelib-devel
16 BuildRequires:  qt-devel
17 #Requires: thekompany-support
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Aethera is a pim application, i.e. it handles all kinds of personal
22 information: email, contacts, notes, tasks, todos, journals.
23
24 %description -l pl
25 Aethera jest aplikacj± zarz±dcy informacji osobistej (PIM). Obs³uguje
26 wszystkie rodzaje informacji osobistych: e-mail, kontakty, notatki,
27 zadania, sprawy do za³atwienia, dzienniki.
28
29 %package devel
30 Summary:        Header files for Aethera
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for Aethera library.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40 %patch1 -p1
41 %patch2 -p1
42
43 mkdir -p include/aethera
44 ln -sf ../../aethera/libs/clientskel/clientrmi.h include/aethera
45 ln -sf ../../aethera/libs/clientskel/vfsmodule.h include/aethera
46
47 %build
48 export QTDIR=/usr
49 export QMAKE_STRIP=:
50
51 # Use the new libraries in building process
52 export LD_LIBRARY_PATH=$dir/lib:$LD_LIBRARY_PATH
53 dir=$(pwd)
54
55 # Compile tkcBase
56 cd tkcbase
57 %if 0
58 cat <<EOF > defines.pri
59 TKCBASE_LIB=%{_libdir}
60 TKCBASE_INCLUDE=%{_includedir}/tkcbase
61 CONFIG += release thread
62 EOF
63 qmake desktop.pro
64 %{__make}
65
66 # Compile tkcSSL
67 cd ../tkcssl
68 cat <<EOF > defines.pri
69 TKCSSL_LIB=%{_libdir}
70 TKCSSL_INCLUDE=%{_includedir}/tkcssl
71 INCLUDEPATH += $dir/tkcbase
72 DEPENDPATH += $dir/tkcbase
73 CONFIG += release thread
74 EOF
75 qmake tkcssl.pro
76 %{__make}
77
78 # Compile webdav
79 cd ../webdav
80 cat <<EOF > defines.pri
81 WEBDAV_LIB=%{_libdir}
82 WEBDAV_INCLUDE=%{_includedir}/tkcbase
83 CONFIG += release thread
84 EOF
85 qmake webdav.pro
86 %{__make}
87
88 # Compile Aethera
89 cd ../aethera
90 cat <<EOF > defines.pri
91 AETHERA_DIR=%{_libdir}/aethera
92 AETHERA_BIN=%{_bindir}
93 AETHERA_LIB=%{_libdir}
94 AETHERA_INCLUDE=%{_includedir}/aethera
95 TINO_LIB=%{_libdir}
96 TINO_INCLUDE=%{_includedir}/tino
97 INCLUDEPATH += $dir/include
98 INCLUDEPATH += $dir/tkcbase
99 DEPENDPATH += $dir/tkcbase
100 INCLUDEPATH += $dir/tkcssl
101 DEPENDPATH += $dir/tkcssl
102
103 CONFIG += qt warn_on release thread
104 EOF
105
106 qmake aethera.pro
107 %{__make}
108 %endif
109
110 # Compile KOrganizer plugin
111 cd ../koplugin
112 cat <<EOF > defines.pri
113 AETHERA_DIR = %{_libdir}/aethera
114
115 INCLUDEPATH += $dir/include
116 INCLUDEPATH += $dir/tkcbase
117 DEPENDPATH += $dir/tkcbase
118
119 INCLUDEPATH += $dir/tkcssl
120 DEPENDPATH += $dir/tkcssl
121
122 INCLUDEPATH += $dir/aethera/libs
123 DEPENDPATH += $dir/aethera/libs
124
125 INCLUDEPATH += $dir/aethera/libs/aethera
126 DEPENDPATH += $dir/aethera/libs/aethera
127
128 INCLUDEPATH += $direbdav/webdav
129 DEPENDPATH += $dir/webdav/webdav
130
131 INCLUDEPATH += $dir/aethera/libs/clientskel
132 DEPENDPATH += $dir/aethera/libs/clientskel
133
134 INCLUDEPATH += $dir/include/aethera/libs/plugins/kommailplugin
135 DEPENDPATH += $dir/include/aethera/libs/plugins/kommailplugin
136
137 INCLUDEPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
138 DEPENDPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
139
140 INCLUDEPATH += $dir/include/tino
141 DEPENDPATH += $dir/include/tino
142
143 CONFIG += qt warn_on release thread
144 DEFINES += AETHERA_KOLAB
145 EOF
146
147 qmake KOPlugin.pro
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT%{_libdir}/aethera
153
154 export QTDIR=/usr
155 %{__make} -C tkcbase install \
156         INSTALL_ROOT=$RPM_BUILD_ROOT
157 %{__make} -C tkcssl install \
158         INSTALL_ROOT=$RPM_BUILD_ROOT
159 %{__make} -C webdav install \
160         INSTALL_ROOT=$RPM_BUILD_ROOT
161 %{__make} -C aethera install \
162         INSTALL_ROOT=$RPM_BUILD_ROOT
163 %{__make} -C koplugin install \
164         INSTALL_ROOT=$RPM_BUILD_ROOT
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %files
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/aethera
172 %dir %attr(755,root,root) %{_libdir}/aethera
173 %dir %attr(755,root,root) %{_libdir}/aethera/plugins
174 %attr(755,root,root) %{_libdir}/aethera/plugins/libkommailplugin.so.1.0.0
175 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomnotesplugin.so.1.0.0
176 %attr(755,root,root) %{_libdir}/aethera/plugins/libkorganizer.so.1.0.0
177 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomcontactsplugin.so.1.0.0
178 %dir %{_libdir}/aethera
179 %{_libdir}/aethera/help
180 %{_libdir}/aethera/pics
181 %{_libdir}/aethera/sound
182 %{_libdir}/aethera/data
183 %dir %{_libdir}/aethera/i18n
184 %lang(de) %{_libdir}/aethera/i18n/aethera_de.qm
185 %lang(de) %{_libdir}/aethera/i18n/aethera_de.ts
186 %lang(de) %{_libdir}/aethera/i18n/koplugin_de.ts
187 %lang(en) %{_libdir}/aethera/i18n/aethera_en.ts
188 %lang(en) %{_libdir}/aethera/i18n/koplugin_en.ts
189 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.qm
190 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.ts
191 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.qm
192 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.ts
193 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.qm
194 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.ts
195 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.qm
196 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.ts
197 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.qm
198 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.ts
199 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.qm
200 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.ts
201 %{_desktopdir}/aethera.desktop
202 %{_iconsdir}/hicolor/*/apps/aethera.png
203 %{_pixmapsdir}/*.png
204
205 %files devel
206 %defattr(644,root,root,755)
207 %{_includedir}/aethera
208 %{_includedir}/tino
209 %{_includedir}/tkcbase
210 %{_includedir}/tkcssl
This page took 0.100973 seconds and 3 git commands to generate.