]> git.pld-linux.org Git - packages/aero.git/blob - aero.spec
819fac4847aa999786d1b96263210dd048c8f6bd
[packages/aero.git] / aero.spec
1 #
2 Summary:        Simulation program based on rigid body systems
3 Name:           aero
4 Version:        1.7.0
5 Release:        0.1
6 License:        Public domain
7 Group:          Applications
8 Source0:        http://robotics.ee.uwa.edu.au/aero/ftp/%{name}_%{version}_src.tar.gz
9 # Source0-md5:  2ea6f065bc77162ce6b4f4c4a17a3636
10 URL:            http://robotics.ee.uwa.edu.au/aero/ftp/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 AERO is a simulation program based on rigid body systems. With the built-in 
15 3D editor you can create a virtual scene consisting of spheres, boxes 
16 (cuboids), cylinders and plains. These objects may be connected with links 
17 like spring, damper, rod and joint.
18
19 %prep
20 %setup -q -n %{name}
21 cp src/Makefile{.linux,}
22
23 %build
24
25 cd src 
26 %{__make} \
27         CFLAGS="%{rpmcflags}" \
28         LDFLAGS="%{rpmldflags}"
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 # create directories if necessary
33 #install -d $RPM_BUILD_ROOT
34 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
35
36 %{__make} install \
37         DESTDIR=$RPM_BUILD_ROOT
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %pre
43
44 %post
45
46 %preun
47
48 %postun
49
50 %if %{with ldconfig}
51 %post   -p /sbin/ldconfig
52 %postun -p /sbin/ldconfig
53 %endif
54
55 %if %{with initscript}
56 %post init
57 /sbin/chkconfig --add %{name}
58 %service %{name} restart
59
60 %preun init
61 if [ "$1" = "0" ]; then
62         %service -q %{name} stop
63         /sbin/chkconfig --del %{name}
64 fi
65 %endif
66
67 %files
68 %defattr(644,root,root,755)
69 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
70
71 %if 0
72 # if _sysconfdir != /etc:
73 #%%dir %{_sysconfdir}
74 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
75 %attr(755,root,root) %{_bindir}/*
76 %{_datadir}/%{name}
77 %endif
78
79 # initscript and its config
80 %if %{with initscript}
81 %attr(754,root,root) /etc/rc.d/init.d/%{name}
82 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
83 %endif
84
85 #%{_examplesdir}/%{name}-%{version}
86
87 %if %{with subpackage}
88 %files subpackage
89 %defattr(644,root,root,755)
90 #%doc extras/*.gz
91 #%{_datadir}/%{name}-ext
92 %endif
This page took 0.109331 seconds and 3 git commands to generate.