]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
- fix build (libtool issue @ sparc64).
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl):    Polecenie i biblioteka do manipulacji listami kontroli dostêpu (ACL)
3 Name:           acl
4 Version:        2.2.28
5 Release:        1
6 License:        LGPL v2+ (library), GPL v2 (utilities)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 # Source0-md5:  69ba4f7e2bb87d20aedd15249f8747eb
10 Patch0:         %{name}-miscfix.patch
11 Patch1:         %{name}-lt.patch
12 URL:            http://oss.sgi.com/projects/xfs/
13 BuildRequires:  attr-devel >= 2.4.16-3
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gettext-devel
17 BuildRequires:  sed >= 4.0
18 Requires:       attr >= 2.4.15
19 Obsoletes:      libacl
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _bindir         /bin
23 %define         _libdir         /%{_lib}
24 %define         _libexecdir     /usr/%{_lib}
25
26 %description
27 A command (chacl) and a library (libacl) to manipulate POSIX access
28 control lists under Linux.
29
30 %description -l pl
31 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
32 POSIX listami kontroli dostêpu (ACL) pod Linuksem.
33
34 %package devel
35 Summary:        Header files for acl library
36 Summary(pl):    Pliki nag³ówkowe biblioteki acl
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       attr-devel >= 2.4.16-3
40
41 %description devel
42 Header files to develop software which manipulate access control
43 lists.
44
45 %description devel -l pl
46 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
47 listami kontroli dostêpu (ACL).
48
49 %package static
50 Summary:        Static acl library
51 Summary(pl):    Statyczna biblioteka acl
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static acl library.
57
58 %description static -l pl
59 Statyczna biblioteka acl.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65
66 %build
67 rm -f aclocal.m4
68 %{__aclocal} -I m4
69 %{__autoconf}
70 %configure \
71         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
72         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
79
80 DIST_ROOT=$RPM_BUILD_ROOT
81 DIST_INSTALL=`pwd`/install.manifest
82 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
83 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
84 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
85
86 %{__make} install \
87         DIST_MANIFEST=$DIST_INSTALL
88 %{__make} install-dev \
89         DIST_MANIFEST=$DIST_INSTALL_DEV
90 %{__make} install-lib \
91         DIST_MANIFEST=$DIST_INSTALL_LIB
92
93 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
94 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
95 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
96 echo ".so acl_get_fd.3"         > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
97 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
98 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
99 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
100
101 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
102 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
103         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
104 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
105         $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc README doc/{CHANGES,TODO}
118 %attr(755,root,root) %{_bindir}/*
119 %attr(755,root,root) %{_libdir}/lib*.so.*.*
120 %{_mandir}/man[15]/*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc doc/{extensions.txt,libacl.txt}
125 %attr(755,root,root) %{_libexecdir}/lib*.so
126 %{_libexecdir}/lib*.la
127 %{_includedir}/acl
128 %{_includedir}/sys/*
129 %{_mandir}/man[23]/*
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libexecdir}/lib*.a
This page took 0.413422 seconds and 4 git commands to generate.