]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
- rely on libattr.la hacked in attr >= 2.4.16-3 instead of hacking libacl.la here
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl):    Polecenie i biblioteka do manipulacji listami kontroli dostêpu (ACL)
3 Name:           acl
4 Version:        2.2.23
5 Release:        2
6 License:        GPL v2 (chacl utility), LGPL v2+ (library and the rest)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 # Source0-md5:  7e13778c38addfcdabf2cef291b78bcc
10 Patch0:         %{name}-miscfix.patch
11 URL:            http://oss.sgi.com/projects/xfs/
12 BuildRequires:  attr-devel >= 2.4.16-3
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  gettext-devel
16 Requires:       attr >= 2.4.15
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _bindir         /bin
20 %define         _libdir         /%{_lib}
21 %define         _libexecdir     /usr/%{_lib}
22
23 %description
24 A command (chacl) and a library (libacl) to manipulate POSIX access
25 control lists under Linux.
26
27 %description -l pl
28 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
29 POSIX listami kontroli dostêpu (ACL) pod Linuksem.
30
31 %package devel
32 Summary:        Header files for acl library
33 Summary(pl):    Pliki nag³ówkowe biblioteki acl
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       attr-devel
37
38 %description devel
39 Header files to develop software which manipulate access control
40 lists.
41
42 %description devel -l pl
43 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
44 listami kontroli dostêpu (ACL).
45
46 %package static
47 Summary:        Static acl library
48 Summary(pl):    Statyczna biblioteka acl
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static acl library.
54
55 %description static -l pl
56 Statyczna biblioteka acl.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 rm -f aclocal.m4
64 %{__aclocal} -I m4
65 %{__autoconf}
66 %configure \
67         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
68         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
75
76 DIST_ROOT=$RPM_BUILD_ROOT
77 DIST_INSTALL=`pwd`/install.manifest
78 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
79 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
80 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
81
82 %{__make} install \
83         DIST_MANIFEST=$DIST_INSTALL
84 %{__make} install-dev \
85         DIST_MANIFEST=$DIST_INSTALL_DEV
86 %{__make} install-lib \
87         DIST_MANIFEST=$DIST_INSTALL_LIB
88
89 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
90 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
91 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
92 echo ".so acl_get_fd.3" > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
93 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
94 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
95 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
96
97 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
98 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
99         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
100
101 %find_lang %{name}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files -f %{name}.lang
110 %defattr(644,root,root,755)
111 %doc README doc/{CHANGES,TODO}
112 %attr(755,root,root) %{_bindir}/*
113 %attr(755,root,root) %{_libdir}/lib*.so.*.*
114 %{_mandir}/man[15]/*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %doc doc/{extensions.txt,libacl.txt}
119 %attr(755,root,root) %{_libexecdir}/lib*.so
120 %{_libexecdir}/lib*.la
121 %{_includedir}/acl
122 %{_includedir}/sys/*
123 %{_mandir}/man[23]/*
124
125 %files static
126 %defattr(644,root,root,755)
127 %{_libexecdir}/lib*.a
This page took 0.06117 seconds and 4 git commands to generate.