]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
- fix url
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl.UTF-8):      Polecenie i biblioteka do manipulacji listami kontroli dostępu (ACL)
3 Name:           acl
4 Version:        2.2.49
5 Release:        1
6 License:        LGPL v2+ (library), GPL v2 (utilities)
7 Group:          Applications/System
8 Source0:        http://download.savannah.gnu.org/releases-noredirect/acl/%{name}-%{version}.src.tar.gz
9 # Source0-md5:  181445894cca986da9ae0099d5ce2d08
10 Patch0:         %{name}-miscfix.patch
11 Patch1:         %{name}-lt.patch
12 Patch2:         %{name}-LDFLAGS.patch
13 Patch3:         %{name}-pl.po-update.patch
14 URL:            http://savannah.nongnu.org/projects/acl/
15 BuildRequires:  attr-devel >= 2.4.16-3
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel
19 BuildRequires:  libtool
20 Requires:       attr >= 2.4.15
21 Obsoletes:      libacl
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _bindir         /bin
25 %define         _libdir         /%{_lib}
26 %define         _libexecdir     /usr/%{_lib}
27
28 %description
29 A command (chacl) and a library (libacl) to manipulate POSIX access
30 control lists under Linux.
31
32 %description -l pl.UTF-8
33 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
34 POSIX listami kontroli dostępu (ACL) pod Linuksem.
35
36 %package devel
37 Summary:        Header files for acl library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki acl
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       attr-devel >= 2.4.16-3
42
43 %description devel
44 Header files to develop software which manipulate access control
45 lists.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe potrzebne do rozwoju oprogramowania manipulującego
49 listami kontroli dostępu (ACL).
50
51 %package static
52 Summary:        Static acl library
53 Summary(pl.UTF-8):      Statyczna biblioteka acl
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static acl library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka acl.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 rm -f aclocal.m4
71
72 %build
73 mv install-sh install-custom-sh
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 cp -f /usr/share/automake/config.sub .
78 mv install-custom-sh install-sh
79 %configure \
80         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
81         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
82
83 %{__make} \
84         LLDFLAGS="%{rpmldflags}" \
85         top_builddir="../"
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
90
91 export DIST_ROOT=$RPM_BUILD_ROOT
92 P=$(pwd)
93 DIST_INSTALL=$P/install.manifest
94 DIST_INSTALL_DEV=$P/install-dev.manifest
95 DIST_INSTALL_LIB=$P/install-lib.manifest
96
97 %{__make} install \
98         DIST_MANIFEST=$DIST_INSTALL \
99         top_builddir="../"
100 %{__make} install-dev \
101         DIST_MANIFEST=$DIST_INSTALL_DEV \
102         top_builddir="../"
103 %{__make} install-lib \
104         DIST_MANIFEST=$DIST_INSTALL_LIB \
105         top_builddir="../"
106
107 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
108 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
109 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
110 echo ".so acl_get_fd.3"         > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
111 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
112 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
113 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
114
115 #rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
116 ln -snf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libacl.so.*.*.*) \
117         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
118 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
119         $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
120
121 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
122
123 # already in /usr
124 rm -f $RPM_BUILD_ROOT%{_libdir}/libacl.{so,la,a}
125
126 %find_lang %{name}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc README doc/{CHANGES,TODO}
137 %attr(755,root,root) %{_bindir}/chacl
138 %attr(755,root,root) %{_bindir}/getfacl
139 %attr(755,root,root) %{_bindir}/setfacl
140 %attr(755,root,root) %{_libdir}/libacl.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libacl.so.1
142 %{_mandir}/man1/chacl.1*
143 %{_mandir}/man1/getfacl.1*
144 %{_mandir}/man1/setfacl.1*
145 %{_mandir}/man5/acl.5*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc doc/{extensions.txt,libacl.txt}
150 %attr(755,root,root) %{_libexecdir}/libacl.so
151 %{_libexecdir}/libacl.la
152 %{_includedir}/acl
153 %{_includedir}/sys/acl.h
154 %{_mandir}/man3/acl_*.3*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libexecdir}/libacl.a
This page took 0.080982 seconds and 3 git commands to generate.