]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- fix files and BRs
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - handle obsolete packages: abrt-plugin-{catcut,rhfastcheck,rhticket,ticketuploader}
4 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
5 #
6 # Conditional build:
7 %bcond_without  tests   # disable pythontests
8
9 %define         libreport_ver   2.10.0
10 Summary:        Automatic bug detection and reporting tool
11 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
12 Name:           abrt
13 Version:        2.13.0
14 Release:        2
15 License:        GPL v2+
16 Group:          Applications/System
17 Source0:        https://github.com/abrt/abrt/archive/%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  4da66a03140254598e5d599a3c805b53
19 Source1:        %{name}.init
20 Patch0:         %{name}-rpm5.patch
21 Patch1:         %{name}-rpm45.patch
22 Patch2:         %{name}-link.patch
23 URL:            https://abrt.readthedocs.org/
24 BuildRequires:  asciidoc
25 BuildRequires:  augeas
26 BuildRequires:  autoconf >= 2.50
27 BuildRequires:  automake
28 BuildRequires:  dbus-devel
29 BuildRequires:  docbook-dtd45-xml
30 BuildRequires:  gettext-tools >= 0.17
31 BuildRequires:  glib2-devel >= 1:2.43
32 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
33 BuildRequires:  gtk+3-devel >= 3.0
34 BuildRequires:  hawkey-devel
35 BuildRequires:  intltool >= 0.35.0
36 BuildRequires:  json-c-devel
37 BuildRequires:  libgomp-devel
38 BuildRequires:  libnotify-devel >= 0.7.0
39 BuildRequires:  libreport-devel >= %{libreport_ver}
40 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
41 BuildRequires:  libreport-web-devel >= %{libreport_ver}
42 BuildRequires:  libselinux-devel
43 BuildRequires:  libtool
44 BuildRequires:  libxml2-devel >= 2
45 BuildRequires:  nss-devel
46 BuildRequires:  pkgconfig
47 BuildRequires:  polkit-devel
48 BuildRequires:  python3-devel >= 1:3
49 BuildRequires:  python3-modules >= 1:3
50 BuildRequires:  python3-nose
51 %{?with_tests:BuildRequires:    python3-nose}
52 BuildRequires:  rpm-devel >= 4.5-28
53 BuildRequires:  rpm-pythonprov
54 BuildRequires:  rpmbuild(macros) >= 1.721
55 BuildRequires:  satyr-devel >= 0.21
56 BuildRequires:  systemd-devel
57 BuildRequires:  xmlto
58 Requires(postun):       /usr/sbin/groupdel
59 Requires(postun):       /usr/sbin/userdel
60 Requires(pre):  /bin/id
61 Requires(pre):  /usr/bin/getgid
62 Requires(pre):  /usr/sbin/groupadd
63 Requires(pre):  /usr/sbin/useradd
64 Requires:       %{name}-libs = %{version}-%{release}
65 Provides:       group(abrt)
66 Provides:       user(abrt)
67 Obsoletes:      abrt-atomic < 2.13.0
68 Obsoletes:      abrt-cli < 2.13.0
69 Obsoletes:      abrt-coredump-helper < 2.13.0
70 Obsoletes:      abrt-plugin-filetransfer
71 Obsoletes:      abrt-plugin-runapp
72 Obsoletes:      abrt-plugin-sosreport
73 Obsoletes:      abrt-plugin-sqlite3
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 ABRT is a tool to help users to detect defects in applications and to
78 create a bug report with all informations needed by maintainer to fix
79 it. It uses plugin system to extend its functionality.
80
81 %description -l pl.UTF-8
82 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
83 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
84 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
85 system wtyczek do rozszerzania funkcjonalności.
86
87 %package -n bash-completion-abrt
88 Summary:        Bash completion for abrt command
89 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla polecenia abrt
90 Group:          Applications/Shells
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       bash-completion
93 Requires:       python3-argcomplete
94 %if "%{_rpmversion}" >= "5"
95 BuildArch:      noarch
96 %endif
97
98 %description -n bash-completion-abrt
99 Bash completion for abrt command.
100
101 %description -n bash-completion-abrt -l pl.UTF-8
102 Bashowe dopełnianie parametrów dla polecenia abrt.
103
104 %package libs
105 Summary:        ABRT shared library
106 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
107 Group:          Libraries
108 Requires:       glib2 >= 1:2.43
109 Requires:       libreport >= %{libreport_ver}
110
111 %description libs
112 ABRT shared library.
113
114 %description libs -l pl.UTF-8
115 Biblioteka współdzielona ABRT.
116
117 %package devel
118 Summary:        Header files for ABRT livrary
119 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
120 Group:          Development/Libraries
121 Requires:       %{name}-libs = %{version}-%{release}
122 Requires:       glib2-devel >= 1:2.43
123 Requires:       libreport-devel >= %{libreport_ver}
124
125 %description devel
126 Header files for ABRT livrary.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe biblioteki ABRT.
130
131 %package addon-ccpp
132 Summary:        ABRT's C/C++ addon
133 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
134 Group:          Libraries
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       %{name}-retrace-client = %{version}-%{release}
137 Requires:       cpio
138 Requires:       elfutils
139 Requires:       gdb >= 7.0-3
140 Requires:       satyr >= 0.21
141 Requires:       yum-utils
142 Obsoletes:      abrt-atomic
143
144 %description addon-ccpp
145 This package contains hook for C/C++ crashed programs and abrt's C/C++
146 analyzer plugin.
147
148 %description addon-ccpp -l pl.UTF-8
149 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
150 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
151
152 %package addon-kerneloops
153 Summary:        ABRT's kerneloops addon
154 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
155 Group:          Libraries
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       curl
158 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
159 Obsoletes:      abrt-plugin-kerneloops
160 Obsoletes:      abrt-plugin-kerneloopsreporter
161 Obsoletes:      kerneloops
162
163 %description addon-kerneloops
164 This package contains plugin for collecting kernel crash information
165 from system log.
166
167 %description addon-kerneloops -l pl.UTF-8
168 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
169 logu systemowego.
170
171 %package addon-pstoreoops
172 Summary:        ABRT's pstoreoops addon
173 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
174 Group:          Libraries
175 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
176 Obsoletes:      abrt-addon-uefioops
177
178 %description addon-pstoreoops
179 This package contains plugin for collecting kernel oopses from pstore
180 storage.
181
182 %description addon-pstoreoops -l pl.UTF-8
183 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
184
185 %package addon-python3
186 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
187 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
188 Group:          Libraries
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       %{name}-python3 = %{version}-%{release}
191 # for detecting package name containing offending file (TODO: python3-rpm package)
192 #Suggests:      python3-rpm
193 # for logging to journal
194 Suggests:       python3-systemd
195
196 %description addon-python3
197 This package contains Python hook and Python analyzer plugin for
198 handling uncaught exception in Python 3 programs.
199
200 %description addon-python3 -l pl.UTF-8
201 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
202 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
203 Pythonie 3.
204
205 %package addon-upload-watch
206 Summary:        ABRT's upload addon
207 Summary(pl.UTF-8):      Dodatek upload do ABRT
208 Group:          Libraries
209 Requires:       %{name} = %{version}-%{release}
210
211 %description addon-upload-watch
212 This package contains hook for uploaded problems.
213
214 %description addon-upload-watch -l pl.UTF-8
215 Ten pakiet zawiera uchwyt dla problemów przysłanych.
216
217 %package addon-vmcore
218 Summary:        ABRT's vmcore addon
219 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
220 Group:          Libraries
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
223 Requires:       crash
224
225 %description addon-vmcore
226 This package contains plugin for collecting kernel crash information
227 from vmcore files.
228
229 %description addon-vmcore -l pl.UTF-8
230 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
231 plików vmcore.
232
233 %package addon-xorg
234 Summary:        ABRT's Xorg addon
235 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
236 Group:          Libraries
237 Requires:       %{name} = %{version}-%{release}
238 Requires:       curl
239
240 %description addon-xorg
241 This package contains plugin for collecting Xorg crash information
242 from Xorg log.
243
244 %description addon-xorg -l pl.UTF-8
245 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
246 logu Xorg.
247
248 %package plugin-bodhi
249 Summary:        ABRT's bodhi plugin
250 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
251 Group:          Libraries
252 Requires:       %{name} = %{version}-%{release}
253 Requires:       libreport-web >= %{libreport_ver}
254 Obsoletes:      libreport-plugin-bodhi
255
256 %description plugin-bodhi
257 Plugin to search for a new updates in bodhi server.
258
259 %description plugin-bodhi -l pl.UTF-8
260 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
261
262 %package retrace-client
263 Summary:        ABRT's retrace client
264 Summary(pl.UTF-8):      Klient Retrace dla ABRT
265 Group:          Libraries
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       xz
268
269 %description retrace-client
270 This package contains the client application for Retrace server which
271 is able to analyze C/C++ crashes remotely.
272
273 %description retrace-client -l pl.UTF-8
274 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
275 potrafi zdalnie przeanalizować awarię programu w C/C++.
276
277 %package dbus
278 Summary:        ABRT DBus service
279 Summary(pl.UTF-8):      Usługa DBus ABRT
280 Group:          Applications/System
281 Requires:       %{name} = %{version}-%{release}
282 Requires:       libreport >= %{libreport_ver}
283
284 %description dbus
285 ABRT DBus service which provides org.freedesktop.problems API on DBus
286 and uses PolicyKit to authorize to access the problem data.
287
288 %description dbus -l pl.UTF-8
289 Usługa DBus ABRT, udostępniająca poprzez DBus API
290 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
291 do danych o problemach.
292
293 %package python3
294 Summary:        ABRT Python 3 API
295 Summary(pl.UTF-8):      API Pythona 3 do ABRT
296 Group:          Libraries/Python
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       python3-libreport >= %{libreport_ver}
299
300 %description python3
301 High-level API for querying, creating and manipulating problems
302 handled by ABRT in Python.
303
304 %description python3 -l pl.UTF-8
305 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
306 Pythona 3 problemów obsługiwanych przez ABRT.
307
308 %package gui
309 Summary:        ABRT's GUI
310 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
311 Group:          X11/Applications
312 Requires(post,postun):  /sbin/ldconfig
313 Requires(post,postun):  gtk-update-icon-cache
314 Requires(post,postun):  hicolor-icon-theme
315 Requires:       %{name} = %{version}-%{release}
316 Requires:       %{name}-dbus = %{version}-%{release}
317 Requires:       %{name}-gui-libs = %{version}-%{release}
318 Suggests:       gnome-abrt
319 Provides:       abrt-applet = %{version}-%{release}
320 Obsoletes:      abrt-applet < 0.0.5
321 Conflicts:      abrt-applet < 0.0.5
322
323 %description gui
324 GTK+ wizard for convenient bug reporting.
325
326 %description gui -l pl.UTF-8
327 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
328
329 %package gui-libs
330 Summary:        ABRT's GUI library
331 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
332 Group:          X11/Libraries
333 Requires:       %{name}-libs = %{version}-%{release}
334 Requires:       gtk+3 >= 3.0
335
336 %description gui-libs
337 ABRT's GUI library.
338
339 %description gui-libs -l pl.UTF-8
340 Biblioteka graficznego interfejsu użytkownika ABRT.
341
342 %package gui-devel
343 Summary:        Header files for ABRT GUI library
344 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
345 Group:          X11/Development/Libraries
346 Requires:       %{name}-devel = %{version}-%{release}
347 Requires:       %{name}-gui-libs = %{version}-%{release}
348 Requires:       gtk+3-devel >= 3.0
349
350 %description gui-devel
351 Header files for ABRT GUI library.
352
353 %description gui-devel -l pl.UTF-8
354 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
355
356 %package desktop
357 Summary:        Virtual package to install all necessary packages for usage from desktop environment
358 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
359 Group:          X11/Applications
360 # This package should be installed when anything requests bug-buddy;
361 # installing abrt-desktop should result in the abrt which works without
362 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
363 Requires:       %{name} = %{version}-%{release}
364 Requires:       %{name}-addon-ccpp = %{version}-%{release}
365 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
366 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
367 Requires:       %{name}-addon-python3 = %{version}-%{release}
368 Requires:       %{name}-addon-vmcore = %{version}-%{release}
369 Requires:       %{name}-addon-xorg = %{version}-%{release}
370 Requires:       %{name}-gui = %{version}-%{release}
371 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
372 Requires:       %{name}-retrace-client = %{version}-%{release}
373 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
374 Requires:       libreport-plugin-logger >= %{libreport_ver}
375 Requires:       libreport-plugin-ureport >= %{libreport_ver}
376 Provides:       bug-buddy
377 Obsoletes:      bug-buddy
378
379 %description desktop
380 Virtual package to make easy default installation on desktop
381 environments.
382
383 %description desktop -l pl.UTF-8
384 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
385 graficznych.
386
387 %package console-notification
388 Summary:        ABRT console notification script
389 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
390 Group:          Applications/System
391 Requires:       %{name} = %{version}-%{release}
392 Requires:       %{name}-cli = %{version}-%{release}
393
394 %description console-notification
395 A small script which prints a count of detected problems when someone
396 logs in to the shell.
397
398 %description console-notification -l pl.UTF-8
399 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
400 się do powłoki.
401
402 %prep
403 %setup -q
404 %if "%{_rpmversion}" >= "5.0"
405 %patch0 -p1
406 %else
407 %patch1 -p1
408 %endif
409 %patch2 -p1
410
411 %{__sed} -n -e '/^%%changelog/,$p' abrt.spec.in | tail -n +2 > changelog
412
413 echo -n %{version} > abrt-version
414
415 %build
416 %{__libtoolize}
417 %{__gettextize}
418 %{__intltoolize}
419 %{__aclocal} -I m4
420 %{__autoconf}
421 %{__autoheader}
422 %{__automake}
423 %configure \
424         PYTHON_NOSE=/usr/bin/nosetests-3.6 \
425         --disable-silent-rules \
426         %{!?with_tests:--without-pythontests} \
427         --with-systemdsystemunitdir=%{systemdunitdir}
428
429 %{__make}
430
431 %install
432 rm -rf $RPM_BUILD_ROOT
433 %{__make} install \
434         DESTDIR=$RPM_BUILD_ROOT \
435         systemdsystemunitdir=%{systemdunitdir} \
436         python3dir=%{py3_sitescriptdir}
437
438 # obsoleted by pkg-config
439 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
440
441 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
442 install -d $RPM_BUILD_ROOT/var/cache/%{name}
443 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
444 install -d $RPM_BUILD_ROOT/var/run/%{name}
445
446 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
447 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
448 d /var/run/%{name} 0755 root root -
449 EOF
450
451 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
452 # examples
453 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
454 # packaged as %doc
455 %{__rm} $RPM_BUILD_ROOT%{_docdir}/abrt/README.md
456
457 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
458 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
459
460 # empty version of nb,ru
461 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{no,ru_RU}
462 # not supported by glibc yet
463 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ach,aln,bal,ilo}
464
465 %find_lang %{name}
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %pre
471 %groupadd -g 248 abrt
472 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
473
474 %post
475 /sbin/chkconfig --add abrtd
476 %service abrtd restart
477 %systemd_post abrtd.service
478
479 %preun
480 if [ "$1" = "0" ]; then
481         %service abrtd stop
482         /sbin/chkconfig --del abrtd
483 fi
484 %systemd_preun abrtd.service
485
486 %postun
487 if [ "$1" = "0" ]; then
488         %userremove abrt
489         %groupremove abrt
490 fi
491
492 %post   libs -p /sbin/ldconfig
493 %postun libs -p /sbin/ldconfig
494
495 %post addon-ccpp
496 %systemd_post abrt-ccpp.service
497 %systemd_post abrt-journal-core.service
498 %journal_catalog_update
499
500 %preun addon-ccpp
501 %systemd_preun abrt-ccpp.service
502 %systemd_preun abrt-journal-core.service
503
504 %post addon-kerneloops
505 %systemd_post abrt-oops.service
506 %journal_catalog_update
507
508 %preun addon-kerneloops
509 %systemd_preun abrt-oops.service
510
511 %post addon-pstoreoops
512 %systemd_post abrt-pstoreoops.service
513
514 %preun addon-pstoreoops
515 %systemd_preun abrt-pstoreoops.service
516
517 %post addon-python3
518 %journal_catalog_update
519
520 %post addon-upload-watch
521 %systemd_post abrt-upload-watch.service
522
523 %preun addon-upload-watch
524 %systemd_preun abrt-upload-watch.service
525
526 %post addon-vmcore
527 %systemd_post abrt-vmcore.service
528 %journal_catalog_update
529
530 %preun addon-vmcore
531 %systemd_preun abrt-vmcore.service
532
533 %post addon-xorg
534 %systemd_post abrt-xorg.service
535 %journal_catalog_update
536
537 %preun addon-xorg
538 %systemd_preun abrt-xorg.service
539
540 %post gui
541 %update_icon_cache hicolor
542
543 %postun gui
544 %update_icon_cache hicolor
545
546 %post   gui-libs -p /sbin/ldconfig
547 %postun gui-libs -p /sbin/ldconfig
548
549 %files -f %{name}.lang
550 %defattr(644,root,root,755)
551 %doc README.md changelog
552 %attr(755,root,root) %{_bindir}/abrt
553 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
554 %attr(755,root,root) %{_bindir}/abrt-action-notify
555 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
556 %attr(755,root,root) %{_bindir}/abrt-handle-upload
557 %attr(755,root,root) %{_bindir}/abrt-watch-log
558 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
559 %attr(755,root,root) %{_sbindir}/abrt-server
560 %attr(755,root,root) %{_sbindir}/abrtd
561 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
562 %attr(755,root,root) %{_libexecdir}/abrt-action-save-container-data
563 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
564 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
565 %{py3_sitedir}/abrtcli
566 %dir %{_datadir}/%{name}
567 %{_datadir}/augeas/lenses/abrt.aug
568 %dir %{_sysconfdir}/%{name}
569 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
570 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
571 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
572 %dir %{_sysconfdir}/%{name}/plugins
573 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/machine-id_event.conf
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
576 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/sosreport_event.conf
577 %attr(754,root,root) /etc/rc.d/init.d/abrtd
578 %{systemdunitdir}/abrtd.service
579 %attr(775,root,abrt) %dir /var/cache/%{name}
580 %dir /var/run/%{name}
581 %{systemdtmpfilesdir}/abrt.conf
582 %{_mandir}/man1/abrt.1*
583 %{_mandir}/man1/abrt-action-analyze-python.1*
584 %{_mandir}/man1/abrt-action-notify.1*
585 %{_mandir}/man1/abrt-action-save-package-data.1*
586 %{_mandir}/man1/abrt-auto-reporting.1*
587 %{_mandir}/man1/abrt-handle-upload.1*
588 %{_mandir}/man1/abrt-server.1*
589 %{_mandir}/man1/abrt-watch-log.1*
590 %{_mandir}/man5/abrt.conf.5*
591 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
592 %{_mandir}/man5/abrt_event.conf.5*
593 %{_mandir}/man5/report_event.conf.5
594 %{_mandir}/man5/gpg_keys.conf.5*
595 %{_mandir}/man5/smart_event.conf.5*
596 %{_mandir}/man8/abrtd.8*
597
598 %files -n bash-completion-abrt
599 %defattr(644,root,root,755)
600 /etc/bash_completion.d/abrt.bash_completion
601
602 %files libs
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
605 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
606
607 %files devel
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/libabrt.so
610 %dir %{_includedir}/abrt
611 %{_includedir}/abrt/abrt-dbus.h
612 %{_includedir}/abrt/hooklib.h
613 %{_includedir}/abrt/libabrt.h
614 %{_includedir}/abrt/problem_api.h
615 %{_pkgconfigdir}/abrt.pc
616
617 %files addon-ccpp
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
620 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
621 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
622 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
623 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
624 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
625 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
626 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
627 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
628 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
629 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
630 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
631 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
632 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
633 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
634 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
635 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
637 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_journal_ccpp_format.conf
638 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
639 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
640 %{_datadir}/libreport/events/analyze_CCpp.xml
641 %{_datadir}/libreport/events/analyze_LocalGDB.xml
642 %{_datadir}/libreport/events/collect_GConf.xml
643 %{_datadir}/libreport/events/collect_vimrc_system.xml
644 %{_datadir}/libreport/events/collect_vimrc_user.xml
645 %{_datadir}/libreport/events/collect_xsession_errors.xml
646 %{_datadir}/libreport/events/post_report.xml
647 %{systemdunitdir}/abrt-journal-core.service
648 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
649 %{_mandir}/man1/abrt-action-analyze-c.1*
650 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
651 %{_mandir}/man1/abrt-action-analyze-core.1*
652 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
653 %{_mandir}/man1/abrt-action-generate-backtrace.1*
654 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
655 %{_mandir}/man1/abrt-action-install-debuginfo.1*
656 %{_mandir}/man1/abrt-action-list-dsos.1*
657 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
658 %{_mandir}/man1/abrt-action-trim-files.1*
659 %{_mandir}/man1/abrt-dump-journal-core.1*
660 %{_mandir}/man5/abrt-CCpp.conf.5*
661 %{_mandir}/man5/ccpp_event.conf.5*
662 %{_mandir}/man5/ccpp_retrace_event.conf.5*
663 %{_mandir}/man5/gconf_event.conf.5*
664 %{_mandir}/man5/vimrc_event.conf.5*
665
666 %files addon-kerneloops
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
669 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-alt-component
670 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
671 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
672 %attr(755,root,root) %{_bindir}/abrt-dump-oops
673 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
674 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_koops_format.conf
675 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
676 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
677 %{systemdunitdir}/abrt-oops.service
678 %{_prefix}/lib/systemd/catalog/abrt_koops.catalog
679 %{_mandir}/man1/abrt-action-analyze-oops.1*
680 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
681 %{_mandir}/man1/abrt-dump-journal-oops.1*
682 %{_mandir}/man1/abrt-dump-oops.1*
683 %{_mandir}/man5/abrt-oops.conf.5*
684 %{_mandir}/man5/koops_event.conf.5*
685
686 %files addon-pstoreoops
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
689 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
690 %{systemdunitdir}/abrt-pstoreoops.service
691 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
692 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
693 %{_mandir}/man1/abrt-merge-pstoreoops.1*
694
695 %files addon-python3
696 %defattr(644,root,root,755)
697 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
698 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
699 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_python3_format.conf
700 %{py3_sitedir}/abrt_exception_handler3.py*
701 %{py3_sitedir}/abrt_exception_handler3_container.py*
702 %{py3_sitedir}/abrt3.pth
703 %{py3_sitedir}/abrt3_container.pth
704 %{_prefix}/lib/systemd/catalog/python3_abrt.catalog
705 %{_mandir}/man5/python3_event.conf.5*
706 %{_mandir}/man5/python3-abrt.conf.5*
707
708 %files addon-upload-watch
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
711 %{systemdunitdir}/abrt-upload-watch.service
712 %{_mandir}/man1/abrt-upload-watch.1*
713
714 %files addon-vmcore
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
717 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
718 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
719 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
720 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_vmcore_format.conf
721 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
722 %{_datadir}/libreport/events/analyze_VMcore.xml
723 %{systemdunitdir}/abrt-vmcore.service
724 %{_prefix}/lib/systemd/catalog/abrt_vmcore.catalog
725 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
726 %{_mandir}/man1/abrt-harvest-vmcore.1*
727 %{_mandir}/man5/abrt-vmcore.conf.5*
728 %{_mandir}/man5/vmcore_event.conf.5*
729
730 %files addon-xorg
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
733 %attr(755,root,root) %{_bindir}/abrt-dump-journal-xorg
734 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
735 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
736 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
737 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_xorg_format.conf
738 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
739 %{systemdunitdir}/abrt-xorg.service
740 %{_prefix}/lib/systemd/catalog/abrt_xorg.catalog
741 %{_mandir}/man1/abrt-action-analyze-xorg.1*
742 %{_mandir}/man1/abrt-dump-journal-xorg.1*
743 %{_mandir}/man1/abrt-dump-xorg.1*
744 %{_mandir}/man5/abrt-xorg.conf.5*
745 %{_mandir}/man5/xorg_event.conf.5*
746
747 %files plugin-bodhi
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_bindir}/abrt-action-find-bodhi-update
750 %attr(755,root,root) %{_bindir}/abrt-bodhi
751 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/bodhi_event.conf
752 %{_datadir}/libreport/events/analyze_BodhiUpdates.xml
753 %{_mandir}/man1/abrt-action-find-bodhi-update.1*
754 %{_mandir}/man1/abrt-bodhi.1*
755
756 %files retrace-client
757 %defattr(644,root,root,755)
758 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
759 %attr(755,root,root) %{_bindir}/abrt-retrace-client
760 %{_datadir}/libreport/events/analyze_RetraceServer.xml
761 %{_mandir}/man1/abrt-retrace-client.1*
762
763 %files dbus
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_sbindir}/abrt-dbus
766 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_dbus_event.conf
767 /etc/dbus-1/system.d/dbus-abrt.conf
768 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
769 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.xml
770 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Entry.xml
771 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Session.xml
772 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Task.xml
773 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
774 %{_datadir}/polkit-1/actions/abrt_polkit.policy
775 %{_mandir}/man8/abrt-dbus.8*
776 %{_docdir}/abrt-dbus-%{version}
777
778 %files python3
779 %defattr(644,root,root,755)
780 %dir %{py3_sitedir}/problem
781 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
782 %{py3_sitedir}/problem/*.py*
783 %{py3_sitedir}/__pycache__
784 %{py3_sitedir}/problem/__pycache__
785 %{_mandir}/man5/python3-abrt.5*
786
787 %files gui
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_bindir}/abrt-applet
790 %attr(755,root,root) %{_bindir}/system-config-abrt
791 %dir %{_datadir}/%{name}
792 %{_datadir}/%{name}/ui
793 %{_iconsdir}/hicolor/scalable/apps/abrt.svg
794 %{_iconsdir}/hicolor/symbolic/apps/abrt-symbolic.svg
795 %{_sysconfdir}/xdg/autostart/org.freedesktop.problems.applet.desktop
796 %{_datadir}/dbus-1/services/org.freedesktop.problems.applet.service
797 %{_mandir}/man1/abrt-applet.1*
798 %{_mandir}/man1/system-config-abrt.1*
799
800 %files gui-libs
801 %defattr(644,root,root,755)
802 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
803 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
804
805 %files gui-devel
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_libdir}/libabrt_gui.so
808 %{_includedir}/abrt/abrt-config-widget.h
809 %{_includedir}/abrt/system-config-abrt.h
810 %{_pkgconfigdir}/abrt_gui.pc
811
812 %files desktop
813 %defattr(644,root,root,755)
814
815 %files console-notification
816 %defattr(644,root,root,755)
817 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.185535 seconds and 4 git commands to generate.