]> git.pld-linux.org Git - packages/abrt.git/blob - abrt.spec
- updated to 2.14.0
[packages/abrt.git] / abrt.spec
1 #
2 # TODO:
3 # - SysV init scripts for -addon-ccpp, -addon-kerneloops, -addon-pstoreoops, -addon-upload-watch, -addon-vmcore, -addon-xorg
4 #
5 # Conditional build:
6 %bcond_without  tests   # disable pythontests
7
8 %define         libreport_ver   2.10.0
9 Summary:        Automatic bug detection and reporting tool
10 Summary(pl.UTF-8):      Narzędzie do automatycznego wykrywania i zgłaszania błędów
11 Name:           abrt
12 Version:        2.14.0
13 Release:        1
14 License:        GPL v2+
15 Group:          Applications/System
16 #Source0Download: https://github.com/abrt/abrt/releases
17 Source0:        https://github.com/abrt/abrt/archive/%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  96c227237c9d66107f3bc62b5921b8c2
19 Source1:        %{name}.init
20 Patch0:         %{name}-rpm5.patch
21 Patch1:         %{name}-rpm45.patch
22 Patch2:         %{name}-link.patch
23 URL:            https://abrt.readthedocs.org/
24 BuildRequires:  asciidoc
25 %{?with_tests:BuildRequires:    augeas}
26 BuildRequires:  autoconf >= 2.50
27 BuildRequires:  automake
28 BuildRequires:  dbus-devel
29 BuildRequires:  docbook-dtd45-xml
30 BuildRequires:  gettext-tools >= 0.17
31 BuildRequires:  glib2-devel >= 1:2.55.1
32 BuildRequires:  gsettings-desktop-schemas-devel >= 3.15.1
33 BuildRequires:  gtk+3-devel >= 3.0
34 BuildRequires:  intltool >= 0.35.0
35 BuildRequires:  json-c-devel
36 BuildRequires:  libcap-devel
37 BuildRequires:  libgomp-devel
38 BuildRequires:  libnotify-devel >= 0.7.0
39 BuildRequires:  libreport-devel >= %{libreport_ver}
40 BuildRequires:  libreport-gtk-devel >= %{libreport_ver}
41 BuildRequires:  libreport-web-devel >= %{libreport_ver}
42 BuildRequires:  libselinux-devel
43 BuildRequires:  libsoup-devel >= 2.4
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2
46 BuildRequires:  pkgconfig
47 BuildRequires:  polkit-devel
48 BuildRequires:  python3-devel >= 1:3.6
49 BuildRequires:  python3-modules >= 1:3.6
50 %{?with_tests:BuildRequires:    python3-nose}
51 BuildRequires:  rpm-devel >= 4.5-28
52 BuildRequires:  rpm-pythonprov
53 BuildRequires:  rpmbuild(macros) >= 1.721
54 BuildRequires:  satyr-devel >= 0.21
55 BuildRequires:  sphinx-pdg-3
56 BuildRequires:  systemd-devel >= 1:209
57 BuildRequires:  xmlto
58 Requires(postun):       /usr/sbin/groupdel
59 Requires(postun):       /usr/sbin/userdel
60 Requires(pre):  /bin/id
61 Requires(pre):  /usr/bin/getgid
62 Requires(pre):  /usr/sbin/groupadd
63 Requires(pre):  /usr/sbin/useradd
64 Requires:       %{name}-libs = %{version}-%{release}
65 Provides:       group(abrt)
66 Provides:       user(abrt)
67 Obsoletes:      abrt-addon-coredump-helper < 2.13.0
68 Obsoletes:      abrt-addon-python < 2.13.0
69 Obsoletes:      abrt-atomic < 2.13.0
70 Obsoletes:      abrt-cli < 2.13.0
71 Obsoletes:      abrt-plugin-catcut
72 Obsoletes:      abrt-plugin-filetransfer
73 Obsoletes:      abrt-plugin-rhfastcheck
74 Obsoletes:      abrt-plugin-rhticket
75 Obsoletes:      abrt-plugin-runapp
76 Obsoletes:      abrt-plugin-sosreport
77 Obsoletes:      abrt-plugin-sqlite3
78 Obsoletes:      abrt-plugin-ticketuploader
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 ABRT is a tool to help users to detect defects in applications and to
83 create a bug report with all informations needed by maintainer to fix
84 it. It uses plugin system to extend its functionality.
85
86 %description -l pl.UTF-8
87 ABRT to narzędzie pomagające użytkownikom w wykrywaniu defektów w
88 aplikacjach oraz tworzeniu raportów błędów ze wszystkimi informacjami
89 potrzebnymi utrzymującemu pakiet do poprawienia go. Wykorzystuje
90 system wtyczek do rozszerzania funkcjonalności.
91
92 %package -n bash-completion-abrt
93 Summary:        Bash completion for abrt command
94 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów dla polecenia abrt
95 Group:          Applications/Shells
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       bash-completion
98 Requires:       python3-argcomplete
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description -n bash-completion-abrt
104 Bash completion for abrt command.
105
106 %description -n bash-completion-abrt -l pl.UTF-8
107 Bashowe dopełnianie parametrów dla polecenia abrt.
108
109 %package libs
110 Summary:        ABRT shared library
111 Summary(pl.UTF-8):      Biblioteka współdzielona ABRT
112 Group:          Libraries
113 Requires:       glib2 >= 1:2.55.1
114 Requires:       libreport >= %{libreport_ver}
115
116 %description libs
117 ABRT shared library.
118
119 %description libs -l pl.UTF-8
120 Biblioteka współdzielona ABRT.
121
122 %package devel
123 Summary:        Header files for ABRT livrary
124 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotekia ABRT
125 Group:          Development/Libraries
126 Requires:       %{name}-libs = %{version}-%{release}
127 Requires:       glib2-devel >= 1:2.55.1
128 Requires:       libreport-devel >= %{libreport_ver}
129
130 %description devel
131 Header files for ABRT livrary.
132
133 %description devel -l pl.UTF-8
134 Pliki nagłówkowe biblioteki ABRT.
135
136 %package addon-ccpp
137 Summary:        ABRT's C/C++ addon
138 Summary(pl.UTF-8):      Dodatek C/C++ do ABRT
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       %{name}-retrace-client = %{version}-%{release}
142 Requires:       cpio
143 Requires:       elfutils
144 Requires:       gdb >= 7.0-3
145 Requires:       satyr >= 0.21
146 Requires:       yum-utils
147 Obsoletes:      abrt-atomic
148
149 %description addon-ccpp
150 This package contains hook for C/C++ crashed programs and abrt's C/C++
151 analyzer plugin.
152
153 %description addon-ccpp -l pl.UTF-8
154 Ten pakiet zawiera punkt zaczepienia dla programów w C/C++, które
155 uległy awarii oraz wtyczkę analizatora C/C++ ABRT.
156
157 %package addon-kerneloops
158 Summary:        ABRT's kerneloops addon
159 Summary(pl.UTF-8):      Dodatek kerneloops do ABRT
160 Group:          Libraries
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       curl
163 Requires:       libreport-plugin-kerneloops >= %{libreport_ver}
164 Obsoletes:      abrt-plugin-kerneloops
165 Obsoletes:      abrt-plugin-kerneloopsreporter
166 Obsoletes:      kerneloops
167
168 %description addon-kerneloops
169 This package contains plugin for collecting kernel crash information
170 from system log.
171
172 %description addon-kerneloops -l pl.UTF-8
173 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
174 logu systemowego.
175
176 %package addon-pstoreoops
177 Summary:        ABRT's pstoreoops addon
178 Summary(pl.UTF-8):      Dodatek pstoreoops do ABRT
179 Group:          Libraries
180 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
181 Obsoletes:      abrt-addon-uefioops
182
183 %description addon-pstoreoops
184 This package contains plugin for collecting kernel oopses from pstore
185 storage.
186
187 %description addon-pstoreoops -l pl.UTF-8
188 Ten pakiet zawiera wtyczkę do zbierania oopsów jądra z danych pstore.
189
190 %package addon-python3
191 Summary:        ABRT's addon for catching and analyzing Python 3 exceptions
192 Summary(pl.UTF-8):      Dodatek ABRT do przechwytywania i analizy wyjątków Pythona 3
193 Group:          Libraries
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       %{name}-python3 = %{version}-%{release}
196 # for detecting package name containing offending file (TODO: python3-rpm package)
197 #Suggests:      python3-rpm
198 # for logging to journal
199 Suggests:       python3-systemd
200
201 %description addon-python3
202 This package contains Python hook and Python analyzer plugin for
203 handling uncaught exception in Python 3 programs.
204
205 %description addon-python3 -l pl.UTF-8
206 Ten pakiet zawiera pythonowy punkt zaczepienia oraz wtyczkę
207 analizatora Pythona do obsługi nie obsłużonych wyjątków w programach w
208 Pythonie 3.
209
210 %package addon-upload-watch
211 Summary:        ABRT's upload addon
212 Summary(pl.UTF-8):      Dodatek upload do ABRT
213 Group:          Libraries
214 Requires:       %{name} = %{version}-%{release}
215
216 %description addon-upload-watch
217 This package contains hook for uploaded problems.
218
219 %description addon-upload-watch -l pl.UTF-8
220 Ten pakiet zawiera uchwyt dla problemów przysłanych.
221
222 %package addon-vmcore
223 Summary:        ABRT's vmcore addon
224 Summary(pl.UTF-8):      Dodatek vmcore do ABRT
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
228 Requires:       crash
229
230 %description addon-vmcore
231 This package contains plugin for collecting kernel crash information
232 from vmcore files.
233
234 %description addon-vmcore -l pl.UTF-8
235 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
236 plików vmcore.
237
238 %package addon-xorg
239 Summary:        ABRT's Xorg addon
240 Summary(pl.UTF-8):      Dodatek Xorg do ABRT
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       curl
244
245 %description addon-xorg
246 This package contains plugin for collecting Xorg crash information
247 from Xorg log.
248
249 %description addon-xorg -l pl.UTF-8
250 Ten pakiet zawiera wtyczkę do zbierania informacji o awarii jądra z
251 logu Xorg.
252
253 %package plugin-bodhi
254 Summary:        ABRT's bodhi plugin
255 Summary(pl.UTF-8):      Wtyczka bodhi do ABRT
256 Group:          Libraries
257 Requires:       %{name} = %{version}-%{release}
258 Requires:       libreport-web >= %{libreport_ver}
259 Obsoletes:      libreport-plugin-bodhi
260
261 %description plugin-bodhi
262 Plugin to search for a new updates in bodhi server.
263
264 %description plugin-bodhi -l pl.UTF-8
265 Wtyczka do wyszukiwania nowych uaktualnień na serwerze bodhi.
266
267 %package retrace-client
268 Summary:        ABRT's retrace client
269 Summary(pl.UTF-8):      Klient Retrace dla ABRT
270 Group:          Libraries
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       xz
273
274 %description retrace-client
275 This package contains the client application for Retrace server which
276 is able to analyze C/C++ crashes remotely.
277
278 %description retrace-client -l pl.UTF-8
279 Ten pakiet zawiera aplikację kliencką dla serwera Retrace, który
280 potrafi zdalnie przeanalizować awarię programu w C/C++.
281
282 %package dbus
283 Summary:        ABRT DBus service
284 Summary(pl.UTF-8):      Usługa DBus ABRT
285 Group:          Applications/System
286 Requires:       %{name} = %{version}-%{release}
287 Requires:       libreport >= %{libreport_ver}
288
289 %description dbus
290 ABRT DBus service which provides org.freedesktop.problems API on DBus
291 and uses PolicyKit to authorize to access the problem data.
292
293 %description dbus -l pl.UTF-8
294 Usługa DBus ABRT, udostępniająca poprzez DBus API
295 org.freedesktop.problems, używająca PolicyKit do autoryzacji dostępu
296 do danych o problemach.
297
298 %package python3
299 Summary:        ABRT Python 3 API
300 Summary(pl.UTF-8):      API Pythona 3 do ABRT
301 Group:          Libraries/Python
302 Requires:       %{name} = %{version}-%{release}
303 Requires:       python3-libreport >= %{libreport_ver}
304 Obsoletes:      abrt-python < 2.13.0
305
306 %description python3
307 High-level API for querying, creating and manipulating problems
308 handled by ABRT in Python.
309
310 %description python3 -l pl.UTF-8
311 Wysokopoziomowe API do odpytywania, tworzenia i obróbki z poziomu
312 Pythona 3 problemów obsługiwanych przez ABRT.
313
314 %package gui
315 Summary:        ABRT's GUI
316 Summary(pl.UTF-8):      Graficzny interfejs użytkownika do ABRT
317 Group:          X11/Applications
318 Requires(post,postun):  /sbin/ldconfig
319 Requires(post,postun):  gtk-update-icon-cache
320 Requires(post,postun):  hicolor-icon-theme
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       %{name}-dbus = %{version}-%{release}
323 Requires:       %{name}-gui-libs = %{version}-%{release}
324 Suggests:       gnome-abrt
325 Provides:       abrt-applet = %{version}-%{release}
326 Obsoletes:      abrt-applet < 0.0.5
327 Conflicts:      abrt-applet < 0.0.5
328
329 %description gui
330 GTK+ wizard for convenient bug reporting.
331
332 %description gui -l pl.UTF-8
333 Oparty na GTK+ kreator do wygodnego zgłaszania błędów.
334
335 %package gui-libs
336 Summary:        ABRT's GUI library
337 Summary(pl.UTF-8):      Biblioteka graficznego interfejsu użytkownika ABRT
338 Group:          X11/Libraries
339 Requires:       %{name}-libs = %{version}-%{release}
340 Requires:       gtk+3 >= 3.0
341
342 %description gui-libs
343 ABRT's GUI library.
344
345 %description gui-libs -l pl.UTF-8
346 Biblioteka graficznego interfejsu użytkownika ABRT.
347
348 %package gui-devel
349 Summary:        Header files for ABRT GUI library
350 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT
351 Group:          X11/Development/Libraries
352 Requires:       %{name}-devel = %{version}-%{release}
353 Requires:       %{name}-gui-libs = %{version}-%{release}
354 Requires:       gtk+3-devel >= 3.0
355
356 %description gui-devel
357 Header files for ABRT GUI library.
358
359 %description gui-devel -l pl.UTF-8
360 Pliki nagłówkowe biblioteki graficznego interfejsu użytkownika ABRT.
361
362 %package desktop
363 Summary:        Virtual package to install all necessary packages for usage from desktop environment
364 Summary(pl.UTF-8):      Writualny pakiet do instalacji pakietów potrzebnych do użycia w środowisku graficznym
365 Group:          X11/Applications
366 # This package should be installed when anything requests bug-buddy;
367 # installing abrt-desktop should result in the abrt which works without
368 # any tweaking in abrt.conf (IOW: all plugins mentioned there must be installed)
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       %{name}-addon-ccpp = %{version}-%{release}
371 Requires:       %{name}-addon-kerneloops = %{version}-%{release}
372 Requires:       %{name}-addon-pstoreoops = %{version}-%{release}
373 Requires:       %{name}-addon-python3 = %{version}-%{release}
374 Requires:       %{name}-addon-vmcore = %{version}-%{release}
375 Requires:       %{name}-addon-xorg = %{version}-%{release}
376 Requires:       %{name}-gui = %{version}-%{release}
377 Requires:       %{name}-plugin-bodhi = %{version}-%{release}
378 Requires:       %{name}-retrace-client = %{version}-%{release}
379 Requires:       libreport-plugin-bugzilla >= %{libreport_ver}
380 Requires:       libreport-plugin-logger >= %{libreport_ver}
381 Requires:       libreport-plugin-ureport >= %{libreport_ver}
382 Provides:       bug-buddy
383 Obsoletes:      bug-buddy
384
385 %description desktop
386 Virtual package to make easy default installation on desktop
387 environments.
388
389 %description desktop -l pl.UTF-8
390 Wirtualny pakiet ułatwiający domyślną instalację w środowiskach
391 graficznych.
392
393 %package console-notification
394 Summary:        ABRT console notification script
395 Summary(pl.UTF-8):      Skrypt ABRT do powiadomień na konsoli
396 Group:          Applications/System
397 Requires:       %{name} = %{version}-%{release}
398
399 %description console-notification
400 A small script which prints a count of detected problems when someone
401 logs in to the shell.
402
403 %description console-notification -l pl.UTF-8
404 Mały skrypt wypisujący liczbę wykrytych problemów, kiedy ktoś loguje
405 się do powłoki.
406
407 %prep
408 %setup -q
409 %if "%{_rpmversion}" >= "5.0"
410 %patch0 -p1
411 %else
412 %patch1 -p1
413 %endif
414 %patch2 -p1
415
416 %{__sed} -n -e '/^%%changelog/,$p' abrt.spec.in | tail -n +2 > changelog
417
418 echo -n %{version} > abrt-version
419
420 %build
421 %{__libtoolize}
422 %{__gettextize}
423 %{__intltoolize}
424 %{__aclocal} -I m4
425 %{__autoconf}
426 %{__autoheader}
427 %{__automake}
428 %configure \
429         AUGPARSE=/usr/bin/augparse \
430         PYTHON_NOSE=/usr/bin/nosetests-%{py3_ver} \
431         --enable-dump-time-unwind \
432         --enable-native-unwinder \
433         --disable-silent-rules \
434         %{!?with_tests:--without-pythontests} \
435         --with-systemdsystemunitdir=%{systemdunitdir}
436
437 %{__make}
438
439 %install
440 rm -rf $RPM_BUILD_ROOT
441 %{__make} install \
442         DESTDIR=$RPM_BUILD_ROOT \
443         systemdsystemunitdir=%{systemdunitdir} \
444         python3dir=%{py3_sitescriptdir}
445
446 # obsoleted by pkg-config
447 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
448
449 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/abrtd
450 install -d $RPM_BUILD_ROOT/var/cache/%{name}
451 install -d $RPM_BUILD_ROOT/var/cache/%{name}-di
452 install -d $RPM_BUILD_ROOT/var/run/%{name}
453
454 install -d $RPM_BUILD_ROOT%{systemdtmpfilesdir}
455 cat > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/abrt.conf <<EOF
456 d /var/run/%{name} 0755 root root -
457 EOF
458
459 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/problem/*.la
460 # examples
461 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/problem_examples
462 # packaged as %doc
463 %{__rm} $RPM_BUILD_ROOT%{_docdir}/abrt/README.md
464
465 # fool man verification - report_event.conf.5 belongs to libreport (NOTE: don't package it here)
466 touch $RPM_BUILD_ROOT%{_mandir}/man5/report_event.conf.5
467
468 %find_lang %{name}
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %pre
474 %groupadd -g 248 abrt
475 %useradd -u 248 -g abrt -d /etc/abrt -s /sbin/nologin abrt
476
477 %post
478 /sbin/chkconfig --add abrtd
479 %service abrtd restart
480 %systemd_post abrtd.service
481
482 %preun
483 if [ "$1" = "0" ]; then
484         %service abrtd stop
485         /sbin/chkconfig --del abrtd
486 fi
487 %systemd_preun abrtd.service
488
489 %postun
490 if [ "$1" = "0" ]; then
491         %userremove abrt
492         %groupremove abrt
493 fi
494
495 %post   libs -p /sbin/ldconfig
496 %postun libs -p /sbin/ldconfig
497
498 %post addon-ccpp
499 %systemd_post abrt-ccpp.service
500 %systemd_post abrt-journal-core.service
501 %journal_catalog_update
502
503 %preun addon-ccpp
504 %systemd_preun abrt-ccpp.service
505 %systemd_preun abrt-journal-core.service
506
507 %post addon-kerneloops
508 %systemd_post abrt-oops.service
509 %journal_catalog_update
510
511 %preun addon-kerneloops
512 %systemd_preun abrt-oops.service
513
514 %post addon-pstoreoops
515 %systemd_post abrt-pstoreoops.service
516
517 %preun addon-pstoreoops
518 %systemd_preun abrt-pstoreoops.service
519
520 %post addon-python3
521 %journal_catalog_update
522
523 %post addon-upload-watch
524 %systemd_post abrt-upload-watch.service
525
526 %preun addon-upload-watch
527 %systemd_preun abrt-upload-watch.service
528
529 %post addon-vmcore
530 %systemd_post abrt-vmcore.service
531 %journal_catalog_update
532
533 %preun addon-vmcore
534 %systemd_preun abrt-vmcore.service
535
536 %post addon-xorg
537 %systemd_post abrt-xorg.service
538 %journal_catalog_update
539
540 %preun addon-xorg
541 %systemd_preun abrt-xorg.service
542
543 %post gui
544 %update_icon_cache hicolor
545
546 %postun gui
547 %update_icon_cache hicolor
548
549 %post   gui-libs -p /sbin/ldconfig
550 %postun gui-libs -p /sbin/ldconfig
551
552 %files -f %{name}.lang
553 %defattr(644,root,root,755)
554 %doc README.md changelog
555 %attr(755,root,root) %{_bindir}/abrt
556 %attr(755,root,root) %{_bindir}/abrt-action-analyze-python
557 %attr(755,root,root) %{_bindir}/abrt-action-notify
558 %attr(755,root,root) %{_bindir}/abrt-action-save-package-data
559 %attr(755,root,root) %{_bindir}/abrt-handle-upload
560 %attr(755,root,root) %{_bindir}/abrt-watch-log
561 %attr(755,root,root) %{_sbindir}/abrt-auto-reporting
562 %attr(755,root,root) %{_sbindir}/abrt-server
563 %attr(755,root,root) %{_sbindir}/abrtd
564 %attr(755,root,root) %{_libexecdir}/abrt-action-generate-machine-id
565 %attr(755,root,root) %{_libexecdir}/abrt-action-save-container-data
566 %attr(755,root,root) %{_libexecdir}/abrt-action-ureport
567 %attr(755,root,root) %{_libexecdir}/abrt-handle-event
568 %{py3_sitescriptdir}/abrtcli
569 %dir %{_datadir}/%{name}
570 %{_datadir}/augeas/lenses/abrt.aug
571 %dir %{_sysconfdir}/%{name}
572 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt.conf
573 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/abrt-action-save-package-data.conf
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/gpg_keys.conf
575 %dir %{_sysconfdir}/%{name}/plugins
576 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_event.conf
577 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/machine-id_event.conf
578 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/smart_event.conf
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/sosreport_event.conf
580 %attr(754,root,root) /etc/rc.d/init.d/abrtd
581 %{systemdunitdir}/abrtd.service
582 %attr(775,root,abrt) %dir /var/cache/%{name}
583 %dir /var/run/%{name}
584 %{systemdtmpfilesdir}/abrt.conf
585 %{_mandir}/man1/abrt.1*
586 %{_mandir}/man1/abrt-action-analyze-python.1*
587 %{_mandir}/man1/abrt-action-notify.1*
588 %{_mandir}/man1/abrt-action-save-package-data.1*
589 %{_mandir}/man1/abrt-auto-reporting.1*
590 %{_mandir}/man1/abrt-handle-upload.1*
591 %{_mandir}/man1/abrt-server.1*
592 %{_mandir}/man1/abrt-watch-log.1*
593 %{_mandir}/man5/abrt.conf.5*
594 %{_mandir}/man5/abrt-action-save-package-data.conf.5*
595 %{_mandir}/man5/abrt_event.conf.5*
596 %{_mandir}/man5/report_event.conf.5
597 %{_mandir}/man5/gpg_keys.conf.5*
598 %{_mandir}/man5/smart_event.conf.5*
599 %{_mandir}/man8/abrtd.8*
600
601 %files -n bash-completion-abrt
602 %defattr(644,root,root,755)
603 /etc/bash_completion.d/abrt.bash_completion
604
605 %files libs
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/libabrt.so.*.*.*
608 %attr(755,root,root) %ghost %{_libdir}/libabrt.so.0
609
610 %files devel
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/libabrt.so
613 %dir %{_includedir}/abrt
614 %{_includedir}/abrt/abrt-dbus.h
615 %{_includedir}/abrt/hooklib.h
616 %{_includedir}/abrt/libabrt.h
617 %{_includedir}/abrt/problem_api.h
618 %{_pkgconfigdir}/abrt.pc
619
620 %files addon-ccpp
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/abrt-action-analyze-backtrace
623 %attr(755,root,root) %{_bindir}/abrt-action-analyze-c
624 %attr(755,root,root) %{_bindir}/abrt-action-analyze-ccpp-local
625 %attr(755,root,root) %{_bindir}/abrt-action-analyze-core
626 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vulnerability
627 %attr(755,root,root) %{_bindir}/abrt-action-generate-backtrace
628 %attr(755,root,root) %{_bindir}/abrt-action-generate-core-backtrace
629 %attr(755,root,root) %{_bindir}/abrt-action-install-debuginfo
630 %attr(755,root,root) %{_bindir}/abrt-action-list-dsos
631 %attr(755,root,root) %{_bindir}/abrt-action-perform-ccpp-analysis
632 %attr(755,root,root) %{_bindir}/abrt-action-trim-files
633 %attr(755,root,root) %{_bindir}/abrt-dump-journal-core
634 %attr(6755,abrt,abrt) %{_libexecdir}/abrt-action-install-debuginfo-to-abrt-cache
635 %attr(755,root,root) %{_libexecdir}/abrt-gdb-exploitable
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/CCpp.conf
637 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_event.conf
638 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/gconf_event.conf
639 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vimrc_event.conf
640 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_journal_ccpp_format.conf
641 %attr(775,abrt,abrt) %dir %{_localstatedir}/cache/abrt-di
642 #%attr(754,root,root) /etc/rc.d/init.d/abrt-ccpp
643 %{_datadir}/libreport/events/analyze_CCpp.xml
644 %{_datadir}/libreport/events/analyze_LocalGDB.xml
645 %{_datadir}/libreport/events/collect_GConf.xml
646 %{_datadir}/libreport/events/collect_vimrc_system.xml
647 %{_datadir}/libreport/events/collect_vimrc_user.xml
648 %{_datadir}/libreport/events/collect_xsession_errors.xml
649 %{_datadir}/libreport/events/post_report.xml
650 %{systemdunitdir}/abrt-journal-core.service
651 %{_prefix}/lib/systemd/catalog/abrt_ccpp.catalog
652 %{_mandir}/man1/abrt-action-analyze-backtrace.1*
653 %{_mandir}/man1/abrt-action-analyze-c.1*
654 %{_mandir}/man1/abrt-action-analyze-ccpp-local.1*
655 %{_mandir}/man1/abrt-action-analyze-core.1*
656 %{_mandir}/man1/abrt-action-analyze-vulnerability.1*
657 %{_mandir}/man1/abrt-action-generate-backtrace.1*
658 %{_mandir}/man1/abrt-action-generate-core-backtrace.1*
659 %{_mandir}/man1/abrt-action-install-debuginfo.1*
660 %{_mandir}/man1/abrt-action-list-dsos.1*
661 %{_mandir}/man1/abrt-action-perform-ccpp-analysis.1*
662 %{_mandir}/man1/abrt-action-trim-files.1*
663 %{_mandir}/man1/abrt-dump-journal-core.1*
664 %{_mandir}/man5/abrt-CCpp.conf.5*
665 %{_mandir}/man5/ccpp_event.conf.5*
666 %{_mandir}/man5/ccpp_retrace_event.conf.5*
667 %{_mandir}/man5/gconf_event.conf.5*
668 %{_mandir}/man5/vimrc_event.conf.5*
669
670 %files addon-kerneloops
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/abrt-action-analyze-oops
673 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-alt-component
674 %attr(755,root,root) %{_bindir}/abrt-action-check-oops-for-hw-error
675 %attr(755,root,root) %{_bindir}/abrt-dump-journal-oops
676 %attr(755,root,root) %{_bindir}/abrt-dump-oops
677 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/koops_event.conf
678 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_koops_format.conf
679 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/oops.conf
680 #%attr(754,root,root) /etc/rc.d/init.d/abrt-oops
681 %{systemdunitdir}/abrt-oops.service
682 %{_prefix}/lib/systemd/catalog/abrt_koops.catalog
683 %{_mandir}/man1/abrt-action-analyze-oops.1*
684 %{_mandir}/man1/abrt-action-check-oops-for-hw-error.1*
685 %{_mandir}/man1/abrt-dump-journal-oops.1*
686 %{_mandir}/man1/abrt-dump-oops.1*
687 %{_mandir}/man5/abrt-oops.conf.5*
688 %{_mandir}/man5/koops_event.conf.5*
689
690 %files addon-pstoreoops
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_bindir}/abrt-merge-pstoreoops
693 %attr(755,root,root) %{_sbindir}/abrt-harvest-pstoreoops
694 %{systemdunitdir}/abrt-pstoreoops.service
695 #%attr(754,root,root) /etc/rc.d/init.d/abrt-pstoreoops
696 %{_mandir}/man1/abrt-harvest-pstoreoops.1*
697 %{_mandir}/man1/abrt-merge-pstoreoops.1*
698
699 %files addon-python3
700 %defattr(644,root,root,755)
701 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/python3.conf
702 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/python3_event.conf
703 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_python3_format.conf
704 %{py3_sitescriptdir}/abrt_exception_handler3.py*
705 %{py3_sitescriptdir}/abrt_exception_handler3_container.py*
706 %{py3_sitescriptdir}/abrt3.pth
707 %{py3_sitescriptdir}/abrt3_container.pth
708 %{py3_sitescriptdir}/__pycache__/abrt_exception_handler3*.cpython-*.py[co]
709 %{_prefix}/lib/systemd/catalog/python3_abrt.catalog
710 %{_mandir}/man5/python3_event.conf.5*
711 %{_mandir}/man5/python3-abrt.conf.5*
712
713 %files addon-upload-watch
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_sbindir}/abrt-upload-watch
716 %{systemdunitdir}/abrt-upload-watch.service
717 %{_mandir}/man1/abrt-upload-watch.1*
718
719 %files addon-vmcore
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_bindir}/abrt-action-analyze-vmcore
722 %attr(755,root,root) %{_sbindir}/abrt-harvest-vmcore
723 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/vmcore.conf
724 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/vmcore_event.conf
725 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_vmcore_format.conf
726 #%attr(754,root,root) /etc/rc.d/init.d/abrt-vmcore
727 %{_datadir}/libreport/events/analyze_VMcore.xml
728 %{systemdunitdir}/abrt-vmcore.service
729 %{_prefix}/lib/systemd/catalog/abrt_vmcore.catalog
730 %{_mandir}/man1/abrt-action-analyze-vmcore.1*
731 %{_mandir}/man1/abrt-harvest-vmcore.1*
732 %{_mandir}/man5/abrt-vmcore.conf.5*
733 %{_mandir}/man5/vmcore_event.conf.5*
734
735 %files addon-xorg
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_bindir}/abrt-action-analyze-xorg
738 %attr(755,root,root) %{_bindir}/abrt-dump-journal-xorg
739 %attr(755,root,root) %{_bindir}/abrt-dump-xorg
740 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/plugins/xorg.conf
741 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/xorg_event.conf
742 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/catalog_xorg_format.conf
743 #%attr(754,root,root) /etc/rc.d/init.d/abrt-xorg
744 %{systemdunitdir}/abrt-xorg.service
745 %{_prefix}/lib/systemd/catalog/abrt_xorg.catalog
746 %{_mandir}/man1/abrt-action-analyze-xorg.1*
747 %{_mandir}/man1/abrt-dump-journal-xorg.1*
748 %{_mandir}/man1/abrt-dump-xorg.1*
749 %{_mandir}/man5/abrt-xorg.conf.5*
750 %{_mandir}/man5/xorg_event.conf.5*
751
752 %files plugin-bodhi
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_bindir}/abrt-action-find-bodhi-update
755 %attr(755,root,root) %{_bindir}/abrt-bodhi
756 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/bodhi_event.conf
757 %{_datadir}/libreport/events/analyze_BodhiUpdates.xml
758 %{_mandir}/man1/abrt-action-find-bodhi-update.1*
759 %{_mandir}/man1/abrt-bodhi.1*
760
761 %files retrace-client
762 %defattr(644,root,root,755)
763 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/ccpp_retrace_event.conf
764 %attr(755,root,root) %{_bindir}/abrt-retrace-client
765 %{_datadir}/libreport/events/analyze_RetraceServer.xml
766 %{_mandir}/man1/abrt-retrace-client.1*
767
768 %files dbus
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_sbindir}/abrt-dbus
771 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/abrt_dbus_event.conf
772 /etc/dbus-1/system.d/dbus-abrt.conf
773 /etc/dbus-1/system.d/org.freedesktop.problems.daemon.conf
774 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.xml
775 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Entry.xml
776 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Session.xml
777 %{_datadir}/dbus-1/interfaces/org.freedesktop.Problems2.Task.xml
778 %{_datadir}/dbus-1/system-services/org.freedesktop.problems.service
779 %{_datadir}/polkit-1/actions/abrt_polkit.policy
780 %{_mandir}/man8/abrt-dbus.8*
781 %{_docdir}/abrt-dbus-%{version}
782
783 %files python3
784 %defattr(644,root,root,755)
785 %dir %{py3_sitedir}/problem
786 %attr(755,root,root) %{py3_sitedir}/problem/_py3abrt.so
787 %{py3_sitedir}/problem/*.py*
788 %{py3_sitedir}/problem/__pycache__
789 %{_mandir}/man5/python3-abrt.5*
790
791 %files gui
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_bindir}/abrt-applet
794 %attr(755,root,root) %{_bindir}/system-config-abrt
795 %dir %{_datadir}/%{name}
796 %{_datadir}/%{name}/ui
797 %{_iconsdir}/hicolor/scalable/apps/abrt.svg
798 %{_iconsdir}/hicolor/symbolic/apps/abrt-symbolic.svg
799 %{_sysconfdir}/xdg/autostart/org.freedesktop.problems.applet.desktop
800 %{_datadir}/dbus-1/services/org.freedesktop.problems.applet.service
801 %{_mandir}/man1/abrt-applet.1*
802 %{_mandir}/man1/system-config-abrt.1*
803
804 %files gui-libs
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_libdir}/libabrt_gui.so.*.*.*
807 %attr(755,root,root) %ghost %{_libdir}/libabrt_gui.so.0
808
809 %files gui-devel
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libabrt_gui.so
812 %{_includedir}/abrt/abrt-config-widget.h
813 %{_includedir}/abrt/system-config-abrt.h
814 %{_pkgconfigdir}/abrt_gui.pc
815
816 %files desktop
817 %defattr(644,root,root,755)
818
819 %files console-notification
820 %defattr(644,root,root,755)
821 %config(noreplace) %verify(not md5 mtime size) /etc/profile.d/abrt-console-notification.sh
This page took 0.105131 seconds and 4 git commands to generate.