]> git.pld-linux.org Git - packages/Zope.git/blob - Zope.spec
- massive attack: adding Source-md5
[packages/Zope.git] / Zope.spec
1 Summary:        An application server and portal toolkit for building Web sites
2 Summary(es):    Un servidor de aplicaciones y un conjunto de herramientas para la construcción de sitios Web
3 Summary(pl):    Serwer aplikacji i toolkit portalowy do tworzenia serwisów WWW
4 Summary(pt_BR): Um servidor de aplicações e um conjunto de ferramentas para construção de sites Web
5 Name:           Zope
6 Version:        2.6.1
7 Release:        1
8 License:        Zope Public License (ZPL)
9 Group:          Networking/Daemons
10 Source0:        http://www.zope.org/Products/%{name}/%{version}/%{name}-%{version}-src.tgz
11 # Source0-md5:  a17f36b86b6e489797d8e52f1ba48efe
12 Source1:        %{name}.init
13 Source2:        %{name}.logrotate
14 Source3:        %{name}-zserver.sh
15 Source4:        http://www.zope.org/Documentation/Guides/ZCMG/ZCMG.html.tgz
16 # Source4-md5:  4c52eebc2e874a0590ac9c04e222e9f1
17 Source5:        http://www.zope.org/Documentation/Guides/DTML/DTML.html.tgz
18 # Source5-md5:  10f363dd061a1af8d472c51c32fa0a0e
19 Source6:        http://www.zope.org/Documentation/Guides/ZSQL/ZSQL.html.tgz
20 # Source6-md5:  0cddb5688fc0f886db468da08251fb81
21 Source7:        http://www.zope.org/Documentation/Guides/%{name}-ProductTutorial.tar.gz
22 Source8:        http://www.zope.org/Documentation/Guides/ZDG/ZDG.html.tgz
23 # Source8-md5:  0344ca88acb8a71688d2925975a55443
24 Source9:        http://www.zope.org/Documentation/Guides/ZAG/ZAG.html.tgz
25 # Source9-md5:  b28bfc4ba4bee880767fcf89d79532d2
26 Source10:       http://www.zope.org/Documentation/Books/ZopeBook/current/ZopeBook.tgz
27 # Source10-md5: 268c38a4c7d9f7334cdc98b0a152f8da
28 URL:            http://www.zope.org/
29 BuildRequires:  python-devel >= 2.2
30 PreReq:         rc-scripts
31 Requires(pre): /usr/bin/getgid
32 Requires(pre): /bin/id
33 Requires(pre): /usr/sbin/groupadd
34 Requires(pre): /usr/sbin/useradd
35 Requires(postun):      /usr/sbin/userdel
36 Requires(postun):      /usr/sbin/groupdel
37 Requires(post,preun):   /sbin/chkconfig
38 Requires:       logrotate
39 Requires:       python-modules >= 2.2
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         python_prefix           %(echo `python -c "import sys; print sys.prefix"`)
43 %define         python_version          %(echo `python -c "import sys; print sys.version[:3]"`)
44 %define         python_libdir           %{python_prefix}/lib/python%{python_version}
45 %define         python_includedir       %{python_prefix}/include/python%{python_version}
46 %define         python_sitedir          %{python_libdir}/site-packages
47 %define         python_configdir        %{python_libdir}/config
48
49 %define         python_compile          python -c "import compileall; compileall.compile_dir('.')"
50 %define         python_compile_opt      python -O -c "import compileall; compileall.compile_dir('.')"
51
52 %description
53 The Z Object Programming Environment (Zope) is a free, Open Source
54 Python-based application server for building high-performance, dynamic
55 web sites, using a powerful and simple scripting object model and
56 high-performance, integrated object database.
57
58 %description -l es
59 Zope es una aplicación basada en Python, Open Source[tm], para la
60 construcción de sitios dinámicos, usa un modelo de escritura de
61 guiones poderoso y sencillo. Para instalar la aplicación Zope, instale
62 ese paquete y después, Zope-server, para un servidor HTTP integrado
63 simple, Zope-pcgi, para uso con el servidor Apache. Si desea instalar
64 solamente algunas partes de la aplicación Zope, están diponibles otros
65 subpaquetes, usted debe instalar éstos en vez de ese RPM.
66
67 %description -l pl
68 Zope (Z Object Programming Environment - Obiektowe ¦rodowisko
69 Programistyczne Z) jest opartym o Pythona serwerem aplikacji do
70 tworzenia wysoko wydajnych, dynamicznych serwisów WWW, przy u¿yciu
71 u¿ytecznego i prostego modelu obiektowego skryptów oraz wysoko
72 wydajnej zintegrowanej obiektowej bazy danych.
73
74 %description -l pt_BR
75 Zope é uma aplicação baseada em Python, Open Source[tm], para
76 construção de sites dinâmicos, usando um modelo de scripting poderoso
77 e simples Para instalar o Zope, instale esse pacote e depois, ou o
78 Zope-server, para um servidor HTTP integrado simples, ou Zope-pcgi,
79 para uso com o Apache. Se você quiser instalar apenas algumas partes
80 do Zope, outros sub-pacotes estão disponíveis, e você deveria instalar
81 eles ao invés desse RPM.
82
83 %prep
84 %setup -q -n %{name}-%{version}-src -a4
85 mkdir ZopeContentManagersGuide GuideToDTML GuideToZSQL ZopeDevelopersGuide ZopeAdminGuide
86 mkdir ZopeBook
87 tar xzf %{SOURCE4} -C ZopeContentManagersGuide
88 tar xzf %{SOURCE5} -C GuideToDTML
89 tar xzf %{SOURCE6} -C GuideToZSQL
90 tar xzf %{SOURCE7} -C ZopeDevelopersGuide
91 tar xzf %{SOURCE8} -C ZopeAdminGuide
92 tar xzf %{SOURCE9} -C ZopeBook
93
94 %build
95 perl -pi -e "s|data_dir\s+=\s+.*?join\(INSTANCE_HOME, 'var'\)|data_dir=INSTANCE_HOME|" lib/python/Globals.py
96 python wo_pcgi.py
97
98 find lib/python -type f -and \( -name 'Setup' -or -name '.cvsignore' \) -exec rm -f \{\} \;
99 find -type f -and \( -name '*.c' -or -name '*.h' -or -name 'Makefile*' \) -exec rm -f \{\} \;
100 rm -f ZServer/medusa/monitor_client_win32.py
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/zope} \
105         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,logrotate},/var/log,/var/lib/zope}
106
107 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/zope
108 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate/zope
109 install %{SOURCE3} $RPM_BUILD_ROOT%{_sbindir}/zope-zserver
110
111 cp -a lib/python/* $RPM_BUILD_ROOT%{_libdir}/zope
112 cp -a ZServer/ utilities/ import/ $RPM_BUILD_ROOT%{_libdir}/zope
113 find $RPM_BUILD_ROOT%{_libdir}/zope -type f -name '*.py' -or -name '*.txt' | xargs -r rm -f
114 cp -a ZServer/medusa/test/* $RPM_BUILD_ROOT%{_libdir}/zope/ZServer/medusa/test/
115
116 install zpasswd.py $RPM_BUILD_ROOT%{_bindir}/zpasswd
117 install z2.py $RPM_BUILD_ROOT%{_libdir}/zope
118 install var/Data.fs $RPM_BUILD_ROOT/var/lib/zope/Data.fs
119
120 python $RPM_BUILD_ROOT%{_bindir}/zpasswd -u zope -p zope -d localhost \
121         $RPM_BUILD_ROOT/var/lib/zope/access
122
123 touch $RPM_BUILD_ROOT/var/log/zope
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %pre
129 if [ -z "`getgid zope`" ]; then
130        echo "Making group zope"
131        /usr/sbin/groupadd -r -f zope
132 fi
133 if [ -z "`id -u zope 2>/dev/null`" ]; then
134        echo "Making user zope"
135        /usr/sbin/useradd -r -d /var/lib/zope -s /bin/false -c "Zope User" -g zope zope
136 fi
137
138 %post
139 /sbin/chkconfig --add zope
140 if [ -f /var/lock/subsys/zope ]; then
141         /etc/rc.d/init.d/zope restart >&2
142 else
143         echo "Create inituser using \"zpasswd inituser\" in directory \"/var/lib/zope\"" >&2
144         echo "Run then \"/etc/rc.d/init.d/zope start\" to start Zope." >&2
145 fi
146
147 %preun
148 if [ "$1" = "0" ]; then
149         if [ -f /var/lock/subsys/zope ]; then
150                 /etc/rc.d/init.d/zope stop
151         fi
152         /sbin/chkconfig --del zope
153 fi
154
155 %postun
156 if [ "$1" = "0" ] ; then
157        echo "Removing user zope"
158        /usr/sbin/userdel zope >/dev/null 2>&1 || :
159        echo "Removing group zope"
160        /usr/sbin/groupdel zope >/dev/null 2>&1 || :    
161 fi
162
163 %files
164 %defattr(644,root,root,755)
165 %doc doc/*.txt *.txt ZopeContentManagersGuide GuideToZSQL ZopeDevelopersGuide ZopeAdminGuide ZopeBook
166 %attr(755,root,root) /etc/rc.d/init.d/zope
167 %attr(755,root,root) %{_bindir}/*
168 %attr(755,root,root) %{_sbindir}/*
169 %{_libdir}/zope
170 %attr(1771,root,zope) %dir /var/lib/zope
171 %attr(660,root,zope) %config(noreplace) %verify(not md5 size mtime) /var/lib/zope/*
172 %ghost /var/log/zope
This page took 0.06469 seconds and 4 git commands to generate.