]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- added req.
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CMFPlone
3 Summary:        Free and open source Content Management System based on Zope and CMF
4 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
5 Name:           Zope-%{zope_subname}
6 Version:        2.0
7 %define         sub_ver beta3
8 Release:        4.%{sub_ver}.2
9 License:        Zope Public License (ZPL), GPL
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
12 # Source0-md5:  ae47b12f56eb6e4f86ec7b0650e35552
13 Patch0:         %{name}-migration.patch
14 URL:            http://www.plone.org/
15 %pyrequires_eq  python-modules
16 Requires:       Zope-CMF >= 1.4
17 Requires:       Zope >= 2.6.2
18 Requires:       Zope-BTreeFolder2
19 Requires:       Zope-CMFQuickInstallerTool
20 Requires:       Zope-ExternalEditor
21 Requires:       Zope-Formulator
22 Requires:       Zope-GroupUserFolder
23 Requires:       Zope-Epoz
24 Requires(post,postun):  /usr/sbin/installzopeproduct
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 Obsoletes:      Plone
28 Conflicts:      CMF
29
30 %description
31 Plone is a free, open source Content Management System. The focus of
32 Plone is to provide value at every level of an organization. It comes
33 with a workflow engine, pre-configured security and roles, a set of
34 content types and multi-lingual support. There are many developers,
35 writers and testers from all over the world, contributing to Plone
36 everyday. Plone is based on the Content Management Framework.
37
38 %description -l pl
39 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
40 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
41 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
42 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
43 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
44 Pythonem.
45
46 %prep
47 %setup -q -n %{zope_subname}-%{version}-%{sub_ver}
48 %patch0 -p1
49
50 %build
51 # remove dirs - additional packages!
52 rm -rf {BTreeFolder2,CMFQuickInstallerTool,ExternalEditor,GroupUserFolder,Formulator}
53
54 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n
55 rm -rf `find . type f -name .cvsignore`
56 mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
57 mv -f CMFPlone/docs/* docs/CMFPlone
58 mv -f CMFPlone/i18n/ChangeLog docs/i18n
59 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
60 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
61 rm -rf CMFPlone/docs
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
66 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
67
68 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
69 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
70
71 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 for p in CMFPlone CMFActionIcons CMFFormController; do
78         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
79 done
80 if [ -f /var/lock/subsys/zope ]; then
81         /etc/rc.d/init.d/zope restart >&2
82 fi
83 echo "From /manage interface there should be a 'Select Type to Add' and says Plone Site" >&2
84
85 %postun
86 if [ "$1" = "0" ]; then
87         for p in CMFPlone CMFActionIcons CMFFormController; do
88                 /usr/sbin/installzopeproduct -d $p
89         done
90         if [ -f /var/lock/subsys/zope ]; then
91                 /etc/rc.d/init.d/zope restart >&2
92         fi
93 fi
94
95 %files
96 %defattr(644,root,root,755)
97 %doc docs/*
98 %{_datadir}/%{name}
This page took 0.073806 seconds and 4 git commands to generate.