]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- release "fixed" (numbers after "beta3" are to be incremented)
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CMFPlone
3 Summary:        Free and open source Content Management System based on Zope and CMF
4 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
5 Name:           Zope-%{zope_subname}
6 Version:        2.0
7 %define         sub_ver beta3
8 Release:        4.%{sub_ver}.1
9 License:        Zope Public License (ZPL), GPL
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
12 # Source0-md5:  ae47b12f56eb6e4f86ec7b0650e35552
13 Patch0:         %{name}-migration.patch
14 URL:            http://www.plone.org/
15 %pyrequires_eq  python-modules
16 Requires:       Zope-CMF >= 1.4
17 Requires:       Zope >= 2.6.2
18 Requires:       Zope-BTreeFolder2
19 Requires:       Zope-CMFQuickInstallerTool
20 Requires:       Zope-ExternalEditor
21 Requires:       Zope-Formulator
22 Requires:       Zope-GroupUserFolder
23 Requires(post,postun):  /usr/sbin/installzopeproduct
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      Plone
27 Conflicts:      CMF
28
29 %description
30 Plone is a free, open source Content Management System. The focus of
31 Plone is to provide value at every level of an organization. It comes
32 with a workflow engine, pre-configured security and roles, a set of
33 content types and multi-lingual support. There are many developers,
34 writers and testers from all over the world, contributing to Plone
35 everyday. Plone is based on the Content Management Framework.
36
37 %description -l pl
38 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
39 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
40 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
41 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
42 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
43 Pythonem.
44
45 %prep
46 %setup -q -n %{zope_subname}-%{version}-%{sub_ver}
47 %patch0 -p1
48
49 %build
50 # remove dirs - additional packages!
51 rm -rf {BTreeFolder2,CMFQuickInstallerTool,ExternalEditor,GroupUserFolder,Formulator}
52
53 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n
54 rm -rf `find . type f -name .cvsignore`
55 mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
56 mv -f CMFPlone/docs/* docs/CMFPlone
57 mv -f CMFPlone/i18n/ChangeLog docs/i18n
58 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
59 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
60 rm -rf CMFPlone/docs
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
65 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
66
67 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
68 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
69
70 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 for p in CMFPlone CMFActionIcons CMFFormController; do
77         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
78 done
79 if [ -f /var/lock/subsys/zope ]; then
80         /etc/rc.d/init.d/zope restart >&2
81 fi
82 echo "From /manage interface there should be a 'Select Type to Add' and says Plone Site" >&2
83
84 %postun
85 if [ "$1" = "0" ]; then
86         for p in CMFPlone CMFActionIcons CMFFormController; do
87                 /usr/sbin/installzopeproduct -d $p
88         done
89         if [ -f /var/lock/subsys/zope ]; then
90                 /etc/rc.d/init.d/zope restart >&2
91         fi
92 fi
93
94 %files
95 %defattr(644,root,root,755)
96 %doc docs/*
97 %{_datadir}/%{name}
This page took 0.033874 seconds and 4 git commands to generate.