]> git.pld-linux.org Git - packages/Smarty.git/blob - Smarty.spec
- don't use separate version for subpackage; braks builder script
[packages/Smarty.git] / Smarty.spec
1 %define         _doc_version    2.6.14
2 %include        /usr/lib/rpm/macros.php
3 Summary:        Template engine for PHP
4 Summary(pl.UTF-8):      System szablonów dla PHP
5 Name:           Smarty
6 Version:        2.6.18
7 Release:        2
8 License:        LGPL
9 Group:          Development/Languages/PHP
10 Source0:        http://smarty.php.net/distributions/%{name}-%{version}.tar.gz
11 # Source0-md5:  cd9b9c78b43c0d0490b71111b2fe1a99
12 Source1:        http://smarty.php.net/distributions/manual/en/%{name}-%{_doc_version}-docs.tar.gz
13 # Source1-md5:  357510250885aab057853949e35845c7
14 Source2:        %{name}-function.html_input_image.php
15 URL:            http://smarty.php.net/
16 BuildRequires:  rpm-php-pearprov >= 4.3
17 Requires:       php-common
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _smartydir      %{_datadir}/php/Smarty
22
23 %description
24 Smarty is a template engine for PHP. Smarty provides your basic
25 variable substitution and dynamic block functionality, and also takes
26 a step further to be a "smart" template engine, adding features such
27 as configuration files, template functions, variable modifiers, and
28 making all of this functionality as easy as possible to use for both
29 programmers and template designers.
30
31 %description -l pl.UTF-8
32 Smarty jest systemem szablonów dla PHP. Pozwala na podstawowe
33 podstawianie wartości zmiennych oraz dynamiczne operacje na blokach;
34 idzie o krok dalej, aby być "mądrym" silnikiem szablonów, dodając
35 takie możliwości jak pliki konfiguracyjne, funkcje, zmienne
36 modyfikatory oraz czyniąc całą funkcjonalność jak najłatwiejszą w
37 użyciu jednocześnie dla programistów i projektantów szablonów.
38
39 %package doc
40 Summary:        Template engine for PHP - documentation
41 Summary(pl.UTF-8):      System szablonów dla PHP - dokumentacja
42 Group:          Development/Languages/PHP
43
44 %description doc
45 Documentation for Smarty template engine.
46
47 %description doc -l pl.UTF-8
48 Dokumentacja do systemu szablonów Smarty.
49
50 %prep
51 %setup -q -a 1
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_smartydir}/{internals,plugins},%{php_pear_dir}}
56
57 install libs/{Config_File,Smarty{,_Compiler}}.class.php $RPM_BUILD_ROOT%{_smartydir}
58 install libs/debug.tpl $RPM_BUILD_ROOT%{_smartydir}
59 install libs/internals/*.php $RPM_BUILD_ROOT%{_smartydir}/internals
60 install libs/plugins/*.php $RPM_BUILD_ROOT%{_smartydir}/plugins
61 install %{SOURCE2} $RPM_BUILD_ROOT%{_smartydir}/plugins/function.html_input_image.php
62
63 # backards compatible
64 ln -s %{_smartydir} $RPM_BUILD_ROOT%{php_pear_dir}/%{name}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 # make compat symlink, the symlink is discarded using %ghost on package uninstall
70 %triggerpostun -- Smarty < 2.6.10-4
71 if [ -d %{php_pear_dir}/%{name}/plugins ]; then
72         mv %{php_pear_dir}/%{name}/plugins/* %{_smartydir}/plugins
73         rmdir %{php_pear_dir}/%{name}/plugins 2>/dev/null
74 fi
75 rmdir %{php_pear_dir}/%{name} 2>/dev/null || mv -v %{php_pear_dir}/%{name}{,.rpmsave}
76 ln -s %{_smartydir} %{php_pear_dir}/%{name}
77
78 %post
79 [ -e %{php_pear_dir}/%{name} ] || ln -s %{_smartydir} %{php_pear_dir}/%{name}
80
81 %files
82 %defattr(644,root,root,755)
83 %doc BUGS ChangeLog FAQ INSTALL NEWS README RELEASE_NOTES TODO
84 %dir %{_smartydir}
85 %dir %{_smartydir}/internals
86 %dir %{_smartydir}/plugins
87 %{_smartydir}/*.class.php
88 %{_smartydir}/debug.tpl
89 %{_smartydir}/internals/*.php
90 %{_smartydir}/plugins/*.php
91
92 # for the sake of bc
93 %ghost %{php_pear_dir}/%{name}
94
95 %files doc
96 %defattr(644,root,root,755)
97 %doc manual/*
This page took 0.03594 seconds and 4 git commands to generate.