]> git.pld-linux.org Git - SPECS.git/blob - Servus.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / Servus.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        C++ network utility library that provides a zeroconf API, URI parsing and UUIDs
6 Summary(pl.UTF-8):      Biblioteka narzędzi sieciowych udostępniająca API zeroconf, analizy URI i UUID
7 Name:           Servus
8 Version:        1.5.2
9 Release:        1
10 License:        LGPL v3
11 Group:          Libraries
12 #Source0Download: https://github.com/HBPVIS/Servus/releases
13 Source0:        https://github.com/HBPVIS/Servus/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  bc6fb62a002fd288fc2c1f12878a533c
15 URL:            https://github.com/HBPVIS/Servus
16 BuildRequires:  Eyescale-CMake >= 2016.04
17 BuildRequires:  Qt5Core-devel >= 5
18 BuildRequires:  Qt5Widgets-devel >= 5
19 BuildRequires:  avahi-devel
20 # unit_test_framework
21 BuildRequires:  boost-devel >= 1.51
22 BuildRequires:  cmake >= 3.1
23 %{?with_apidocs:BuildRequires:  doxygen}
24 BuildRequires:  libstdc++-devel >= 6:4.7
25 BuildRequires:  pkgconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Servus is a small C++ network utility library that provides a zeroconf
30 API, URI parsing and UUIDs.
31
32 %description -l pl.UTF-8
33 Servus to mała biblioteka C++ narzędzi sieciowych, udostępnikająca API
34 zeroconf, analizy URI i UUID.
35
36 %package devel
37 Summary:        Header files for Servus library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Servus
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libstdc++-devel >= 6:4.7
42
43 %description devel
44 Header files for Servus library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki Servus.
48
49 %package qt
50 Summary:        Servus Qt library
51 Summary(pl.UTF-8):      Biblioteka Servus Qt
52 Group:          Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description qt
56 Servus Qt library.
57
58 %description qt -l pl.UTF-8
59 Biblioteka Servus Qt.
60
61 %package qt-devel
62 Summary:        Header files for Servus Qt library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Servus Qt
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66 Requires:       %{name}-qt = %{version}-%{release}
67 Requires:       Qt5Core-devel >= 5
68
69 %description qt-devel
70 Header files for Servus Qt library.
71
72 %description qt-devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki Servus Qt.
74
75 %package apidocs
76 Summary:        Servus API documentation
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki Servus
78 Group:          Documentation
79 BuildArch:      noarch
80
81 %description apidocs
82 API documentation for Servus library.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki Servus.
86
87 %package browser
88 Summary:        servusBrowser GUI
89 Summary(pl.UTF-8):      Graficzny interfejs servusBrowser
90 Group:          X11/Applications
91 Requires:       %{name}-qt = %{version}-%{release}
92
93 %description browser
94 servusBrowser GUI.
95
96 %description browser -l pl.UTF-8
97 Graficzny interfejs servusBrowser.
98
99 %prep
100 %setup -q
101
102 rmdir CMake/common
103 ln -s %{_datadir}/Eyescale-CMake CMake/common
104
105 %build
106 install -d build
107 cd build
108 %cmake .. \
109         -DBUILDYARD_DISABLED=ON \
110         -DCOMMON_DISABLE_WERROR:BOOL=ON
111 %{__make}
112
113 %if %{with apidocs}
114 doxygen doc/Doxyfile
115 %endif
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} -C build install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # disable completeness check incompatible with split packaging
124 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_datadir}/Servus/CMake/ServusTargets.cmake
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %post   qt -p /sbin/ldconfig
133 %postun qt -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt LICENSE.txt README.md doc/Changelog.md
138 %attr(755,root,root) %{_libdir}/libServus.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libServus.so.6
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libServus.so
144 %dir %{_includedir}/servus
145 %{_includedir}/servus/*.h
146 %dir %{_datadir}/Servus
147 %{_datadir}/Servus/CMake
148
149 %files qt
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libServusQt.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libServusQt.so.6
153
154 %files qt-devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libServusQt.so
157 %{_includedir}/servus/qt
158
159 %if %{with apidocs}
160 %files apidocs
161 %defattr(644,root,root,755)
162 %doc build/doc/html/*
163 %endif
164
165 %files browser
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/servusBrowser
This page took 0.445766 seconds and 3 git commands to generate.