]> git.pld-linux.org Git - packages/STLport.git/blob - STLport.spec
b4adc7fc7508479503563b3e90a2f6402431c7ca
[packages/STLport.git] / STLport.spec
1 Summary:        C++ standard library
2 Summary(pl):    Biblioteki standardowe C++
3 Name:           STLport
4 Version:        5.0.0
5 Release:        0.1
6 Epoch:          2
7 License:        distributable (see README.gz)
8 Group:          Libraries
9 #Source0:       http://www.stlport.com/archive/%{name}-%{version}.tar.bz2
10 Source0:        http://dl.sourceforge.net/stlport/%{name}-%{version}.tar.bz2
11 # Source0-md5:  5aefcbb0c30a91d50bb2d6c7b30e8393
12 Patch0:         %{name}-nodebug.patch
13 Patch1:         %{name}-soname.patch
14 Patch2:         %{name}-gcc34.patch
15 Patch3:         %{name}-4.5.3-gcc3stdexcept.patch
16 Patch4:         %{name}-4.5.3-extra-cxxflags.patch
17 URL:            http://www.stlport.org/
18 BuildRequires:  libstdc++-devel >= 5:3.3.2
19 %requires_eq    libstdc++
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 STLport is a multiplatform implementation of C++ Standard Template
24 Library based on SGI STL. It's used by e.g. OpenOffice.
25
26 %description -l pl
27 STLport to wieloplatformowa implementacja standardowej biblioteki
28 szablonów (Standard Template Library) C++ oparta na SGI STL. Jest
29 u¿ywana m.in. przez OpenOffice.
30
31 %package devel
32 Summary:        STLport heades files, documentation
33 Summary(pl):    Pliki nag³ówkowe i dokumentacja do STLport
34 Group:          Development/Libraries
35 Requires:       %{name} = %{epoch}:%{version}-%{release}
36
37 %description devel
38 Header files and development documentation for STLport.
39
40 %description devel -l pl
41 Pliki nag³ówkowe i dokumentacja dla STLport.
42
43 %package static
44 Summary:        Static STLport libraries
45 Summary(pl):    Biblioteki statyczne do STLport
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
48
49 %description static
50 Static STLport libraries.
51
52 %description static -l pl
53 Biblioteki statyczne do STLport.
54
55 %prep
56 %setup -q -n %{name}
57 #patch0 -p1
58 #patch1 -p1
59 #patch2 -p1
60 #patch3 -p1
61 #patch4 -p1
62
63 %build
64 %{__make} -C build/lib -f gcc.mak \
65         release-shared \
66         release-static \
67         CXXFLAGS="%{rpmcxxflags}" \
68         CXX="%{__cxx}"
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT%{_includedir}
73
74 %{__make} -C build/lib -f gcc.mak \
75         install-release-shared \
76         install-release-static \
77         INSTALL_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
78         INSTALL_LIB_DIR=$RPM_BUILD_ROOT%{_libdir}
79
80 cp -a stlport $RPM_BUILD_ROOT%{_includedir}
81 rm -rf $RPM_BUILD_ROOT%{_includedir}/stlport/BC50
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README
92 %attr(755,root,root) %{_libdir}/*.so.*.*
93 %attr(755,root,root) %{_libdir}/*.so
94
95 %files devel
96 %defattr(644,root,root,755)
97 %doc doc/{FAQ,*.txt}
98 %{_includedir}/stlport
99
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/*.a
This page took 0.099376 seconds and 3 git commands to generate.