]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- reverted
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 %bcond_with     aalib           # with aalib graphics support
4 %bcond_with     caca            # with caca graphics support
5 %bcond_with     directfb        # with DirectFB graphics support
6 %bcond_with     ggi             # with GGI graphics support
7 %bcond_with     nas             # with NAS audio support
8 %bcond_with     svga            # with svgalib graphics support
9 %bcond_without  alsa            # without ALSA audio support
10 %bcond_without  arts            # without aRts audio support
11 %bcond_without  esd             # without EsounD audio support
12 #
13 # NOTE: the following libraries are dlopened by soname detected at build time:
14 # libasound.so.2
15 # libesd.so.0
16 # libX11.so.6
17 # libXext.so.6
18 # libXrender.so.1
19 # libXrandr.so.2
20 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
21 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
22 Summary(zh_CN): SDL (Simple DirectMedia Layer) Generic APIs - ÓÎÏ·/¶àýÌå¿â
23 Name:           SDL
24 Version:        1.2.11
25 Release:        1
26 License:        LGPL
27 Group:          Libraries
28 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
29 # Source0-md5:  418b42956b7cd103bfab1b9077ccc149
30 Patch0:         %{name}-mmx-constraints.patch
31 Patch1:         %{name}-acfix.patch
32 Patch2:         %{name}-caca.patch
33 URL:            http://www.libsdl.org/
34 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.15}
35 BuildRequires:  OpenGL-GLU-devel
36 %{?with_aalib:BuildRequires:    aalib-devel}
37 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
38 %{?with_arts:BuildRequires:     artsc-devel >= 1.1}
39 BuildRequires:  autoconf >= 2.59-9
40 BuildRequires:  automake
41 %{?with_esd:BuildRequires:      esound-devel >= 0.2.8}
42 BuildRequires:  gcc >= 5:4.0
43 %{?with_caca:BuildRequires:     libcaca-devel}
44 %{?with_ggi:BuildRequires:      libggi-devel}
45 BuildRequires:  libtool >= 2:1.4d
46 %{?with_nas:BuildRequires:      nas-devel}
47 %ifarch %{ix86}
48 BuildRequires:  nasm
49 %endif
50 BuildRequires:  perl-modules
51 %{?with_directfb:BuildRequires: pkgconfig >= 1:0.7}
52 %{?with_svga:BuildRequires:     svgalib-devel >= 1.4.0}
53 BuildRequires:  xorg-lib-libX11-devel
54 BuildRequires:  xorg-lib-libXext-devel
55 BuildRequires:  xorg-lib-libXrandr-devel
56 BuildRequires:  xorg-lib-libXrender-devel
57 BuildRequires:  xorg-proto-xextproto-devel
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 SDL (Simple DirectMedia Layer) is a library that allows you portable,
62 low level access to a video framebuffer, audio output, mouse, and
63 keyboard. It can support both windowed and DGA modes of XFree86, and
64 it is designed to be portable - applications linked with SDL can also
65 be built on Win32 and BeOS.
66
67 %description -l pl
68 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
69 przeno¶ny, niskopoziomowy dostêp do bufora ramki video, wyj¶cia audio,
70 myszy oraz klawiatury. Mo¿e obs³ugiwaæ zarówno okienkowy tryb XFree86
71 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
72 konsolidowane z SDL mo¿na równie¿ budowaæ w systemach Win32 i BeOS.
73
74 %description -l pt_BR
75 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
76 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
77
78 Essa biblioteca é usada por alguns jogos.
79
80 %description -l ru
81 SDL (Simple DirectMedia Layer) ÜÔÏ ÎÁÂÏÒ ÆÕÎËÃÉÊ, ÐÒÅÄÏÓÔÁ×ÌÑÀÝÉÊ
82 ÎÉÚËÏÕÒÏ×ÎÅ×ÙÊ ÄÏÓÔÕРˠÚ×ÕËÕ, ËÌÁ×ÉÁÔÕÒÅ, ÍÁÎÉÐÕÌÑÔÏÒÕ ÍÙÛØ É Ë
83 ÂÕÆÅÒÕ ÜËÒÁÎÁ ÎÁ ÍÎÏÖÅÓÔ×Å ÒÁÚÌÉÞÎÙÈ ÐÌÁÔÆÏÒÍ.
84
85 %package devel
86 Summary:        SDL - Header files
87 Summary(pl):    SDL - Pliki nag³ówkowe
88 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
89 Summary(ru):    æÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ, ÉÓÐÏÌØÚÕÀÝÉÈ SDL
90 Summary(uk):    æÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL
91 Summary(zh_CN): SDL (Simple DirectMedia Layer) ¿ª·¢¿â
92 Group:          Development/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 %{?with_directfb:Requires:      DirectFB-devel >= 0.9.15}
95 %{?with_aa:Requires:    aalib-devel}
96 %{?with_caca:Requires:  libcaca-devel}
97 %{?with_ggi:Requires:   libggi-devel}
98 %{?with_nas:Requires:   nas-devel}
99 %{?with_svga:Requires:  svgalib-devel >= 1.4.0}
100
101 %description devel
102 SDL - Header files.
103
104 %description devel -l pl
105 SDL - Pliki nag³ówkowe.
106
107 %description devel -l pt_BR
108 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
109 recursos para o desenvolvimento de aplicativos com SDL.
110
111 %description devel -l ru
112 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
113 ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
114
115 %description devel -l uk
116 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
117 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
118
119 %package static
120 Summary:        SDL - static libraries
121 Summary(pl):    SDL - biblioteki statyczne
122 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
123 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ SDL
124 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SDL
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127
128 %description static
129 SDL - static libraries.
130
131 %description static -l pl
132 SDL - biblioteki statyczne.
133
134 %description static -l pt_BR
135 Biblioteca estática para desenvolvimento de aplicações com a SDL.
136
137 %description static -l ru
138 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
139 ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
140
141 %description static -l uk
142 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
143 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
144
145 %package examples
146 Summary:        SDL - example programs
147 Summary(pl):    SDL - programy przyk³adowe
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150
151 %description examples
152 SDL - example programs.
153
154 %description examples -l pl
155 SDL - przyk³adowe programy.
156
157 %prep
158 %setup -q
159 %patch0 -p1
160 %patch1 -p1
161 #%patch2 -p1    # needs rewrite
162
163 %{!?with_alsa:echo 'AC_DEFUN([AM_PATH_ALSA],[$3])' >> acinclude.m4}
164 %{!?with_esd:echo 'AC_DEFUN([AM_PATH_ESD],[$3])' >> acinclude.m4}
165
166 %build
167 %{__libtoolize}
168 %{__aclocal}
169 %{__autoconf}
170 %configure \
171 %ifarch %{ix86}
172         --enable-nasm \
173 %else
174         --disable-nasm \
175 %endif
176         --disable-rpath \
177         %{!?with_alsa:--disable-alsa} \
178         %{!?with_arts:--disable-arts} \
179         --enable-dga \
180         %{!?with_esd:--disable-esd} \
181         %{!?with_nas:--disable-nas} \
182         --enable-pthreads \
183         --enable-pthread-sem \
184         %{?with_aalib:--enable-video-aalib} \
185         %{?with_caca:--enable-video-caca} \
186         %{!?with_directfb:--disable-video-directfb} \
187         --enable-video-dga \
188         --enable-video-fbcon \
189         %{?with_ggi:--enable-video-ggi} \
190         --enable-video-opengl \
191         %{!?with_svga:--disable-video-svga} \
192         --enable-video-x11-dgamouse \
193         --enable-video-x11-vm \
194         --enable-video-x11-xinerama \
195         --enable-video-x11-xme \
196         --enable-video-x11-xrandr \
197         --enable-video-x11-xv \
198         --with-x
199
200 %{__make}
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
205
206 %{__make} install \
207         DESTDIR=$RPM_BUILD_ROOT \
208         m4datadir=%{_aclocaldir}
209
210 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
211
212 rm -rf docs/man3
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post   -p /sbin/ldconfig
218 %postun -p /sbin/ldconfig
219
220 %files
221 %defattr(644,root,root,755)
222 %doc BUGS CREDITS README TODO WhatsNew
223 %attr(755,root,root) %{_libdir}/libSDL-*.so.*.*
224
225 %files devel
226 %defattr(644,root,root,755)
227 %doc docs.html docs
228 %attr(755,root,root) %{_bindir}/sdl-config
229 %attr(755,root,root) %{_libdir}/libSDL.so
230 %{_libdir}/libSDL.la
231 %{_libdir}/libSDLmain.a
232 %{_includedir}/SDL
233 %{_aclocaldir}/sdl.m4
234 %{_pkgconfigdir}/sdl.pc
235 %{_mandir}/man3/*
236
237 %files static
238 %defattr(644,root,root,755)
239 %{_libdir}/libSDL.a
240
241 %files examples
242 %defattr(644,root,root,755)
243 %{_examplesdir}/%{name}-%{version}
This page took 0.086685 seconds and 4 git commands to generate.