]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- release 2.
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.4
20 Release:        2
21 License:        LGPL
22 Group:          X11/Libraries
23 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
24 Patch0:         %{name}-byteorder.patch
25 Patch1:         %{name}-fixlibs.patch
26 Patch2:         %{name}-amfix.patch
27 Patch3:         %{name}-lpthread.patch
28 Patch4:         %{name}-ac25x.patch
29 URL:            http://www.libsdl.org/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %{!?_without_esound:BuildRequires:      esound-devel}
33 %{!?_without_arts:BuildRequires:        arts-devel}
34 BuildRequires:  XFree86-devel >= 4.0.2
35 BuildRequires:  OpenGL-devel
36 BuildRequires:  perl-modules
37 %ifarch %{ix86}
38 BuildRequires:  nasm
39 %endif
40 %ifnarch sparc sparc64
41 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
42 %endif
43 %{?_with_svgalib:BuildRequires: svgalib-devel}
44 %{?_with_aalib:BuildRequires:   aalib-devel}
45 %{?_with_ggi:BuildRequires:     libggi-devel}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _prefix         /usr/X11R6
49 %define         _mandir         %{_prefix}/man
50
51 %description
52 SDL (Simple DirectMedia Layer) is a library that allows you portable,
53 low level access to a video framebuffer, audio output, mouse, and
54 keyboard. It can support both windowed and DGA modes of XFree86, and
55 it is designed to be portable - applications linked with SDL can also
56 be built on Win32 and BeOS.
57
58 %description -l pl
59 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
60 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
61 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
62 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
63 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
64
65 %description -l pt_BR
66 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
67 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
68
69 Essa biblioteca é usada por alguns jogos.
70
71 %package devel
72 Summary:        SDL - Header files
73 Summary(pl):    SDL - Pliki nag³ówkowe
74 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
75 Group:          X11/Development/Libraries
76 Requires:       %{name} = %{version}
77 %ifnarch sparc sparc64
78 %{!?_without_alsa:Requires:     alsa-lib-devel}
79 %endif
80 %{!?_without_esound:Requires:   esound-devel}
81 %{!?_without_arts:Requires:     arts-devel}
82 Requires:       XFree86-devel >= 4.0.2
83
84 %description devel
85 SDL - Header files.
86
87 %description devel -l pl
88 SDL - Pliki nag³ówkowe.
89
90 %description devel -l pt_BR
91 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
92 recursos para o desenvolvimento de aplicativos com SDL.
93
94 %package static
95 Summary:        SDL - static libraries
96 Summary(pl):    SDL - biblioteki statyczne
97 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}
100
101 %description static
102 SDL - static libraries.
103
104 %description static -l pl
105 SDL - biblioteki statyczne.
106
107 %description static -l pt_BR
108 Biblioteca estática para desenvolvimento de aplicações com a SDL.
109
110 %package examples
111 Summary:        SDL - example programs
112 Summary(pl):    SDL - programy przyk³adowe
113 Group:          X11/Development/Libraries
114 Requires:       %{name}-devel = %{version}
115
116 %description examples
117 SDL - example programs.
118
119 %description examples -l pl
120 SDL - przyk³adowe programy.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %patch1 -p1
126 %patch2 -p1
127 %patch3 -p1
128 %patch4 -p1
129
130 %build
131 rm -f missing
132 libtoolize --copy --force
133 aclocal
134 autoconf
135 # Another hack
136 cp -f src/hermes/Makefile.in Makefile.in.ok
137 automake -a -c --foreign
138 cp -f Makefile.in.ok src/hermes/Makefile.in
139 %configure \
140 %ifarch %{ix86}
141         --enable-nasm \
142 %else
143         --disable-nasm \
144 %endif
145         --enable-pthreads \
146         --enable-pthread-sem \
147         --with-x \
148         --enable-dga \
149         --enable-video-dga \
150         --enable-video-x11-dgamouse \
151         --enable-video-x11-vm \
152         --enable-video-x11-xv \
153         --enable-video-opengl \
154         --enable-video-fbcon \
155         %{?_with_svga:--enable-video-svga} \
156         %{?_with_aalib:--enable-video-aalib} \
157         %{?_with_ggi:--enable-video-ggi} \
158 %ifnarch sparc sparc64
159         %{!?_without_alsa:--enable-alsa} \
160 %endif
161         %{!?_without_esound:--enable-esd} \
162         %{!?_without_arts:--enable-arts}
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT \
169         m4datadir=%{_aclocaldir}
170
171 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
172
173 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
174 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
175
176 gzip -9nf BUGS CREDITS README TODO WhatsNew
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/lib*.so.*.*
187
188 %files devel
189 %defattr(644,root,root,755)
190 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
191 %attr(755,root,root) %{_bindir}/sdl-config
192 %attr(755,root,root) %{_libdir}/lib*.so
193 %attr(755,root,root) %{_libdir}/lib*.la
194 %{_libdir}/libSDLmain.a
195 %{_includedir}/SDL
196 %{_aclocaldir}/*
197 %{_mandir}/man3/*
198
199 %files examples
200 %{_examplesdir}/%{name}-%{version}
201
202 %files static
203 %defattr(644,root,root,755)
204 %{_libdir}/libSDL.a
This page took 0.087833 seconds and 4 git commands to generate.