]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- -devel reqs XFree86-devel
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.3
20 Release:        1
21 License:        LGPL
22 Group:          X11/Libraries
23 Group(de):      X11/Libraries
24 Group(es):      X11/Bibliotecas
25 Group(fr):      X11/Librairies
26 Group(pl):      X11/Biblioteki
27 Group(pt_BR):   X11/Bibliotecas
28 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
29 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
30 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
31 Patch0:         %{name}-byteorder.patch
32 Patch1:         %{name}-fixlibs.patch
33 Patch2:         %{name}-amfix.patch
34 Patch3:         %{name}-lpthread.patch
35 URL:            http://www.libsdl.org/
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{!?_without_esound:BuildRequires:      esound-devel}
39 %{!?_without_arts:BuildRequires:        arts-devel}
40 BuildRequires:  gtk+-devel >= 1.2.1
41 BuildRequires:  XFree86-devel >= 4.0.2
42 BuildRequires:  OpenGL-devel
43 BuildRequires:  perl-modules
44 BuildRequires:  nasm
45 %ifnarch sparc sparc64
46 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
47 %endif
48 %{?_with_svgalib:BuildRequires: svgalib-devel}
49 %{?_with_aalib:BuildRequires:   aalib-devel}
50 %{?_with_ggi:BuildRequires:     libggi-devel}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _prefix         /usr/X11R6
54 %define         _mandir         %{_prefix}/man
55
56 %description
57 SDL (Simple DirectMedia Layer) is a library that allows you portable,
58 low level access to a video framebuffer, audio output, mouse, and
59 keyboard. It can support both windowed and DGA modes of XFree86, and
60 it is designed to be portable - applications linked with SDL can also
61 be built on Win32 and BeOS.
62
63 %description -l pl
64 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
65 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
66 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
67 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
68 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
69
70 %description -l pt_BR
71 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
72 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
73
74 Essa biblioteca é usada por alguns jogos.
75
76 %package devel
77 Summary:        SDL - Header files
78 Summary(pl):    SDL - Pliki nag³ówkowe
79 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
80 Group:          X11/Libraries
81 Group(de):      X11/Libraries
82 Group(es):      X11/Bibliotecas
83 Group(fr):      X11/Librairies
84 Group(pl):      X11/Biblioteki
85 Group(pt_BR):   X11/Bibliotecas
86 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
87 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
88 Requires:       %{name} = %{version}
89 %ifnarch sparc sparc64
90 %{!?_without_alsa:Requires:     alsa-lib-devel}
91 %endif
92 %{!?_without_esound:Requires:   esound-devel}
93 %{!?_without_arts:Requires:     arts-devel}
94 Requires:       XFree86-devel >= 4.0.2
95
96 %description devel
97 SDL - Header files.
98
99 %description -l pl devel
100 SDL - Pliki nag³ówkowe.
101
102 %description -l pt_BR devel
103 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
104 recursos para o desenvolvimento de aplicativos com SDL.
105
106 %package static
107 Summary:        SDL - static libraries
108 Summary(pl):    SDL - biblioteki statyczne
109 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
110 Group:          X11/Libraries
111 Group(de):      X11/Libraries
112 Group(es):      X11/Bibliotecas
113 Group(fr):      X11/Librairies
114 Group(pl):      X11/Biblioteki
115 Group(pt_BR):   X11/Bibliotecas
116 Group(ru):      X11/âÉÂÌÉÏÔÅËÉ
117 Group(uk):      X11/â¦Â̦ÏÔÅËÉ
118 Requires:       %{name}-devel = %{version}
119
120 %description static
121 SDL - static libraries.
122
123 %description -l pl static
124 SDL - biblioteki statyczne.
125
126 %description -l pt_BR static
127 Biblioteca estática para desenvolvimento de aplicações com a SDL.
128
129 %prep
130 %setup -q
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134 %patch3 -p1
135
136 %build
137 rm missing
138 libtoolize --copy --force
139 aclocal
140 autoconf
141 # Another hack
142 cp src/hermes/Makefile.in Makefile.in.ok
143 automake -a -c --foreign
144 cp Makefile.in.ok src/hermes/Makefile.in
145 %configure \
146 %ifnarch sparc sparc64
147         %{!?_without_alsa:--enable-alsa} \
148 %endif
149         --disable-nasm \
150         --enable-pthreads \
151         --enable-pthread-sem \
152         --with-x \
153         --enable-video-x11-vm \
154         --enable-video-x11-dga \
155         --enable-video-x11-mtrr \
156         --enable-video-x11-dgamouse \
157         --enable-video-opengl \
158         %{!?_without_esound:--enable-esd} \
159         %{!?_without_arts:--enable-arts} \
160         %{?_with_svga:--enable-video-svga} \
161         %{?_with_aalib:--enable-video-aalib} \
162         %{?_with_ggi:--enable-video-ggi}
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT \
169         m4datadir=%{_aclocaldir}
170
171 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
172
173 gzip -9nf BUGS CREDITS README TODO WhatsNew
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %files
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/lib*.so.*.*
184
185 %files devel
186 %defattr(644,root,root,755)
187 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
188 %attr(755,root,root) %{_bindir}/sdl-config
189 %attr(755,root,root) %{_libdir}/lib*.so
190 %attr(755,root,root) %{_libdir}/lib*.la
191 %{_libdir}/libSDLmain.a
192 %{_includedir}/SDL
193 %{_aclocaldir}/*
194 %{_mandir}/man3/*
195
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/lib*.a
This page took 0.051237 seconds and 4 git commands to generate.