]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- removed libSDLmain.a from -static (it is in -devel)
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha ppc
11 %define _without_arts 1
12 %endif
13
14 %ifarch ppc
15 %define _without_alsa   1
16 %endif
17
18 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
19 Summary(es):    Simple DirectMedia Layer
20 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
21 Summary(pt_BR): Simple DirectMedia Layer
22 Name:           SDL
23 Version:        1.2.3
24 Release:        6
25 License:        LGPL
26 Group:          X11/Libraries
27 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
28 Patch0:         %{name}-byteorder.patch
29 Patch1:         %{name}-fixlibs.patch
30 Patch2:         %{name}-amfix.patch
31 Patch3:         %{name}-lpthread.patch
32 URL:            http://www.libsdl.org/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 %{!?_without_esound:BuildRequires:      esound-devel}
36 %{!?_without_arts:BuildRequires:        arts-devel}
37 BuildRequires:  XFree86-devel >= 4.0.2
38 BuildRequires:  OpenGL-devel
39 BuildRequires:  perl-modules
40 %ifarch %{ix86}
41 BuildRequires:  nasm
42 %endif
43 %ifnarch sparc sparc64
44 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
45 %endif
46 %{?_with_svgalib:BuildRequires: svgalib-devel}
47 %{?_with_aalib:BuildRequires:   aalib-devel}
48 %{?_with_ggi:BuildRequires:     libggi-devel}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _prefix         /usr/X11R6
52 %define         _mandir         %{_prefix}/man
53
54 %description
55 SDL (Simple DirectMedia Layer) is a library that allows you portable,
56 low level access to a video framebuffer, audio output, mouse, and
57 keyboard. It can support both windowed and DGA modes of XFree86, and
58 it is designed to be portable - applications linked with SDL can also
59 be built on Win32 and BeOS.
60
61 %description -l pl
62 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
63 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
64 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
65 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
66 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
67
68 %description -l pt_BR
69 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
70 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
71
72 Essa biblioteca é usada por alguns jogos.
73
74 %package devel
75 Summary:        SDL - Header files
76 Summary(pl):    SDL - Pliki nag³ówkowe
77 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
78 Group:          X11/Development/Libraries
79 Requires:       %{name} = %{version}
80 %ifnarch sparc sparc64
81 %{!?_without_alsa:Requires:     alsa-lib-devel}
82 %endif
83 %{!?_without_esound:Requires:   esound-devel}
84 %{!?_without_arts:Requires:     arts-devel}
85 Requires:       XFree86-devel >= 4.0.2
86
87 %description devel
88 SDL - Header files.
89
90 %description devel -l pl
91 SDL - Pliki nag³ówkowe.
92
93 %description devel -l pt_BR
94 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
95 recursos para o desenvolvimento de aplicativos com SDL.
96
97 %package static
98 Summary:        SDL - static libraries
99 Summary(pl):    SDL - biblioteki statyczne
100 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
101 Group:          X11/Development/Libraries
102 Requires:       %{name}-devel = %{version}
103
104 %description static
105 SDL - static libraries.
106
107 %description static -l pl
108 SDL - biblioteki statyczne.
109
110 %description static -l pt_BR
111 Biblioteca estática para desenvolvimento de aplicações com a SDL.
112
113 %package examples
114 Summary:        SDL - example programs
115 Summary(pl):    SDL - programy przyk³adowe
116 Group:          X11/Development/Libraries
117 Requires:       %{name}-devel = %{version}
118
119 %description examples
120 SDL - example programs.
121
122 %description examples -l pl
123 SDL - przyk³adowe programy.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129 %patch2 -p1
130 %patch3 -p1
131
132 %build
133 rm -f missing
134 libtoolize --copy --force
135 aclocal
136 autoconf
137 # Another hack
138 cp -f src/hermes/Makefile.in Makefile.in.ok
139 automake -a -c --foreign
140 cp -f Makefile.in.ok src/hermes/Makefile.in
141 %configure \
142 %ifarch %{ix86}
143         --enable-nasm \
144 %else
145         --disable-nasm \
146 %endif
147         --enable-pthreads \
148         --enable-pthread-sem \
149         --with-x \
150         --enable-dga \
151         --enable-video-dga \
152         --enable-video-x11-dgamouse \
153         --enable-video-x11-vm \
154         --enable-video-x11-xv \
155         --enable-video-opengl \
156         --enable-video-fbcon \
157         %{?_with_svga:--enable-video-svga} \
158         %{?_with_aalib:--enable-video-aalib} \
159         %{?_with_ggi:--enable-video-ggi} \
160 %ifnarch sparc sparc64
161         %{!?_without_alsa:--enable-alsa} \
162 %endif
163         %{!?_without_esound:--enable-esd} \
164         %{!?_without_arts:--enable-arts}
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168
169 %{__make} install \
170         DESTDIR=$RPM_BUILD_ROOT \
171         m4datadir=%{_aclocaldir}
172
173 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
174
175 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
176 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
177
178 gzip -9nf BUGS CREDITS README TODO WhatsNew
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %files
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/lib*.so.*.*
189
190 %files devel
191 %defattr(644,root,root,755)
192 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
193 %attr(755,root,root) %{_bindir}/sdl-config
194 %attr(755,root,root) %{_libdir}/lib*.so
195 %attr(755,root,root) %{_libdir}/lib*.la
196 %{_libdir}/libSDLmain.a
197 %{_includedir}/SDL
198 %{_aclocaldir}/*
199 %{_mandir}/man3/*
200
201 %files examples
202 %{_examplesdir}/%{name}-%{version}
203
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/libSDL.a
This page took 0.074164 seconds and 4 git commands to generate.