]> git.pld-linux.org Git - SPECS.git/blob - ResIL.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ResIL.spec
1 # Note: ResIL is meant to be "maintained DevIL replacement", but Linux build
2 # is heavily broken and all non-Windows ILUT backends are outdated
3 #
4 # Conditional build:
5 %bcond_with     sse     # use SSE extension
6 %bcond_with     sse2    # use SSE2 extension
7 %bcond_with     sse3    # use SSE3 extension
8 #
9 %ifarch pentium3 pentium4 %{x8664}
10 %define with_sse        1
11 %endif
12 %ifarch pentium4 %{x8664}
13 %define with_sse2       1
14 %endif
15 Summary:        Full featured image library
16 Summary(pl.UTF-8):      Biblioteka obsługi obrazów z mnóstwem funkcji
17 Name:           ResIL
18 Version:        1.8.4
19 Release:        0.1
20 License:        LGPL v2.1
21 Group:          Libraries
22 Source0:        http://downloads.sourceforge.net/resil/%{name}-%{version}.zip
23 # Source0-md5:  3fe55b630edd468374c10c301ea2afeb
24 Patch0:         %{name}-restrict.patch
25 Patch1:         %{name}-am.patch
26 URL:            http://resil.sourceforge.net/
27 BuildRequires:  OpenEXR-devel
28 BuildRequires:  OpenGL-GLU-devel
29 BuildRequires:  SDL-devel >= 1.2.5
30 BuildRequires:  allegro-devel >= 4.1.16
31 BuildRequires:  autoconf >= 2.52
32 BuildRequires:  automake
33 BuildRequires:  jasper-devel
34 #BuildRequires: jxrlib-devel
35 BuildRequires:  lcms-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libmng-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtiff-devel
40 BuildRequires:  libtool >= 2:1.5
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.533
43 BuildRequires:  squish-devel
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  unzip
46 BuildRequires:  xorg-lib-libXext-devel
47 BuildRequires:  zlib-devel
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Developer's Image Library (ResIL) is a programmer's library to develop
52 applications with very powerful image loading capabilities, yet is
53 easy for a developer to learn and use. Ultimate control of images is
54 left to the developer, so unnecessary conversions, etc. are not
55 performed. ResIL utilizes a simple, yet powerful, syntax. ResIL can
56 load, save, convert, manipulate, filter and display a wide variety of
57 image formats.
58
59 Currently, ResIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .icns,
60 .jp2, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic,
61 .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif files.
62
63 Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm,
64 .pcx, .pgm, .png, .ppm, .raw, .sgi, .tga and .tif.
65
66 %description -l pl.UTF-8
67 Developer's Image Library (ResIL) jest biblioteką programisty
68 pozwalającą tworzyć aplikacje z potężnymi możliwościami ładowania
69 obrazów. Pozostaje przy tym łatwa w użyciu i prosta do nauczenia się.
70 Ostateczna kontrola nad obrazami jest zostawiona programiście, nie
71 wprowadza się niepotrzebnych konwersji, itp. ResIL używa prostej, lecz
72 potężnej składni poleceń, wzorowanej na OpenGL-u. ResIL potrafi
73 ładować, zapisywać, konwertować, manipulować, filtrować szeroki
74 wachlarz formatów plików graficznych.
75
76 W chwili obecnej ResIL odczytuje pliki z rozszerzeniami bmp, cut, dds,
77 doom, gif, icns, ico, jp2, jpg, lbm, mdl, mng, pal, pbm, pcd, pcx,
78 pgm, pic, png, ppm, psd, psp, raw, sgi, tga i tif.
79
80 Obsługiwane jest zapisywanie do plików bmp, dds, h, jpg, pal, pbm,
81 pcx, pgm, png, ppm, raw, sgi, tga i tif.
82
83 %package devel
84 Summary:        ResIL development files
85 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ResIL
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       OpenEXR-devel
89 Requires:       jasper-devel
90 Requires:       lcms-devel
91 Requires:       libjpeg-devel
92 Requires:       libmng-devel
93 Requires:       libpng-devel
94 Requires:       libtiff-devel
95 Requires:       squish-devel
96
97 %description devel
98 ResIL development files (for IL and ILU libraries).
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe bibliotek ResIL (IL i ILU).
102
103 %package static
104 Summary:        Static ResIL libraries
105 Summary(pl.UTF-8):      Statyczne biblioteki ResIL
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description static
110 Static ResIL libraries (IL and ILU).
111
112 %description static -l pl.UTF-8
113 Statyczne biblioteki ResIL (IL i ILU).
114
115 %package ILUT
116 Summary:        ResIL ILUT library
117 Summary(pl.UTF-8):      Biblioteka ResIL ILUT
118 Group:          Libraries
119 Requires:       %{name} = %{version}-%{release}
120 Requires:       SDL >= 1.2.5
121 Requires:       allegro >= 4.1.16
122
123 %description ILUT
124 ResIL ILUT library - connection to higher level libraries.
125
126 %description ILUT -l pl.UTF-8
127 Biblioteka ResIL ILUT - łącznik z bibliotekami wyższego poziomu.
128
129 %package ILUT-devel
130 Summary:        Development files for ResIL ILUT library
131 Summary(pl.UTF-8):      Pliki programistyczne biblioteki ResIL ILUT
132 Group:          Development/Libraries
133 Requires:       %{name}-ILUT = %{version}-%{release}
134 Requires:       %{name}-devel = %{version}-%{release}
135 Requires:       OpenGL-GLU-devel
136 Requires:       SDL-devel >= 1.2.5
137 Requires:       allegro-devel >= 4.1.16
138 Requires:       xorg-lib-libXext-devel
139
140 %description ILUT-devel
141 Development files for ResIL ILUT library.
142
143 %description ILUT-devel -l pl.UTF-8
144 Pliki programistyczne biblioteki ResIL ILUT.
145
146 %package ILUT-static
147 Summary:        Static ResIL ILUT library
148 Summary(pl.UTF-8):      Statyczna biblioteka ResIL ILUT
149 Group:          Development/Libraries
150 Requires:       %{name}-ILUT-devel = %{version}-%{release}
151
152 %description ILUT-static
153 Static ResIL ILUT library.
154
155 %description ILUT-static -l pl.UTF-8
156 Statyczna biblioteka ResIL ILUT.
157
158 %package doc
159 Summary:        ResIL documentation
160 Summary(pl.UTF-8):      Dokumentacja ResIL
161 Group:          Documentation
162
163 %description doc
164 ResIL documentation.
165
166 %description doc -l pl.UTF-8
167 Dokumentacja ResIL.
168
169 %prep
170 %setup -q -c -T
171 %{__unzip} -qq %{SOURCE0} -d .. -x 'ResIL-1.8.4/projects/*'
172
173 %build
174 install -d build
175 cd build
176 %cmake ..
177
178 %{__make}
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} -C build install \
184         DESTDIR=$RPM_BUILD_ROOT
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post   -p /sbin/ldconfig
190 %postun -p /sbin/ldconfig
191
192 %post   devel -p /sbin/postshell
193 -/usr/sbin/fix-info-dir -c %{_infodir}
194
195 %postun devel -p /sbin/postshell
196 -/usr/sbin/fix-info-dir -c %{_infodir}
197
198 %files
199 %defattr(644,root,root,755)
200 %doc AUTHORS CREDITS ChangeLog README.unix
201 %attr(755,root,root) %{_bindir}/ilur
202 %attr(755,root,root) %{_libdir}/libIL.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libIL.so.1
204 %attr(755,root,root) %{_libdir}/libILU.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libILU.so.1
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libIL.so
210 %attr(755,root,root) %{_libdir}/libILU.so
211 %{_libdir}/libIL.la
212 %{_libdir}/libILU.la
213 %dir %{_includedir}/IL
214 %{_includedir}/IL/il.h
215 %{_includedir}/IL/ilu.h
216 %{_includedir}/IL/ilu_region.h
217 %{_pkgconfigdir}/IL.pc
218 %{_pkgconfigdir}/ILU.pc
219 %{_infodir}/ResIL_manual.info*
220
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/libIL.a
224 %{_libdir}/libILU.a
225
226 %files ILUT
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/libILUT.so.*.*.*
229 %attr(755,root,root) %ghost %{_libdir}/libILUT.so.1
230
231 %files ILUT-devel
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_libdir}/libILUT.so
234 %{_includedir}/IL/devil_cpp_wrapper.hpp
235 %{_includedir}/IL/ilut.h
236 %{_libdir}/libILUT.la
237 %{_pkgconfigdir}/ILUT.pc
238
239 %files ILUT-static
240 %defattr(644,root,root,755)
241 %{_libdir}/libILUT.a
242
243 %files doc
244 %defattr(644,root,root,755)
245 %doc ResIL*.pdf
This page took 0.592914 seconds and 3 git commands to generate.