]> git.pld-linux.org Git - packages/R-cran-abind.git/blob - R-cran-abind.spec
ff6b7ac34e31eafc5128713b30b47359cbc73f8a
[packages/R-cran-abind.git] / R-cran-abind.spec
1 %define         fversion        %(echo %{version} |tr r -)
2 %define         modulename      abind
3 Summary:        Combine multi-dimensional arrays
4 Summary(pl.UTF-8):      Łączenie wielowymiarowych tablic
5 Name:           R-cran-%{modulename}
6 Version:        1.4r0
7 Release:        2
8 License:        LGPL v2+
9 Group:          Applications/Math
10 Source0:        ftp://stat.ethz.ch/R-CRAN/src/contrib/%{modulename}_%{fversion}.tar.gz
11 # Source0-md5:  4dd1b633959a2fc73491e897f84857a7
12 BuildRequires:  R >= 2.8.1
13 Requires(post,postun):  R >= 2.8.1
14 Requires(post,postun):  perl-base
15 Requires(post,postun):  textutils
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Combine multi-dimensional arrays. This is a generalization of cbind
20 and rbind. Takes a sequence of vectors, matrices, or arrays and
21 produces a single array of the same or higher dimension.
22
23 %description -l pl.UTF-8
24 Moduł ten łączy wielowymiarowe tablice. Jest uogólnieniem cbind i
25 rbind. Pobiera listę wektorów, macierzy lub tablic i tworzy pojedynczą
26 tablice tego samego lub wyższego wymiaru.
27
28 %prep
29 %setup -q -c
30
31 %build
32 R CMD build %{modulename}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_libdir}/R/library/
37 R CMD INSTALL %{modulename} --library=$RPM_BUILD_ROOT%{_libdir}/R/library/
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
44  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --index)
45
46 %postun
47 if [ -f %{_libdir}/R/bin/Rcmd ];then
48         (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
49         R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --index)
50 fi
51
52 %files
53 %defattr(644,root,root,755)
54 %doc %{modulename}/{DESCRIPTION,ChangeLog}
55 %{_libdir}/R/library/%{modulename}
This page took 0.059625 seconds and 3 git commands to generate.