]> git.pld-linux.org Git - packages/PHP-nuke.git/blob - PHP-nuke.spec
- updated to 7.6
[packages/PHP-nuke.git] / PHP-nuke.spec
1 # TODO:
2 # - SECURITY: http://securitytracker.com/alerts/2004/Jul/1010734.html
3 # - SECURITY: http://securitytracker.com/alerts/2004/Jul/1010722.html
4 # - SECURITY: http://securitytracker.com/alerts/2004/Jun/1010571.html
5 # - SECURITY: http://securitytracker.com/alerts/2004/Jun/1010477.html
6 # - SECURITY: http://securitytracker.com/alerts/2004/Aug/1010924.html
7 # - SECURITY: http://securitytracker.com/alerts/2004/Sep/1011160.html
8 Summary:        Slashdot-like webnews site written in php, easy to install and use
9 Summary(pl):    Serwis nowinek WWW w stylu Slashdota napisany w PHP, ³atwy w instalacji i u¿ywaniu
10 Name:           PHP-nuke
11 Version:        7.6
12 Release:        1
13 License:        GPL
14 Group:          Applications/Databases/Interfaces
15 Source0:        http://phpnuke.org/files/PHP-Nuke-%{version}.zip
16 # Source0-md5:  1996a21729c06dc2b975342ee945d7e1
17 Source1:        PHP-Nuke.README.first
18 Source2:        %{name}.conf
19 #Icon:          phpnuke.gif
20 URL:            http://phpnuke.org/
21 Requires:       php-mysql
22 Requires:       php-pcre
23 Requires:       webserver
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _nukeroot       %{_datadir}/phpnuke
28
29 %description
30 Web-portal writen in php. Very powerful, yet easy to install and use:
31 see documentation in %{_docdir}/%{name}-%{version} for details.
32
33 You only have to run:
34 mysqladmin create nuke
35 mysql nuke < %{_docdir}/%{name}-%{version}/nuke.sql
36
37 (read %{_docdir}/%{name}-%{version}/README.first for further
38 information)
39
40 %description -l pl
41 Portal WWW napisany w PHP. Ma du¿e mo¿liwo¶ci, jest ³atwy w instalacji
42 u u¿ywaniu. Szczegó³y w dokumentacji w %{_docdir}/%{name}-%{version}.
43
44 Wystarczy zrobiæ jedno:
45 mysqladmin create nuke
46 mysql nuke < %{_docdir}/%{name}-%{version}/nuke.sql
47
48 (wiêcej informacji w %{_docdir}/%{name}-%{version}/README.first)
49
50 %prep
51 %setup -q -c
52
53 install %{SOURCE1} README.first
54
55 # (TV): workaround for bad tarball
56 find -type d -exec chmod 755 '{}' \;
57 find -type f -exec chmod 644 '{}' \;
58 find -type f -empty |xargs rm -f
59 chmod 755 */*/*/
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_nukeroot},/etc/httpd}
64
65 cp -ar html/* $RPM_BUILD_ROOT%{_nukeroot}
66
67 install %{SOURCE2} $RPM_BUILD_ROOT/etc/httpd/phpnuke.conf
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %triggerpostun -- %{name} <= 7.4-2
73 if [ -s /home/services/httpd/html/nuke/config.php ]; then
74         mv -f /home/services/httpd/html/nuke/config.php %{_nukeroot}
75 fi
76
77 %post
78 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*phpnuke.conf" /etc/httpd/httpd.conf; then
79         echo "Include /etc/httpd/phpnuke.conf" >> /etc/httpd/httpd.conf
80         if [ -f /var/lock/subsys/httpd ]; then
81                 /usr/sbin/apachectl restart 1>&2
82         fi
83 elif [ -d /etc/httpd/httpd.conf ]; then
84         ln -sf /etc/httpd/phpnuke.conf /etc/httpd/httpd.conf/phpnuke.conf
85         if [ -f /var/lock/subsys/httpd ]; then
86                 /usr/sbin/apachectl restart 1>&2
87         fi
88 fi
89
90 %preun
91 if [ "$1" = "0" ]; then
92         umask 027
93         if [ -d /etc/httpd/httpd.conf ]; then
94                 rm -f /etc/httpd/httpd.conf/99_phpnuke.conf
95         else
96                 grep -v "^Include.*phpnuke.conf" /etc/httpd/httpd.conf > \
97                         /etc/httpd/httpd.conf.tmp
98                 mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
99         fi
100         if [ -f /var/lock/subsys/httpd ]; then
101                 /usr/sbin/apachectl restart 1>&2
102         fi
103 fi
104
105 %files
106 %defattr(644,root,root,755)
107 %doc Addons* Blocks* Changes* Credits* Install* README* Readme*
108 %doc Support* Upgrade* sql/nuke.sql upgrades
109 %config(noreplace) %verify(not size mtime md5) /etc/httpd/phpnuke.conf
110 %dir %{_nukeroot}
111 %config(noreplace) %attr(640,http,http) %{_nukeroot}/config.php
112 %{_nukeroot}/[!c]*
113 # more needed?
This page took 0.107626 seconds and 4 git commands to generate.