]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- updated to 1.16.0
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # ALSA backend
4 %bcond_without  fluidsynth      # FluidSynth MIDI support
5 %bcond_without  portaudio       # PortAudio backend
6 %bcond_without  pulseaudio      # PulseAudio backend
7 %bcond_without  gui             # alsoft-config GUI
8 #
9 Summary:        Open Audio Library
10 Summary(pl.UTF-8):      Otwarta Biblioteka Dźwięku
11 Name:           OpenAL
12 Version:        1.16.0
13 Release:        1
14 License:        LGPL v2+
15 Group:          Libraries
16 Source0:        http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
17 # Source0-md5:  14db4b0d12f07252070b4fe5eb5911f6
18 #URL:           http://kcat.strangesoft.net/openal.html
19 URL:            http://www.openal.org/
20 %{?with_alsa:BuildRequires:     alsa-lib-devel}
21 BuildRequires:  cmake >= 2.6
22 %{?with_fluidsynth:BuildRequires:       fluidsynth-devel}
23 BuildRequires:  pkgconfig
24 %{?with_portaudio:BuildRequires:        portaudio-devel}
25 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
26 %if %{with gui}
27 BuildRequires:  QtCore-devel >= 4.8.0
28 BuildRequires:  QtGui-devel >= 4.8.0
29 BuildRequires:  qt4-build >= 4.8.0
30 %endif
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 OpenAL, the Open Audio Library, is a joint effort to create an open,
35 vendor-neutral, cross-platform API for interactive, primarily
36 spatialized audio. OpenAL's primary audience are application
37 developers and desktop users that rely on portable standards like
38 OpenGL, for games and other multimedia applications. OpenAL is already
39 supported by a number of hardware vendors and developers.
40
41 %description -l pl.UTF-8
42 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
43 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
44 interfejsu projektowania aplikacji w części obsługi dźwięku.
45 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
46 którzy wybierają przenośne standardy, jak OpenGL, w grach i
47 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
48 dostarczycieli sprzętu i programistów.
49
50 %package devel
51 Summary:        Headers for OpenAL
52 Summary(pl.UTF-8):      Pliki nagłówkowe do OpenAL
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Header files for OpenAL-based programs.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
61 OpenAL.
62
63 %package gui
64 Summary:        OpenAL configuration GUI
65 Summary(pl.UTF-8):      Graficzny interfejs do konfiguracji biblioteki OpenAL
66 Group:          X11/Applications/Sound
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       QtCore >= 4.8.0
69 Requires:       QtGui >= 4.8.0
70
71 %description gui
72 OpenAL configuration GUI.
73
74 %description gui -l pl.UTF-8
75 Graficzny interfejs do konfiguracji biblioteki OpenAL.
76
77 %prep
78 %setup -q -n openal-soft-%{version}
79
80 %build
81 %cmake . \
82         %{!?with_fluidsynth:-DALSOFT_MIDI_FLUIDSYNTH=ON} \
83         %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
84         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
85         -DCMAKE_VERBOSE_MAKEFILE=1 \
86         -DEXAMPLES=OFF \
87         -DLIB_INSTALL_DIR=%{_lib} \
88         %{!?with_alsa:-DALSA=OFF} \
89         %{!?with_portaudio:-DPORTAUDIO=OFF} \
90         %{!?with_pulseaudio:-DPULSEAUDIO=OFF}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
112 %attr(755,root,root) %{_bindir}/makehrtf
113 %attr(755,root,root) %{_bindir}/openal-info
114 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
116 %{_datadir}/openal
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libopenal.so
121 %{_includedir}/AL
122 %{_pkgconfigdir}/openal.pc
123
124 %if %{with gui}
125 %files gui
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/alsoft-config
128 %endif
This page took 0.084452 seconds and 4 git commands to generate.