]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- new Source0 URL, updated to 1.19.1
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # ALSA backend
4 %bcond_without  jack            # JACK backend
5 %bcond_without  portaudio       # PortAudio backend
6 %bcond_without  pulseaudio      # PulseAudio backend
7 %bcond_with     sdl             # SDL2 backend
8 %bcond_with     sse             # force use of SSE instructions (x86)
9 %bcond_with     sse2            # force use of SSE2 instructions (x86)
10 %bcond_without  gui             # alsoft-config GUI
11 %bcond_with     qt4             # Qt 4 instead of Qt 5 for GUI
12 #
13 %ifarch pentium3 pentium4
14 %define with_sse        1
15 %endif
16 %ifarch pentium4
17 %define with_sse2       1
18 %endif
19 Summary:        Open Audio Library
20 Summary(pl.UTF-8):      Otwarta Biblioteka Dźwięku
21 Name:           OpenAL
22 Version:        1.19.1
23 Release:        1
24 License:        LGPL v2+
25 Group:          Libraries
26 Source0:        http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
27 # Source0-md5:  af6f148c342276a51ea9c33ebd303f78
28 URL:            http://www.openal.org/
29 %{?with_sdl:BuildRequires:      SDL2-devel >= 2}
30 %{?with_alsa:BuildRequires:     alsa-lib-devel}
31 BuildRequires:  cmake >= 3.0.2
32 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
33 BuildRequires:  pkgconfig
34 %{?with_portaudio:BuildRequires:        portaudio-devel}
35 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
36 BuildRequires:  rpmbuild(macros) >= 1.605
37 %if %{with gui}
38 %if %{with qt4}
39 BuildRequires:  QtCore-devel >= 4.8.0
40 BuildRequires:  QtGui-devel >= 4.8.0
41 BuildRequires:  qt4-build >= 4.8.0
42 %else
43 BuildRequires:  Qt5Core-devel >= 5
44 BuildRequires:  Qt5Gui-devel >= 5
45 BuildRequires:  Qt5Widgets-devel >= 5
46 BuildRequires:  qt5-build >= 5
47 %endif
48 %endif
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 OpenAL, the Open Audio Library, is a joint effort to create an open,
53 vendor-neutral, cross-platform API for interactive, primarily
54 spatialized audio. OpenAL's primary audience are application
55 developers and desktop users that rely on portable standards like
56 OpenGL, for games and other multimedia applications. OpenAL is already
57 supported by a number of hardware vendors and developers.
58
59 %description -l pl.UTF-8
60 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
61 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
62 interfejsu projektowania aplikacji w części obsługi dźwięku.
63 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
64 którzy wybierają przenośne standardy, jak OpenGL, w grach i
65 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
66 dostarczycieli sprzętu i programistów.
67
68 %package devel
69 Summary:        Headers for OpenAL
70 Summary(pl.UTF-8):      Pliki nagłówkowe do OpenAL
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 Header files for OpenAL-based programs.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
79 OpenAL.
80
81 %package gui
82 Summary:        OpenAL configuration GUI
83 Summary(pl.UTF-8):      Graficzny interfejs do konfiguracji biblioteki OpenAL
84 Group:          X11/Applications/Sound
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       QtCore >= 4.8.0
87 Requires:       QtGui >= 4.8.0
88
89 %description gui
90 OpenAL configuration GUI.
91
92 %description gui -l pl.UTF-8
93 Graficzny interfejs do konfiguracji biblioteki OpenAL.
94
95 %prep
96 %setup -q -n openal-soft-%{version}
97
98 %build
99 cd build
100 %cmake .. \
101         %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
102         %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
103         %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
104         %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
105         %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
106         %{!?with_sse:-DALSOFT_ENABLE_SSE_CODEGEN=OFF} \
107         %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
108         -DALSOFT_EXAMPLES=OFF \
109         %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
110         %{?with_qt4:-DALSOFT_NO_QT5=ON} \
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
117
118 %{__make} -C build install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
122
123 # these look not really useful
124 %{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
135 %attr(755,root,root) %{_bindir}/makehrtf
136 %attr(755,root,root) %{_bindir}/openal-info
137 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
139 %{_datadir}/openal
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libopenal.so
144 %{_includedir}/AL
145 %{_pkgconfigdir}/openal.pc
146 %{_libdir}/cmake/OpenAL
147
148 %if %{with gui}
149 %files gui
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/alsoft-config
152 %endif
This page took 0.059137 seconds and 4 git commands to generate.