]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- up to 1.12.854
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # TODO:
3 # - not sure where %{_bindir}/openal-info should go, correct this or remove TODO
4 #
5 # Conditional build:
6 #
7 %bcond_without  alsa            # without ALSA support
8 %bcond_without  portaudio       # without PortAudio support
9 #
10 Summary:        Open Audio Library
11 Summary(pl.UTF-8):      Otwarta Biblioteka Dźwięku
12 Name:           OpenAL
13 Version:        1.12.854
14 Release:        1
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
18 # Source0-md5:  fbf36451fdebd6466edbdc0ee7db9603
19 #URL:           http://kcat.strangesoft.net/openal.html
20 URL:            http://www.openal.org/
21 %{?with_alsa:BuildRequires:     alsa-lib-devel}
22 BuildRequires:  cmake
23 %{?with_portaudio:BuildRequires:        portaudio-devel}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 OpenAL, the Open Audio Library, is a joint effort to create an open,
28 vendor-neutral, cross-platform API for interactive, primarily
29 spatialized audio. OpenAL's primary audience are application
30 developers and desktop users that rely on portable standards like
31 OpenGL, for games and other multimedia applications. OpenAL is already
32 supported by a number of hardware vendors and developers.
33
34 %description -l pl.UTF-8
35 OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
36 stworzenia otwartego, niezależnego od producentów, międzyplatformowego
37 interfejsu projektowania aplikacji w części obsługi dźwięku.
38 Biblioteka adresowana jest do twórców aplikacji i użytkowników,
39 którzy wybierają przenośne standardy, jak OpenGL, w grach i
40 aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
41 dostarczycieli sprzętu i programistów.
42
43 %package devel
44 Summary:        Headers for OpenAL
45 Summary(pl.UTF-8):      Pliki nagłówkowe do OpenAL
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for OpenAL-based programs.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
54 OpenAL.
55
56 %prep
57 %setup -q -n openal-soft-%{version}
58
59 %build
60 %cmake \
61         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
62         -DLIB_INSTALL_DIR=%{_lib} \
63         .
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
81 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.?
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/openal-info
86 %attr(755,root,root) %{_libdir}/libopenal.so
87 %{_includedir}/AL
88 %{_pkgconfigdir}/openal.pc
This page took 0.109768 seconds and 3 git commands to generate.