]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- fixed build, cleanups etc.
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 # _without_alsa         - without ALSA support
4 # _without_doc          - don't build HTML documentation (from SGML source)
5 # _with_mmx             - use MMX (won't run on non-MMX CPU)
6 #
7 %ifarch athlon
8 %define         _with_mmx       1
9 %endif
10 %ifnarch i586 i686 athlon
11 %define         _with_mmx       0
12 %endif
13 Summary:        Open Audio Library
14 Summary(pl):    Otwarta Biblioteka D¼wiêku
15 Name:           OpenAL
16 Version:        0.0.6
17 Release:        1
18 License:        LGPL
19 Group:          Libraries
20 Vendor:         Loki Entertainment Software - http://www.lokigames.com/
21 # This is tarball taken directly form Mandrake Cooker .src.rpm
22 Source0:        %{name}-linuxonly-20010805.tar.bz2
23 # Those patches came from Mandrake Cooker (only changed names)
24 Patch0:         %{name}-prefix.patch
25 Patch1:         %{name}-build.patch
26 Patch2:         %{name}-acfix.patch
27 Patch3:         %{name}-info.patch
28 URL:            http://www.openal.com/
29 BuildRequires:  SDL-devel
30 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 %{!?_without_doc:BuildRequires: docbook-utils}
34 %{!?_without_doc:BuildRequires: gnome-doc-tools}
35 BuildRequires:  libvorbis-devel
36 %{?_with_mmx:BuildRequires:     nasm}
37 BuildRequires:  smpeg-devel
38 BuildRequires:  texinfo
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 OpenAL, the Open Audio Library, is a joint effort to create an open,
43 vendor-neutral, cross-platform API for interactive, primarily
44 spatialized audio. OpenAL's primary audience are application
45 developers and desktop users that rely on portable standards like
46 OpenGL, for games and other multimedia applications. OpenAL is already
47 supported by a number of hardware vendors and developers.
48
49 %description -l pl
50 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
51 stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
52 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
53 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
54 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
55 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
56 dostarczycieli sprzêtu i programistów.
57
58 %package devel
59 Summary:        Headers for OpenAL
60 Summary(pl):    Pliki nag³ówkowe do OpenAL
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}
63
64 %description devel
65 Header files for OpenAL-based programs.
66
67 %description devel -l pl
68 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
69 OpenAL.
70
71 %package static
72 Summary:        OpenAL static library
73 Summary(pl):    Statyczna biblioteka OpenAL
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}
76
77 %description static
78 OpenAL static library.
79
80 %description static -l pl
81 Biblioteka OpenAL do statycznego linkowania.
82
83 %prep
84 %setup -q -n tmp
85 %patch0 -p1
86 %patch2 -p1
87 %patch3 -p1
88 cd openal
89 %patch1 -p0
90
91 echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
92
93 %build
94 cd openal/linux
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %configure \
99         %{!?debug:--enable-optimization} \
100         %{?_with_mmx:--enable-arch-asm} \
101         %{!?_without_alsa:--enable-alsa} \
102         --enable-sdl \
103         --enable-vorbis \
104         --enable-smpeg \
105         --enable-capture \
106         --with-gcc=%{__cc}                          
107
108 %{__make}
109
110 cd ../docs
111 %{!?_without_doc:%{__make} full-html}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_infodir}
116
117 cd openal/linux
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %post devel
130 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
131
132 %postun devel
133 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
134
135 %files
136 %defattr(644,root,root,755)
137 %doc openal/linux/{CREDITS,ChangeLog,NOTES,TODO}
138 %attr(755,root,root) %{_libdir}/lib*.so.*.*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc openal/linux/doc/LOKI* %{!?_without_doc:openal/docs/oalspecs-full}
143 %attr(755,root,root) %{_libdir}/lib*.so
144 %{_includedir}/AL
145 %{_infodir}/openal.info*
146
147 %files static
148 %defattr(644,root,root,755)
149 %attr(755,root,root)%{_libdir}/*.a
This page took 0.043037 seconds and 3 git commands to generate.