]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- added using %%{__make} macro.
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.2
5 Release:        3
6 License:        GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://ftp.mesa3d.org/mesa/%{name}Lib-%{version}.tar.bz2
10 Source1:        ftp://ftp.mesa3d.org/mesa/%{name}Demos-%{version}.tar.bz2
11 Patch0:         Mesa-paths.patch
12 URL:            http://www.mesa3d.org/
13 BuildRequires:  XFree86-devel
14 Provides:       OpenGL
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _prefix         /usr/X11R6
18 %define         _mandir         %{_prefix}/man
19
20 %description
21 Mesa is a 3-D graphics library with an API which is very similar to
22 that of OpenGL*. To the extent that Mesa utilizes the OpenGL command
23 syntax or state machine, it is being used with authorization from
24 Silicon Graphics, Inc. However, the author makes no claim that Mesa is
25 in any way a compatible replacement for OpenGL or associated with
26 Silicon Graphics, Inc. Those who want a licensed implementation of
27 OpenGL should contact a licensed vendor. This software is distributed
28 under the terms of the GNU Library General Public License, see the
29 LICENSE file for details.
30
31 - OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
32
33 %description -l pl
34 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu
35 OpenGL(*).
36
37 - OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics,
38   Inc.
39
40 %package devel
41 Summary:        Development environment for Mesa
42 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
43 Group:          Development/Libraries
44 Group(fr):      Development/Librairies
45 Group(pl):      Programowanie/Biblioteki
46 Requires:       %{name} = %{version}
47 Provides:       OpenGL-devel
48
49 %description devel
50 Header files and documentation needed for development.
51
52 %description -l pl devel
53 Pliki nag³ówkowe i dokumentacja do Mesy.
54
55 %package static
56 Summary:        Mesa static libraries
57 Summary(pl):    Biblioteki statyczne Mesy
58 Group:          Development/Libraries
59 Group(fr):      Development/Librairies
60 Group(pl):      Programowanie/Biblioteki
61 Requires:       %{name}-devel = %{version}
62 Provides:       OpenGL-static
63
64 %description static
65 The static version of the Mesa libraries
66
67 %description -l pl static
68 Biblioteki statyczne Mesy.
69
70 %package demos
71 Summary:        Mesa Demos
72 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
73 Group:          Development/Libraries
74 Group(fr):      Development/Librairies
75 Group(pl):      Programowanie/Biblioteki
76 Requires:       %{name} = %{version}
77
78 %description demos
79 Demonstration programs for the Mesa libraries.
80
81 %description -l pl demos
82 Programy demonstracyjne dla biblioteki Mesa.
83
84 %prep
85 %setup -q -n Mesa-%{version} -b 1
86 %patch0 -p1
87
88 %build
89 LDFLAGS="-s"; export LDFLAGS
90 CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
91 %configure \
92         --enable-static \
93         --enable-shared \
94         --with-ggi="no" \
95         --with-svga="no" \
96         --disable-ggi-fbdev \
97         --disable-ggi-genkgi \
98 %ifarch %{ix86} \
99         --enable-x86 \
100   %ifarch i686 \
101         --enable-mmx \
102         --enable-3dnow \
103   %else \
104     %ifarch k6 \
105         --enable-mmx \
106         --enable-3dnow" \
107     %else \
108         --disable-mmx \
109         --disable-3dnow \
110     %endif \
111   %endif \
112 %else \
113         --disable-x86 \
114         --disable-mmx \
115         --disable-3dnow
116 %endif
117
118 make
119         
120 (cd widgets-mesa; autoconf; \
121 LDFLAGS="-s"; export LDFLAGS
122 %configure
123 make)
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 %{__make} install DESTDIR=$RPM_BUILD_ROOT
128
129 install -d $RPM_BUILD_ROOT%{_mandir}/man3
130
131 (cd widgets-mesa; \
132 %{__make} install \
133         prefix=$RPM_BUILD_ROOT%{_prefix} \
134         mandir=$RPM_BUILD_ROOT%{_mandir}/man3)
135
136 install -d $RPM_BUILD_ROOT/usr/src/examples/Mesa
137 for l in book demos samples xdemos ; do
138         cp -R $l $RPM_BUILD_ROOT/usr/src/examples/Mesa/$l
139 done
140
141 gzip -9nf docs/*
142         
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %clean
147 rm -fr $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 %doc docs/CONFIG.gz
152 %attr(755,root,root) %{_libdir}/libGL*.so.*.*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %doc docs/{IAFA-PACKAGE,README,RELNOTES-*,VERSIONS,CONFORM,COPYRIGHT,DEVINFO,*.spec}.gz
157 %doc docs/README.{3DFX,GGI,MGL,QUAKE,X11,THREADS}.gz
158 %attr(755,root,root) %{_libdir}/libGL*.so
159
160 %dir %{_includedir}/GL
161 %{_includedir}GL/GLwDrawA.h
162 %{_includedir}GL/GLwDrawAP.h
163 %{_includedir}GL/GLwMDrawA.h
164 %{_includedir}GL/GLwMDrawAP.h
165 %{_includedir}GL/MesaDrawingArea.h
166 %{_includedir}GL/MesaDrawingAreaP.h
167 %{_includedir}GL/MesaMDrawingArea.h
168 %{_includedir}GL/MesaMDrawingAreaP.h
169 %{_includedir}GL/MesaWorkstation.h
170 %{_includedir}GL/MesaWorkstationP.h
171 %{_includedir}GL/gl.h
172 %{_includedir}GL/gl_mangle.h
173 %{_includedir}GL/glu.h
174 %{_includedir}GL/glu_mangle.h
175 %{_includedir}GL/glx.h
176 %{_includedir}GL/glx_mangle.h
177 %{_includedir}GL/osmesa.h
178 %{_includedir}GL/xmesa.h
179 %{_includedir}GL/xmesa_x.h
180 %{_includedir}GL/xmesa_xf86.h
181 %{_mandir}/man3/*
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libGL*.a
186
187 %files demos
188 %defattr(644,root,root,755)
189 %dir /usr/src/examples/Mesa/book
190 %dir /usr/src/examples/Mesa/demos
191 %dir /usr/src/examples/Mesa/samples
192 %dir /usr/src/examples/Mesa/xdemos
193
194 %doc /usr/src/examples/Mesa/book/*
195 %doc /usr/src/examples/Mesa/demos/*
196 %doc /usr/src/examples/Mesa/samples/*
197 %doc /usr/src/examples/Mesa/xdemos/*
This page took 0.040519 seconds and 4 git commands to generate.