]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- DO track sonames (for libGL* it's part of ABI defined by OpenGL standard)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_with     gallium_radeon
11 %bcond_without  gallium_nouveau
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.21
25 %define         dri2proto_ver   1.99.3
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.9
32 Release:        3%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  82c740c49d572baa6da2b1a1eee90bca
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-selinux.patch
39 Patch2:         %{name}-git.patch
40 URL:            http://www.mesa3d.org/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  expat-devel
44 BuildRequires:  libdrm-devel >= %{libdrm_ver}
45 BuildRequires:  libselinux-devel
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool >= 2:1.4d
48 %{?with_motif:BuildRequires:    motif-devel}
49 BuildRequires:  pixman-devel
50 BuildRequires:  pkgconfig
51 BuildRequires:  pkgconfig(talloc) >= 2.0.1
52 BuildRequires:  python
53 BuildRequires:  python-modules
54 BuildRequires:  rpmbuild(macros) >= 1.470
55 BuildRequires:  sed >= 4.0
56 BuildRequires:  xorg-lib-libXdamage-devel
57 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
58 BuildRequires:  xorg-lib-libXt-devel
59 BuildRequires:  xorg-lib-libXxf86vm-devel
60 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
61 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
62 BuildRequires:  xorg-util-makedepend
63 BuildRequires:  xorg-xserver-server-devel
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %if %{without gallium}
67 %undefine       with_gallium_intel
68 %undefine       with_gallium_radeon
69 %endif
70
71 %description
72 Mesa is a 3-D graphics library with an API which is very similar to
73 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
74 syntax or state machine, it is being used with authorization from
75 Silicon Graphics, Inc. However, the author does not possess an OpenGL
76 license from SGI, and makes no claim that Mesa is in any way a
77 compatible replacement for OpenGL or associated with SGI.
78
79 %description -l pl.UTF-8
80 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
81 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
82 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
83 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
84 OpenGL ani powiązana z SGI.
85
86 %package libEGL
87 Summary:        SGI implementation of libEGL OpenGL library
88 Summary(pl.UTF-8):      Implementacja SGI biblioteki libEGL ze standardu OpenGL
89 License:        SGI Free Software License B v2.0 (MIT-like)
90 Group:          Libraries
91 Requires:       OpenGL >= 1.2
92 Provides:       OpenGL-EGL = 1.0
93
94 %description libEGL
95 SGI implementation of libEGL OpenGL library.
96
97 %description libEGL -l pl.UTF-8
98 Implementacja SGI biblioteki libEGL ze standardu OpenGL.
99
100 %package libEGL-devel
101 Summary:        Header files for SGI libEGL library
102 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libEGL
103 License:        SGI Free Software License B v2.0 (MIT-like)
104 Group:          Development/Libraries
105 Requires:       %{name}-libEGL = %{version}-%{release}
106 Requires:       OpenGL-devel >= 1.2
107 Requires:       libstdc++-devel
108 Provides:       OpenGL-EGL-devel = 1.0
109
110 %description libEGL-devel
111 Header files for SGI libEGL library.
112
113 %description libEGL-devel -l pl.UTF-8
114 Pliki nagłówkowe biblioteki SGI libEGL.
115
116 %package libEGL-static
117 Summary:        Static SGI libEGL library
118 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
119 License:        SGI Free Software License B v2.0 (MIT-like)
120 Group:          Development/Libraries
121 Requires:       %{name}-libEGL-devel = %{version}-%{release}
122 Provides:       OpenGL-EGL-static = 1.0
123
124 %description libEGL-static
125 Static SGI libEGL library.
126
127 %description libEGL-static -l pl.UTF-8
128 Statyczna biblioteka SGI libEGL.
129
130 %package libGL
131 Summary:        Free Mesa3D implementation of libGL OpenGL library
132 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
133 License:        MIT
134 Group:          X11/Libraries
135 Requires:       libdrm >= %{libdrm_ver}
136 Provides:       OpenGL = 2.1
137 # reports version 1.3, but supports glXGetProcAddress() from 1.4
138 Provides:       OpenGL-GLX = 1.4
139 Obsoletes:      Mesa
140 Obsoletes:      Mesa-dri
141 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
142 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
143
144 %description libGL
145 Mesa is a 3-D graphics library with an API which is very similar to
146 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
147 syntax or state machine, it is being used with authorization from
148 Silicon Graphics, Inc. However, the author does not possess an OpenGL
149 license from SGI, and makes no claim that Mesa is in any way a
150 compatible replacement for OpenGL or associated with SGI.
151
152 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
153 specifications. It uses DRI for rendering.
154
155 %description libGL -l pl.UTF-8
156 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
157 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
158 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
159 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
160 OpenGL ani powiązana z SGI.
161
162 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
163 GLX 1.4. Używa DRI do renderowania.
164
165 %package libGL-devel
166 Summary:        Header files for Mesa3D libGL library
167 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
168 License:        MIT
169 Group:          X11/Development/Libraries
170 # loose dependency on libGL to use with other libGL binaries
171 Requires:       OpenGL >= 1.5
172 Requires:       libdrm-devel >= %{libdrm_ver}
173 Requires:       xorg-lib-libX11-devel
174 Requires:       xorg-lib-libXdamage-devel
175 Requires:       xorg-lib-libXext-devel
176 Requires:       xorg-lib-libXxf86vm-devel
177 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
178 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
179 Suggests:       OpenGL-doc-man
180 Provides:       OpenGL-GLX-devel = 1.4
181 Provides:       OpenGL-devel = 2.1
182 Obsoletes:      Mesa-devel
183 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
184 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
185 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
186 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
187
188 %description libGL-devel
189 Header files for Mesa3D libGL library.
190
191 %description libGL-devel -l pl.UTF-8
192 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
193
194 %package libGL-static
195 Summary:        Static Mesa3D libGL library
196 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
197 License:        MIT
198 Group:          X11/Development/Libraries
199 Requires:       %{name}-libGL-devel = %{version}-%{release}
200 Provides:       OpenGL-static = 2.1
201 Obsoletes:      Mesa-static
202 Obsoletes:      X11-OpenGL-static < 1:7.0.0
203 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
204
205 %description libGL-static
206 Static Mesa3D libGL library. It uses software renderer.
207
208 %description libGL-static -l pl.UTF-8
209 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
210 renderingu.
211
212 %package libGLU
213 Summary:        SGI implementation of libGLU OpenGL library
214 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
215 License:        SGI Free Software License B v2.0 (MIT-like)
216 Group:          Libraries
217 # loose dependency on libGL.so.1 to use with other libGL binaries
218 Requires:       OpenGL >= 1.2
219 Provides:       OpenGL-GLU = 1.3
220 Obsoletes:      Mesa-devel
221 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
222 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
223
224 %description libGLU
225 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
226 1.3 specifications.
227
228 %description libGLU -l pl.UTF-8
229 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
230 specyfikację OpenGL GLU 1.3.
231
232 %package libGLU-devel
233 Summary:        Header files for SGI libGLU library
234 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
235 License:        SGI Free Software License B v2.0 (MIT-like)
236 Group:          Development/Libraries
237 Requires:       %{name}-libGLU = %{version}-%{release}
238 Requires:       OpenGL-devel >= 1.2
239 Requires:       libstdc++-devel
240 Provides:       OpenGL-GLU-devel = 1.3
241
242 %description libGLU-devel
243 Header files for SGI libGLU library.
244
245 %description libGLU-devel -l pl.UTF-8
246 Pliki nagłówkowe biblioteki SGI libGLU.
247
248 %package libGLU-static
249 Summary:        Static SGI libGLU library
250 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
251 License:        SGI Free Software License B v2.0 (MIT-like)
252 Group:          Development/Libraries
253 Requires:       %{name}-libGLU-devel = %{version}-%{release}
254 Provides:       OpenGL-GLU-static = 1.3
255
256 %description libGLU-static
257 Static SGI libGLU library.
258
259 %description libGLU-static -l pl.UTF-8
260 Statyczna biblioteka SGI libGLU.
261
262 %package libGLw
263 Summary:        SGI OpenGL Xt widgets library
264 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
265 License:        SGI MIT-like
266 Group:          Libraries
267 # loose dependency on libGL.so.1 to use with other libGL binaries
268 Requires:       OpenGL >= 1.1
269 Provides:       OpenGL-GLw
270
271 %description libGLw
272 SGI OpenGL Xt widgets library.
273
274 %description libGLU -l pl.UTF-8
275 Biblioteka SGI widgetów Xt dla OpenGL-a.
276
277 %package libGLw-devel
278 Summary:        Header files for SGI libGLw library
279 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
280 License:        SGI MIT-like
281 Group:          Development/Libraries
282 Requires:       %{name}-libGLw = %{version}-%{release}
283 Requires:       OpenGL-devel >= 1.2
284 Provides:       OpenGL-GLw-devel
285
286 %description libGLw-devel
287 Header files for SGI libGLw library.
288
289 %description libGLw-devel -l pl.UTF-8
290 Pliki nagłówkowe biblioteki SGI libGLw.
291
292 %package libGLw-static
293 Summary:        Static SGI libGLw library
294 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
295 License:        SGI MIT-like
296 Group:          Development/Libraries
297 Requires:       %{name}-libGLw-devel = %{version}-%{release}
298 Provides:       OpenGL-GLw-static
299
300 %description libGLw-static
301 Static SGI libGLw library.
302
303 %description libGLw-static -l pl.UTF-8
304 Statyczna biblioteka SGI libGLw.
305
306 %package libOSMesa
307 Summary:        OSMesa (off-screen renderer) library
308 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
309 License:        MIT
310 Group:          Libraries
311 # doesn't require base
312
313 %description libOSMesa
314 OSMesa (off-screen renderer) library.
315
316 %description libOSMesa -l pl.UTF-8
317 Biblioteka OSMesa (renderująca bitmapy w pamięci).
318
319 %package libOSMesa-devel
320 Summary:        Header file for OSMesa (off-screen renderer) library
321 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
322 License:        MIT
323 Group:          Development/Libraries
324 Requires:       %{name}-libOSMesa = %{version}-%{release}
325 # for <GL/gl.h> only
326 Requires:       OpenGL-devel
327
328 %description libOSMesa-devel
329 Header file for OSMesa (off-screen renderer) library.
330
331 %description libOSMesa-devel -l pl.UTF-8
332 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
333
334 %package libOSMesa-static
335 Summary:        Static OSMesa (off-screen renderer) library
336 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
337 License:        MIT
338 Group:          Development/Libraries
339 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
340 # this static build of OSMesa needs static non-dri Mesa implementation
341 Requires:       %{name}-libGL-static = %{version}-%{release}
342
343 %description libOSMesa-static
344 Static OSMesa (off-screen renderer) library.
345
346 %description libOSMesa-static -l pl.UTF-8
347 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
348
349 %package utils
350 Summary:        OpenGL utilities from Mesa3D
351 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
352 License:        MIT
353 Group:          X11/Applications/Graphics
354 # loose deps on libGL/libGLU
355
356 %description utils
357 OpenGL utilities from Mesa3D: glxgears and glxinfo.
358
359 %description utils -l pl.UTF-8
360 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
361
362 %package dri-driver-ati-mach64
363 Summary:        X.org DRI driver for ATI Mach64 card family
364 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
365 License:        MIT
366 Group:          X11/Libraries
367 Requires:       xorg-driver-video-mach64
368 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
369 Requires:       xorg-xserver-server >= %{xserver_ver}
370
371 %description dri-driver-ati-mach64
372 X.org DRI driver for ATI Mach64 card family.
373
374 %description dri-driver-ati-mach64 -l pl.UTF-8
375 Sterownik X.org DRI dla rodziny kart ATI Mach64.
376
377 %package dri-driver-ati-radeon-R100
378 Summary:        X.org DRI driver for ATI R100 card family
379 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
380 License:        MIT
381 Group:          X11/Libraries
382 Requires:       xorg-driver-video-ati
383 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
384 Requires:       xorg-xserver-server >= %{xserver_ver}
385 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
386
387 %description dri-driver-ati-radeon-R100
388 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
389
390 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
391 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
392
393 %package dri-driver-ati-radeon-R200
394 Summary:        X.org DRI driver for ATI R200 card family
395 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
396 License:        MIT
397 Group:          X11/Libraries
398 Requires:       xorg-driver-video-ati
399 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
400 Requires:       xorg-xserver-server >= %{xserver_ver}
401 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
402
403 %description dri-driver-ati-radeon-R200
404 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
405
406 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
407 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
408
409 %package dri-driver-ati-radeon-R300
410 Summary:        X.org DRI driver for ATI R300 card family
411 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
412 License:        MIT
413 Group:          X11/Libraries
414 Requires:       xorg-driver-video-ati
415 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
416 Requires:       xorg-xserver-server >= %{xserver_ver}
417 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
418
419 %description dri-driver-ati-radeon-R300
420 X.org DRI driver for ATI R300 card family.
421
422 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
423 Sterownik X.org DRI dla rodziny kart ATI R300.
424
425 %package dri-driver-ati-radeon-R600
426 Summary:        X.org DRI driver for ATI R600 card family
427 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
428 License:        MIT
429 Group:          X11/Libraries
430 Requires:       radeon-ucode
431 Requires:       xorg-driver-video-ati
432 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
433 Requires:       xorg-xserver-server >= %{xserver_ver}
434
435 %description dri-driver-ati-radeon-R600
436 X.org DRI driver for ATI R600 card family.
437
438 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
439 Sterownik X.org DRI dla rodziny kart ATI R600.
440
441 %package dri-driver-ati-rage128
442 Summary:        X.org DRI driver for ATI Rage128 card family
443 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
444 License:        MIT
445 Group:          X11/Libraries
446 Requires:       xorg-driver-video-r128
447 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
448 Requires:       xorg-xserver-server >= %{xserver_ver}
449 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
450
451 %description dri-driver-ati-rage128
452 X.org DRI driver for ATI Rage128 card family.
453
454 %description dri-driver-ati-rage128 -l pl.UTF-8
455 Sterownik X.org DRI dla rodziny kart ATI Rage128.
456
457 %package dri-driver-ffb
458 Summary:        X.org DRI driver for Sun FFB card family
459 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
460 License:        MIT
461 Group:          X11/Libraries
462 Requires:       xorg-driver-video-sunffb
463 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
464 Requires:       xorg-xserver-server >= %{xserver_ver}
465
466 %description dri-driver-ffb
467 X.org DRI driver for SUN Creator3D and Elite3D card family.
468
469 %description dri-driver-ffb -l pl.UTF-8
470 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
471
472 %package dri-driver-glint
473 Summary:        X.org DRI driver for GLINT/Permedia card family
474 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
475 License:        MIT
476 Group:          X11/Libraries
477 Requires:       xorg-driver-video-glint
478 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
479 Requires:       xorg-xserver-server >= %{xserver_ver}
480 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
481
482 %description dri-driver-glint
483 X.org DRI driver for GLINT/Permedia card family.
484
485 %description dri-driver-glint -l pl.UTF-8
486 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
487
488 %package dri-driver-intel-i810
489 Summary:        X.org DRI driver for Intel i810 card family
490 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
491 License:        MIT
492 Group:          X11/Libraries
493 Requires:       xorg-driver-video-intel
494 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
495 Requires:       xorg-xserver-server >= %{xserver_ver}
496 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
497
498 %description dri-driver-intel-i810
499 X.org DRI driver for Intel i810 card family.
500
501 %description dri-driver-intel-i810 -l pl.UTF-8
502 Sterownik X.org DRI dla rodziny kart Intel i810.
503
504 %package dri-driver-intel-i915
505 Summary:        X.org DRI driver for Intel i915 card family
506 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
507 License:        MIT
508 Group:          X11/Libraries
509 Requires:       xorg-driver-video-intel
510 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
511 Requires:       xorg-xserver-server >= %{xserver_ver}
512 Obsoletes:      Mesa-dri-driver-intel-i830
513 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
514
515 %description dri-driver-intel-i915
516 X.org DRI driver for Intel i915 card family.
517
518 %description dri-driver-intel-i915 -l pl.UTF-8
519 Sterownik X.org DRI dla rodziny kart Intel i915.
520
521 %package dri-driver-intel-i965
522 Summary:        X.org DRI driver for Intel i965 card family
523 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
524 License:        MIT
525 Group:          X11/Libraries
526 Requires:       xorg-driver-video-intel
527 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
528 Requires:       xorg-xserver-server >= %{xserver_ver}
529 Obsoletes:      Mesa-dri-driver-intel-i830
530 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
531
532 %description dri-driver-intel-i965
533 X.org DRI driver for Intel i965 card family.
534
535 %description dri-driver-intel-i965 -l pl.UTF-8
536 Sterownik X.org DRI dla rodziny kart Intel i965.
537
538 %package dri-driver-matrox
539 Summary:        X.org DRI driver for Matrox G card family
540 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
541 License:        MIT
542 Group:          X11/Libraries
543 Requires:       xorg-driver-video-mga
544 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
545 Requires:       xorg-xserver-server >= %{xserver_ver}
546 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
547
548 %description dri-driver-matrox
549 X.org DRI drivers for Matrox G card family.
550
551 %description dri-driver-matrox -l pl.UTF-8
552 Sterowniki X.org DRI dla rodziny kart Matrox G.
553
554 %package dri-driver-nouveau
555 Summary:        X.org DRI driver for NVIDIA card family
556 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
557 License:        MIT
558 Group:          X11/Libraries
559 Requires:       xorg-driver-video-nouveau
560 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
561 Requires:       xorg-xserver-server >= %{xserver_ver}
562
563 %description dri-driver-nouveau
564 X.org DRI drivers for NVIDIA card family.
565
566 %description dri-driver-nouveau -l pl.UTF-8
567 Sterowniki X.org DRI dla rodziny kart NVIDIA.
568
569 %package dri-driver-savage
570 Summary:        X.org DRI driver for S3 Savage card family
571 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
572 License:        MIT
573 Group:          X11/Libraries
574 Requires:       xorg-driver-video-savage
575 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
576 Requires:       xorg-xserver-server >= %{xserver_ver}
577
578 %description dri-driver-savage
579 X.org DRI driver for S3 Savage card family.
580
581 %description dri-driver-savage -l pl.UTF-8
582 Sterownik X.org DRI dla rodziny kart S3 Savage.
583
584 %package dri-driver-sis
585 Summary:        X.org DRI driver for SiS card family
586 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
587 License:        MIT
588 Group:          X11/Libraries
589 Requires:       xorg-driver-video-sis
590 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
591 Requires:       xorg-xserver-server >= %{xserver_ver}
592 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
593
594 %description dri-driver-sis
595 X.org DRI driver for SiS card family.
596
597 %description dri-driver-sis -l pl.UTF-8
598 Sterownik X.org DRI dla rodziny kart SiS.
599
600 %package dri-driver-swrast
601 Summary:        X.org DRI software rasterizer driver
602 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
603 License:        MIT
604 Group:          X11/Libraries
605 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
606 Requires:       xorg-xserver-server >= %{xserver_ver}
607
608 %description dri-driver-swrast
609 X.org DRI software rasterizer driver.
610
611 %description dri-driver-swrast -l pl.UTF-8
612 Sterownik X.org DRI obsługujący rysowanie programowe.
613
614 %package dri-driver-tdfx
615 Summary:        X.org DRI driver for 3DFX Voodoo card family
616 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
617 License:        MIT
618 Group:          X11/Libraries
619 Requires:       Glide3-DRI
620 Requires:       xorg-driver-video-tdfx
621 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
622 Requires:       xorg-xserver-server >= %{xserver_ver}
623 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
624
625 %description dri-driver-tdfx
626 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
627 and Velocity 100/200).
628
629 %description dri-driver-tdfx -l pl.UTF-8
630 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
631 Banshee i Velocity 100/200).
632
633 %package dri-driver-via-unichrome
634 Summary:        X.org DRI driver for VIA Unichrome card family
635 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
636 License:        MIT
637 Group:          X11/Libraries
638 Requires:       xorg-driver-video-openchrome
639 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
640 Requires:       xorg-xserver-server >= %{xserver_ver}
641
642 %description dri-driver-via-unichrome
643 X.org DRI driver for VIA Unichrome card family.
644
645 %description dri-driver-via-unichrome -l pl.UTF-8
646 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
647
648 %package dri-driver-vmwgfx
649 Summary:        X.org DRI driver for VMware
650 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
651 License:        MIT
652 Group:          X11/Libraries
653 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
654 Requires:       xorg-xserver-server >= %{xserver_ver}
655
656 %description dri-driver-vmwgfx
657 X.org DRI driver for VMWare.
658
659 %description dri-driver-vmwgfx -l pl.UTF-8
660 Sterownik X.org DRI dla VMware.
661
662 %prep
663 %setup -q
664 %patch0 -p0
665 %patch1 -p0
666 %patch2 -p1
667
668 %build
669 #autoreconf --install
670 %{__aclocal}
671 %{__autoconf}
672
673 dri_drivers="i810 i965 mach64 mga r128 \
674 %if %{without gallium_radeon}
675 r200 r300 r600 radeon \
676 %endif
677 savage \
678 %if %{without gallium_intel}
679 i915 \
680 %endif
681 %ifarch sparc sparcv9 sparc64
682 ffb \
683 %endif
684 %ifarch %{ix86} %{x8664}
685 sis \
686 %endif
687 swrast tdfx unichrome"
688
689 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
690
691 common_flags="\
692         --enable-shared \
693         --enable-selinux \
694         --enable-pic \
695         --enable-glx-tls \
696         --disable-glut \
697         --disable-os-mesa \
698         --%{?with_egl:en}%{!?with_egl:dis}able-egl"
699
700 osmesa_common_flags="\
701         --with-driver=osmesa \
702         --disable-asm \
703         --disable-glu"
704
705 %if %{with osmesa}
706 # osmesa variants
707 %configure $common_flags $osmesa_common_flags \
708         --with-osmesa-bits=8
709 %{__make}
710 mv %{_lib} osmesa8
711 %{__make} clean
712
713 %configure $common_flags $osmesa_common_flags \
714         --with-osmesa-bits=16
715 %{__make}
716 mv %{_lib} osmesa16
717 %{__make} clean
718
719 %configure $common_flags $osmesa_common_flags \
720         --with-osmesa-bits=32
721 %{__make}
722 mv %{_lib} osmesa32
723 %{__make} clean
724 %endif
725
726 %configure $common_flags \
727 %if %{with gallium}
728         --enable-gallium \
729         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
730         --%{?with_gallium_radeon:en}%{!?with_gallium_radeon:dis}able-gallium-radeon \
731         --enable-gallium-svga \
732 %{?with_gallium_nouveau:--enable-gallium-nouveau} \
733         --with-state-trackers=dri,glx \
734 %else
735         --disable-gallium \
736 %endif
737         --with-driver=dri \
738         --with-dri-drivers=${dri_drivers} \
739         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
740
741 %{__make}
742
743 %install
744 rm -rf $RPM_BUILD_ROOT
745
746 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
747
748 # libs without drivers
749 %{__make} install \
750         DESTDIR=$RPM_BUILD_ROOT
751
752 %if %{with osmesa}
753 install osmesa*/*OSMesa* $RPM_BUILD_ROOT%{_libdir}
754 %endif
755
756 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
757
758 # strip out undesirable headers
759 olddir=$(pwd)
760 cd $RPM_BUILD_ROOT%{_includedir}/GL
761 rm [a-fh-np-wyz]*.h glf*.h
762 cd $RPM_BUILD_ROOT%{_libdir}
763 cd $olddir
764
765 %if %{with multigl}
766 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
767
768 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
769 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
770
771 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
772 %endif
773
774 %clean
775 rm -rf $RPM_BUILD_ROOT
776
777 %post   libEGL -p /sbin/ldconfig
778 %postun libEGL -p /sbin/ldconfig
779
780 %post   libGL -p /sbin/ldconfig
781 %postun libGL -p /sbin/ldconfig
782
783 %post   libGLU -p /sbin/ldconfig
784 %postun libGLU -p /sbin/ldconfig
785
786 %post   libGLw -p /sbin/ldconfig
787 %postun libGLw -p /sbin/ldconfig
788
789 %if %{with egl}
790 %files libEGL
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
793 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
794 %dir %{_libdir}/egl
795 %attr(755,root,root) %{_libdir}/egl/egl_dri2.so
796 %attr(755,root,root) %{_libdir}/egl/egl_glx.so
797
798 %files libEGL-devel
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libEGL.so
801 %dir %{_includedir}/EGL
802 %{_includedir}/EGL/egl.h
803 %{_includedir}/EGL/eglext.h
804 %{_includedir}/EGL/eglplatform.h
805 %dir %{_includedir}/KHR
806 %{_includedir}/KHR/khrplatform.h
807 %{_pkgconfigdir}/egl.pc
808
809 %if %{with static}
810 %files libEGL-static
811 %defattr(644,root,root,755)
812 %{_libdir}/libEGL.a
813 %endif
814 %endif
815
816 %files libGL
817 %defattr(644,root,root,755)
818 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
819 %if %{with multigl}
820 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
821 %dir %{_libdir}/Mesa
822 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
823 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
824 %else
825 %attr(755,root,root) %{_libdir}/libGL.so.*.*
826 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
827 # symlink for binary apps which fail to conform Linux OpenGL ABI
828 # (and dlopen libGL.so instead of libGL.so.1)
829 %attr(755,root,root) %{_libdir}/libGL.so
830 %endif
831
832 %files libGL-devel
833 %defattr(644,root,root,755)
834 %doc docs/*.spec
835 %if %{with multigl}
836 %attr(755,root,root) %{_libdir}/libGL.so
837 %endif
838 %dir %{_includedir}/GL
839 %{_includedir}/GL/gl.h
840 %{_includedir}/GL/glext.h
841 %{_includedir}/GL/gl_mangle.h
842 %{_includedir}/GL/glx.h
843 %{_includedir}/GL/glxext.h
844 %{_includedir}/GL/glx_mangle.h
845 %dir %{_includedir}/GL/internal
846 %{_includedir}/GL/internal/dri_interface.h
847 %{_pkgconfigdir}/dri.pc
848 %{_pkgconfigdir}/gl.pc
849
850 %if %{with static}
851 %files libGL-static
852 %defattr(644,root,root,755)
853 %{_libdir}/libGL.a
854 %endif
855
856 %files libGLU
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
859 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
860
861 %files libGLU-devel
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_libdir}/libGLU.so
864 %{_includedir}/GL/glu.h
865 %{_includedir}/GL/glu_mangle.h
866 %{_pkgconfigdir}/glu.pc
867
868 %if %{with static}
869 %files libGLU-static
870 %defattr(644,root,root,755)
871 %{_libdir}/libGLU.a
872 %endif
873
874 %files libGLw
875 %defattr(644,root,root,755)
876 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
877 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
878
879 %files libGLw-devel
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_libdir}/libGLw.so
882 %{_includedir}/GL/GLwDrawA.h
883 %{_includedir}/GL/GLwDrawAP.h
884 %{_includedir}/GL/GLwMDrawA.h
885 %{_includedir}/GL/GLwMDrawAP.h
886 %{_pkgconfigdir}/glw.pc
887
888 %if %{with static}
889 %files libGLw-static
890 %defattr(644,root,root,755)
891 %{_libdir}/libGLw.a
892 %endif
893
894 %if %{with osmesa}
895 %files libOSMesa
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
898 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
899
900 %files libOSMesa-devel
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/libOSMesa*.so
903 %{_includedir}/GL/osmesa.h
904
905 %if %{with static}
906 %files libOSMesa-static
907 %defattr(644,root,root,755)
908 %{_libdir}/libOSMesa*.a
909 %endif
910 %endif
911
912 %files dri-driver-ati-mach64
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
915
916 %files dri-driver-ati-radeon-R100
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
919
920 %files dri-driver-ati-radeon-R200
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
923
924 %files dri-driver-ati-radeon-R300
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
927
928 %files dri-driver-ati-radeon-R600
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
931
932 %files dri-driver-ati-rage128
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
935
936 # sunffb (sparc only)
937 %ifarch sparc sparcv9 sparc64
938 %files dri-driver-ffb
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
941 %endif
942
943 # glint (requires update)
944 %if 0
945 %files dri-driver-glint
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
948 %endif
949
950 %files dri-driver-intel-i810
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
953
954 %files dri-driver-intel-i915
955 %defattr(644,root,root,755)
956 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
957
958 %files dri-driver-intel-i965
959 %defattr(644,root,root,755)
960 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
961
962 %files dri-driver-matrox
963 %defattr(644,root,root,755)
964 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
965
966 %if %{with gallium}
967 %if %{with gallium_nouveau}
968 %files dri-driver-nouveau
969 %defattr(644,root,root,755)
970 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
971 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
972 %endif
973 %endif
974
975 %files dri-driver-savage
976 %defattr(644,root,root,755)
977 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
978
979 %ifarch %{ix86} %{x8664}
980 %files dri-driver-sis
981 %defattr(644,root,root,755)
982 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
983 %endif
984
985 %files dri-driver-swrast
986 %defattr(644,root,root,755)
987 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
988 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrastg_dri.so
989
990 %files dri-driver-tdfx
991 %defattr(644,root,root,755)
992 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
993
994 %files dri-driver-via-unichrome
995 %defattr(644,root,root,755)
996 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
997
998 %if %{with gallium}
999 %files dri-driver-vmwgfx
1000 %defattr(644,root,root,755)
1001 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
1002 %endif
This page took 0.096181 seconds and 4 git commands to generate.