]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- merged some changes from HEAD
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_without  gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_without  gallium_radeon  # gallium radeon driver
11 %bcond_without  gallium_nouveau # gallium nouveau driver
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_without  gbm     # with Graphics Buffer Manager
16 %bcond_with     static_libs     # static libraries
17 #
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.25
26 %define         dri2proto_ver   2.6
27 %define         glproto_ver     1.4.11
28 #
29 %define         snap            20110901
30 #
31 Summary:        Free OpenGL implementation
32 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
33 Name:           Mesa
34 Version:        7.12
35 Release:        0.%{snap}.1%{?with_multigl:.mgl}
36 License:        MIT (core), SGI (GLU) and others - see license.html file
37 Group:          X11/Libraries
38 Source0:        %{name}Lib-%{snap}.tar.bz2
39 # Source0-md5:  2b4e889af7e86cbd0f8718263d5b1a11
40 Patch0:         %{name}-realclean.patch
41 Patch2:         %{name}-selinux.patch
42 URL:            http://www.mesa3d.org/
43 BuildRequires:  autoconf >= 2.59
44 BuildRequires:  automake
45 BuildRequires:  expat-devel
46 BuildRequires:  libdrm-devel >= %{libdrm_ver}
47 # drop when 2.4.24 is released
48 %{?with_nouveau:BuildRequires:  libdrm-devel >= 2.4.24}
49 BuildRequires:  libselinux-devel
50 BuildRequires:  libstdc++-devel >= 5:3.3.0
51 BuildRequires:  libtalloc-devel >= 2:2.0.1
52 BuildRequires:  libtool >= 2:1.4d
53 BuildRequires:  libvdpau-devel
54 BuildRequires:  llvm-devel >= 2.9
55 %{?with_motif:BuildRequires:    motif-devel}
56 BuildRequires:  pixman-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  pkgconfig(talloc) >= 2.0.1
59 BuildRequires:  python
60 BuildRequires:  python-libxml2
61 BuildRequires:  python-modules
62 BuildRequires:  rpmbuild(macros) >= 1.470
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  xorg-lib-libXdamage-devel
65 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
66 BuildRequires:  xorg-lib-libXt-devel
67 BuildRequires:  xorg-lib-libXxf86vm-devel
68 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
69 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
70 BuildRequires:  xorg-util-makedepend
71 BuildRequires:  xorg-xserver-server-devel
72 %if %{with egl}
73 BuildRequires:  libxcb-devel
74 BuildRequires:  udev-devel >= 150
75 %endif
76 %if %{with gallium}
77 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
78 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
79 %endif
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %if %{without gallium}
83 %undefine       with_gallium_intel
84 %undefine       with_gallium_radeon
85 %endif
86
87 %if %{without egl}
88 %undefine       with_gbm
89 %endif
90
91 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
92 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.*
93
94 %description
95 Mesa is a 3-D graphics library with an API which is very similar to
96 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
97 syntax or state machine, it is being used with authorization from
98 Silicon Graphics, Inc. However, the author does not possess an OpenGL
99 license from SGI, and makes no claim that Mesa is in any way a
100 compatible replacement for OpenGL or associated with SGI.
101
102 %description -l pl.UTF-8
103 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
104 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
105 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
106 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
107 OpenGL ani powiązana z SGI.
108
109 %package libEGL
110 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
111 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
112 License:        MIT
113 Group:          Libraries
114 Requires:       OpenGL >= 1.2
115 Requires:       udev-libs >= 150
116 Provides:       EGL = 1.4
117
118 %description libEGL
119 This package contains shared libEGL - Mesa implementation of EGL
120 Native Platform Graphics Interface as specified by Khronos Group:
121 <http://www.khronos.org/egl/>.
122
123 %description libEGL -l pl.UTF-8
124 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
125 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
126 graficznego platformy natywnej) wg specyfikacji Khronos Group:
127 <http://www.khronos.org/egl/>.
128
129 %package libEGL-devel
130 Summary:        Header files for Mesa implementation of EGL library
131 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
132 License:        MIT
133 Group:          Development/Libraries
134 Requires:       %{name}-libEGL = %{version}-%{release}
135 Requires:       OpenGL-devel >= 1.2
136 Requires:       libstdc++-devel
137 Provides:       EGL-devel = 1.4
138
139 %description libEGL-devel
140 Header files for Mesa implementation of EGL library.
141
142 %description libEGL-devel -l pl.UTF-8
143 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
144
145 %package libEGL-static
146 Summary:        Static SGI libEGL library
147 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
148 License:        MIT
149 Group:          Development/Libraries
150 Requires:       %{name}-libEGL-devel = %{version}-%{release}
151 Provides:       EGL-static = 1.4
152
153 %description libEGL-static
154 Static Mesa libEGL library.
155
156 %description libEGL-static -l pl.UTF-8
157 Statyczna biblioteka Mesa libEGL.
158
159 %package libGLES
160 Summary:        Mesa libGLES runtime libraries
161 Group:          Libraries
162
163 %description libGLES
164 Mesa GLES runtime libraries.
165
166 %description libGLES -l pl.UTF-8
167 Biblioteka Mesa GLES.
168
169 %package libGLES-devel
170 Summary:        Header files for libGLES library
171 Group:          Development/Libraries
172 Requires:       %{name}-libGLES = %{version}-%{release}
173
174 %description libGLES-devel
175 Header files for libGLES library.
176
177 %description libGLES-devel -l pl.UTF-8
178 Pliki nagłówkowe biblioteki libGLES.
179
180 %package libGL
181 Summary:        Free Mesa3D implementation of libGL OpenGL library
182 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
183 License:        MIT
184 Group:          X11/Libraries
185 Requires:       libdrm >= %{libdrm_ver}
186 Provides:       OpenGL = 2.1
187 # reports version 1.3, but supports glXGetProcAddress() from 1.4
188 Provides:       OpenGL-GLX = 1.4
189 Obsoletes:      Mesa
190 Obsoletes:      Mesa-dri
191 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
192 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
193
194 %description libGL
195 Mesa is a 3-D graphics library with an API which is very similar to
196 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
197 syntax or state machine, it is being used with authorization from
198 Silicon Graphics, Inc. However, the author does not possess an OpenGL
199 license from SGI, and makes no claim that Mesa is in any way a
200 compatible replacement for OpenGL or associated with SGI.
201
202 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
203 specifications. It uses DRI for rendering.
204
205 %description libGL -l pl.UTF-8
206 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
207 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
208 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
209 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
210 OpenGL ani powiązana z SGI.
211
212 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
213 GLX 1.4. Używa DRI do renderowania.
214
215 %package libGL-devel
216 Summary:        Header files for Mesa3D libGL library
217 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
218 License:        MIT
219 Group:          X11/Development/Libraries
220 # loose dependency on libGL to use with other libGL binaries
221 Requires:       OpenGL >= 1.5
222 Requires:       libdrm-devel >= %{libdrm_ver}
223 Requires:       xorg-lib-libX11-devel
224 Requires:       xorg-lib-libXdamage-devel
225 Requires:       xorg-lib-libXext-devel
226 Requires:       xorg-lib-libXxf86vm-devel
227 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
228 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
229 Suggests:       OpenGL-doc-man
230 Provides:       OpenGL-GLX-devel = 1.4
231 Provides:       OpenGL-devel = 2.1
232 Obsoletes:      Mesa-devel
233 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
234 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
235 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
236 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
237
238 %description libGL-devel
239 Header files for Mesa3D libGL library.
240
241 %description libGL-devel -l pl.UTF-8
242 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
243
244 %package libGL-static
245 Summary:        Static Mesa3D libGL library
246 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
247 License:        MIT
248 Group:          X11/Development/Libraries
249 Requires:       %{name}-libGL-devel = %{version}-%{release}
250 Provides:       OpenGL-static = 2.1
251 Obsoletes:      Mesa-static
252 Obsoletes:      X11-OpenGL-static < 1:7.0.0
253 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
254
255 %description libGL-static
256 Static Mesa3D libGL library. It uses software renderer.
257
258 %description libGL-static -l pl.UTF-8
259 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
260 renderingu.
261
262 %package libGLU
263 Summary:        SGI implementation of libGLU OpenGL library
264 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
265 License:        SGI Free Software License B v2.0 (MIT-like)
266 Group:          Libraries
267 # loose dependency on libGL.so.1 to use with other libGL binaries
268 Requires:       OpenGL >= 1.2
269 Provides:       OpenGL-GLU = 1.3
270 Obsoletes:      Mesa-devel
271 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
272 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
273
274 %description libGLU
275 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
276 1.3 specifications.
277
278 %description libGLU -l pl.UTF-8
279 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
280 specyfikację OpenGL GLU 1.3.
281
282 %package libGLU-devel
283 Summary:        Header files for SGI libGLU library
284 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
285 License:        SGI Free Software License B v2.0 (MIT-like)
286 Group:          Development/Libraries
287 Requires:       %{name}-libGLU = %{version}-%{release}
288 Requires:       OpenGL-devel >= 1.2
289 Requires:       libstdc++-devel
290 Provides:       OpenGL-GLU-devel = 1.3
291
292 %description libGLU-devel
293 Header files for SGI libGLU library.
294
295 %description libGLU-devel -l pl.UTF-8
296 Pliki nagłówkowe biblioteki SGI libGLU.
297
298 %package libGLU-static
299 Summary:        Static SGI libGLU library
300 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
301 License:        SGI Free Software License B v2.0 (MIT-like)
302 Group:          Development/Libraries
303 Requires:       %{name}-libGLU-devel = %{version}-%{release}
304 Provides:       OpenGL-GLU-static = 1.3
305
306 %description libGLU-static
307 Static SGI libGLU library.
308
309 %description libGLU-static -l pl.UTF-8
310 Statyczna biblioteka SGI libGLU.
311
312 %package libOSMesa
313 Summary:        OSMesa (off-screen renderer) library
314 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
315 License:        MIT
316 Group:          Libraries
317 # doesn't require base
318
319 %description libOSMesa
320 OSMesa (off-screen renderer) library.
321
322 %description libOSMesa -l pl.UTF-8
323 Biblioteka OSMesa (renderująca bitmapy w pamięci).
324
325 %package libOSMesa-devel
326 Summary:        Header file for OSMesa (off-screen renderer) library
327 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
328 License:        MIT
329 Group:          Development/Libraries
330 Requires:       %{name}-libOSMesa = %{version}-%{release}
331 # for <GL/gl.h> only
332 Requires:       OpenGL-devel
333
334 %description libOSMesa-devel
335 Header file for OSMesa (off-screen renderer) library.
336
337 %description libOSMesa-devel -l pl.UTF-8
338 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
339
340 %package libOSMesa-static
341 Summary:        Static OSMesa (off-screen renderer) library
342 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
343 License:        MIT
344 Group:          Development/Libraries
345 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
346 # this static build of OSMesa needs static non-dri Mesa implementation
347 Requires:       %{name}-libGL-static = %{version}-%{release}
348
349 %description libOSMesa-static
350 Static OSMesa (off-screen renderer) library.
351
352 %description libOSMesa-static -l pl.UTF-8
353 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
354
355 %package libOpenVG
356 Summary:        OpenVG API implementation
357 Summary(pl.UTF-8):      Implementacja API OpenVG
358 License:        MIT
359 Group:          Libraries
360 # doesn't require base
361
362 %description libOpenVG
363 OpenVG API implementation.
364
365 %description libOpenVG -l pl.UTF-8
366 Implementacja API OpenVG.
367
368 %package libOpenVG-devel
369 Summary:        Header file for libOpenVG library
370 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libOpenVG
371 License:        MIT
372 Group:          Development/Libraries
373 # for <KHR/khrplatform.h>
374 Requires:       %{name}-libEGL-devel = %{version}-%{release}
375 Requires:       %{name}-libOpenVG = %{version}-%{release}
376
377 %description libOpenVG-devel
378 Header file for libOpenVG library.
379
380 %description libOpenVG-devel -l pl.UTF-8
381 Plik nagłówkowy biblioteki libOpenVG.
382
383 %package utils
384 Summary:        OpenGL utilities from Mesa3D
385 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
386 License:        MIT
387 Group:          X11/Applications/Graphics
388 # loose deps on libGL/libGLU
389
390 %description utils
391 OpenGL utilities from Mesa3D: glxgears and glxinfo.
392
393 %description utils -l pl.UTF-8
394 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
395
396 %package dri-driver-ati-radeon-R100
397 Summary:        X.org DRI driver for ATI R100 card family
398 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
399 License:        MIT
400 Group:          X11/Libraries
401 Requires:       xorg-driver-video-ati
402 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
403 Requires:       xorg-xserver-server >= %{xserver_ver}
404 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
405
406 %description dri-driver-ati-radeon-R100
407 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
408
409 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
410 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
411
412 %package dri-driver-ati-radeon-R200
413 Summary:        X.org DRI driver for ATI R200 card family
414 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
415 License:        MIT
416 Group:          X11/Libraries
417 Requires:       xorg-driver-video-ati
418 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
419 Requires:       xorg-xserver-server >= %{xserver_ver}
420 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
421
422 %description dri-driver-ati-radeon-R200
423 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
424
425 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
426 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
427
428 %package dri-driver-ati-radeon-R300
429 Summary:        X.org DRI driver for ATI R300 card family
430 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
431 License:        MIT
432 Group:          X11/Libraries
433 Requires:       xorg-driver-video-ati
434 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
435 Requires:       xorg-xserver-server >= %{xserver_ver}
436 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
437
438 %description dri-driver-ati-radeon-R300
439 X.org DRI driver for ATI R300 card family.
440
441 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
442 Sterownik X.org DRI dla rodziny kart ATI R300.
443
444 %package dri-driver-ati-radeon-R600
445 Summary:        X.org DRI driver for ATI R600 card family
446 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
447 License:        MIT
448 Group:          X11/Libraries
449 Requires:       radeon-ucode
450 Requires:       xorg-driver-video-ati
451 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
452 Requires:       xorg-xserver-server >= %{xserver_ver}
453
454 %description dri-driver-ati-radeon-R600
455 X.org DRI driver for ATI R600 card family.
456
457 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
458 Sterownik X.org DRI dla rodziny kart ATI R600.
459
460 %package dri-driver-ffb
461 Summary:        X.org DRI driver for Sun FFB card family
462 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
463 License:        MIT
464 Group:          X11/Libraries
465 Requires:       xorg-driver-video-sunffb
466 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
467 Requires:       xorg-xserver-server >= %{xserver_ver}
468
469 %description dri-driver-ffb
470 X.org DRI driver for SUN Creator3D and Elite3D card family.
471
472 %description dri-driver-ffb -l pl.UTF-8
473 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
474
475 %package dri-driver-glint
476 Summary:        X.org DRI driver for GLINT/Permedia card family
477 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
478 License:        MIT
479 Group:          X11/Libraries
480 Requires:       xorg-driver-video-glint
481 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
482 Requires:       xorg-xserver-server >= %{xserver_ver}
483 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
484
485 %description dri-driver-glint
486 X.org DRI driver for GLINT/Permedia card family.
487
488 %description dri-driver-glint -l pl.UTF-8
489 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
490
491 %package dri-driver-intel-i915
492 Summary:        X.org DRI driver for Intel i915 card family
493 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
494 License:        MIT
495 Group:          X11/Libraries
496 Requires:       xorg-driver-video-intel
497 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
498 Requires:       xorg-xserver-server >= %{xserver_ver}
499 Obsoletes:      Mesa-dri-driver-intel-i830
500 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
501
502 %description dri-driver-intel-i915
503 X.org DRI driver for Intel i915 card family.
504
505 %description dri-driver-intel-i915 -l pl.UTF-8
506 Sterownik X.org DRI dla rodziny kart Intel i915.
507
508 %package dri-driver-intel-i965
509 Summary:        X.org DRI driver for Intel i965 card family
510 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
511 License:        MIT
512 Group:          X11/Libraries
513 Requires:       xorg-driver-video-intel
514 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
515 Requires:       xorg-xserver-server >= %{xserver_ver}
516 Obsoletes:      Mesa-dri-driver-intel-i830
517 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
518
519 %description dri-driver-intel-i965
520 X.org DRI driver for Intel i965 card family.
521
522 %description dri-driver-intel-i965 -l pl.UTF-8
523 Sterownik X.org DRI dla rodziny kart Intel i965.
524
525 %package dri-driver-nouveau
526 Summary:        X.org DRI driver for NVIDIA card family
527 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
528 License:        MIT
529 Group:          X11/Libraries
530 Requires:       xorg-driver-video-nouveau
531 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
532 Requires:       xorg-xserver-server >= %{xserver_ver}
533
534 %description dri-driver-nouveau
535 X.org DRI drivers for NVIDIA card family.
536
537 %description dri-driver-nouveau -l pl.UTF-8
538 Sterowniki X.org DRI dla rodziny kart NVIDIA.
539
540 %package dri-driver-swrast
541 Summary:        X.org DRI software rasterizer driver
542 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
543 License:        MIT
544 Group:          X11/Libraries
545 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
546 Requires:       xorg-xserver-server >= %{xserver_ver}
547
548 %description dri-driver-swrast
549 X.org DRI software rasterizer driver.
550
551 %description dri-driver-swrast -l pl.UTF-8
552 Sterownik X.org DRI obsługujący rysowanie programowe.
553
554 %package dri-driver-vmwgfx
555 Summary:        X.org DRI driver for VMware
556 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
557 License:        MIT
558 Group:          X11/Libraries
559 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
560 Requires:       xorg-xserver-server >= %{xserver_ver}
561
562 %description dri-driver-vmwgfx
563 X.org DRI driver for VMWare.
564
565 %description dri-driver-vmwgfx -l pl.UTF-8
566 Sterownik X.org DRI dla VMware.
567
568 %package -n libvdpau-driver-mesa
569 Summary:        Mesa driver for the vdpau API
570 Summary(pl.UTF-8):      Sterownik Mesa dla API vdpau
571 License:        MIT
572 Group:          X11/Libraries
573
574 %description -n libvdpau-driver-mesa
575 Mesa driver for the vdpau API.
576
577 %description -n libvdpau-driver-mesa -l pl.UTF-8
578 Sterownik Mesa dla API vdpau.
579
580 %prep
581 %setup -q
582 %patch0 -p0
583 %patch2 -p1
584
585 %build
586 %{__aclocal}
587 %{__autoconf}
588
589 dri_drivers="r200 radeon \
590 %if %{without gallium_radeon}
591 r300 r600 \
592 %endif
593 %if %{without gallium_intel}
594 i915 i965 \
595 %endif
596 %ifarch sparc sparcv9 sparc64
597 ffb \
598 %endif
599 swrast"
600
601 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
602
603 gallium_drivers="svga swrast \
604 %if %{with gallium_intel}
605 i915 \
606 i965 \
607 %endif
608 %if %{with gallium_radeon}
609 r300 \
610 r600 \
611 %endif
612 %if %{with gallium_nouveau}
613 nouveau \
614 %endif
615 "
616
617 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
618
619 common_flags="\
620         --enable-shared \
621         --enable-selinux \
622         --enable-pic \
623         --enable-glx-tls \
624 %if %{with egl}
625         --enable-egl \
626         --enable-gles1 \
627         --enable-gles2 \
628 %endif
629 "
630
631 osmesa_common_flags="\
632         --with-driver=osmesa \
633         --disable-asm \
634         --disable-glu \
635         --disable-egl"
636
637 %if %{with osmesa}
638 %configure $common_flags $osmesa_common_flags \
639         --with-osmesa-bits=8
640 %{__make}
641 mv %{_lib} osmesa8
642 %{__make} clean
643 %endif
644
645 %configure $common_flags \
646         --enable-shared-glapi \
647 %if %{with egl}
648         --enable-egl \
649         --enable-gles1 \
650         --enable-gles2 \
651         %{__enable gbm} \
652 %endif
653 %if %{with gallium}
654         --enable-openvg \
655         %{__enable egl gallium-egl} \
656         %{__enable gbm gallium-gbm} \
657         --enable-vdpau \
658         --with-gallium-drivers=${gallium_drivers} \
659 %else
660         --disable-gallium \
661 %endif
662         --with-driver=dri \
663         --with-dri-drivers=${dri_drivers} \
664         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
665
666 %{__make}
667
668 %install
669 rm -rf $RPM_BUILD_ROOT
670
671 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
672
673 # libs without drivers
674 %{__make} install \
675         DESTDIR=$RPM_BUILD_ROOT
676
677 %if %{with osmesa}
678 cp -dp osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
679 %endif
680
681 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
682
683 # strip out undesirable headers
684 olddir=$(pwd)
685 cd $RPM_BUILD_ROOT%{_includedir}/GL
686 rm [a-fh-np-wyz]*.h glf*.h
687 cd $RPM_BUILD_ROOT%{_libdir}
688 cd $olddir
689
690 %if %{with multigl}
691 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
692
693 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
694 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
695
696 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
697 %endif
698
699 %clean
700 rm -rf $RPM_BUILD_ROOT
701
702 %post   libEGL -p /sbin/ldconfig
703 %postun libEGL -p /sbin/ldconfig
704
705 %post   libGL -p /sbin/ldconfig
706 %postun libGL -p /sbin/ldconfig
707
708 %post   libGLES -p /sbin/ldconfig
709 %postun libGLES -p /sbin/ldconfig
710
711 %post   libGLU -p /sbin/ldconfig
712 %postun libGLU -p /sbin/ldconfig
713
714 %post   libOSMesa -p /sbin/ldconfig
715 %postun libOSMesa -p /sbin/ldconfig
716
717 %post   libOpenVG -p /sbin/ldconfig
718 %postun libOpenVG -p /sbin/ldconfig
719
720 %if %{with egl}
721 %files libEGL
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
724 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
725 %if %{with gbm}
726 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
727 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
728 %endif
729 %if %{with gallium}
730 %dir %{_libdir}/egl
731 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
732 #%attr(755,root,root) %{_libdir}/egl/st_GL.so
733 %if %{with gbm}
734 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
735 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
736 %if %{with gallium_nouveau}
737 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
738 %endif
739 %if %{with gallium_radeon}
740 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
741 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
742 %endif
743 %if %{with gallium_intel}
744 %attr(755,root,root) %{_libdir}/gbm/pipe_i915.so
745 %attr(755,root,root) %{_libdir}/gbm/pipe_i965.so
746 %endif
747 %endif
748 %endif
749
750 %files libEGL-devel
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libEGL.so
753 %dir %{_includedir}/EGL
754 %{_includedir}/EGL/egl.h
755 %{_includedir}/EGL/eglext.h
756 %{_includedir}/EGL/eglplatform.h
757 %dir %{_includedir}/KHR
758 %{_includedir}/KHR/khrplatform.h
759 %{_pkgconfigdir}/egl.pc
760 %if %{with gbm}
761 %attr(755,root,root) %{_libdir}/libgbm.so
762 %{_includedir}/gbm.h
763 %{_pkgconfigdir}/gbm.pc
764 %endif
765
766 %if %{with static_libs}
767 %files libEGL-static
768 %defattr(644,root,root,755)
769 %{_libdir}/libEGL.a
770 %endif
771 %endif
772
773 %files libGL
774 %defattr(644,root,root,755)
775 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
776 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
777 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
778 %if %{with multigl}
779 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
780 %dir %{_libdir}/Mesa
781 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
782 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
783 %else
784 %attr(755,root,root) %{_libdir}/libGL.so.*.*
785 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
786 # symlink for binary apps which fail to conform Linux OpenGL ABI
787 # (and dlopen libGL.so instead of libGL.so.1)
788 %attr(755,root,root) %{_libdir}/libGL.so
789 %endif
790
791 %files libGL-devel
792 %defattr(644,root,root,755)
793 %doc docs/*.spec
794 %attr(755,root,root) %{_libdir}/libglapi.so
795 %if %{with multigl}
796 %attr(755,root,root) %{_libdir}/libGL.so
797 %endif
798 %dir %{_includedir}/GL
799 %{_includedir}/GL/gl.h
800 %{_includedir}/GL/glext.h
801 %{_includedir}/GL/gl_mangle.h
802 %{_includedir}/GL/glx.h
803 %{_includedir}/GL/glxext.h
804 %{_includedir}/GL/glx_mangle.h
805 %dir %{_includedir}/GL/internal
806 %{_includedir}/GL/internal/dri_interface.h
807 %{_pkgconfigdir}/dri.pc
808 %{_pkgconfigdir}/gl.pc
809
810 %files libGLES
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libGLES*.so.*.*
813 %attr(755,root,root) %ghost %{_libdir}/libGLES*.so.[0-9]
814
815 %files libGLES-devel
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libGLES*.so
818 %{_includedir}/GLES
819 %{_includedir}/GLES2
820 %{_pkgconfigdir}/gles*.pc
821
822 %if %{with static_libs}
823 %files libGL-static
824 %defattr(644,root,root,755)
825 %{_libdir}/libGL.a
826 %endif
827
828 %files libGLU
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
831 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
832
833 %files libGLU-devel
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_libdir}/libGLU.so
836 %{_includedir}/GL/glu.h
837 %{_includedir}/GL/glu_mangle.h
838 %{_pkgconfigdir}/glu.pc
839
840 %if %{with static_libs}
841 %files libGLU-static
842 %defattr(644,root,root,755)
843 %{_libdir}/libGLU.a
844 %endif
845
846 %if %{with osmesa}
847 %files libOSMesa
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
850 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
851
852 %files libOSMesa-devel
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/libOSMesa*.so
855 %{_includedir}/GL/osmesa.h
856
857 %if %{with static_libs}
858 %files libOSMesa-static
859 %defattr(644,root,root,755)
860 %{_libdir}/libOSMesa*.a
861 %endif
862 %endif
863
864 %if %{with gallium}
865 %files libOpenVG
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
868 %attr(755,root,root) %{_libdir}/libOpenVG.so.1.0.0
869
870 %files libOpenVG-devel
871 %defattr(644,root,root,755)
872 %{_includedir}/VG
873 %{_libdir}/libOpenVG.so
874 %{_pkgconfigdir}/vg.pc
875 %endif
876
877 %files dri-driver-ati-radeon-R100
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
880
881 %files dri-driver-ati-radeon-R200
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
884
885 %files dri-driver-ati-radeon-R300
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
888
889 %files dri-driver-ati-radeon-R600
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
892
893 # sunffb (sparc only)
894 %ifarch sparc sparcv9 sparc64
895 %files dri-driver-ffb
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
898 %endif
899
900 # glint (requires update)
901 %if 0
902 %files dri-driver-glint
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
905 %endif
906
907 %files dri-driver-intel-i915
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
910
911 %files dri-driver-intel-i965
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
914 %if %{with gallium_intel}
915 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
916 %endif
917
918 %if %{with gallium}
919 %if %{with gallium_nouveau}
920 %files dri-driver-nouveau
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
923 %endif
924 %endif
925
926 %files dri-driver-swrast
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
929
930 %if %{with gallium}
931 %files dri-driver-vmwgfx
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
934 %endif
935
936 %files -n libvdpau-driver-mesa
937 %defattr(644,root,root,755)
938 # there is no ldconfig here
939 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
940 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
941 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
942 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
943 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
944 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
945 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
946 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
947 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
This page took 0.178732 seconds and 4 git commands to generate.