]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- fixed libEGL* description and license information
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_with     gallium_radeon  # gallium radeon driver
11 %bcond_without  gallium_nouveau # gallium nouveau driver
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static  # static libraries
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.23
25 %define         dri2proto_ver   2.1
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.10.1
32 Release:        1%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  efe8da4d80c2a5d32a800770b8ce5dfa
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-selinux.patch
39 Patch2:         %{name}-git.patch
40 Patch3:         %{name}-nouveau-updates.patch
41 Patch4:         %{name}-nouveau-revert.patch
42 Patch5:         %{name}-nouveau-classic-libdrm.patch
43 URL:            http://www.mesa3d.org/
44 BuildRequires:  autoconf >= 2.59
45 BuildRequires:  automake
46 BuildRequires:  expat-devel
47 BuildRequires:  libdrm-devel >= %{libdrm_ver}
48 BuildRequires:  libselinux-devel
49 BuildRequires:  libstdc++-devel >= 5:3.3.0
50 BuildRequires:  libtalloc-devel >= 2:2.0.1
51 BuildRequires:  libtool >= 2:1.4d
52 %{?with_motif:BuildRequires:    motif-devel}
53 BuildRequires:  pixman-devel
54 BuildRequires:  pkgconfig
55 BuildRequires:  python
56 BuildRequires:  python-modules
57 BuildRequires:  rpmbuild(macros) >= 1.470
58 BuildRequires:  sed >= 4.0
59 BuildRequires:  xorg-lib-libXdamage-devel
60 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
61 BuildRequires:  xorg-lib-libXt-devel
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
64 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
65 BuildRequires:  xorg-util-makedepend
66 BuildRequires:  xorg-xserver-server-devel
67 %if %{with egl}
68 BuildRequires:  libxcb-devel
69 BuildRequires:  udev-devel >= 150
70 %endif
71 %if %{with gallium}
72 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
73 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
74 %endif
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %if %{without gallium}
78 %undefine       with_gallium_intel
79 %undefine       with_gallium_radeon
80 %endif
81
82 %description
83 Mesa is a 3-D graphics library with an API which is very similar to
84 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
85 syntax or state machine, it is being used with authorization from
86 Silicon Graphics, Inc. However, the author does not possess an OpenGL
87 license from SGI, and makes no claim that Mesa is in any way a
88 compatible replacement for OpenGL or associated with SGI.
89
90 %description -l pl.UTF-8
91 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
92 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
93 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
94 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
95 OpenGL ani powiązana z SGI.
96
97 %package libEGL
98 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
99 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
100 License:        MIT
101 Group:          Libraries
102 Requires:       OpenGL >= 1.2
103 Requires:       udev-libs >= 150
104 Provides:       EGL = 1.4
105
106 %description libEGL
107 This package contains shared libEGL - Mesa implementation of EGL
108 Native Platform Graphics Interface as specified by Khronos Group:
109 <http://www.khronos.org/egl/>.
110
111 %description libEGL -l pl.UTF-8
112 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
113 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
114 graficznego platformy natywnej) wg specyfikacji Khronos Group:
115 <http://www.khronos.org/egl/>.
116
117 %package libEGL-devel
118 Summary:        Header files for Mesa implementation of EGL library
119 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
120 License:        MIT
121 Group:          Development/Libraries
122 Requires:       %{name}-libEGL = %{version}-%{release}
123 Requires:       OpenGL-devel >= 1.2
124 Requires:       libstdc++-devel
125 Provides:       EGL-devel = 1.4
126
127 %description libEGL-devel
128 Header files for Mesa implementation of EGL library.
129
130 %description libEGL-devel -l pl.UTF-8
131 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
132
133 %package libEGL-static
134 Summary:        Static Mesa libEGL library
135 Summary(pl.UTF-8):      Statyczna biblioteka Mesa libEGL
136 License:        MIT
137 Group:          Development/Libraries
138 Requires:       %{name}-libEGL-devel = %{version}-%{release}
139 Provides:       EGL-static = 1.4
140
141 %description libEGL-static
142 Static Mesa libEGL library.
143
144 %description libEGL-static -l pl.UTF-8
145 Statyczna biblioteka Mesa libEGL.
146
147 %package libGL
148 Summary:        Free Mesa3D implementation of libGL OpenGL library
149 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
150 License:        MIT
151 Group:          X11/Libraries
152 Requires:       libdrm >= %{libdrm_ver}
153 Provides:       OpenGL = 2.1
154 # reports version 1.3, but supports glXGetProcAddress() from 1.4
155 Provides:       OpenGL-GLX = 1.4
156 Obsoletes:      Mesa
157 Obsoletes:      Mesa-dri
158 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
159 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
160
161 %description libGL
162 Mesa is a 3-D graphics library with an API which is very similar to
163 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
164 syntax or state machine, it is being used with authorization from
165 Silicon Graphics, Inc. However, the author does not possess an OpenGL
166 license from SGI, and makes no claim that Mesa is in any way a
167 compatible replacement for OpenGL or associated with SGI.
168
169 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
170 specifications. It uses DRI for rendering.
171
172 %description libGL -l pl.UTF-8
173 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
174 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
175 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
176 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
177 OpenGL ani powiązana z SGI.
178
179 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
180 GLX 1.4. Używa DRI do renderowania.
181
182 %package libGL-devel
183 Summary:        Header files for Mesa3D libGL library
184 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
185 License:        MIT
186 Group:          X11/Development/Libraries
187 # loose dependency on libGL to use with other libGL binaries
188 Requires:       OpenGL >= 1.5
189 Requires:       libdrm-devel >= %{libdrm_ver}
190 Requires:       xorg-lib-libX11-devel
191 Requires:       xorg-lib-libXdamage-devel
192 Requires:       xorg-lib-libXext-devel
193 Requires:       xorg-lib-libXxf86vm-devel
194 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
195 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
196 Suggests:       OpenGL-doc-man
197 Provides:       OpenGL-GLX-devel = 1.4
198 Provides:       OpenGL-devel = 2.1
199 Obsoletes:      Mesa-devel
200 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
201 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
202 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
203 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
204
205 %description libGL-devel
206 Header files for Mesa3D libGL library.
207
208 %description libGL-devel -l pl.UTF-8
209 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
210
211 %package libGL-static
212 Summary:        Static Mesa3D libGL library
213 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
214 License:        MIT
215 Group:          X11/Development/Libraries
216 Requires:       %{name}-libGL-devel = %{version}-%{release}
217 Provides:       OpenGL-static = 2.1
218 Obsoletes:      Mesa-static
219 Obsoletes:      X11-OpenGL-static < 1:7.0.0
220 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
221
222 %description libGL-static
223 Static Mesa3D libGL library. It uses software renderer.
224
225 %description libGL-static -l pl.UTF-8
226 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
227 renderingu.
228
229 %package libGLU
230 Summary:        SGI implementation of libGLU OpenGL library
231 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
232 License:        SGI Free Software License B v2.0 (MIT-like)
233 Group:          Libraries
234 # loose dependency on libGL.so.1 to use with other libGL binaries
235 Requires:       OpenGL >= 1.2
236 Provides:       OpenGL-GLU = 1.3
237 Obsoletes:      Mesa-devel
238 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
239 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
240
241 %description libGLU
242 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
243 1.3 specifications.
244
245 %description libGLU -l pl.UTF-8
246 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
247 specyfikację OpenGL GLU 1.3.
248
249 %package libGLU-devel
250 Summary:        Header files for SGI libGLU library
251 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
252 License:        SGI Free Software License B v2.0 (MIT-like)
253 Group:          Development/Libraries
254 Requires:       %{name}-libGLU = %{version}-%{release}
255 Requires:       OpenGL-devel >= 1.2
256 Requires:       libstdc++-devel
257 Provides:       OpenGL-GLU-devel = 1.3
258
259 %description libGLU-devel
260 Header files for SGI libGLU library.
261
262 %description libGLU-devel -l pl.UTF-8
263 Pliki nagłówkowe biblioteki SGI libGLU.
264
265 %package libGLU-static
266 Summary:        Static SGI libGLU library
267 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
268 License:        SGI Free Software License B v2.0 (MIT-like)
269 Group:          Development/Libraries
270 Requires:       %{name}-libGLU-devel = %{version}-%{release}
271 Provides:       OpenGL-GLU-static = 1.3
272
273 %description libGLU-static
274 Static SGI libGLU library.
275
276 %description libGLU-static -l pl.UTF-8
277 Statyczna biblioteka SGI libGLU.
278
279 %package libGLw
280 Summary:        SGI OpenGL Xt widgets library
281 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
282 License:        SGI MIT-like
283 Group:          Libraries
284 # loose dependency on libGL.so.1 to use with other libGL binaries
285 Requires:       OpenGL >= 1.1
286 Provides:       OpenGL-GLw
287
288 %description libGLw
289 SGI OpenGL Xt widgets library.
290
291 %description libGLw -l pl.UTF-8
292 Biblioteka SGI widgetów Xt dla OpenGL-a.
293
294 %package libGLw-devel
295 Summary:        Header files for SGI libGLw library
296 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
297 License:        SGI MIT-like
298 Group:          Development/Libraries
299 Requires:       %{name}-libGLw = %{version}-%{release}
300 Requires:       OpenGL-devel >= 1.2
301 Provides:       OpenGL-GLw-devel
302
303 %description libGLw-devel
304 Header files for SGI libGLw library.
305
306 %description libGLw-devel -l pl.UTF-8
307 Pliki nagłówkowe biblioteki SGI libGLw.
308
309 %package libGLw-static
310 Summary:        Static SGI libGLw library
311 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
312 License:        SGI MIT-like
313 Group:          Development/Libraries
314 Requires:       %{name}-libGLw-devel = %{version}-%{release}
315 Provides:       OpenGL-GLw-static
316
317 %description libGLw-static
318 Static SGI libGLw library.
319
320 %description libGLw-static -l pl.UTF-8
321 Statyczna biblioteka SGI libGLw.
322
323 %package libOSMesa
324 Summary:        OSMesa (off-screen renderer) library
325 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
326 License:        MIT
327 Group:          Libraries
328 # doesn't require base
329
330 %description libOSMesa
331 OSMesa (off-screen renderer) library.
332
333 %description libOSMesa -l pl.UTF-8
334 Biblioteka OSMesa (renderująca bitmapy w pamięci).
335
336 %package libOSMesa-devel
337 Summary:        Header file for OSMesa (off-screen renderer) library
338 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
339 License:        MIT
340 Group:          Development/Libraries
341 Requires:       %{name}-libOSMesa = %{version}-%{release}
342 # for <GL/gl.h> only
343 Requires:       OpenGL-devel
344
345 %description libOSMesa-devel
346 Header file for OSMesa (off-screen renderer) library.
347
348 %description libOSMesa-devel -l pl.UTF-8
349 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
350
351 %package libOSMesa-static
352 Summary:        Static OSMesa (off-screen renderer) library
353 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
354 License:        MIT
355 Group:          Development/Libraries
356 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
357 # this static build of OSMesa needs static non-dri Mesa implementation
358 Requires:       %{name}-libGL-static = %{version}-%{release}
359
360 %description libOSMesa-static
361 Static OSMesa (off-screen renderer) library.
362
363 %description libOSMesa-static -l pl.UTF-8
364 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
365
366 %package utils
367 Summary:        OpenGL utilities from Mesa3D
368 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
369 License:        MIT
370 Group:          X11/Applications/Graphics
371 # loose deps on libGL/libGLU
372
373 %description utils
374 OpenGL utilities from Mesa3D: glxgears and glxinfo.
375
376 %description utils -l pl.UTF-8
377 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
378
379 %package dri-driver-ati-mach64
380 Summary:        X.org DRI driver for ATI Mach64 card family
381 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
382 License:        MIT
383 Group:          X11/Libraries
384 Requires:       xorg-driver-video-mach64
385 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
386 Requires:       xorg-xserver-server >= %{xserver_ver}
387
388 %description dri-driver-ati-mach64
389 X.org DRI driver for ATI Mach64 card family.
390
391 %description dri-driver-ati-mach64 -l pl.UTF-8
392 Sterownik X.org DRI dla rodziny kart ATI Mach64.
393
394 %package dri-driver-ati-radeon-R100
395 Summary:        X.org DRI driver for ATI R100 card family
396 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
397 License:        MIT
398 Group:          X11/Libraries
399 Requires:       xorg-driver-video-ati
400 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
401 Requires:       xorg-xserver-server >= %{xserver_ver}
402 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
403
404 %description dri-driver-ati-radeon-R100
405 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
406
407 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
408 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
409
410 %package dri-driver-ati-radeon-R200
411 Summary:        X.org DRI driver for ATI R200 card family
412 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
413 License:        MIT
414 Group:          X11/Libraries
415 Requires:       xorg-driver-video-ati
416 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
417 Requires:       xorg-xserver-server >= %{xserver_ver}
418 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
419
420 %description dri-driver-ati-radeon-R200
421 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
422
423 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
424 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
425
426 %package dri-driver-ati-radeon-R300
427 Summary:        X.org DRI driver for ATI R300 card family
428 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
429 License:        MIT
430 Group:          X11/Libraries
431 Requires:       xorg-driver-video-ati
432 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
433 Requires:       xorg-xserver-server >= %{xserver_ver}
434 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
435
436 %description dri-driver-ati-radeon-R300
437 X.org DRI driver for ATI R300 card family.
438
439 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
440 Sterownik X.org DRI dla rodziny kart ATI R300.
441
442 %package dri-driver-ati-radeon-R600
443 Summary:        X.org DRI driver for ATI R600 card family
444 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
445 License:        MIT
446 Group:          X11/Libraries
447 Requires:       radeon-ucode
448 Requires:       xorg-driver-video-ati
449 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
450 Requires:       xorg-xserver-server >= %{xserver_ver}
451
452 %description dri-driver-ati-radeon-R600
453 X.org DRI driver for ATI R600 card family.
454
455 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
456 Sterownik X.org DRI dla rodziny kart ATI R600.
457
458 %package dri-driver-ati-rage128
459 Summary:        X.org DRI driver for ATI Rage128 card family
460 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
461 License:        MIT
462 Group:          X11/Libraries
463 Requires:       xorg-driver-video-r128
464 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
465 Requires:       xorg-xserver-server >= %{xserver_ver}
466 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
467
468 %description dri-driver-ati-rage128
469 X.org DRI driver for ATI Rage128 card family.
470
471 %description dri-driver-ati-rage128 -l pl.UTF-8
472 Sterownik X.org DRI dla rodziny kart ATI Rage128.
473
474 %package dri-driver-ffb
475 Summary:        X.org DRI driver for Sun FFB card family
476 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
477 License:        MIT
478 Group:          X11/Libraries
479 Requires:       xorg-driver-video-sunffb
480 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
481 Requires:       xorg-xserver-server >= %{xserver_ver}
482
483 %description dri-driver-ffb
484 X.org DRI driver for SUN Creator3D and Elite3D card family.
485
486 %description dri-driver-ffb -l pl.UTF-8
487 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
488
489 %package dri-driver-glint
490 Summary:        X.org DRI driver for GLINT/Permedia card family
491 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
492 License:        MIT
493 Group:          X11/Libraries
494 Requires:       xorg-driver-video-glint
495 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
496 Requires:       xorg-xserver-server >= %{xserver_ver}
497 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
498
499 %description dri-driver-glint
500 X.org DRI driver for GLINT/Permedia card family.
501
502 %description dri-driver-glint -l pl.UTF-8
503 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
504
505 %package dri-driver-intel-i810
506 Summary:        X.org DRI driver for Intel i810 card family
507 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
508 License:        MIT
509 Group:          X11/Libraries
510 Requires:       xorg-driver-video-intel
511 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
512 Requires:       xorg-xserver-server >= %{xserver_ver}
513 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
514
515 %description dri-driver-intel-i810
516 X.org DRI driver for Intel i810 card family.
517
518 %description dri-driver-intel-i810 -l pl.UTF-8
519 Sterownik X.org DRI dla rodziny kart Intel i810.
520
521 %package dri-driver-intel-i915
522 Summary:        X.org DRI driver for Intel i915 card family
523 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
524 License:        MIT
525 Group:          X11/Libraries
526 Requires:       xorg-driver-video-intel
527 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
528 Requires:       xorg-xserver-server >= %{xserver_ver}
529 Obsoletes:      Mesa-dri-driver-intel-i830
530 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
531
532 %description dri-driver-intel-i915
533 X.org DRI driver for Intel i915 card family.
534
535 %description dri-driver-intel-i915 -l pl.UTF-8
536 Sterownik X.org DRI dla rodziny kart Intel i915.
537
538 %package dri-driver-intel-i965
539 Summary:        X.org DRI driver for Intel i965 card family
540 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
541 License:        MIT
542 Group:          X11/Libraries
543 Requires:       xorg-driver-video-intel
544 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
545 Requires:       xorg-xserver-server >= %{xserver_ver}
546 Obsoletes:      Mesa-dri-driver-intel-i830
547 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
548
549 %description dri-driver-intel-i965
550 X.org DRI driver for Intel i965 card family.
551
552 %description dri-driver-intel-i965 -l pl.UTF-8
553 Sterownik X.org DRI dla rodziny kart Intel i965.
554
555 %package dri-driver-matrox
556 Summary:        X.org DRI driver for Matrox G card family
557 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
558 License:        MIT
559 Group:          X11/Libraries
560 Requires:       xorg-driver-video-mga
561 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
562 Requires:       xorg-xserver-server >= %{xserver_ver}
563 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
564
565 %description dri-driver-matrox
566 X.org DRI drivers for Matrox G card family.
567
568 %description dri-driver-matrox -l pl.UTF-8
569 Sterowniki X.org DRI dla rodziny kart Matrox G.
570
571 %package dri-driver-nouveau
572 Summary:        X.org DRI driver for NVIDIA card family
573 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
574 License:        MIT
575 Group:          X11/Libraries
576 Requires:       xorg-driver-video-nouveau
577 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
578 Requires:       xorg-xserver-server >= %{xserver_ver}
579
580 %description dri-driver-nouveau
581 X.org DRI drivers for NVIDIA card family.
582
583 %description dri-driver-nouveau -l pl.UTF-8
584 Sterowniki X.org DRI dla rodziny kart NVIDIA.
585
586 %package dri-driver-savage
587 Summary:        X.org DRI driver for S3 Savage card family
588 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
589 License:        MIT
590 Group:          X11/Libraries
591 Requires:       xorg-driver-video-savage
592 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
593 Requires:       xorg-xserver-server >= %{xserver_ver}
594
595 %description dri-driver-savage
596 X.org DRI driver for S3 Savage card family.
597
598 %description dri-driver-savage -l pl.UTF-8
599 Sterownik X.org DRI dla rodziny kart S3 Savage.
600
601 %package dri-driver-sis
602 Summary:        X.org DRI driver for SiS card family
603 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
604 License:        MIT
605 Group:          X11/Libraries
606 Requires:       xorg-driver-video-sis
607 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
608 Requires:       xorg-xserver-server >= %{xserver_ver}
609 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
610
611 %description dri-driver-sis
612 X.org DRI driver for SiS card family.
613
614 %description dri-driver-sis -l pl.UTF-8
615 Sterownik X.org DRI dla rodziny kart SiS.
616
617 %package dri-driver-swrast
618 Summary:        X.org DRI software rasterizer driver
619 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
620 License:        MIT
621 Group:          X11/Libraries
622 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
623 Requires:       xorg-xserver-server >= %{xserver_ver}
624
625 %description dri-driver-swrast
626 X.org DRI software rasterizer driver.
627
628 %description dri-driver-swrast -l pl.UTF-8
629 Sterownik X.org DRI obsługujący rysowanie programowe.
630
631 %package dri-driver-tdfx
632 Summary:        X.org DRI driver for 3DFX Voodoo card family
633 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
634 License:        MIT
635 Group:          X11/Libraries
636 Requires:       Glide3-DRI
637 Requires:       xorg-driver-video-tdfx
638 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
639 Requires:       xorg-xserver-server >= %{xserver_ver}
640 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
641
642 %description dri-driver-tdfx
643 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
644 and Velocity 100/200).
645
646 %description dri-driver-tdfx -l pl.UTF-8
647 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
648 Banshee i Velocity 100/200).
649
650 %package dri-driver-via-unichrome
651 Summary:        X.org DRI driver for VIA Unichrome card family
652 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
653 License:        MIT
654 Group:          X11/Libraries
655 Requires:       xorg-driver-video-openchrome
656 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
657 Requires:       xorg-xserver-server >= %{xserver_ver}
658
659 %description dri-driver-via-unichrome
660 X.org DRI driver for VIA Unichrome card family.
661
662 %description dri-driver-via-unichrome -l pl.UTF-8
663 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
664
665 %package dri-driver-vmwgfx
666 Summary:        X.org DRI driver for VMware
667 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
668 License:        MIT
669 Group:          X11/Libraries
670 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
671 Requires:       xorg-xserver-server >= %{xserver_ver}
672
673 %description dri-driver-vmwgfx
674 X.org DRI driver for VMWare.
675
676 %description dri-driver-vmwgfx -l pl.UTF-8
677 Sterownik X.org DRI dla VMware.
678
679 %prep
680 %setup -q
681 %patch0 -p0
682 %patch1 -p1
683 #patch2 -p1
684 %patch3 -p1
685 %patch4 -p1
686 %patch5 -p1
687
688 %build
689 %{__aclocal}
690 %{__autoconf}
691
692 dri_drivers="i810 i965 mach64 mga r128 \
693 %if %{without gallium_radeon}
694 r200 r300 r600 radeon \
695 %endif
696 savage \
697 %if %{without gallium_intel}
698 i915 \
699 %endif
700 %ifarch sparc sparcv9 sparc64
701 ffb \
702 %endif
703 %ifarch %{ix86} %{x8664}
704 sis \
705 %endif
706 swrast tdfx unichrome"
707
708 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
709
710 common_flags="\
711         --enable-shared \
712         --enable-selinux \
713         --enable-pic \
714         --enable-glx-tls \
715         --disable-glut \
716         --disable-os-mesa \
717         --%{?with_egl:en}%{!?with_egl:dis}able-egl"
718
719 osmesa_common_flags="\
720         --with-driver=osmesa \
721         --disable-asm \
722         --disable-glu"
723
724 %if %{with osmesa}
725 # osmesa variants
726 %configure $common_flags $osmesa_common_flags \
727         --with-osmesa-bits=8
728 %{__make}
729 mv %{_lib} osmesa8
730 %{__make} clean
731
732 %configure $common_flags $osmesa_common_flags \
733         --with-osmesa-bits=16
734 %{__make}
735 mv %{_lib} osmesa16
736 %{__make} clean
737
738 %configure $common_flags $osmesa_common_flags \
739         --with-osmesa-bits=32
740 %{__make}
741 mv %{_lib} osmesa32
742 %{__make} clean
743 %endif
744
745 %configure $common_flags \
746 %if %{with gallium}
747         --enable-gallium \
748         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
749         --%{?with_gallium_radeon:en}%{!?with_gallium_radeon:dis}able-gallium-radeon \
750         --enable-gallium-svga \
751         %{?with_gallium_nouveau:--enable-gallium-nouveau} \
752         --with-state-trackers=dri,glx \
753 %else
754         --disable-gallium \
755 %endif
756         --with-driver=dri \
757         --with-dri-drivers=${dri_drivers} \
758         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
759
760 %{__make}
761
762 %install
763 rm -rf $RPM_BUILD_ROOT
764
765 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
766
767 # libs without drivers
768 %{__make} install \
769         DESTDIR=$RPM_BUILD_ROOT
770
771 %if %{with osmesa}
772 install osmesa*/*OSMesa* $RPM_BUILD_ROOT%{_libdir}
773 %endif
774
775 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
776
777 # strip out undesirable headers
778 olddir=$(pwd)
779 cd $RPM_BUILD_ROOT%{_includedir}/GL
780 rm [a-fh-np-wyz]*.h glf*.h
781 cd $RPM_BUILD_ROOT%{_libdir}
782 cd $olddir
783
784 %if %{with multigl}
785 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
786
787 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
788 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
789
790 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
791 %endif
792
793 %clean
794 rm -rf $RPM_BUILD_ROOT
795
796 %post   libEGL -p /sbin/ldconfig
797 %postun libEGL -p /sbin/ldconfig
798
799 %post   libGL -p /sbin/ldconfig
800 %postun libGL -p /sbin/ldconfig
801
802 %post   libGLU -p /sbin/ldconfig
803 %postun libGLU -p /sbin/ldconfig
804
805 %post   libGLw -p /sbin/ldconfig
806 %postun libGLw -p /sbin/ldconfig
807
808 %if %{with egl}
809 %files libEGL
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
812 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
813 %dir %{_libdir}/egl
814 %attr(755,root,root) %{_libdir}/egl/egl_dri2.so
815 %attr(755,root,root) %{_libdir}/egl/egl_glx.so
816
817 %files libEGL-devel
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libEGL.so
820 %dir %{_includedir}/EGL
821 %{_includedir}/EGL/egl.h
822 %{_includedir}/EGL/eglext.h
823 %{_includedir}/EGL/eglplatform.h
824 %dir %{_includedir}/KHR
825 %{_includedir}/KHR/khrplatform.h
826 %{_pkgconfigdir}/egl.pc
827
828 %if %{with static}
829 %files libEGL-static
830 %defattr(644,root,root,755)
831 %{_libdir}/libEGL.a
832 %endif
833 %endif
834
835 %files libGL
836 %defattr(644,root,root,755)
837 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
838 %if %{with multigl}
839 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
840 %dir %{_libdir}/Mesa
841 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
842 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
843 %else
844 %attr(755,root,root) %{_libdir}/libGL.so.*.*
845 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
846 # symlink for binary apps which fail to conform Linux OpenGL ABI
847 # (and dlopen libGL.so instead of libGL.so.1)
848 %attr(755,root,root) %{_libdir}/libGL.so
849 %endif
850
851 %files libGL-devel
852 %defattr(644,root,root,755)
853 %doc docs/*.spec
854 %if %{with multigl}
855 %attr(755,root,root) %{_libdir}/libGL.so
856 %endif
857 %dir %{_includedir}/GL
858 %{_includedir}/GL/gl.h
859 %{_includedir}/GL/glext.h
860 %{_includedir}/GL/gl_mangle.h
861 %{_includedir}/GL/glx.h
862 %{_includedir}/GL/glxext.h
863 %{_includedir}/GL/glx_mangle.h
864 %dir %{_includedir}/GL/internal
865 %{_includedir}/GL/internal/dri_interface.h
866 %{_pkgconfigdir}/dri.pc
867 %{_pkgconfigdir}/gl.pc
868
869 %if %{with static}
870 %files libGL-static
871 %defattr(644,root,root,755)
872 %{_libdir}/libGL.a
873 %endif
874
875 %files libGLU
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
878 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
879
880 %files libGLU-devel
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/libGLU.so
883 %{_includedir}/GL/glu.h
884 %{_includedir}/GL/glu_mangle.h
885 %{_pkgconfigdir}/glu.pc
886
887 %if %{with static}
888 %files libGLU-static
889 %defattr(644,root,root,755)
890 %{_libdir}/libGLU.a
891 %endif
892
893 %files libGLw
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
896 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
897
898 %files libGLw-devel
899 %defattr(644,root,root,755)
900 %attr(755,root,root) %{_libdir}/libGLw.so
901 %{_includedir}/GL/GLwDrawA.h
902 %{_includedir}/GL/GLwDrawAP.h
903 %{_includedir}/GL/GLwMDrawA.h
904 %{_includedir}/GL/GLwMDrawAP.h
905 %{_pkgconfigdir}/glw.pc
906
907 %if %{with static}
908 %files libGLw-static
909 %defattr(644,root,root,755)
910 %{_libdir}/libGLw.a
911 %endif
912
913 %if %{with osmesa}
914 %files libOSMesa
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
917 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.7
918
919 %files libOSMesa-devel
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/libOSMesa*.so
922 %{_includedir}/GL/osmesa.h
923
924 %if %{with static}
925 %files libOSMesa-static
926 %defattr(644,root,root,755)
927 %{_libdir}/libOSMesa*.a
928 %endif
929 %endif
930
931 %files dri-driver-ati-mach64
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
934
935 %files dri-driver-ati-radeon-R100
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
938
939 %files dri-driver-ati-radeon-R200
940 %defattr(644,root,root,755)
941 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
942
943 %files dri-driver-ati-radeon-R300
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
946
947 %files dri-driver-ati-radeon-R600
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
950
951 %files dri-driver-ati-rage128
952 %defattr(644,root,root,755)
953 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
954
955 # sunffb (sparc only)
956 %ifarch sparc sparcv9 sparc64
957 %files dri-driver-ffb
958 %defattr(644,root,root,755)
959 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
960 %endif
961
962 # glint (requires update)
963 %if 0
964 %files dri-driver-glint
965 %defattr(644,root,root,755)
966 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
967 %endif
968
969 %files dri-driver-intel-i810
970 %defattr(644,root,root,755)
971 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
972
973 %files dri-driver-intel-i915
974 %defattr(644,root,root,755)
975 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
976
977 %files dri-driver-intel-i965
978 %defattr(644,root,root,755)
979 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
980
981 %files dri-driver-matrox
982 %defattr(644,root,root,755)
983 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
984
985 %if %{with gallium}
986 %if %{with gallium_nouveau}
987 %files dri-driver-nouveau
988 %defattr(644,root,root,755)
989 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
990 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
991 %endif
992 %endif
993
994 %files dri-driver-savage
995 %defattr(644,root,root,755)
996 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
997
998 %ifarch %{ix86} %{x8664}
999 %files dri-driver-sis
1000 %defattr(644,root,root,755)
1001 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
1002 %endif
1003
1004 %files dri-driver-swrast
1005 %defattr(644,root,root,755)
1006 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
1007 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrastg_dri.so
1008
1009 %files dri-driver-tdfx
1010 %defattr(644,root,root,755)
1011 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
1012
1013 %files dri-driver-via-unichrome
1014 %defattr(644,root,root,755)
1015 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
1016
1017 %if %{with gallium}
1018 %files dri-driver-vmwgfx
1019 %defattr(644,root,root,755)
1020 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
1021 %endif
This page took 0.089536 seconds and 4 git commands to generate.