]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- ffb and glint drivers are finally gone as well
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - consider:
4 #   --enable-shared-dricore
5 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
6 # - resurrect static if it's useful
7 #
8 # Conditional build:
9 %bcond_without  egl             # EGL libraries
10 %bcond_without  gallium         # gallium drivers
11 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  gallium_nouveau # gallium nouveau driver
13 %bcond_without  osmesa          # OSMesa libraries
14 %bcond_without  gbm             # with Graphics Buffer Manager
15 %bcond_with     static_libs     # static libraries
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.30
25 %define         dri2proto_ver   2.6
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        8.0.1
32 Release:        1
33 License:        MIT (core), SGI (GLU) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  24eeebf66971809d8f40775a379b36c9
37 Patch0:         %{name}-realclean.patch
38 URL:            http://www.mesa3d.org/
39 BuildRequires:  autoconf >= 2.59
40 BuildRequires:  automake
41 BuildRequires:  expat-devel
42 BuildRequires:  gcc >= 5:3.3
43 BuildRequires:  libdrm-devel >= %{libdrm_ver}
44 BuildRequires:  libselinux-devel
45 BuildRequires:  libstdc++-devel >= 5:3.3.0
46 BuildRequires:  libtalloc-devel >= 2:2.0.1
47 BuildRequires:  libtool >= 2:1.4d
48 BuildRequires:  libvdpau-devel
49 BuildRequires:  llvm-devel >= 2.9
50 BuildRequires:  pixman-devel
51 BuildRequires:  pkgconfig
52 BuildRequires:  pkgconfig(talloc) >= 2.0.1
53 BuildRequires:  python
54 BuildRequires:  python-libxml2
55 BuildRequires:  python-modules
56 BuildRequires:  rpmbuild(macros) >= 1.470
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  xorg-lib-libXdamage-devel
59 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
60 BuildRequires:  xorg-lib-libXt-devel
61 BuildRequires:  xorg-lib-libXvMC-devel
62 BuildRequires:  xorg-lib-libXxf86vm-devel
63 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
64 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
65 BuildRequires:  xorg-util-makedepend
66 BuildRequires:  xorg-xserver-server-devel
67 %if %{with egl}
68 BuildRequires:  libxcb-devel
69 BuildRequires:  udev-devel >= 150
70 %endif
71 %if %{with gallium}
72 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
73 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
74 %endif
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %if %{without gallium}
78 %undefine       with_gallium_intel
79 %endif
80
81 %if %{without egl}
82 %undefine       with_gbm
83 %endif
84
85 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
86 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.* libvdpau_nouveau.so.1.*
87
88 %description
89 Mesa is a 3-D graphics library with an API which is very similar to
90 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
91 syntax or state machine, it is being used with authorization from
92 Silicon Graphics, Inc. However, the author does not possess an OpenGL
93 license from SGI, and makes no claim that Mesa is in any way a
94 compatible replacement for OpenGL or associated with SGI.
95
96 %description -l pl.UTF-8
97 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
98 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
99 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
100 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
101 OpenGL ani powiązana z SGI.
102
103 %package libEGL
104 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
105 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
106 License:        MIT
107 Group:          Libraries
108 # glx driver in libEGL dlopens libGL.so
109 Requires:       OpenGL >= 1.2
110 Requires:       libdrm >= %{libdrm_ver}
111 %if %{with gallium}
112 # for egl_gallium.so
113 Requires:       Mesa-libOpenVG = %{version}-%{release}
114 Requires:       udev-libs >= 150
115 %endif
116 Provides:       EGL = 1.4
117
118 %description libEGL
119 This package contains shared libEGL - Mesa implementation of EGL
120 Native Platform Graphics Interface as specified by Khronos Group:
121 <http://www.khronos.org/egl/>.
122
123 %description libEGL -l pl.UTF-8
124 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
125 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
126 graficznego platformy natywnej) wg specyfikacji Khronos Group:
127 <http://www.khronos.org/egl/>.
128
129 %package libEGL-devel
130 Summary:        Header files for Mesa implementation of EGL library
131 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
132 License:        MIT
133 Group:          Development/Libraries
134 Requires:       %{name}-libEGL = %{version}-%{release}
135 Requires:       libdrm-devel >= %{libdrm_ver}
136 Requires:       xorg-lib-libX11-devel
137 Requires:       xorg-lib-libXdamage-devel
138 Requires:       xorg-lib-libXext-devel
139 Requires:       xorg-lib-libXfixes-devel
140 Requires:       xorg-lib-libXxf86vm-devel
141 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
142 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
143 Provides:       EGL-devel = 1.4
144
145 %description libEGL-devel
146 Header files for Mesa implementation of EGL library.
147
148 %description libEGL-devel -l pl.UTF-8
149 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
150
151 %package libEGL-static
152 Summary:        Static Mesa EGL library
153 Summary(pl.UTF-8):      Statyczna biblioteka Mesa EGL
154 License:        MIT
155 Group:          Development/Libraries
156 Requires:       %{name}-libEGL-devel = %{version}-%{release}
157 Provides:       EGL-static = 1.4
158
159 %description libEGL-static
160 Static Mesa EGL library.
161
162 %description libEGL-static -l pl.UTF-8
163 Statyczna biblioteka Mesa EGL.
164
165 %package libGL
166 Summary:        Free Mesa3D implementation of libGL OpenGL library
167 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
168 License:        MIT
169 Group:          X11/Libraries
170 Requires:       libdrm >= %{libdrm_ver}
171 Provides:       OpenGL = 2.1
172 Provides:       OpenGL-GLX = 1.4
173 Obsoletes:      Mesa
174 Obsoletes:      Mesa-dri
175 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
176 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
177
178 %description libGL
179 Mesa is a 3-D graphics library with an API which is very similar to
180 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
181 syntax or state machine, it is being used with authorization from
182 Silicon Graphics, Inc. However, the author does not possess an OpenGL
183 license from SGI, and makes no claim that Mesa is in any way a
184 compatible replacement for OpenGL or associated with SGI.
185
186 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
187 specifications. It uses DRI for rendering.
188
189 %description libGL -l pl.UTF-8
190 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
191 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
192 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
193 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
194 OpenGL ani powiązana z SGI.
195
196 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
197 GLX 1.4. Używa DRI do renderowania.
198
199 %package libGL-devel
200 Summary:        Header files for Mesa3D libGL library
201 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
202 License:        MIT
203 Group:          X11/Development/Libraries
204 # loose dependency on libGL to use with other libGL binaries
205 Requires:       OpenGL >= 1.5
206 Requires:       libdrm-devel >= %{libdrm_ver}
207 Requires:       xorg-lib-libX11-devel
208 Requires:       xorg-lib-libXdamage-devel
209 Requires:       xorg-lib-libXext-devel
210 Requires:       xorg-lib-libXxf86vm-devel
211 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
212 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
213 Suggests:       OpenGL-doc-man
214 Provides:       OpenGL-GLX-devel = 1.4
215 Provides:       OpenGL-devel = 2.1
216 Obsoletes:      Mesa-devel
217 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
218 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
219 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
220 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
221
222 %description libGL-devel
223 Header files for Mesa3D libGL library.
224
225 %description libGL-devel -l pl.UTF-8
226 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
227
228 %package libGL-static
229 Summary:        Static Mesa3D libGL library
230 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
231 License:        MIT
232 Group:          X11/Development/Libraries
233 Requires:       %{name}-libGL-devel = %{version}-%{release}
234 Provides:       OpenGL-static = 2.1
235 Obsoletes:      Mesa-static
236 Obsoletes:      X11-OpenGL-static < 1:7.0.0
237 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
238
239 %description libGL-static
240 Static Mesa3D libGL library. It uses software renderer.
241
242 %description libGL-static -l pl.UTF-8
243 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
244 renderingu.
245
246 %package libGLES
247 Summary:        Mesa implementation of GLES (OpenGL ES) libraries
248 Summary(pl.UTF-8):      Implementacja Mesa bibliotek GLES (OpenGL ES)
249 Group:          Libraries
250 # only for libglapi.so.0
251 Requires:       %{name}-libEGL = %{version}-%{release}
252
253 %description libGLES
254 This package contains shared libraries of Mesa implementation of GLES
255 (OpenGL ES) - cross-platform API for full-function 2D and 3D graphics
256 on embedded systems. OpenGL ES specification can be found on Khronos
257 Group site: <http://www.khronos.org/opengles/>. Mesa implements OpenGL
258 ES 1.1 and 2.0.
259
260 %description libGLES -l pl.UTF-8
261 Ten pakiet zawiera biblioteki współdzielone implementacji Mesa
262 standardu GLES (OpenGL ES) - wieloplatformowego API do w pełni
263 funkcjonalnej grafiki 2D i 3D na systemach wbudowanych. Specyfikację
264 OpenGL ES można znaleźć na stronie Khronos Group:
265 <http://www.khronos.org/opengles/>. Mesa zawiera implementacją OpenGL
266 ES 1.1 i 2.0.
267
268 %package libGLES-devel
269 Summary:        Header files for Mesa GLES libraries
270 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Mesa GLES
271 Group:          Development/Libraries
272 # EGL for libglapi.so, <KHR/khrplatform.h> always required, <EGL/egl.h> for <GLES/egl.h>
273 Requires:       %{name}-libEGL-devel = %{version}-%{release}
274 Requires:       %{name}-libGLES = %{version}-%{release}
275
276 %description libGLES-devel
277 Header files for Mesa GLES libraries.
278
279 %description libGLES-devel -l pl.UTF-8
280 Pliki nagłówkowe bibliotek Mesa GLES.
281
282 %package libGLU
283 Summary:        SGI implementation of libGLU OpenGL library
284 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
285 License:        SGI Free Software License B v2.0 (MIT-like)
286 Group:          Libraries
287 # loose dependency on libGL.so.1 to use with other libGL binaries
288 Requires:       OpenGL >= 1.2
289 Provides:       OpenGL-GLU = 1.3
290 Obsoletes:      Mesa-devel
291 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
292 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
293
294 %description libGLU
295 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
296 1.3 specifications.
297
298 %description libGLU -l pl.UTF-8
299 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
300 specyfikację OpenGL GLU 1.3.
301
302 %package libGLU-devel
303 Summary:        Header files for SGI libGLU library
304 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
305 License:        SGI Free Software License B v2.0 (MIT-like)
306 Group:          Development/Libraries
307 Requires:       %{name}-libGLU = %{version}-%{release}
308 Requires:       OpenGL-devel >= 1.2
309 Requires:       libstdc++-devel
310 Provides:       OpenGL-GLU-devel = 1.3
311
312 %description libGLU-devel
313 Header files for SGI libGLU library.
314
315 %description libGLU-devel -l pl.UTF-8
316 Pliki nagłówkowe biblioteki SGI libGLU.
317
318 %package libGLU-static
319 Summary:        Static SGI libGLU library
320 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
321 License:        SGI Free Software License B v2.0 (MIT-like)
322 Group:          Development/Libraries
323 Requires:       %{name}-libGLU-devel = %{version}-%{release}
324 Provides:       OpenGL-GLU-static = 1.3
325
326 %description libGLU-static
327 Static SGI libGLU library.
328
329 %description libGLU-static -l pl.UTF-8
330 Statyczna biblioteka SGI libGLU.
331
332 %package libOSMesa
333 Summary:        OSMesa (off-screen renderer) library
334 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
335 License:        MIT
336 Group:          Libraries
337 # doesn't require base
338
339 %description libOSMesa
340 OSMesa (off-screen renderer) library.
341
342 %description libOSMesa -l pl.UTF-8
343 Biblioteka OSMesa (renderująca bitmapy w pamięci).
344
345 %package libOSMesa-devel
346 Summary:        Header file for OSMesa (off-screen renderer) library
347 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
348 License:        MIT
349 Group:          Development/Libraries
350 Requires:       %{name}-libOSMesa = %{version}-%{release}
351 # for <GL/gl.h> only
352 Requires:       OpenGL-devel
353 Requires:       libselinux-devel
354
355 %description libOSMesa-devel
356 Header file for OSMesa (off-screen renderer) library.
357
358 %description libOSMesa-devel -l pl.UTF-8
359 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
360
361 %package libOSMesa-static
362 Summary:        Static OSMesa (off-screen renderer) library
363 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
364 License:        MIT
365 Group:          Development/Libraries
366 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
367 # this static build of OSMesa needs static non-dri Mesa implementation
368 Requires:       %{name}-libGL-static = %{version}-%{release}
369
370 %description libOSMesa-static
371 Static OSMesa (off-screen renderer) library.
372
373 %description libOSMesa-static -l pl.UTF-8
374 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
375
376 %package libOpenVG
377 Summary:        Mesa implementation of OpenVG (Vector Graphics Accelleration) API
378 Summary(pl.UTF-8):      Implementacja Mesa API OpenVG (akceleracji grafiki wektorowej)
379 License:        MIT
380 Group:          Libraries
381 # doesn't require base
382
383 %description libOpenVG
384 This package contains Mesa implementation of OpenVG - cross-platform
385 API that provides a low-level hardware acceleration interface for
386 vector graphics libraries such as Flash and SVG. OpenVG specification
387 can be found on Khronos Group site: <http://www.khronos.org/openvg/>.
388 Mesa implements OpenVG 1.1.
389
390 %description libOpenVG -l pl.UTF-8
391 Ten pakiet zawiera implementację Mesa standardu OpenVG -
392 wieloplatfomowego API zapewniającego niskopoziomowy interfejs
393 akceleracji sprzętowej dla bibliotek grafiki wektorowej, takiej jak
394 Flash czy SVG. Specyfikację OpenVG można znaleźć na stronie Khronos
395 Group: <http://www.khronos.org/openvg/>. Mesa zawiera implementację
396 OpenVG w wersji 1.1.
397
398 %package libOpenVG-devel
399 Summary:        Header file for Mesa OpenVG library
400 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Mesa OpenVG
401 License:        MIT
402 Group:          Development/Libraries
403 # EGL headers for <KHR/khrplatform.h>
404 Requires:       %{name}-libEGL-devel = %{version}-%{release}
405 Requires:       %{name}-libOpenVG = %{version}-%{release}
406
407 %description libOpenVG-devel
408 Header file for Mesa OpenVG library.
409
410 %description libOpenVG-devel -l pl.UTF-8
411 Plik nagłówkowy biblioteki Mesa OpenVG.
412
413 %package libXvMC
414 Summary:        Mesa implementations of XvMC API
415 Summary(pl.UTF-8):      Implementacje Mesa API XvMC
416 License:        MIT
417 Group:          Libraries
418 # doesn't require base
419
420 %description libXvMC
421 Mesa implementations of XvMC API.
422
423 %description libXvMC -l pl.UTF-8
424 Implementacje Mesa API XvMC.
425
426 %package dri-driver-ati-radeon-R100
427 Summary:        X.org DRI driver for ATI R100 card family
428 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
429 License:        MIT
430 Group:          X11/Libraries
431 Requires:       xorg-driver-video-ati
432 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
433 Requires:       xorg-xserver-server >= %{xserver_ver}
434 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
435
436 %description dri-driver-ati-radeon-R100
437 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
438
439 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
440 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
441
442 %package dri-driver-ati-radeon-R200
443 Summary:        X.org DRI driver for ATI R200 card family
444 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
445 License:        MIT
446 Group:          X11/Libraries
447 Requires:       xorg-driver-video-ati
448 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
449 Requires:       xorg-xserver-server >= %{xserver_ver}
450 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
451
452 %description dri-driver-ati-radeon-R200
453 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
454
455 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
456 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
457
458 %package dri-driver-ati-radeon-R300
459 Summary:        X.org DRI driver for ATI R300 card family
460 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
461 License:        MIT
462 Group:          X11/Libraries
463 Requires:       xorg-driver-video-ati
464 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
465 Requires:       xorg-xserver-server >= %{xserver_ver}
466 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
467
468 %description dri-driver-ati-radeon-R300
469 X.org DRI driver for ATI R300 card family.
470
471 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
472 Sterownik X.org DRI dla rodziny kart ATI R300.
473
474 %package dri-driver-ati-radeon-R600
475 Summary:        X.org DRI driver for ATI R600 card family
476 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
477 License:        MIT
478 Group:          X11/Libraries
479 Requires:       radeon-ucode
480 Requires:       xorg-driver-video-ati
481 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
482 Requires:       xorg-xserver-server >= %{xserver_ver}
483
484 %description dri-driver-ati-radeon-R600
485 X.org DRI driver for ATI R600 card family.
486
487 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
488 Sterownik X.org DRI dla rodziny kart ATI R600.
489
490 %package dri-driver-intel-i915
491 Summary:        X.org DRI driver for Intel i915 card family
492 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
493 License:        MIT
494 Group:          X11/Libraries
495 Requires:       xorg-driver-video-intel
496 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
497 Requires:       xorg-xserver-server >= %{xserver_ver}
498 Obsoletes:      Mesa-dri-driver-intel-i830
499 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
500
501 %description dri-driver-intel-i915
502 X.org DRI driver for Intel i915 card family.
503
504 %description dri-driver-intel-i915 -l pl.UTF-8
505 Sterownik X.org DRI dla rodziny kart Intel i915.
506
507 %package dri-driver-intel-i965
508 Summary:        X.org DRI driver for Intel i965 card family
509 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
510 License:        MIT
511 Group:          X11/Libraries
512 Requires:       xorg-driver-video-intel
513 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
514 Requires:       xorg-xserver-server >= %{xserver_ver}
515 Obsoletes:      Mesa-dri-driver-intel-i830
516 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
517
518 %description dri-driver-intel-i965
519 X.org DRI driver for Intel i965 card family.
520
521 %description dri-driver-intel-i965 -l pl.UTF-8
522 Sterownik X.org DRI dla rodziny kart Intel i965.
523
524 %package dri-driver-nouveau
525 Summary:        X.org DRI driver for NVIDIA card family
526 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
527 License:        MIT
528 Group:          X11/Libraries
529 Requires:       xorg-driver-video-nouveau
530 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
531 Requires:       xorg-xserver-server >= %{xserver_ver}
532
533 %description dri-driver-nouveau
534 X.org DRI drivers for NVIDIA card family.
535
536 %description dri-driver-nouveau -l pl.UTF-8
537 Sterowniki X.org DRI dla rodziny kart NVIDIA.
538
539 %package dri-driver-swrast
540 Summary:        X.org DRI software rasterizer driver
541 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
542 License:        MIT
543 Group:          X11/Libraries
544 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
545 Requires:       xorg-xserver-server >= %{xserver_ver}
546
547 %description dri-driver-swrast
548 X.org DRI software rasterizer driver.
549
550 %description dri-driver-swrast -l pl.UTF-8
551 Sterownik X.org DRI obsługujący rysowanie programowe.
552
553 %package dri-driver-vmwgfx
554 Summary:        X.org DRI driver for VMware
555 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
556 License:        MIT
557 Group:          X11/Libraries
558 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
559 Requires:       xorg-xserver-server >= %{xserver_ver}
560
561 %description dri-driver-vmwgfx
562 X.org DRI driver for VMWare.
563
564 %description dri-driver-vmwgfx -l pl.UTF-8
565 Sterownik X.org DRI dla VMware.
566
567 %package -n libvdpau-driver-mesa
568 Summary:        Mesa drivers for the vdpau API
569 Summary(pl.UTF-8):      Sterowniki Mesa dla API vdpau
570 License:        MIT
571 Group:          X11/Libraries
572
573 %description -n libvdpau-driver-mesa
574 Mesa drivers for the vdpau API.
575
576 %description -n libvdpau-driver-mesa -l pl.UTF-8
577 Sterowniki Mesa dla API vdpau.
578
579 # llvm build broken
580 %define         filterout_ld    -Wl,--as-needed
581
582 %prep
583 %setup -q
584 %patch0 -p0
585
586 %build
587 %{__aclocal}
588 %{__autoconf}
589
590 dri_drivers="r200 radeon \
591 %if %{without gallium_intel}
592 i915 i965 \
593 %endif
594 %ifarch sparc sparcv9 sparc64
595 ffb \
596 %endif
597 swrast"
598
599 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
600
601 gallium_drivers="svga swrast \
602 %if %{with gallium_intel}
603 i915 \
604 i965 \
605 %endif
606 r300 \
607 r600 \
608 %if %{with gallium_nouveau}
609 nouveau \
610 %endif
611 "
612
613 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
614
615 common_flags="\
616         --enable-shared \
617         --enable-glx-tls \
618         --enable-pic \
619         --enable-selinux \
620         %{?with_static_libs:--enable-static} \
621 "
622
623 osmesa_common_flags="\
624         --with-driver=osmesa \
625         --disable-asm \
626         --disable-egl \
627         --disable-glu"
628
629 %if %{with osmesa}
630 %configure $common_flags $osmesa_common_flags \
631         --with-osmesa-bits=8
632 %{__make}
633 %{__make} -C src/mesa osmesa.pc
634 mv %{_lib} osmesa8
635 cp -p src/mesa/osmesa.pc osmesa8
636 %{__make} clean
637 %endif
638
639 %configure $common_flags \
640         --enable-shared-glapi \
641         %{__enable gbm} \
642 %if %{with egl}
643         --enable-egl \
644         --enable-gles1 \
645         --enable-gles2 \
646 %endif
647 %if %{with gallium}
648         --enable-openvg \
649         --enable-gallium-llvm \
650         %{__enable egl gallium-egl} \
651         %{__enable gbm gallium-gbm} \
652         --enable-vdpau \
653         --enable-xvmc \
654         --with-gallium-drivers=${gallium_drivers} \
655 %else
656         --without-gallium-drivers \
657 %endif
658         --with-driver=dri \
659         --with-dri-drivers=${dri_drivers} \
660         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
661
662 %{__make}
663
664 %install
665 rm -rf $RPM_BUILD_ROOT
666
667 # libs without drivers
668 %{__make} install \
669         DESTDIR=$RPM_BUILD_ROOT
670
671 %if %{with osmesa}
672 cp -p osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
673 cp -p osmesa8/osmesa.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
674 %endif
675
676 # strip out undesirable headers
677 %{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{vms_x_fix,wglext,wmesa}.h
678
679 # remove "OS ABI: Linux 2.4.20" tag, so private copies (nvidia or fglrx),
680 # set up via /etc/ld.so.conf.d/*.conf will be preferred over this
681 strip -R .note.ABI-tag $RPM_BUILD_ROOT%{_libdir}/libGL.so.*.*
682
683 %clean
684 rm -rf $RPM_BUILD_ROOT
685
686 %post   libEGL -p /sbin/ldconfig
687 %postun libEGL -p /sbin/ldconfig
688
689 %post   libGL -p /sbin/ldconfig
690 %postun libGL -p /sbin/ldconfig
691
692 %post   libGLES -p /sbin/ldconfig
693 %postun libGLES -p /sbin/ldconfig
694
695 %post   libGLU -p /sbin/ldconfig
696 %postun libGLU -p /sbin/ldconfig
697
698 %post   libOSMesa -p /sbin/ldconfig
699 %postun libOSMesa -p /sbin/ldconfig
700
701 %post   libOpenVG -p /sbin/ldconfig
702 %postun libOpenVG -p /sbin/ldconfig
703
704 %post   libXvMC -p /sbin/ldconfig
705 %postun libXvMC -p /sbin/ldconfig
706
707 %if %{with egl}
708 %files libEGL
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
711 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
712 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
713 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
714 %if %{with gbm}
715 %dir %{_libdir}/gbm
716 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
718 %endif
719 %if %{with gallium}
720 %dir %{_libdir}/egl
721 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
722 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
723 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
724 %if %{with gbm}
725 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
726 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
727 %if %{with gallium_nouveau}
728 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
729 %endif
730 %if %{with gallium_intel}
731 %attr(755,root,root) %{_libdir}/egl/pipe_i915.so
732 %attr(755,root,root) %{_libdir}/egl/pipe_i965.so
733 %endif
734 %endif
735 %endif
736
737 %files libEGL-devel
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/libEGL.so
740 %attr(755,root,root) %{_libdir}/libglapi.so
741 %dir %{_includedir}/EGL
742 %{_includedir}/EGL/egl.h
743 %{_includedir}/EGL/eglext.h
744 %{_includedir}/EGL/eglmesaext.h
745 %{_includedir}/EGL/eglplatform.h
746 %dir %{_includedir}/KHR
747 %{_includedir}/KHR/khrplatform.h
748 %{_pkgconfigdir}/egl.pc
749 %if %{with gbm}
750 %attr(755,root,root) %{_libdir}/libgbm.so
751 %{_includedir}/gbm.h
752 %{_pkgconfigdir}/gbm.pc
753 %endif
754
755 %if %{with static_libs}
756 %files libEGL-static
757 %defattr(644,root,root,755)
758 %{_libdir}/libEGL.a
759 %endif
760 %endif
761
762 %files libGL
763 %defattr(644,root,root,755)
764 %doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
765 %attr(755,root,root) %{_libdir}/libGL.so.*.*
766 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
767 # symlink for binary apps which fail to conform Linux OpenGL ABI
768 # (and dlopen libGL.so instead of libGL.so.1; the same does Mesa libEGL)
769 %attr(755,root,root) %{_libdir}/libGL.so
770
771 %files libGL-devel
772 %defattr(644,root,root,755)
773 %doc docs/*.spec
774 %dir %{_includedir}/GL
775 %{_includedir}/GL/gl.h
776 %{_includedir}/GL/glext.h
777 %{_includedir}/GL/gl_mangle.h
778 %{_includedir}/GL/glx.h
779 %{_includedir}/GL/glxext.h
780 %{_includedir}/GL/glx_mangle.h
781 %dir %{_includedir}/GL/internal
782 %{_includedir}/GL/internal/dri_interface.h
783 %{_pkgconfigdir}/dri.pc
784 %{_pkgconfigdir}/gl.pc
785
786 %if %{with static_libs}
787 %files libGL-static
788 %defattr(644,root,root,755)
789 %{_libdir}/libGL.a
790 %endif
791
792 %files libGLES
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so.*.*.*
795 %attr(755,root,root) %ghost %{_libdir}/libGLESv1_CM.so.1
796 %attr(755,root,root) %{_libdir}/libGLESv2.so.*.*
797 %attr(755,root,root) %ghost %{_libdir}/libGLESv2.so.2
798
799 %files libGLES-devel
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so
802 %attr(755,root,root) %{_libdir}/libGLESv2.so
803 %{_includedir}/GLES
804 %{_includedir}/GLES2
805 %{_pkgconfigdir}/glesv1_cm.pc
806 %{_pkgconfigdir}/glesv2.pc
807
808 %files libGLU
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
811 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
812
813 %files libGLU-devel
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libGLU.so
816 %{_includedir}/GL/glu.h
817 %{_includedir}/GL/glu_mangle.h
818 %{_pkgconfigdir}/glu.pc
819
820 %if %{with static_libs}
821 %files libGLU-static
822 %defattr(644,root,root,755)
823 %{_libdir}/libGLU.a
824 %endif
825
826 %if %{with osmesa}
827 %files libOSMesa
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
830 %attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.8
831
832 %files libOSMesa-devel
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/libOSMesa.so
835 %{_includedir}/GL/osmesa.h
836 %{_pkgconfigdir}/osmesa.pc
837
838 %if %{with static_libs}
839 %files libOSMesa-static
840 %defattr(644,root,root,755)
841 %{_libdir}/libOSMesa.a
842 %endif
843 %endif
844
845 %if %{with gallium}
846 %files libOpenVG
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_libdir}/libOpenVG.so.*.*.*
849 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
850
851 %files libOpenVG-devel
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_libdir}/libOpenVG.so
854 %{_includedir}/VG
855 %{_pkgconfigdir}/vg.pc
856 %endif
857
858 %files libXvMC
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
861 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.0
862 %attr(755,root,root) %ghost %{_libdir}/libXvMCr300.so.1
863 %attr(755,root,root) %{_libdir}/libXvMCr300.so.1.0
864 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
865 %attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0
866 %attr(755,root,root) %ghost %{_libdir}/libXvMCsoftpipe.so.1
867 %attr(755,root,root) %{_libdir}/libXvMCsoftpipe.so.1.0
868
869 %files dri-driver-ati-radeon-R100
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
872
873 %files dri-driver-ati-radeon-R200
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
876
877 %files dri-driver-ati-radeon-R300
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
880
881 %files dri-driver-ati-radeon-R600
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
884
885 %files dri-driver-intel-i915
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
888
889 %files dri-driver-intel-i965
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
892 %if %{with gallium_intel}
893 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
894 %endif
895
896 %if %{with gallium_nouveau}
897 %files dri-driver-nouveau
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
900 %endif
901
902 %files dri-driver-swrast
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
905
906 %if %{with gallium}
907 %files dri-driver-vmwgfx
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
910 %endif
911
912 %files -n libvdpau-driver-mesa
913 %defattr(644,root,root,755)
914 # there is no ldconfig here
915 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
916 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
917 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
918 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
919 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
920 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
921 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
922 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
923 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
924 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1.0
925 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1
926 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so
This page took 0.113107 seconds and 4 git commands to generate.