]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- downgrade libXext BR
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  demos   # don't build demos
8 %bcond_without  motif   # build static libGLw without Motif interface
9 %bcond_without  gallium
10 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
11 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
12 %bcond_with     static
13 #
14 # minimal supported xserver version
15 %define         xserver_ver     1.5.0
16 # glapi version (glapi tables in dri drivers and libglx must be in sync);
17 # set to current Mesa version on ABI break, when xserver tables get regenerated
18 # (until they start to be somehow versioned themselves)
19 %define         glapi_ver       7.1.0
20 #
21 Summary:        Free OpenGL implementation
22 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
23 Name:           Mesa
24 Version:        7.5
25 Release:        7%{?with_multigl:.mgl}
26 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
27 Group:          X11/Libraries
28 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
29 # Source0-md5:  459f332551f6ebb86f384d21dd15e1f0
30 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
31 # Source1-md5:  398ee8801814a00e47f6c2314e3dfddc
32 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
33 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
34 Patch0:         %{name}-realclean.patch
35 Patch1:         %{name}-noveau-abi-0.0.15.patch
36 Patch2:         %{name}-sparc64.patch
37 Patch3:         %{name}-git.patch
38 URL:            http://www.mesa3d.org/
39 BuildRequires:  expat-devel
40 %{?with_demos:BuildRequires:    glew-devel}
41 BuildRequires:  libdrm-devel >= 2.4.12-3
42 BuildRequires:  libselinux-devel
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 2:1.4d
45 %{?with_motif:BuildRequires:    motif-devel}
46 BuildRequires:  rpmbuild(macros) >= 1.470
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  xorg-lib-libXdamage-devel
49 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
50 BuildRequires:  xorg-lib-libXt-devel
51 BuildRequires:  xorg-lib-libXxf86vm-devel
52 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
53 BuildRequires:  xorg-proto-glproto-devel
54 BuildRequires:  xorg-proto-printproto-devel
55 BuildRequires:  xorg-util-makedepend
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %if %{without gallium}
59 %undefine       with_gallium_intel
60 %endif
61
62 %description
63 Mesa is a 3-D graphics library with an API which is very similar to
64 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
65 syntax or state machine, it is being used with authorization from
66 Silicon Graphics, Inc. However, the author does not possess an OpenGL
67 license from SGI, and makes no claim that Mesa is in any way a
68 compatible replacement for OpenGL or associated with SGI.
69
70 %description -l pl.UTF-8
71 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
72 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
73 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
74 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
75 OpenGL ani powiązana z SGI.
76
77 %package libGL
78 Summary:        Free Mesa3D implementation of libGL OpenGL library
79 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
80 License:        MIT
81 Group:          X11/Libraries
82 Requires:       libdrm >= 2.4.5
83 Provides:       OpenGL = 2.1
84 # reports version 1.3, but supports glXGetProcAddress() from 1.4
85 Provides:       OpenGL-GLX = 1.4
86 Obsoletes:      Mesa
87 Obsoletes:      Mesa-dri
88 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
89 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
90
91 %description libGL
92 Mesa is a 3-D graphics library with an API which is very similar to
93 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
94 syntax or state machine, it is being used with authorization from
95 Silicon Graphics, Inc. However, the author does not possess an OpenGL
96 license from SGI, and makes no claim that Mesa is in any way a
97 compatible replacement for OpenGL or associated with SGI.
98
99 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
100 specifications. It uses DRI for rendering.
101
102 %description libGL -l pl.UTF-8
103 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
104 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
105 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
106 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
107 OpenGL ani powiązana z SGI.
108
109 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
110 GLX 1.4. Używa DRI do renderowania.
111
112 %package libGL-devel
113 Summary:        Header files for Mesa3D libGL library
114 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
115 License:        MIT
116 Group:          X11/Development/Libraries
117 # loose dependency on libGL to use with other libGL binaries
118 Requires:       OpenGL >= 1.5
119 Requires:       xorg-lib-libX11-devel
120 Provides:       OpenGL-GLX-devel = 1.4
121 Provides:       OpenGL-devel = 2.1
122 Obsoletes:      Mesa-devel
123 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
124 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
125 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
126 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
127
128 %description libGL-devel
129 Header files for Mesa3D libGL library.
130
131 %description libGL-devel -l pl.UTF-8
132 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
133
134 %package libGL-static
135 Summary:        Static Mesa3D libGL library
136 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
137 License:        MIT
138 Group:          X11/Development/Libraries
139 Requires:       %{name}-libGL-devel = %{version}-%{release}
140 Provides:       OpenGL-static = 2.1
141 Obsoletes:      Mesa-static
142 Obsoletes:      X11-OpenGL-static < 1:7.0.0
143 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
144
145 %description libGL-static
146 Static Mesa3D libGL library. It uses software renderer.
147
148 %description libGL-static -l pl.UTF-8
149 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
150 renderingu.
151
152 %package libGLU
153 Summary:        SGI implementation of libGLU OpenGL library
154 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
155 License:        SGI Free Software License B v2.0 (MIT-like)
156 Group:          Libraries
157 # loose dependency on libGL.so.1 to use with other libGL binaries
158 Requires:       OpenGL >= 1.2
159 Provides:       OpenGL-GLU = 1.3
160 Obsoletes:      Mesa-devel
161 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
162 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
163
164 %description libGLU
165 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
166 1.3 specifications.
167
168 %description libGLU -l pl.UTF-8
169 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
170 specyfikację OpenGL GLU 1.3.
171
172 %package libGLU-devel
173 Summary:        Header files for SGI libGLU library
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
175 License:        SGI Free Software License B v2.0 (MIT-like)
176 Group:          Development/Libraries
177 Requires:       %{name}-libGLU = %{version}-%{release}
178 Requires:       OpenGL-devel >= 1.2
179 Requires:       libstdc++-devel
180 Provides:       OpenGL-GLU-devel = 1.3
181
182 %description libGLU-devel
183 Header files for SGI libGLU library.
184
185 %description libGLU-devel -l pl.UTF-8
186 Pliki nagłówkowe biblioteki SGI libGLU.
187
188 %package libGLU-static
189 Summary:        Static SGI libGLU library
190 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
191 License:        SGI Free Software License B v2.0 (MIT-like)
192 Group:          Development/Libraries
193 Requires:       %{name}-libGLU-devel = %{version}-%{release}
194 Provides:       OpenGL-GLU-static = 1.3
195
196 %description libGLU-static
197 Static SGI libGLU library.
198
199 %description libGLU-static -l pl.UTF-8
200 Statyczna biblioteka SGI libGLU.
201
202 %package libGLw
203 Summary:        SGI OpenGL Xt widgets library
204 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
205 License:        SGI MIT-like
206 Group:          Libraries
207 # loose dependency on libGL.so.1 to use with other libGL binaries
208 Requires:       OpenGL >= 1.1
209 Provides:       OpenGL-GLw
210
211 %description libGLw
212 SGI OpenGL Xt widgets library.
213
214 %description libGLU -l pl.UTF-8
215 Biblioteka SGI widgetów Xt dla OpenGL-a.
216
217 %package libGLw-devel
218 Summary:        Header files for SGI libGLw library
219 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
220 License:        SGI MIT-like
221 Group:          Development/Libraries
222 Requires:       %{name}-libGLw = %{version}-%{release}
223 Requires:       OpenGL-devel >= 1.2
224 Provides:       OpenGL-GLw-devel
225
226 %description libGLw-devel
227 Header files for SGI libGLw library.
228
229 %description libGLw-devel -l pl.UTF-8
230 Pliki nagłówkowe biblioteki SGI libGLw.
231
232 %package libGLw-static
233 Summary:        Static SGI libGLw library
234 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
235 License:        SGI MIT-like
236 Group:          Development/Libraries
237 Requires:       %{name}-libGLw-devel = %{version}-%{release}
238 Provides:       OpenGL-GLw-static
239
240 %description libGLw-static
241 Static SGI libGLw library.
242
243 %description libGLw-static -l pl.UTF-8
244 Statyczna biblioteka SGI libGLw.
245
246 %package libOSMesa
247 Summary:        OSMesa (off-screen renderer) library
248 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
249 License:        MIT
250 Group:          Libraries
251 # doesn't require base
252
253 %description libOSMesa
254 OSMesa (off-screen renderer) library.
255
256 %description libOSMesa -l pl.UTF-8
257 Biblioteka OSMesa (renderująca bitmapy w pamięci).
258
259 %package libOSMesa-devel
260 Summary:        Header file for OSMesa (off-screen renderer) library
261 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
262 License:        MIT
263 Group:          Development/Libraries
264 Requires:       %{name}-libOSMesa = %{version}-%{release}
265 # for <GL/gl.h> only
266 Requires:       OpenGL-devel
267
268 %description libOSMesa-devel
269 Header file for OSMesa (off-screen renderer) library.
270
271 %description libOSMesa-devel -l pl.UTF-8
272 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
273
274 %package libOSMesa-static
275 Summary:        Static OSMesa (off-screen renderer) library
276 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
277 License:        MIT
278 Group:          Development/Libraries
279 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
280 # this static build of OSMesa needs static non-dri Mesa implementation
281 Requires:       %{name}-libGL-static = %{version}-%{release}
282
283 %description libOSMesa-static
284 Static OSMesa (off-screen renderer) library.
285
286 %description libOSMesa-static -l pl.UTF-8
287 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
288
289 %package utils
290 Summary:        OpenGL utilities from Mesa3D
291 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
292 License:        MIT
293 Group:          X11/Applications/Graphics
294 # loose deps on libGL/libGLU
295
296 %description utils
297 OpenGL utilities from Mesa3D: glxgears and glxinfo.
298
299 %description utils -l pl.UTF-8
300 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
301
302 %package demos
303 Summary:        Mesa Demos source code
304 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
305 License:        various (MIT, SGI, GPL - see copyright notes in sources)
306 Group:          Development/Libraries
307 Requires:       OpenGL-devel
308
309 %description demos
310 Demonstration programs for the Mesa libraries in source code form.
311
312 %description demos -l pl.UTF-8
313 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
314
315 %package dri-driver-ati-mach64
316 Summary:        X.org DRI driver for ATI Mach64 card family
317 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
318 License:        MIT
319 Group:          X11/Libraries
320 Requires:       xorg-driver-video-mach64
321 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
322 Requires:       xorg-xserver-server >= %{xserver_ver}
323
324 %description dri-driver-ati-mach64
325 X.org DRI driver for ATI Mach64 card family.
326
327 %description dri-driver-ati-mach64 -l pl.UTF-8
328 Sterownik X.org DRI dla rodziny kart ATI Mach64.
329
330 %package dri-driver-ati-radeon-R100
331 Summary:        X.org DRI driver for ATI R100 card family
332 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
333 License:        MIT
334 Group:          X11/Libraries
335 Requires:       xorg-driver-video-ati
336 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
337 Requires:       xorg-xserver-server >= %{xserver_ver}
338 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
339
340 %description dri-driver-ati-radeon-R100
341 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
342
343 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
344 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
345
346 %package dri-driver-ati-radeon-R200
347 Summary:        X.org DRI driver for ATI R200 card family
348 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
349 License:        MIT
350 Group:          X11/Libraries
351 Requires:       xorg-driver-video-ati
352 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
353 Requires:       xorg-xserver-server >= %{xserver_ver}
354 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
355
356 %description dri-driver-ati-radeon-R200
357 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
358
359 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
360 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
361
362 %package dri-driver-ati-radeon-R300
363 Summary:        X.org DRI driver for ATI R300 card family
364 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
365 License:        MIT
366 Group:          X11/Libraries
367 Requires:       xorg-driver-video-ati
368 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
369 Requires:       xorg-xserver-server >= %{xserver_ver}
370 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
371
372 %description dri-driver-ati-radeon-R300
373 X.org DRI driver for ATI R300 card family.
374
375 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
376 Sterownik X.org DRI dla rodziny kart ATI R300.
377
378 %package dri-driver-ati-rage128
379 Summary:        X.org DRI driver for ATI Rage128 card family
380 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
381 License:        MIT
382 Group:          X11/Libraries
383 Requires:       xorg-driver-video-r128
384 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
385 Requires:       xorg-xserver-server >= %{xserver_ver}
386 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
387
388 %description dri-driver-ati-rage128
389 X.org DRI driver for ATI Rage128 card family.
390
391 %description dri-driver-ati-rage128 -l pl.UTF-8
392 Sterownik X.org DRI dla rodziny kart ATI Rage128.
393
394 %package dri-driver-ffb
395 Summary:        X.org DRI driver for Sun FFB card family
396 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
397 License:        MIT
398 Group:          X11/Libraries
399 Requires:       xorg-driver-video-sunffb
400 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
401 Requires:       xorg-xserver-server >= %{xserver_ver}
402
403 %description dri-driver-ffb
404 X.org DRI driver for SUN Creator3D and Elite3D card family.
405
406 %description dri-driver-ffb -l pl.UTF-8
407 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
408
409 %package dri-driver-glint
410 Summary:        X.org DRI driver for GLINT/Permedia card family
411 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
412 License:        MIT
413 Group:          X11/Libraries
414 Requires:       xorg-driver-video-glint
415 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
416 Requires:       xorg-xserver-server >= %{xserver_ver}
417 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
418
419 %description dri-driver-glint
420 X.org DRI driver for GLINT/Permedia card family.
421
422 %description dri-driver-glint -l pl.UTF-8
423 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
424
425 %package dri-driver-intel-i810
426 Summary:        X.org DRI driver for Intel i810 card family
427 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
428 License:        MIT
429 Group:          X11/Libraries
430 Requires:       xorg-driver-video-intel
431 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
432 Requires:       xorg-xserver-server >= %{xserver_ver}
433 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
434
435 %description dri-driver-intel-i810
436 X.org DRI driver for Intel i810 card family.
437
438 %description dri-driver-intel-i810 -l pl.UTF-8
439 Sterownik X.org DRI dla rodziny kart Intel i810.
440
441 %package dri-driver-intel-i915
442 Summary:        X.org DRI driver for Intel i915 card family
443 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
444 License:        MIT
445 Group:          X11/Libraries
446 Requires:       xorg-driver-video-intel
447 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
448 Requires:       xorg-xserver-server >= %{xserver_ver}
449 Obsoletes:      Mesa-dri-driver-intel-i830
450 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
451
452 %description dri-driver-intel-i915
453 X.org DRI driver for Intel i915 card family.
454
455 %description dri-driver-intel-i915 -l pl.UTF-8
456 Sterownik X.org DRI dla rodziny kart Intel i915.
457
458 %package dri-driver-intel-i965
459 Summary:        X.org DRI driver for Intel i965 card family
460 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
461 License:        MIT
462 Group:          X11/Libraries
463 Requires:       xorg-driver-video-intel
464 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
465 Requires:       xorg-xserver-server >= %{xserver_ver}
466 Obsoletes:      Mesa-dri-driver-intel-i830
467 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
468
469 %description dri-driver-intel-i965
470 X.org DRI driver for Intel i965 card family.
471
472 %description dri-driver-intel-i965 -l pl.UTF-8
473 Sterownik X.org DRI dla rodziny kart Intel i965.
474
475 %package dri-driver-matrox
476 Summary:        X.org DRI driver for Matrox G card family
477 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
478 License:        MIT
479 Group:          X11/Libraries
480 Requires:       xorg-driver-video-mga
481 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
482 Requires:       xorg-xserver-server >= %{xserver_ver}
483 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
484
485 %description dri-driver-matrox
486 X.org DRI drivers for Matrox G card family.
487
488 %description dri-driver-matrox -l pl.UTF-8
489 Sterowniki X.org DRI dla rodziny kart Matrox G.
490
491 %package dri-driver-nouveau
492 Summary:        X.org DRI driver for NVIDIA card family
493 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
494 License:        MIT
495 Group:          X11/Libraries
496 Requires:       xorg-driver-video-nouveau
497 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
498 Requires:       xorg-xserver-server >= %{xserver_ver}
499
500 %description dri-driver-nouveau
501 X.org DRI drivers for NVIDIA card family.
502
503 %description dri-driver-nouveau -l pl.UTF-8
504 Sterowniki X.org DRI dla rodziny kart NVIDIA.
505
506 %package dri-driver-s3virge
507 Summary:        X.org DRI driver for S3 Virge card family
508 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
509 License:        MIT
510 Group:          X11/Libraries
511 Requires:       xorg-driver-video-s3virge
512 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
513 Requires:       xorg-xserver-server >= %{xserver_ver}
514
515 %description dri-driver-s3virge
516 X.org DRI driver for S3 Virge card family.
517
518 %description dri-driver-s3virge -l pl.UTF-8
519 Sterownik X.org DRI dla rodziny kart S3 Virge.
520
521 %package dri-driver-savage
522 Summary:        X.org DRI driver for S3 Savage card family
523 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
524 License:        MIT
525 Group:          X11/Libraries
526 Requires:       xorg-driver-video-savage
527 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
528 Requires:       xorg-xserver-server >= %{xserver_ver}
529
530 %description dri-driver-savage
531 X.org DRI driver for S3 Savage card family.
532
533 %description dri-driver-savage -l pl.UTF-8
534 Sterownik X.org DRI dla rodziny kart S3 Savage.
535
536 %package dri-driver-sis
537 Summary:        X.org DRI driver for SiS card family
538 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
539 License:        MIT
540 Group:          X11/Libraries
541 Requires:       xorg-driver-video-sis
542 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
543 Requires:       xorg-xserver-server >= %{xserver_ver}
544 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
545
546 %description dri-driver-sis
547 X.org DRI driver for SiS card family.
548
549 %description dri-driver-sis -l pl.UTF-8
550 Sterownik X.org DRI dla rodziny kart SiS.
551
552 %package dri-driver-swrast
553 Summary:        X.org DRI software rasterizer driver
554 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
555 License:        MIT
556 Group:          X11/Libraries
557 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
558 Requires:       xorg-xserver-server >= %{xserver_ver}
559
560 %description dri-driver-swrast
561 X.org DRI software rasterizer driver.
562
563 %description dri-driver-swrast -l pl.UTF-8
564 Sterownik X.org DRI obsługujący rysowanie programowe.
565
566 %package dri-driver-tdfx
567 Summary:        X.org DRI driver for 3DFX Voodoo card family
568 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
569 License:        MIT
570 Group:          X11/Libraries
571 Requires:       Glide3-DRI
572 Requires:       xorg-driver-video-tdfx
573 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
574 Requires:       xorg-xserver-server >= %{xserver_ver}
575 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
576
577 %description dri-driver-tdfx
578 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
579 and Velocity 100/200).
580
581 %description dri-driver-tdfx -l pl.UTF-8
582 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
583 Banshee i Velocity 100/200).
584
585 %package dri-driver-trident
586 Summary:        X.org DRI driver for Trident card family
587 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
588 License:        MIT
589 Group:          X11/Libraries
590 Requires:       xorg-driver-video-trident
591 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
592 Requires:       xorg-xserver-server >= %{xserver_ver}
593
594 %description dri-driver-trident
595 X.org DRI drivers for Trident card family.
596
597 %description dri-driver-trident -l pl.UTF-8
598 Sterowniki X.org DRI dla rodziny kart Trident.
599
600 %package dri-driver-via-unichrome
601 Summary:        X.org DRI driver for VIA Unichrome card family
602 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
603 License:        MIT
604 Group:          X11/Libraries
605 Requires:       xorg-driver-video-openchrome
606 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
607 Requires:       xorg-xserver-server >= %{xserver_ver}
608
609 %description dri-driver-via-unichrome
610 X.org DRI driver for VIA Unichrome card family.
611
612 %description dri-driver-via-unichrome -l pl.UTF-8
613 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
614
615 %prep
616 %setup -q -b1 -a2
617 %patch0 -p0
618 %patch1 -p1
619 %patch2 -p1
620 %patch3 -p1
621
622 # fix demos
623 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
624
625 %build
626 [ ! -f configure ] && ./autogen.sh
627
628 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
629 %if %{without gallium_intel}
630 i915 \
631 %endif
632 %ifarch sparc sparcv9 sparc64
633 ffb \
634 %endif
635 %ifarch %{ix86} %{x8664}
636 sis \
637 %endif
638 swrast tdfx unichrome"
639
640 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
641
642 common_flags="\
643         --enable-shared \
644         --enable-selinux \
645         --enable-pic \
646         --disable-egl \
647         --with%{!?with_demos:out}-demos"
648
649 # osmesa variants
650 %configure $common_flags \
651         --with-driver=osmesa \
652         --disable-asm \
653         --with-osmesa-bits=8
654 %{__make} \
655         SRC_DIRS=mesa
656 mv %{_lib} osmesa8
657 %{__make} clean
658
659 %configure $common_flags \
660         --with-driver=osmesa \
661         --disable-asm \
662         --with-osmesa-bits=16
663 %{__make} \
664         SRC_DIRS=mesa
665 mv %{_lib} osmesa16
666 %{__make} clean
667
668 %configure $common_flags \
669         --with-driver=osmesa \
670         --disable-asm \
671         --with-osmesa-bits=32
672 %{__make} \
673         SRC_DIRS=mesa
674 mv %{_lib} osmesa32
675 %{__make} clean
676
677 %configure $common_flags \
678         --enable-glu \
679         --enable-glw \
680         --disable-glut \
681 %if %{with gallium}
682         --enable-gallium \
683         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
684         --enable-gallium-nouveau \
685         --with-state-trackers=dri \
686 %else
687         --disable-gallium \
688 %endif
689         --with-driver=dri \
690         --with-dri-drivers=${dri_drivers} \
691         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
692
693 %{__make}
694 %{__make} -C progs/xdemos glxgears glxinfo
695 %if %{with demos}
696 %{__make} -C progs/demos
697 %endif
698
699 cd gl-manpages-*
700 %configure
701 %{__make}
702
703 %install
704 rm -rf $RPM_BUILD_ROOT
705
706 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
707
708 # libs without drivers
709 %{__make} install \
710         DESTDIR=$RPM_BUILD_ROOT
711
712 cd gl-manpages-*
713 %{__make} install \
714         DESTDIR=$RPM_BUILD_ROOT
715 cd ..
716
717 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
718
719 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
720 # work on copy to keep -bi --short-circuit working
721 rm -rf progs-clean
722 install -d progs-clean
723 for l in demos glsl osdemos redbook samples xdemos ; do
724         cp -a progs/$l progs-clean/$l
725         %{__make} -C progs-clean/$l clean
726         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
727 done
728 rm -rf progs-clean
729 for l in util images ; do
730         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
731 done
732 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
733
734 # strip out undesirable headers
735 olddir=$(pwd)
736 cd $RPM_BUILD_ROOT%{_includedir}/GL
737 rm [a-fh-np-wyz]*.h gg*.h glf*.h
738 cd $RPM_BUILD_ROOT%{_libdir}
739 cd $olddir
740
741 %if %{with multigl}
742 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
743
744 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
745 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
746
747 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
748 %endif
749
750 %clean
751 rm -rf $RPM_BUILD_ROOT
752
753 %post   libGL -p /sbin/ldconfig
754 %postun libGL -p /sbin/ldconfig
755
756 %post   libGLU -p /sbin/ldconfig
757 %postun libGLU -p /sbin/ldconfig
758
759 %post   libGLw -p /sbin/ldconfig
760 %postun libGLw -p /sbin/ldconfig
761
762 %files libGL
763 %defattr(644,root,root,755)
764 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
765 %if %{with multigl}
766 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
767 %dir %{_libdir}/Mesa
768 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
769 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
770 %else
771 %attr(755,root,root) %{_libdir}/libGL.so.*.*
772 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
773 # symlink for binary apps which fail to conform Linux OpenGL ABI
774 # (and dlopen libGL.so instead of libGL.so.1)
775 %attr(755,root,root) %{_libdir}/libGL.so
776 %endif
777
778 %files libGL-devel
779 %defattr(644,root,root,755)
780 %doc docs/*.spec
781 %if %{with multigl}
782 %attr(755,root,root) %{_libdir}/libGL.so
783 %endif
784 %dir %{_includedir}/GL
785 %{_includedir}/GL/gl.h
786 %{_includedir}/GL/glext.h
787 %{_includedir}/GL/gl_mangle.h
788 %{_includedir}/GL/glx.h
789 %{_includedir}/GL/glxext.h
790 %{_includedir}/GL/glx_mangle.h
791 %dir %{_includedir}/GL/internal
792 %{_includedir}/GL/internal/dri_interface.h
793 %{_pkgconfigdir}/dri.pc
794 %{_pkgconfigdir}/gl.pc
795 %{_mandir}/man3/gl[^uX]*.3gl*
796 %{_mandir}/man3/glX*.3gl*
797
798 %if %{with static}
799 %files libGL-static
800 %defattr(644,root,root,755)
801 %{_libdir}/libGL.a
802 %endif
803
804 %files libGLU
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
807 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
808
809 %files libGLU-devel
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libGLU.so
812 %{_includedir}/GL/glu.h
813 %{_includedir}/GL/glu_mangle.h
814 %{_pkgconfigdir}/glu.pc
815 %{_mandir}/man3/glu*.3gl*
816
817 %if %{with static}
818 %files libGLU-static
819 %defattr(644,root,root,755)
820 %{_libdir}/libGLU.a
821 %endif
822
823 %files libGLw
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
826 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
827
828 %files libGLw-devel
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_libdir}/libGLw.so
831 %{_includedir}/GL/GLwDrawA.h
832 %{_includedir}/GL/GLwDrawAP.h
833 %{_includedir}/GL/GLwMDrawA.h
834 %{_includedir}/GL/GLwMDrawAP.h
835 %{_pkgconfigdir}/glw.pc
836
837 %if %{with static}
838 %files libGLw-static
839 %defattr(644,root,root,755)
840 %{_libdir}/libGLw.a
841 %endif
842
843 %files libOSMesa
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
846 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
847
848 %files libOSMesa-devel
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/libOSMesa*.so
851 %{_includedir}/GL/osmesa.h
852
853 %if %{with static}
854 %files libOSMesa-static
855 %defattr(644,root,root,755)
856 %{_libdir}/libOSMesa*.a
857 %endif
858
859 %files utils
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_bindir}/glxgears
862 %attr(755,root,root) %{_bindir}/glxinfo
863
864 %files dri-driver-ati-mach64
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
867
868 %files dri-driver-ati-radeon-R100
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
871
872 %files dri-driver-ati-radeon-R200
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
875
876 %files dri-driver-ati-radeon-R300
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
879
880 %files dri-driver-ati-rage128
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
883
884 # sunffb (sparc only)
885 %ifarch sparc sparcv9 sparc64
886 %files dri-driver-ffb
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
889 %endif
890
891 # glint (requires update)
892 %if 0
893 %files dri-driver-glint
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
896 %endif
897
898 %files dri-driver-intel-i810
899 %defattr(644,root,root,755)
900 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
901
902 %files dri-driver-intel-i915
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
905
906 %files dri-driver-intel-i965
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
909
910 %files dri-driver-matrox
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
913
914 %if %{with gallium}
915 %files dri-driver-nouveau
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
918 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri2.so
919 %endif
920
921 %files dri-driver-s3virge
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
924
925 %files dri-driver-savage
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
928
929 %ifarch %{ix86} %{x8664}
930 %files dri-driver-sis
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
933 %endif
934
935 %files dri-driver-swrast
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
938
939 %files dri-driver-tdfx
940 %defattr(644,root,root,755)
941 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
942
943 %files dri-driver-trident
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
946
947 %files dri-driver-via-unichrome
948 %defattr(644,root,root,755)
949 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
950
951 %if %{with demos}
952 %files demos
953 %defattr(644,root,root,755)
954 %{_examplesdir}/%{name}-%{version}
955 %endif
This page took 0.127152 seconds and 4 git commands to generate.