]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 7.8.2
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.19
25 %define         dri2proto_ver   1.99.3
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.8.2
32 Release:        1%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  6be2d343a0089bfd395ce02aaf8adb57
37 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
38 # Source1-md5:  757d9e2e06f48b1a52848be9b0307ced
39 Patch0:         %{name}-realclean.patch
40 Patch1:         %{name}-tgsi_dump.patch
41 URL:            http://www.mesa3d.org/
42 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 BuildRequires:  expat-devel
46 #%%{?with_demos:BuildRequires:  glew-devel}
47 BuildRequires:  libdrm-devel >= %{libdrm_ver}
48 BuildRequires:  libselinux-devel
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtool >= 2:1.4d
51 %{?with_motif:BuildRequires:    motif-devel}
52 BuildRequires:  pixman-devel
53 BuildRequires:  pkgconfig
54 BuildRequires:  python
55 BuildRequires:  python-modules
56 BuildRequires:  rpmbuild(macros) >= 1.470
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  xorg-lib-libXdamage-devel
59 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
60 BuildRequires:  xorg-lib-libXt-devel
61 BuildRequires:  xorg-lib-libXxf86vm-devel
62 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
63 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
64 BuildRequires:  xorg-util-makedepend
65 BuildRequires:  xorg-xserver-server-devel
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %if %{without gallium}
69 %undefine       with_gallium_intel
70 %endif
71
72 %description
73 Mesa is a 3-D graphics library with an API which is very similar to
74 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
75 syntax or state machine, it is being used with authorization from
76 Silicon Graphics, Inc. However, the author does not possess an OpenGL
77 license from SGI, and makes no claim that Mesa is in any way a
78 compatible replacement for OpenGL or associated with SGI.
79
80 %description -l pl.UTF-8
81 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
82 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
83 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
84 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
85 OpenGL ani powiązana z SGI.
86
87 %package libGL
88 Summary:        Free Mesa3D implementation of libGL OpenGL library
89 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
90 License:        MIT
91 Group:          X11/Libraries
92 Requires:       libdrm >= %{libdrm_ver}
93 Provides:       OpenGL = 2.1
94 # reports version 1.3, but supports glXGetProcAddress() from 1.4
95 Provides:       OpenGL-GLX = 1.4
96 Obsoletes:      Mesa
97 Obsoletes:      Mesa-dri
98 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
99 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
100
101 %description libGL
102 Mesa is a 3-D graphics library with an API which is very similar to
103 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
104 syntax or state machine, it is being used with authorization from
105 Silicon Graphics, Inc. However, the author does not possess an OpenGL
106 license from SGI, and makes no claim that Mesa is in any way a
107 compatible replacement for OpenGL or associated with SGI.
108
109 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
110 specifications. It uses DRI for rendering.
111
112 %description libGL -l pl.UTF-8
113 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
114 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
115 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
116 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
117 OpenGL ani powiązana z SGI.
118
119 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
120 GLX 1.4. Używa DRI do renderowania.
121
122 %package libGL-devel
123 Summary:        Header files for Mesa3D libGL library
124 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
125 License:        MIT
126 Group:          X11/Development/Libraries
127 # loose dependency on libGL to use with other libGL binaries
128 Requires:       OpenGL >= 1.5
129 Requires:       libdrm-devel >= %{libdrm_ver}
130 Requires:       xorg-lib-libX11-devel
131 Requires:       xorg-lib-libXdamage-devel
132 Requires:       xorg-lib-libXext-devel
133 Requires:       xorg-lib-libXxf86vm-devel
134 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
135 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
136 Suggests:       OpenGL-doc-man
137 Provides:       OpenGL-GLX-devel = 1.4
138 Provides:       OpenGL-devel = 2.1
139 Obsoletes:      Mesa-devel
140 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
141 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
142 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
143 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
144
145 %description libGL-devel
146 Header files for Mesa3D libGL library.
147
148 %description libGL-devel -l pl.UTF-8
149 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
150
151 %package libGL-static
152 Summary:        Static Mesa3D libGL library
153 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
154 License:        MIT
155 Group:          X11/Development/Libraries
156 Requires:       %{name}-libGL-devel = %{version}-%{release}
157 Provides:       OpenGL-static = 2.1
158 Obsoletes:      Mesa-static
159 Obsoletes:      X11-OpenGL-static < 1:7.0.0
160 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
161
162 %description libGL-static
163 Static Mesa3D libGL library. It uses software renderer.
164
165 %description libGL-static -l pl.UTF-8
166 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
167 renderingu.
168
169 %package libGLU
170 Summary:        SGI implementation of libGLU OpenGL library
171 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
172 License:        SGI Free Software License B v2.0 (MIT-like)
173 Group:          Libraries
174 # loose dependency on libGL.so.1 to use with other libGL binaries
175 Requires:       OpenGL >= 1.2
176 Provides:       OpenGL-GLU = 1.3
177 Obsoletes:      Mesa-devel
178 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
179 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
180
181 %description libGLU
182 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
183 1.3 specifications.
184
185 %description libGLU -l pl.UTF-8
186 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
187 specyfikację OpenGL GLU 1.3.
188
189 %package libGLU-devel
190 Summary:        Header files for SGI libGLU library
191 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
192 License:        SGI Free Software License B v2.0 (MIT-like)
193 Group:          Development/Libraries
194 Requires:       %{name}-libGLU = %{version}-%{release}
195 Requires:       OpenGL-devel >= 1.2
196 Requires:       libstdc++-devel
197 Provides:       OpenGL-GLU-devel = 1.3
198
199 %description libGLU-devel
200 Header files for SGI libGLU library.
201
202 %description libGLU-devel -l pl.UTF-8
203 Pliki nagłówkowe biblioteki SGI libGLU.
204
205 %package libGLU-static
206 Summary:        Static SGI libGLU library
207 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
208 License:        SGI Free Software License B v2.0 (MIT-like)
209 Group:          Development/Libraries
210 Requires:       %{name}-libGLU-devel = %{version}-%{release}
211 Provides:       OpenGL-GLU-static = 1.3
212
213 %description libGLU-static
214 Static SGI libGLU library.
215
216 %description libGLU-static -l pl.UTF-8
217 Statyczna biblioteka SGI libGLU.
218
219 %package libGLw
220 Summary:        SGI OpenGL Xt widgets library
221 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
222 License:        SGI MIT-like
223 Group:          Libraries
224 # loose dependency on libGL.so.1 to use with other libGL binaries
225 Requires:       OpenGL >= 1.1
226 Provides:       OpenGL-GLw
227
228 %description libGLw
229 SGI OpenGL Xt widgets library.
230
231 %description libGLU -l pl.UTF-8
232 Biblioteka SGI widgetów Xt dla OpenGL-a.
233
234 %package libGLw-devel
235 Summary:        Header files for SGI libGLw library
236 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
237 License:        SGI MIT-like
238 Group:          Development/Libraries
239 Requires:       %{name}-libGLw = %{version}-%{release}
240 Requires:       OpenGL-devel >= 1.2
241 Provides:       OpenGL-GLw-devel
242
243 %description libGLw-devel
244 Header files for SGI libGLw library.
245
246 %description libGLw-devel -l pl.UTF-8
247 Pliki nagłówkowe biblioteki SGI libGLw.
248
249 %package libGLw-static
250 Summary:        Static SGI libGLw library
251 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
252 License:        SGI MIT-like
253 Group:          Development/Libraries
254 Requires:       %{name}-libGLw-devel = %{version}-%{release}
255 Provides:       OpenGL-GLw-static
256
257 %description libGLw-static
258 Static SGI libGLw library.
259
260 %description libGLw-static -l pl.UTF-8
261 Statyczna biblioteka SGI libGLw.
262
263 %package libOSMesa
264 Summary:        OSMesa (off-screen renderer) library
265 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
266 License:        MIT
267 Group:          Libraries
268 # doesn't require base
269
270 %description libOSMesa
271 OSMesa (off-screen renderer) library.
272
273 %description libOSMesa -l pl.UTF-8
274 Biblioteka OSMesa (renderująca bitmapy w pamięci).
275
276 %package libOSMesa-devel
277 Summary:        Header file for OSMesa (off-screen renderer) library
278 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
279 License:        MIT
280 Group:          Development/Libraries
281 Requires:       %{name}-libOSMesa = %{version}-%{release}
282 # for <GL/gl.h> only
283 Requires:       OpenGL-devel
284
285 %description libOSMesa-devel
286 Header file for OSMesa (off-screen renderer) library.
287
288 %description libOSMesa-devel -l pl.UTF-8
289 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
290
291 %package libOSMesa-static
292 Summary:        Static OSMesa (off-screen renderer) library
293 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
294 License:        MIT
295 Group:          Development/Libraries
296 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
297 # this static build of OSMesa needs static non-dri Mesa implementation
298 Requires:       %{name}-libGL-static = %{version}-%{release}
299
300 %description libOSMesa-static
301 Static OSMesa (off-screen renderer) library.
302
303 %description libOSMesa-static -l pl.UTF-8
304 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
305
306 %package utils
307 Summary:        OpenGL utilities from Mesa3D
308 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
309 License:        MIT
310 Group:          X11/Applications/Graphics
311 # loose deps on libGL/libGLU
312
313 %description utils
314 OpenGL utilities from Mesa3D: glxgears and glxinfo.
315
316 %description utils -l pl.UTF-8
317 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
318
319 %package demos
320 Summary:        Mesa Demos source code
321 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
322 License:        various (MIT, SGI, GPL - see copyright notes in sources)
323 Group:          Development/Libraries
324 Requires:       OpenGL-devel
325
326 %description demos
327 Demonstration programs for the Mesa libraries in source code form.
328
329 %description demos -l pl.UTF-8
330 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
331
332 %package dri-driver-ati-mach64
333 Summary:        X.org DRI driver for ATI Mach64 card family
334 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
335 License:        MIT
336 Group:          X11/Libraries
337 Requires:       xorg-driver-video-mach64
338 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
339 Requires:       xorg-xserver-server >= %{xserver_ver}
340
341 %description dri-driver-ati-mach64
342 X.org DRI driver for ATI Mach64 card family.
343
344 %description dri-driver-ati-mach64 -l pl.UTF-8
345 Sterownik X.org DRI dla rodziny kart ATI Mach64.
346
347 %package dri-driver-ati-radeon-R100
348 Summary:        X.org DRI driver for ATI R100 card family
349 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
350 License:        MIT
351 Group:          X11/Libraries
352 Requires:       xorg-driver-video-ati
353 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
354 Requires:       xorg-xserver-server >= %{xserver_ver}
355 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
356
357 %description dri-driver-ati-radeon-R100
358 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
359
360 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
361 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
362
363 %package dri-driver-ati-radeon-R200
364 Summary:        X.org DRI driver for ATI R200 card family
365 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
366 License:        MIT
367 Group:          X11/Libraries
368 Requires:       xorg-driver-video-ati
369 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
370 Requires:       xorg-xserver-server >= %{xserver_ver}
371 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
372
373 %description dri-driver-ati-radeon-R200
374 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
375
376 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
377 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
378
379 %package dri-driver-ati-radeon-R300
380 Summary:        X.org DRI driver for ATI R300 card family
381 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
382 License:        MIT
383 Group:          X11/Libraries
384 Requires:       xorg-driver-video-ati
385 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
386 Requires:       xorg-xserver-server >= %{xserver_ver}
387 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
388
389 %description dri-driver-ati-radeon-R300
390 X.org DRI driver for ATI R300 card family.
391
392 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
393 Sterownik X.org DRI dla rodziny kart ATI R300.
394
395 %package dri-driver-ati-radeon-R600
396 Summary:        X.org DRI driver for ATI R600 card family
397 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
398 License:        MIT
399 Group:          X11/Libraries
400 Requires:       radeon-ucode
401 Requires:       xorg-driver-video-ati
402 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
403 Requires:       xorg-xserver-server >= %{xserver_ver}
404
405 %description dri-driver-ati-radeon-R600
406 X.org DRI driver for ATI R600 card family.
407
408 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
409 Sterownik X.org DRI dla rodziny kart ATI R600.
410
411 %package dri-driver-ati-rage128
412 Summary:        X.org DRI driver for ATI Rage128 card family
413 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
414 License:        MIT
415 Group:          X11/Libraries
416 Requires:       xorg-driver-video-r128
417 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
418 Requires:       xorg-xserver-server >= %{xserver_ver}
419 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
420
421 %description dri-driver-ati-rage128
422 X.org DRI driver for ATI Rage128 card family.
423
424 %description dri-driver-ati-rage128 -l pl.UTF-8
425 Sterownik X.org DRI dla rodziny kart ATI Rage128.
426
427 %package dri-driver-ffb
428 Summary:        X.org DRI driver for Sun FFB card family
429 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
430 License:        MIT
431 Group:          X11/Libraries
432 Requires:       xorg-driver-video-sunffb
433 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
434 Requires:       xorg-xserver-server >= %{xserver_ver}
435
436 %description dri-driver-ffb
437 X.org DRI driver for SUN Creator3D and Elite3D card family.
438
439 %description dri-driver-ffb -l pl.UTF-8
440 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
441
442 %package dri-driver-glint
443 Summary:        X.org DRI driver for GLINT/Permedia card family
444 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
445 License:        MIT
446 Group:          X11/Libraries
447 Requires:       xorg-driver-video-glint
448 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
449 Requires:       xorg-xserver-server >= %{xserver_ver}
450 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
451
452 %description dri-driver-glint
453 X.org DRI driver for GLINT/Permedia card family.
454
455 %description dri-driver-glint -l pl.UTF-8
456 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
457
458 %package dri-driver-intel-i810
459 Summary:        X.org DRI driver for Intel i810 card family
460 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
461 License:        MIT
462 Group:          X11/Libraries
463 Requires:       xorg-driver-video-intel
464 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
465 Requires:       xorg-xserver-server >= %{xserver_ver}
466 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
467
468 %description dri-driver-intel-i810
469 X.org DRI driver for Intel i810 card family.
470
471 %description dri-driver-intel-i810 -l pl.UTF-8
472 Sterownik X.org DRI dla rodziny kart Intel i810.
473
474 %package dri-driver-intel-i915
475 Summary:        X.org DRI driver for Intel i915 card family
476 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
477 License:        MIT
478 Group:          X11/Libraries
479 Requires:       xorg-driver-video-intel
480 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
481 Requires:       xorg-xserver-server >= %{xserver_ver}
482 Obsoletes:      Mesa-dri-driver-intel-i830
483 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
484
485 %description dri-driver-intel-i915
486 X.org DRI driver for Intel i915 card family.
487
488 %description dri-driver-intel-i915 -l pl.UTF-8
489 Sterownik X.org DRI dla rodziny kart Intel i915.
490
491 %package dri-driver-intel-i965
492 Summary:        X.org DRI driver for Intel i965 card family
493 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
494 License:        MIT
495 Group:          X11/Libraries
496 Requires:       xorg-driver-video-intel
497 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
498 Requires:       xorg-xserver-server >= %{xserver_ver}
499 Obsoletes:      Mesa-dri-driver-intel-i830
500 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
501
502 %description dri-driver-intel-i965
503 X.org DRI driver for Intel i965 card family.
504
505 %description dri-driver-intel-i965 -l pl.UTF-8
506 Sterownik X.org DRI dla rodziny kart Intel i965.
507
508 %package dri-driver-matrox
509 Summary:        X.org DRI driver for Matrox G card family
510 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
511 License:        MIT
512 Group:          X11/Libraries
513 Requires:       xorg-driver-video-mga
514 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
515 Requires:       xorg-xserver-server >= %{xserver_ver}
516 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
517
518 %description dri-driver-matrox
519 X.org DRI drivers for Matrox G card family.
520
521 %description dri-driver-matrox -l pl.UTF-8
522 Sterowniki X.org DRI dla rodziny kart Matrox G.
523
524 %package dri-driver-nouveau
525 Summary:        X.org DRI driver for NVIDIA card family
526 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
527 License:        MIT
528 Group:          X11/Libraries
529 Requires:       xorg-driver-video-nouveau
530 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
531 Requires:       xorg-xserver-server >= %{xserver_ver}
532
533 %description dri-driver-nouveau
534 X.org DRI drivers for NVIDIA card family.
535
536 %description dri-driver-nouveau -l pl.UTF-8
537 Sterowniki X.org DRI dla rodziny kart NVIDIA.
538
539 %package dri-driver-savage
540 Summary:        X.org DRI driver for S3 Savage card family
541 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
542 License:        MIT
543 Group:          X11/Libraries
544 Requires:       xorg-driver-video-savage
545 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
546 Requires:       xorg-xserver-server >= %{xserver_ver}
547
548 %description dri-driver-savage
549 X.org DRI driver for S3 Savage card family.
550
551 %description dri-driver-savage -l pl.UTF-8
552 Sterownik X.org DRI dla rodziny kart S3 Savage.
553
554 %package dri-driver-sis
555 Summary:        X.org DRI driver for SiS card family
556 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
557 License:        MIT
558 Group:          X11/Libraries
559 Requires:       xorg-driver-video-sis
560 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
561 Requires:       xorg-xserver-server >= %{xserver_ver}
562 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
563
564 %description dri-driver-sis
565 X.org DRI driver for SiS card family.
566
567 %description dri-driver-sis -l pl.UTF-8
568 Sterownik X.org DRI dla rodziny kart SiS.
569
570 %package dri-driver-swrast
571 Summary:        X.org DRI software rasterizer driver
572 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
573 License:        MIT
574 Group:          X11/Libraries
575 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
576 Requires:       xorg-xserver-server >= %{xserver_ver}
577
578 %description dri-driver-swrast
579 X.org DRI software rasterizer driver.
580
581 %description dri-driver-swrast -l pl.UTF-8
582 Sterownik X.org DRI obsługujący rysowanie programowe.
583
584 %package dri-driver-tdfx
585 Summary:        X.org DRI driver for 3DFX Voodoo card family
586 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
587 License:        MIT
588 Group:          X11/Libraries
589 Requires:       Glide3-DRI
590 Requires:       xorg-driver-video-tdfx
591 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
592 Requires:       xorg-xserver-server >= %{xserver_ver}
593 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
594
595 %description dri-driver-tdfx
596 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
597 and Velocity 100/200).
598
599 %description dri-driver-tdfx -l pl.UTF-8
600 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
601 Banshee i Velocity 100/200).
602
603 %package dri-driver-via-unichrome
604 Summary:        X.org DRI driver for VIA Unichrome card family
605 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
606 License:        MIT
607 Group:          X11/Libraries
608 Requires:       xorg-driver-video-openchrome
609 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
610 Requires:       xorg-xserver-server >= %{xserver_ver}
611
612 %description dri-driver-via-unichrome
613 X.org DRI driver for VIA Unichrome card family.
614
615 %description dri-driver-via-unichrome -l pl.UTF-8
616 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
617
618 %package dri-driver-vmwgfx
619 Summary:        X.org DRI driver for VMware
620 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
621 License:        MIT
622 Group:          X11/Libraries
623 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
624 Requires:       xorg-xserver-server >= %{xserver_ver}
625
626 %description dri-driver-vmwgfx
627 X.org DRI driver for VMWare.
628
629 %description dri-driver-vmwgfx -l pl.UTF-8
630 Sterownik X.org DRI dla VMware.
631
632 %prep
633 %setup -q -b1
634 %patch0 -p0
635 %patch1 -p1
636
637 # fix demos
638 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
639
640 %build
641 autoreconf --install
642 #%{__aclocal}
643 #%{__autoconf}
644
645 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
646 %if %{without gallium_intel}
647 i915 \
648 %endif
649 %ifarch sparc sparcv9 sparc64
650 ffb \
651 %endif
652 %ifarch %{ix86} %{x8664}
653 sis \
654 %endif
655 swrast tdfx unichrome"
656
657 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
658
659 common_flags="\
660         --enable-shared \
661         --enable-selinux \
662         --enable-pic \
663         --enable-glx-tls \
664         --disable-glut \
665         --disable-os-mesa \
666         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
667         --with%{!?with_demos:out}-demos"
668
669 osmesa_common_flags="\
670         --with-driver=osmesa \
671         --disable-asm \
672         --disable-glu"
673
674 %if %{with osmesa}
675 # osmesa variants
676 %configure $common_flags $osmesa_common_flags \
677         --with-osmesa-bits=8
678 %{__make}
679 mv %{_lib} osmesa8
680 %{__make} clean
681
682 %configure $common_flags $osmesa_common_flags \
683         --with-osmesa-bits=16
684 %{__make}
685 mv %{_lib} osmesa16
686 %{__make} clean
687
688 %configure $common_flags $osmesa_common_flags \
689         --with-osmesa-bits=32
690 %{__make}
691 mv %{_lib} osmesa32
692 %{__make} clean
693 %endif
694
695 %configure $common_flags \
696 %if %{with gallium}
697         --enable-gallium \
698         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
699         --enable-gallium-svga \
700         --enable-gallium-nouveau \
701         --with-state-trackers=dri,xorg,glx \
702 %else
703         --disable-gallium \
704 %endif
705         --with-driver=dri \
706         --with-dri-drivers=${dri_drivers} \
707         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
708
709 %{__make}
710 %{__make} -C progs/xdemos glxgears glxinfo
711 %if %{with demos}
712 %{__make} -C progs/demos
713 %endif
714
715 %install
716 rm -rf $RPM_BUILD_ROOT
717
718 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
719
720 # libs without drivers
721 %{__make} install \
722         DESTDIR=$RPM_BUILD_ROOT
723
724 %if %{with osmesa}
725 rm -f osmesa*/libGLEW.*
726 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
727 %endif
728
729 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
730 # work on copy to keep -bi --short-circuit working
731 rm -rf progs-clean
732 install -d progs-clean
733 for l in demos glsl osdemos redbook samples xdemos ; do
734         cp -a progs/$l progs-clean/$l
735         %{__make} -C progs-clean/$l clean
736         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
737 done
738 rm -rf progs-clean
739 for l in util images ; do
740         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
741 done
742 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
743
744 # strip out undesirable headers
745 olddir=$(pwd)
746 cd $RPM_BUILD_ROOT%{_includedir}/GL
747 rm [a-fh-np-wyz]*.h glf*.h
748 cd $RPM_BUILD_ROOT%{_libdir}
749 cd $olddir
750
751 %if %{with multigl}
752 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
753
754 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
755 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
756
757 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
758 %endif
759
760 %clean
761 rm -rf $RPM_BUILD_ROOT
762
763 %post   libGL -p /sbin/ldconfig
764 %postun libGL -p /sbin/ldconfig
765
766 %post   libGLU -p /sbin/ldconfig
767 %postun libGLU -p /sbin/ldconfig
768
769 %post   libGLw -p /sbin/ldconfig
770 %postun libGLw -p /sbin/ldconfig
771
772 %files libGL
773 %defattr(644,root,root,755)
774 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
775 %if %{with multigl}
776 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
777 %dir %{_libdir}/Mesa
778 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
779 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
780 %else
781 %attr(755,root,root) %{_libdir}/libGL.so.*.*
782 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
783 # symlink for binary apps which fail to conform Linux OpenGL ABI
784 # (and dlopen libGL.so instead of libGL.so.1)
785 %attr(755,root,root) %{_libdir}/libGL.so
786 %endif
787
788 %files libGL-devel
789 %defattr(644,root,root,755)
790 %doc docs/*.spec
791 %if %{with multigl}
792 %attr(755,root,root) %{_libdir}/libGL.so
793 %endif
794 %dir %{_includedir}/GL
795 %{_includedir}/GL/gl.h
796 %{_includedir}/GL/glext.h
797 %{_includedir}/GL/gl_mangle.h
798 %{_includedir}/GL/glx.h
799 %{_includedir}/GL/glxext.h
800 %{_includedir}/GL/glx_mangle.h
801 %dir %{_includedir}/GL/internal
802 %{_includedir}/GL/internal/dri_interface.h
803 %{_pkgconfigdir}/dri.pc
804 %{_pkgconfigdir}/gl.pc
805
806 %if %{with static}
807 %files libGL-static
808 %defattr(644,root,root,755)
809 %{_libdir}/libGL.a
810 %endif
811
812 %files libGLU
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
815 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
816
817 %files libGLU-devel
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libGLU.so
820 %{_includedir}/GL/glu.h
821 %{_includedir}/GL/glu_mangle.h
822 %{_pkgconfigdir}/glu.pc
823
824 %if %{with static}
825 %files libGLU-static
826 %defattr(644,root,root,755)
827 %{_libdir}/libGLU.a
828 %endif
829
830 %files libGLw
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
833 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
834
835 %files libGLw-devel
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/libGLw.so
838 %{_includedir}/GL/GLwDrawA.h
839 %{_includedir}/GL/GLwDrawAP.h
840 %{_includedir}/GL/GLwMDrawA.h
841 %{_includedir}/GL/GLwMDrawAP.h
842 %{_pkgconfigdir}/glw.pc
843
844 %if %{with static}
845 %files libGLw-static
846 %defattr(644,root,root,755)
847 %{_libdir}/libGLw.a
848 %endif
849
850 %if %{with osmesa}
851 %files libOSMesa
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
854 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
855
856 %files libOSMesa-devel
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/libOSMesa*.so
859 %{_includedir}/GL/osmesa.h
860
861 %if %{with static}
862 %files libOSMesa-static
863 %defattr(644,root,root,755)
864 %{_libdir}/libOSMesa*.a
865 %endif
866 %endif
867
868 %files utils
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_bindir}/glxgears
871 %attr(755,root,root) %{_bindir}/glxinfo
872
873 %files dri-driver-ati-mach64
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
876
877 %files dri-driver-ati-radeon-R100
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
880
881 %files dri-driver-ati-radeon-R200
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
884
885 %files dri-driver-ati-radeon-R300
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
888
889 %files dri-driver-ati-radeon-R600
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
892
893 %files dri-driver-ati-rage128
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
896
897 # sunffb (sparc only)
898 %ifarch sparc sparcv9 sparc64
899 %files dri-driver-ffb
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
902 %endif
903
904 # glint (requires update)
905 %if 0
906 %files dri-driver-glint
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
909 %endif
910
911 %files dri-driver-intel-i810
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
914
915 %files dri-driver-intel-i915
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
918
919 %files dri-driver-intel-i965
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
922
923 %files dri-driver-matrox
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
926
927 %if %{with gallium}
928 %files dri-driver-nouveau
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
932 %endif
933
934 %files dri-driver-savage
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
937
938 %ifarch %{ix86} %{x8664}
939 %files dri-driver-sis
940 %defattr(644,root,root,755)
941 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
942 %endif
943
944 %files dri-driver-swrast
945 %defattr(644,root,root,755)
946 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
947
948 %files dri-driver-tdfx
949 %defattr(644,root,root,755)
950 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
951
952 %files dri-driver-via-unichrome
953 %defattr(644,root,root,755)
954 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
955
956 %if %{with gallium}
957 %files dri-driver-vmwgfx
958 %defattr(644,root,root,755)
959 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
960 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
961 %endif
962
963 %if %{with demos}
964 %files demos
965 %defattr(644,root,root,755)
966 %{_examplesdir}/%{name}-%{version}
967 %endif
This page took 0.08737 seconds and 4 git commands to generate.